source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ffmpeg/self-build-gstreamer-plugins-ffmpeg-vl.spec @ 1480

Revision 1480, 6.0 KB checked in by munepi, 14 years ago (diff)

updated self-build-gstreamer

Line 
1%define pkgname gstreamer-plugins-ffmpeg
2%define name    self-build-%{pkgname}
3%define version 0.10.11
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPLv2+ and LGPLv2+
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20# (build)requies of target package.
21Requires:       gstreamer >= 0.10.0
22Requires:       gstreamer-plugins-base >= 0.10.0
23Requires(post):         gstreamer-devel >= 0.10.0
24Requires(post):         gstreamer-plugins-base-devel >= 0.10.0
25Requires(post):         liboil-devel
26Requires(post):         bzip2-devel
27## Use internal ffmpeg
28# Requires(post):       self-build-ffmpeg
29
30BuildArch:      noarch
31BuildRoot:      %{_tmppath}/%{name}-%{version}-root
32
33Packager:       munepi
34
35%description
36GStreamer is a streaming media framework, based on graphs of filters which
37operate on media data. Applications using this library can do anything
38from real-time sound processing to playing videos, and just about anything
39else media-related.  Its plugin-based architecture means that new data
40types or processing capabilities can be added simply by installing new
41plugins.
42
43This package provides FFmpeg-based GStreamer plug-ins.
44
45If you install this package, it automaticaly downloads source
46code, compile it, and create rpm packages of
47%{pkgname}-%{version}.
48And the created rpm packages are automatically installed
49if installation is executed by apt-get command or synaptic
50package manager.
51
52
53[Note]
54This package requires many other packages to compile
55targetsoftware. So it consume more disk space than usual.
56Also installation takes logner time because of compilation.
57(This will take a few minutes to quarter or half of an hour,
58depends on building environment)
59
60[About self-build package]
61For some kind of software, distributing of binary package
62may viorate the patent or law. Therefore we chose self-build
63packge, create binary package on your machine, for such kind
64of softwares instead of distributing binary package.
65
66Please obey the national law when you use the created binary
67packages. And if you want to use the softwares using patented
68thechnology, it may be required to get a permission, make an
69agreement or purchas a license. Please consider it with your
70purpose or way of use and take appropriate action.
71
72%description -l ja
73GStreamer はメディアデータ操作用の filter graph をベースにし
74たストリーミングメディアフレームワークです。 このライブラリを
75使用すればアプリケーションは、サウンドのリアルタイム処理から
76ビデオ再生まで、メディアに関係する全ての機能が利用できます。
77また Gstremer はプラグイン方式を採用していることから、新しい
78種類のデータや機能への対応が、プラグインを追加することで簡単
79に実現できます。
80
81このパッケージは ffmpeg ベースの GStreamer プラグインを提供し
82ます。
83
84このパッケージをインストールすると、自動的にソースコードをダ
85ウンロードしてコンパイルし、%{pkgname}-%{version}
86の rpm パッケージを作成します。
87また apt-get コマンドや synaptic パッケージマネージャから実行
88した場合は、作成された rpm パッケージのインストールも自動的に
89行います。
90
91
92[注意]
93コンパイルに必要な多くの関連パッケージを要求するので通常より
94ディスクの領域を多く消費します。
95またインストール時にコンパイルを行うため、通常より時間がかか
96る場合があります。(環境にもよりますが数分から数十分程度)
97
98[self-build パッケージについて]
99ソフトウェアによってはバイナリパッケージの配布が特許や法律に
100違反する可能性があるものがあります。その為、このような問題が
101懸念されるソフトウェアについてはバイナリパッケージを直接配布
102せずに、ユーザの環境でバイナリを作成する self-build パッケー
103ジという方法を採っています。
104
105作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
106アのライセンス、および利用する国の各種法令に従ってください。
107また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
108センスの購入などが必要となる場合がありますので、利用する目的
109や形態に応じて各自で判断し適切な対応を取ってください。
110
111
112%prep
113[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
114
115%install
116%{__rm} -rf ${RPM_BUILD_ROOT}
117%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
118%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
119
120
121%clean
122%{__rm} -rf ${RPM_BUILD_ROOT}
123
124%posttrans
125/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 43000
126
127%files
128%defattr(-,root,root)
129%{_datadir}/%{name}/*
130
131%changelog
132* Sat Jul 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-1
133- new upstream release
134
135* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.10-1
136- new upstream release
137- renamed %%{Source0} to gstreamer-plugins-ffmpeg-vl.spec
138
139* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.9-1
140- new upstream release
141
142* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
143- new upstream release
144
145* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-2
146- added BuildArch: noarch
147- avoided to execute self-build-rpm.sh on RPM transaction
148  - moved %%post actions to %%posttrans
149
150* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-1
151- new upstream release
152- corrected %%description
153
154* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.6-1
155- initial build
156
157### end of file
Note: See TracBrowser for help on using the repository browser.