source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ffmpeg/self-build-gstreamer-plugins-ffmpeg-vl.spec @ 7923

Revision 7923, 6.7 KB checked in by tomop, 10 years ago (diff)

self-build-gstreamer-plugins-ffmpeg-0.10.13-2

Line 
1%define pkgname gstreamer-plugins-ffmpeg
2%define name    self-build-%{pkgname}
3%define version 0.10.13
4%define release 2%{?_dist_release}
5
6%define sourceurl0      http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14Source1:        gst-ffmpeg-0.10.13_gcc47.patch
15License:        GPLv2+ and LGPLv2+
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20# (build)requies of target package.
21Requires:       gstreamer >= 0.10.0
22Requires:       gstreamer-plugins-base >= 0.10.0
23Requires(post):         gstreamer-devel >= 0.10.0
24Requires(post):         gstreamer-plugins-base-devel >= 0.10.0
25Requires(post):         liboil-devel
26Requires(post):         bzip2-devel
27Requires(post): self-build-ffmpeg
28
29BuildArch:      noarch
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31
32Packager:       munepi
33
34%description
35GStreamer is a streaming media framework, based on graphs of filters which
36operate on media data. Applications using this library can do anything
37from real-time sound processing to playing videos, and just about anything
38else media-related.  Its plugin-based architecture means that new data
39types or processing capabilities can be added simply by installing new
40plugins.
41
42This package provides FFmpeg-based GStreamer plug-ins.
43
44If you install this package, it automaticaly downloads source
45code, compile it, and create rpm packages of
46%{pkgname}-%{version}.
47And the created rpm packages are automatically installed
48if installation is executed by apt-get command or synaptic
49package manager.
50
51
52[Note]
53This package requires many other packages to compile
54targetsoftware. So it consume more disk space than usual.
55Also installation takes logner time because of compilation.
56(This will take a few minutes to quarter or half of an hour,
57depends on building environment)
58
59[About self-build package]
60For some kind of software, distributing of binary package
61may viorate the patent or law. Therefore we chose self-build
62packge, create binary package on your machine, for such kind
63of softwares instead of distributing binary package.
64
65Please obey the national law when you use the created binary
66packages. And if you want to use the softwares using patented
67thechnology, it may be required to get a permission, make an
68agreement or purchas a license. Please consider it with your
69purpose or way of use and take appropriate action.
70
71%description -l ja
72GStreamer はメディアデータ操作用の filter graph をベースにし
73たストリーミングメディアフレームワークです。 このライブラリを
74使用すればアプリケーションは、サウンドのリアルタイム処理から
75ビデオ再生まで、メディアに関係する全ての機能が利用できます。
76また Gstremer はプラグイン方式を採用していることから、新しい
77種類のデータや機能への対応が、プラグインを追加することで簡単
78に実現できます。
79
80このパッケージは ffmpeg ベースの GStreamer プラグインを提供し
81ます。
82
83このパッケージをインストールすると、自動的にソースコードをダ
84ウンロードしてコンパイルし、%{pkgname}-%{version}
85の rpm パッケージを作成します。
86また apt-get コマンドや synaptic パッケージマネージャから実行
87した場合は、作成された rpm パッケージのインストールも自動的に
88行います。
89
90
91[注意]
92コンパイルに必要な多くの関連パッケージを要求するので通常より
93ディスクの領域を多く消費します。
94またインストール時にコンパイルを行うため、通常より時間がかか
95る場合があります。(環境にもよりますが数分から数十分程度)
96
97[self-build パッケージについて]
98ソフトウェアによってはバイナリパッケージの配布が特許や法律に
99違反する可能性があるものがあります。その為、このような問題が
100懸念されるソフトウェアについてはバイナリパッケージを直接配布
101せずに、ユーザの環境でバイナリを作成する self-build パッケー
102ジという方法を採っています。
103
104作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
105アのライセンス、および利用する国の各種法令に従ってください。
106また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
107センスの購入などが必要となる場合がありますので、利用する目的
108や形態に応じて各自で判断し適切な対応を取ってください。
109
110
111%prep
112[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
113
114%install
115%{__rm} -rf ${RPM_BUILD_ROOT}
116%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
117%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
118%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
119
120
121%clean
122%{__rm} -rf ${RPM_BUILD_ROOT}
123
124%posttrans
125/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 126000
126
127%files
128%defattr(-,root,root)
129%{_datadir}/%{name}/*
130
131%changelog
132* Tue Oct 22 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.13-2
133- added Source1 to build with gcc-4.7 or later.
134
135* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
136- new upstream release
137
138* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
139- new upstream release
140
141* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-3
142- dropped --with-system-ffmpeg in configure options
143  (gstreamer-plugins-ffmpeg-vl.spec)
144
145* Sun Feb 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-2
146- added Requires(post): self-build-ffmpeg
147  - already used system ffmpeg
148
149* Sat Jul 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-1
150- new upstream release
151
152* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.10-1
153- new upstream release
154- renamed %%{Source0} to gstreamer-plugins-ffmpeg-vl.spec
155
156* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.9-1
157- new upstream release
158
159* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
160- new upstream release
161
162* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-2
163- added BuildArch: noarch
164- avoided to execute self-build-rpm.sh on RPM transaction
165  - moved %%post actions to %%posttrans
166
167* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-1
168- new upstream release
169- corrected %%description
170
171* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.6-1
172- initial build
173
174### end of file
Note: See TracBrowser for help on using the repository browser.