source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-bad/self-build-gstreamer-plugins-bad-vl.spec @ 1258

Revision 1258, 6.4 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1%define pkgname gstreamer-plugins-bad
2%define majorminor   0.10
3%define gstreamer    gstreamer
4%define gst_minver   0.10.22.1
5%define gstpb_minver 0.10.22.1
6%define _gst_ver     0.10.19
7%define release 1%{?_dist_release}
8
9%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{_gst_ver}.tar.bz2
10
11Summary:        Package to automatically build %{pkgname} rpm package
12Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
13Name:           self-build-%{pkgname}
14Version:        %{_gst_ver}
15Release:        %{release}
16Source0:        %{pkgname}-vl.spec
17License:        LGPLv2+ and LGPLv2
18Group:          Restricted Software
19
20Requires(post):         self-build-setup >= 0.9.9
21
22# (build)requies of target package.
23Requires: %{gstreamer} >= %{gst_minver}
24Requires(post): %{gstreamer}-devel >= %{gst_minver}
25Requires(post): %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
26
27Requires(post): check
28Requires(post): gettext
29Requires(post): PyXML
30Requires(post): libXt-devel
31
32Requires(post): liboil-devel
33Requires(post): libdirectfb-devel
34Requires(post): self-build-libdca
35Requires(post): self-build-faac
36Requires(post): self-build-faad2
37Requires(post): gsm-devel
38Requires(post): libmpcdec-devel
39Requires(post): SDL-devel
40#Requires(post): soundtouch-devel
41#Requires(post): swfdec-devel
42#Buildrequires: wavpack-devel
43Requires(post): self-build-xvidcore
44Requires(post): bzip2-devel
45Requires(post): mesa-libGLU-devel
46Requires(post): neon-devel
47#Requires(post): libmms-devel
48Requires(post): libmusicbrainz-devel
49#Requires(post): libcdaudio-devel
50Requires(post): jack-audio-connection-kit-devel
51#Requires(post): mjpegtools-devel
52#Requires(post): nas-devel
53Requires(post): self-build-x264
54#Requires(post): wildmidi-devel
55Requires(post): libsndfile-devel
56#Requires(post): libmodplug-devel
57#Requires(post): libtimidity-devel
58#Requires(post): gmyth-devel >= 0.4
59Requires(post): libdc1394-devel
60Requires(post): libexif-devel
61#Requires(post): libiptcdata-devel
62#Requires(post): exempi-devel
63#Requires(post): dirac-devel
64#Requires(post): libofa-devel
65Requires(post): self-build-libdvdnav
66Requires(post): jasper-devel
67Requires(post): openssl-devel
68Requires(post): twolame-devel
69Requires(post): libvdpau-devel
70
71
72BuildArch:      noarch
73BuildRoot:      %{_tmppath}/%{name}-%{version}-root
74
75Packager:       munepi
76
77%description
78GStreamer is a streaming media framework, based on graphs of elements which
79operate on media data.
80
81This package contains plug-ins that have licensing issues, aren't tested
82well enough, or the code is not of good enough quality.
83
84If you install this package, it automaticaly downloads source
85code, compile it, and create rpm packages of
86%{pkgname}-%{version}.
87And the created rpm packages are automatically installed
88if installation is executed by apt-get command or synaptic
89package manager.
90
91
92[Note]
93This package requires many other packages to compile
94targetsoftware. So it consume more disk space than usual.
95Also installation takes logner time because of compilation.
96(This will take a few minutes to quarter or half of an hour,
97depends on building environment)
98
99[About self-build package]
100For some kind of software, distributing of binary package
101may viorate the patent or law. Therefore we chose self-build
102packge, create binary package on your machine, for such kind
103of softwares instead of distributing binary package.
104
105Please obey the national law when you use the created binary
106packages. And if you want to use the softwares using patented
107thechnology, it may be required to get a permission, make an
108agreement or purchas a license. Please consider it with your
109purpose or way of use and take appropriate action.
110
111# '
112
113%description -l ja
114gstreamer-plugins-bad は GStreamer ストリーミングメディア
115フレームワーク用 bad プラグイン集です。
116
117このパッケージをインストールすると、自動的にソースコードを
118ダウンロードしてコンパイルし、%{pkgname}-%{version}
119の rpm パッケージを作成します。
120また apt-get コマンドや synaptic パッケージマネージャから実行
121した場合は、作成された rpm パッケージのインストールも自動的に
122行います。
123
124
125[注意]
126コンパイルに必要な多くの関連パッケージを要求するので通常より
127ディスクの領域を多く消費します。
128またインストール時にコンパイルを行うため、通常より時間がかか
129る場合があります。(環境にもよりますが数分から数十分程度)
130
131[self-build パッケージについて]
132ソフトウェアによってはバイナリパッケージの配布が特許や法律に
133違反する可能性があるものがあります。その為、このような問題が
134懸念されるソフトウェアについてはバイナリパッケージを直接配布
135せずに、ユーザの環境でバイナリを作成する self-build パッケー
136ジという方法を採っています。
137
138作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
139アのライセンス、および利用する国の各種法令に従ってください。
140また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
141センスの購入などが必要となる場合がありますので、利用する目的
142や形態に応じて各自で判断し適切な対応を取ってください。
143
144%prep
145[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
146
147
148%install
149%{__rm} -rf ${RPM_BUILD_ROOT}
150%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
151%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
152
153
154%clean
155%{__rm} -rf ${RPM_BUILD_ROOT}
156
157%posttrans
158/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 269000
159/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
160                                 %{pkgname}-devel-%{version}-%{release}
161
162
163%files
164%defattr(-,root,root)
165%{_datadir}/%{name}
166
167%changelog
168* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
169- new upstream release
170
171* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
172- new upstream release
173- renamed %%{Source0} to gstreamer-plugins-bad-vl.spec
174- added Requires(post): libvdpau-devel
175- check version between original spec and self-build spec in %%prep
176
177* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
178- new upstream release
179
180* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
181- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.