source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-bad/gstreamer-plugins-bad-vl.spec @ 1258

Revision 1258, 16.9 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1%define majorminor   0.10
2%define gstreamer    gstreamer
3
4%define gst_minver   0.10.22.1
5%define gstpb_minver 0.10.22.1
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Name: gstreamer-plugins-bad
9Version: 0.10.19
10Release: 1%{?_dist_release}
11# The freeze and nfs plugins are LGPLv2 (only)
12License: LGPLv2+
13Group: Applications/Multimedia
14URL: http://gstreamer.freedesktop.org/
15Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.bz2
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires: %{gstreamer} >= %{gst_minver}
18BuildRequires: %{gstreamer}-devel >= %{gst_minver}
19BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
20
21BuildRequires: check
22BuildRequires: gettext
23BuildRequires: PyXML
24BuildRequires: libXt-devel
25
26BuildRequires: liboil-devel
27BuildRequires: libdirectfb-devel
28# BuildRequires: self-build-libdca-devel
29# BuildRequires: self-build-faac-devel
30# BuildRequires: self-build-faad2
31BuildRequires: gsm-devel
32BuildRequires: libmpcdec-devel
33BuildRequires: SDL-devel
34#BuildRequires: soundtouch-devel
35#BuildRequires: swfdec-devel
36#Buildrequires: wavpack-devel
37# BuildRequires: self-build-xvidcore-devel
38BuildRequires: bzip2-devel
39BuildRequires: mesa-libGLU-devel
40BuildRequires: neon-devel
41#BuildRequires: libmms-devel
42BuildRequires: libmusicbrainz-devel
43#BuildRequires: libcdaudio-devel
44BuildRequires: jack-audio-connection-kit-devel
45#BuildRequires: mjpegtools-devel
46#BuildRequires: nas-devel
47# BuildRequires: self-build-x264-devel
48#BuildRequires: wildmidi-devel
49BuildRequires: libsndfile-devel
50#BuildRequires: libmodplug-devel
51#BuildRequires: libtimidity-devel
52#BuildRequires: gmyth-devel >= 0.4
53BuildRequires: libdc1394-devel
54BuildRequires: libexif-devel
55#BuildRequires: libiptcdata-devel
56#BuildRequires: exempi-devel
57#BuildRequires: dirac-devel
58#BuildRequires: libofa-devel
59# BuildRequires: self-build-libdvdnav-devel
60BuildRequires: jasper-devel
61BuildRequires: openssl-devel
62BuildRequires: twolame-devel
63BuildRequires: libvdpau-devel
64
65%description
66GStreamer is a streaming media framework, based on graphs of elements which
67operate on media data.
68
69This package contains plug-ins that have licensing issues, aren't tested
70well enough, or the code is not of good enough quality.
71
72
73# %package extras
74# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
75# Group: Applications/Multimedia
76# Requires: %{name} = %{version}-%{release}
77
78# %description extras
79# GStreamer is a streaming media framework, based on graphs of elements which
80# operate on media data.
81
82# gstreamer-plugins-bad contains plug-ins that have licensing issues, aren't
83# tested well enough, or the code is not of good enough quality.
84
85# This package (gstreamer-plugins-bad-extras) contains extra "bad" plugins for
86# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
87# very much and require additional libraries to be installed.
88
89
90%package devel
91Summary: Development files for the GStreamer media framework "bad" plug-ins
92Group: Development/Libraries
93Requires: %{name} = %{version}-%{release}
94Requires: gstreamer-plugins-base-devel
95
96%description devel
97GStreamer is a streaming media framework, based on graphs of elements which
98operate on media data.
99
100This package contains the development files for the plug-ins that have
101licensing issues, aren't tested well enough, or the code is not of good
102enough quality.
103
104# '
105
106%prep
107%setup -q -n gst-plugins-bad-%{version}
108
109
110%build
111%configure \
112    --enable-debug --disable-static --disable-gtk-doc \
113    --disable-ladspa --enable-experimental \
114    --disable-siren --disable-valve --disable-dtmf --disable-autoconvert \
115    --disable-liveadder --disable-rtpmux \
116    ;
117
118# Don't use rpath!
119%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
120%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
121%{__make} %{?_smp_mflags}
122
123
124%install
125%{__rm} -rf %{buildroot}
126%{__make} install DESTDIR="%{buildroot}"
127%find_lang gst-plugins-bad-%{majorminor}
128
129# Clean out files that should not be part of the rpm.
130%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
131%{__rm} -f %{buildroot}%{_libdir}/*.la
132
133
134%clean
135%{__rm} -rf %{buildroot}
136
137
138%post -p /sbin/ldconfig
139
140%postun -p /sbin/ldconfig
141
142
143%files -f gst-plugins-bad-%{majorminor}.lang
144%defattr(-,root,root,-)
145%doc AUTHORS COPYING README REQUIREMENTS
146# %{_bindir}/gst-camera
147# %{_bindir}/gst-camera-perf
148%{_libdir}/*.so.*
149%{_libdir}/gstreamer-%{majorminor}/*.so
150#%{_datadir}/gstreamer-0.10/presets/GstX264Enc.prs
151#%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.glade
152%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.ui
153
154# # Plugins without external dependencies
155# %{_libdir}/gstreamer-%{majorminor}/libgstaacparse.so
156# %{_libdir}/gstreamer-%{majorminor}/libgstaiffparse.so
157# %{_libdir}/gstreamer-%{majorminor}/libgstamrparse.so
158# %{_libdir}/gstreamer-%{majorminor}/libgstbayer.so
159# %{_libdir}/gstreamer-%{majorminor}/libgstcdxaparse.so
160# %{_libdir}/gstreamer-%{majorminor}/libgstdccp.so
161# %{_libdir}/gstreamer-%{majorminor}/libgstdeinterlace.so
162# %{_libdir}/gstreamer-%{majorminor}/libgstdeinterlace2.so
163# %{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
164# %{_libdir}/gstreamer-%{majorminor}/libgstfestival.so
165# %{_libdir}/gstreamer-%{majorminor}/libgstfilter.so
166# %{_libdir}/gstreamer-%{majorminor}/libgstflv.so
167# %{_libdir}/gstreamer-%{majorminor}/libgstfreeze.so
168# %{_libdir}/gstreamer-%{majorminor}/libgsth264parse.so
169# %{_libdir}/gstreamer-%{majorminor}/libgstlegacyresample.so
170# %{_libdir}/gstreamer-%{majorminor}/libgstrfbsrc.so
171# %{_libdir}/gstreamer-%{majorminor}/libgstmpeg4videoparse.so
172# %{_libdir}/gstreamer-%{majorminor}/libgstmpegdemux.so
173# %{_libdir}/gstreamer-%{majorminor}/libgstmpegtsmux.so
174# %{_libdir}/gstreamer-%{majorminor}/libgstmpegvideoparse.so
175# %{_libdir}/gstreamer-%{majorminor}/libgstmve.so
176# %{_libdir}/gstreamer-%{majorminor}/libgstmxf.so
177# %{_libdir}/gstreamer-%{majorminor}/libgstnsf.so
178# %{_libdir}/gstreamer-%{majorminor}/libgstnuvdemux.so
179# %{_libdir}/gstreamer-%{majorminor}/libgstpcapparse.so
180# %{_libdir}/gstreamer-%{majorminor}/libgstqtmux.so
181# %{_libdir}/gstreamer-%{majorminor}/libgstrawparse.so
182# %ifarch %{ix86} x86_64
183# %{_libdir}/gstreamer-%{majorminor}/libgstreal.so
184# %endif
185# %{_libdir}/gstreamer-%{majorminor}/libgstrtpmanager.so
186# %{_libdir}/gstreamer-%{majorminor}/libgstscaletempoplugin.so
187# %{_libdir}/gstreamer-%{majorminor}/libgstsdpelem.so
188# %{_libdir}/gstreamer-%{majorminor}/libgstselector.so
189# %{_libdir}/gstreamer-%{majorminor}/libgstspeed.so
190# %{_libdir}/gstreamer-%{majorminor}/libgststereo.so
191# %{_libdir}/gstreamer-%{majorminor}/libgstsubenc.so
192# %{_libdir}/gstreamer-%{majorminor}/libgsttta.so
193# %{_libdir}/gstreamer-%{majorminor}/libgstvideosignal.so
194# %{_libdir}/gstreamer-%{majorminor}/libgstvmnc.so
195# %{_libdir}/gstreamer-%{majorminor}/libgsty4menc.so
196
197# # System (Linux) specific plugins
198# %{_libdir}/gstreamer-%{majorminor}/libgstdvb.so
199# %{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
200# %{_libdir}/gstreamer-%{majorminor}/libgstoss4audio.so
201# %{_libdir}/gstreamer-%{majorminor}/libgstvcdsrc.so
202
203# # Plugins with external dependencies
204# %{_libdir}/gstreamer-%{majorminor}/libgstalsaspdif.so
205# %{_libdir}/gstreamer-%{majorminor}/libgstapexsink.so
206# %{_libdir}/gstreamer-%{majorminor}/libgstbz2.so
207# #%{_libdir}/gstreamer-%{majorminor}/libgstcdaudio.so
208# #%{_libdir}/gstreamer-%{majorminor}/libgstdc1394.so
209# %{_libdir}/gstreamer-%{majorminor}/libgstdfbvideosink.so
210# #%{_libdir}/gstreamer-%{majorminor}/libgstdirac.so
211# %{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
212# %{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
213# %{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
214# %{_libdir}/gstreamer-%{majorminor}/libgstgsm.so
215# %{_libdir}/gstreamer-%{majorminor}/libgstjp2k.so
216# #%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
217# %{_libdir}/gstreamer-%{majorminor}/libgstmetadata.so
218# #%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
219# %{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
220# %{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
221# %{_libdir}/gstreamer-%{majorminor}/libgstmusepack.so
222# %{_libdir}/gstreamer-%{majorminor}/libgsttrm.so
223# %{_libdir}/gstreamer-%{majorminor}/libgstneonhttpsrc.so
224# #%{_libdir}/gstreamer-%{majorminor}/libgstofa.so
225# %{_libdir}/gstreamer-%{majorminor}/libresindvd.so
226# %{_libdir}/gstreamer-%{majorminor}/libgstsdl.so
227# %{_libdir}/gstreamer-%{majorminor}/libgstsndfile.so
228# #%{_libdir}/gstreamer-%{majorminor}/libgstswfdec.so
229# #%{_libdir}/gstreamer-%{majorminor}/libgsttimidity.so
230# %{_libdir}/gstreamer-%{majorminor}/libgsttwolame.so
231# #%{_libdir}/gstreamer-%{majorminor}/libgstwildmidi.so
232# %{_libdir}/gstreamer-%{majorminor}/libgstx264.so
233# %{_libdir}/gstreamer-%{majorminor}/libgstxvid.so
234
235# %files extras
236# %defattr(-,root,root,-)
237# # Plugins with external dependencies
238# %{_libdir}/gstreamer-%{majorminor}/libgstjack.so
239# #%{_libdir}/gstreamer-%{majorminor}/libgstmythtvsrc.so
240# #%{_libdir}/gstreamer-%{majorminor}/libgstnassink.so
241# #%{_libdir}/gstreamer-%{majorminor}/libgstsoundtouch.so
242
243%files devel
244%defattr(-,root,root,-)
245%{_libdir}/*.so
246%{_includedir}/gstreamer-%{majorminor}/gst/signalprocessor/gstsignalprocessor.h
247%{_includedir}/gstreamer-%{majorminor}/gst/video/*
248%{_includedir}/gstreamer-%{majorminor}/gst/interfaces/photography*
249%{_includedir}/gstreamer-%{majorminor}/gst/vdpau/*
250%{_libdir}/pkgconfig/*
251#%doc %{_datadir}/gtk-doc/html/gst-plugins-bad-plugins-0.10
252
253
254
255%changelog
256* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
257- new upstream release
258
259* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
260- new upstream release
261- added BuildRequires: libvdpau-devel
262
263* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
264- new upstream release
265
266* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
267- new upstream release
268- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
269  gst-plugins-bad-0.10.5-mms-seek.patch
270
271* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
272- new upstream release
273- dropped devel and devel-docs subpackages
274
275* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
276- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
277- changed to BuildRequires:  self-build-faad2 from faad2-devel
278
279* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
280- initial build based on RPM Fusion package
281
282* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
283- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
284
285* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
286- Rebuild for new x264 (using patch from Rathann)
287
288* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
289- New upstream release 0.10.9
290- Rebuild for new directfb
291
292* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
293- Rebuild for new x264 and to generate new magic gstreamer provides
294
295* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
296- Enable DVD navigation plugin
297
298* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
299- Release bump to keep rpmfusion version higher then livna
300
301* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
302- New upstream release 0.10.8
303- Merge changes from latest freshrpms package: enable ofa and dirac plugins
304
305* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
306- Rebuild for new x264
307
308* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
309- New upstream release 0.10.7
310- Drop many upstreamed patches
311
312* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
313- Rebuild for new x264
314
315* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
316- Enable dc1394 plugin
317
318* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
319- New upstream release 0.10.6-1
320- Drop many upstreamed patches
321- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
322
323* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
324- Fix compilation with gcc 4.3
325
326* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
327- Add flv demuxer from CVS (livna bug 1846)
328
329* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
330- Add patch fixing compilation with mjpegtools 1.9.0rc3
331
332* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
333- Add patch from upstream vcs which makes mms honor your connection speed
334  settings
335- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
336
337* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
338- Rebuild for new faad2
339
340* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
341- Rebuild for new libdca
342
343* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
344- Rebuild for new (old) faad2 (livna bug 1679)
345
346* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
347- Update mythtvsrc code to CVS version (livna bug 1660)
348
349* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
350- No libgstreal.so on ppc / ppc64
351
352* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
353- Fix detection of libdts with current livna libtds, this might need to be
354  changed back again for rpmfusion, depending on how libdts will look there
355
356* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
357- Add mythtvsrc plugin (livna 1646)
358- Put some less often used plugins, which bring in also usually not installed
359  deps in a -extras package
360
361* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
362- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
363- Set release to 4 to be higher as both livna and freshrpms latest release
364- Set package name and origin to rpmfusion
365- Make mpeg2enc plugin compile with current mjpegtools
366- Make the real plugins search for the RealPlayer .so files in various
367  known possible locations instead of using only one hardcoded path to them
368- Make the wildmidi plugin work with the default Fedora timidity patch set
369- Add a couple of missing modtracker mimetypes to the modplug plugin
370- Use the system version of libmodplug
371- Fix building of the neonsrc plugin with the latest (rawhide) neon
372- Disable the ladspa plugin as this has been added to Fedora's rawhide
373  gstreamer-plugins-good
374- Don't put an rpath in the .so's on x86_64
375- Re-enable gtk-doc now that we have a -devel package again
376- Enable libtimidity plugin
377- Fix detection of (and linking with) libdca for the dtsdec plugin
378
379* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
380- Update to 0.10.5.
381- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
382- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
383- Enable new nas, x264, wildmidi and libsndfile plugins.
384- Re-add devel package now that we have a main shared lib and header files.
385- Add check build requirement.
386
387* Wed Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
388- Update to 0.10.4 for F7.
389- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
390  somewhat more, maybe then it'll be worth re-enabling.
391- Re-enable wavpack, it works again now.
392- Enable libcdaudio support.
393- Enable jack support.
394- Enable ladspa support.
395- Enable mpeg2enc (mjpegtools) support.
396- Remove no longer present libgstvideo4linux2.so and add all new plugins.
397- Remove all gtk-doc references (all gone...?) and devel package too.
398
399* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
400- Update faad2 patch to also update the plugin sources, not just configure.
401
402* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
403- Try to rebuild against new wavpack 4.40 from Extras : Fails.
404- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
405- Try to include patch to update wavpack plugin source from 0.10.3.2
406  pre-release : Fails to find wavpack/md5.h.
407- Give up and disable wavpack support for now, sorry! Patches welcome.
408- Include patch to fix faad2 2.5 detection.
409- Add soundtouch support.
410
411* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
412- Update to 0.10.3.
413- Add new translations.
414- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
415- Add new libmusicbrainz support.
416
417* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
418- Add libmms support, thanks to Daniel S. Rogers.
419
420* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
421- Update to 0.10.1.
422- Add libgstcdxaparse.so and libgstfreeze.so.
423- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
424
425* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
426- Update to 0.10.0.1, add new plugins.
427- Spec file cleanup and rebuild for FC5.
428
429* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
430- 0.10.0-0.gst.1
431- new release
432
433* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
434- 0.9.7-0.gst.1
435- new release with 0.10 major/minor
436
437* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
438- new release
439- remove tta patch
440- don't check for languages, no translations yet
441- added gtk-doc
442
443* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
444- 0.9.4-0.gst.1
445- new release
446- added speed plugin
447
448* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
449- 0.9.3-0.gst.1
450- new release
451
Note: See TracBrowser for help on using the repository browser.