source: projects/specs/trunk/nonfree/self-build-gpac/self-build-gpac-vl.spec @ 7852

Revision 7852, 9.3 KB checked in by munepi, 11 years ago (diff)

added Obsoletes: %{name} <= %{version}-%{release} and so on.

Line 
1#% global svndate  20111217
2
3%define pkgname gpac
4%define name    self-build-%{pkgname}
5%define version 0.5.0
6%define release 3%{?svndate:.svn%svndate}%{?_dist_release}
7
8%define sourceurl0      http://prdownloads.sourceforge.net/gpac/%{pkgname}-%{version}.tar.gz
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           %{name}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16
17#Source9:     gpac-snapshot-vine.sh
18
19Source101:      gpac-0.5.0-libdir.patch
20Source102:      gpac-0.4.6-amr.patch
21
22License:        LGPLv2+
23Group:          Restricted Software
24
25Obsoletes:      %{pkgname} < %{version}, %{pkgname}-libs < %{version}
26Obsoletes:      %{pkgname}-devel < %{version}
27Obsoletes:      %{pkgname}-devel-static < %{version}
28Obsoletes:      %{name} < %{version}-%{release}
29
30Requires(post):         self-build-setup >= 0.9.9
31Requires(post):         subversion
32
33Requires(post):  ImageMagick
34Requires(post):  SDL-devel
35Requires(post):  librsvg2-devel >= 2.5.0
36Requires(post):  libGLU-devel
37Requires(post):  freeglut-devel
38Requires(post):  freetype2-devel >= 2.1.4
39Requires(post):  libjpeg-devel
40Requires(post):  libpng-devel >= 1.2.5
41Requires(post):  libxml2-devel
42Requires(post):  openssl-devel
43#Requires(post):  openjpeg-devel
44Requires(post):  pulseaudio-libs-devel
45Requires(post):  zlib-devel
46Requires(post):  libogg-devel libvorbis-devel libtheora-devel
47Requires(post):  libXt-devel
48Requires(post):  libXpm-devel
49Requires(post):  libXv-devel
50#Requires(post):  wxGTK-devel
51Requires(post):  xmlrpc-epi-devel
52%{?_with_mozilla:Requires(post): gecko-devel}
53#Requires(post):  doxygen
54Requires(post):  desktop-file-utils
55%{?_with_amr:Requires(post): amrnb-devel amrwb-devel}
56Requires(post):  self-build-a52dec
57Requires(post):  self-build-faad2
58Requires(post):  self-build-libmad
59Requires(post):  self-build-xvidcore >= 1.0.0
60##Requires(post):  self-build-ffmpeg
61
62BuildArch:      noarch
63BuildRoot:      %{_tmppath}/%{name}-%{version}-root
64
65Packager:       munepi
66
67%description
68GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
69from scratch in ANSI C.  The original development goal is to provide a clean,
70small and flexible alternative to the MPEG-4 Systems reference software.
71
72GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
73X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
74MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
75for MP4 and 3GPP(2) files and many tools for scene descriptions
76(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
77
78
79If you install this package, it automaticaly downloads source
80code ,compile it, and create rpm packages of %{pkgname}-%{version}.
81And the created rpm packages are automatically installed
82if installation is executed by apt-get command or synaptic
83package manager.
84
85[Note]
86This package requires many other packages to compile
87targetsoftware. So it consume more disk space than usual.
88Also installation takes logner time because of compilation.
89(This will take a few minutes to quarter or half of an hour,
90depends on building environment)
91
92[About self-build package]
93For some kind of software, distributing of binary package
94may viorate the patent or law. Therefore we chose self-build
95packge, create binary package on your machine, for such kind
96of softwares instead of distributing binary package.
97
98Please obey the national law when you use the created binary
99packages. And if you want to use the softwares using patented
100thechnology, it may be required to get a permission, make an
101agreement or purchas a license. Please consider it with your
102purpose or way of use and take appropriate action.
103
104%description -l ja
105GPAC は ANSI C でスクラッチから開発されている MPEG-4 システムの標準に基づいた
106マルチメディアフレームワークです。
107当初の開発目標には、MPEG-4 システムリファレンスソフトウェアに
108簡潔で小さく柔軟な代替を提供することです。
109
110GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
111X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
112MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
113for MP4 and 3GPP(2) files and many tools for scene descriptions
114(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
115
116
117このパッケージをインストールすると、自動的にソースコードを
118ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
119パッケージを作成します。
120また apt-get コマンドや synaptic パッケージマネージャから実行
121した場合は、作成された rpm パッケージのインストールも自動的に
122行います。
123
124[注意]
125コンパイルに必要な多くの関連パッケージを要求するので通常より
126ディスクの領域を多く消費します。
127またインストール時にコンパイルを行うため、通常より時間がかか
128る場合があります。(環境にもよりますが数分から数十分程度)
129
130[self-build パッケージについて]
131ソフトウェアによってはバイナリパッケージの配布が特許や法律に
132違反する可能性があるものがあります。その為、このような問題が
133懸念されるソフトウェアについてはバイナリパッケージを直接配布
134せずに、ユーザの環境でバイナリを作成する self-build パッケー
135ジという方法を採っています。
136
137作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
138アのライセンス、および利用する国の各種法令に従ってください。
139また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
140センスの購入などが必要となる場合がありますので、利用する目的
141や形態に応じて各自で判断し適切な対応を取ってください。
142
143
144%prep
145[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
146
147%install
148%{__rm} -rf ${RPM_BUILD_ROOT}
149%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
150%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
151%{__install} -m 644 %{SOURCE101} %{SOURCE102} \
152    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
153
154%clean
155%{__rm} -rf ${RPM_BUILD_ROOT}
156
157%posttrans
158# ## svn checkout
159# # set locale
160# case $LANG in
161#     ja*)LOCALE=ja ;;
162#     *) LOCALE=C ;;
163# esac
164
165# GetSrc_C(){
166#     echo -n "     "
167#     echo "Download source file with Subversion..."
168# }
169
170# GetSrc_ja(){
171#     echo -n "     "
172#     echo "Subversion を用いてソースファイルをダウンロードしています..."
173# }
174
175# GetSrc_$LOCALE
176
177# # svn checkout
178# . /etc/self-build.conf
179# (cd $TEMP_DIR
180# su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
181# %__mv %{pkgname}-%{svndate}.tar.bz2 %{_datadir}/%{name}/ || exit 1
182# )
183
184/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl0} 107000
185/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
186                                 %{pkgname}-libs-%{version}-%{release} \
187                                 %{pkgname}-devel-%{version}-%{release} \
188                                 %{pkgname}-devel-static-%{version}-%{release}
189
190
191%files
192%defattr(-,root,root)
193%{_datadir}/%{name}
194
195%changelog
196* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
197- added Obsoletes: %{name} < %{version}-%{release},
198  Obsoletes: %{pkgname} < %{version} and so on.
199
200* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
201- rebuild
202
203* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
204- new upstream release
205
206* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
207- rebuild
208
209* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
210- update snapshot svn20111217
211- removed upstreamed/obsolated patches
212- added Requires(post): subversion
213
214* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
215- rebuilt with internal openjpeg
216
217* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
218- rebuild
219
220* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
221- dropped Requires(post):  doxygen
222
223* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
224- renamed %%{Source0} to gpac-vl.spec
225
226* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
227- rebuild
228
229* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
230- changed from http://prdownloads.sourceforge.net in sourceurl0
231- added devel-static subpackage in gpac.spec
232- added gpac-0.4.5-mozjis-vine.patch
233  (do not install in /usr/share/self-build-gpac)
234
235* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-5
236- avoided to execute self-build-rpm.sh on RPM transaction
237  - moved %%post actions to %%posttrans
238
239* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
240- changed from http://prdownloads.sourceforge.net to http://dl.sourceforge.net
241  in sourceurl0
242- added BuildArch: noarch
243
244* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
245- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
246
247* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
248- dropped PreReq: self-build-ffmpeg
249  - rebuilt with ffmpeg-devel by self-build-ffmpeg
250
251* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
252- initial bulid
Note: See TracBrowser for help on using the repository browser.