source: projects/specs/trunk/nonfree/self-build-gpac/self-build-gpac-vl.spec @ 12249

Revision 12249, 10.1 KB checked in by ara_t, 4 years ago (diff)

self-build-gpac: update to 0.8.0

Line 
1#% global svndate  20111217
2
3%define pkgname gpac
4%define name  self-build-%{pkgname}
5%define version 0.8.0
6%define release 1%{?svndate:.svn%svndate}%{?_dist_release}
7
8%define sourceurl0  https://github.com/gpac/gpac/archive/v%{version}.tar.gz
9
10Summary:  Package to automatically build %{pkgname} rpm package
11Summary(ja):  %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:   %{name}
13Version:  %{version}
14Release:  %{release}
15Source0:  %{pkgname}-vl.spec
16
17#Source9:     gpac-snapshot-vine.sh
18
19# Source102:      gpac-0.4.6-amr.patch
20# Source103:      gpac-compatibility-openssl-1.1.patch
21
22License:  LGPLv2+
23Group:    Restricted Software
24
25Obsoletes:      %{pkgname} < %{version}, %{pkgname}-libs < %{version}
26Obsoletes:      %{pkgname}-devel < %{version}
27Obsoletes:      %{pkgname}-devel-static < %{version}
28Obsoletes:      %{name} < %{version}-%{release}
29
30Requires(post):   self-build-setup >= 0.9.9
31Requires(post):   subversion
32
33Requires(post):  ImageMagick
34Requires(post):  SDL-devel
35Requires(post):  librsvg2-devel >= 2.5.0
36Requires(post):  libGLU-devel
37Requires(post):  freeglut-devel
38Requires(post):  freetype2-devel >= 2.1.4
39Requires(post):  libjpeg-devel
40Requires(post):  libpng-devel >= 1.2.5
41Requires(post):  libxml2-devel
42Requires(post):  openssl-devel
43#Requires(post):  openjpeg-devel
44Requires(post):  pulseaudio-libs-devel
45Requires(post):  zlib-devel
46Requires(post):  libogg-devel libvorbis-devel libtheora-devel
47Requires(post):  libXt-devel
48Requires(post):  libXpm-devel
49Requires(post):  libXv-devel
50#Requires(post):  wxGTK-devel
51%{?_with_mozilla:Requires(post): gecko-devel}
52#Requires(post):  doxygen
53Requires(post):  desktop-file-utils
54%{?_with_amr:Requires(post): amrnb-devel amrwb-devel}
55Requires(post):  a52dec-devel
56# Requires(post):  self-build-a52dec
57Requires(post):  self-build-faad2
58Requires(post):  self-build-libmad
59Requires(post):  self-build-xvidcore >= 1.0.0
60##Requires(post):  self-build-ffmpeg
61
62BuildArch:  noarch
63BuildRoot:  %{_tmppath}/%{name}-%{version}-root
64
65Packager: munepi
66
67%description
68GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
69from scratch in ANSI C.  The original development goal is to provide a clean,
70small and flexible alternative to the MPEG-4 Systems reference software.
71
72GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
73X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
74MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
75for MP4 and 3GPP(2) files and many tools for scene descriptions
76(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
77
78
79If you install this package, it automaticaly downloads source
80code ,compile it, and create rpm packages of %{pkgname}-%{version}.
81And the created rpm packages are automatically installed
82if installation is executed by apt-get command or synaptic
83package manager.
84
85[Note]
86This package requires many other packages to compile
87targetsoftware. So it consume more disk space than usual.
88Also installation takes logner time because of compilation.
89(This will take a few minutes to quarter or half of an hour,
90depends on building environment)
91
92[About self-build package]
93For some kind of software, distributing of binary package
94may viorate the patent or law. Therefore we chose self-build
95packge, create binary package on your machine, for such kind
96of softwares instead of distributing binary package.
97
98Please obey the national law when you use the created binary
99packages. And if you want to use the softwares using patented
100thechnology, it may be required to get a permission, make an
101agreement or purchas a license. Please consider it with your
102purpose or way of use and take appropriate action.
103
104%description -l ja
105GPAC は ANSI C でスクラッチから開発されている MPEG-4 システムの標準に基づいた
106マルチメディアフレームワークです。
107当初の開発目標には、MPEG-4 システムリファレンスソフトウェアに
108簡潔で小さく柔軟な代替を提供することです。
109
110GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
111X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
112MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
113for MP4 and 3GPP(2) files and many tools for scene descriptions
114(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
115
116
117このパッケージをインストールすると、自動的にソースコードを
118ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
119パッケージを作成します。
120また apt-get コマンドや synaptic パッケージマネージャから実行
121した場合は、作成された rpm パッケージのインストールも自動的に
122行います。
123
124[注意]
125コンパイルに必要な多くの関連パッケージを要求するので通常より
126ディスクの領域を多く消費します。
127またインストール時にコンパイルを行うため、通常より時間がかか
128る場合があります。(環境にもよりますが数分から数十分程度)
129
130[self-build パッケージについて]
131ソフトウェアによってはバイナリパッケージの配布が特許や法律に
132違反する可能性があるものがあります。その為、このような問題が
133懸念されるソフトウェアについてはバイナリパッケージを直接配布
134せずに、ユーザの環境でバイナリを作成する self-build パッケー
135ジという方法を採っています。
136
137作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
138アのライセンス、および利用する国の各種法令に従ってください。
139また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
140センスの購入などが必要となる場合がありますので、利用する目的
141や形態に応じて各自で判断し適切な対応を取ってください。
142
143
144%prep
145[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
146
147%install
148%{__rm} -rf ${RPM_BUILD_ROOT}
149%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
150%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
151# %{__install} -m 644 %{SOURCE103} \
152#     ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
153
154%clean
155%{__rm} -rf ${RPM_BUILD_ROOT}
156
157%posttrans
158# ## svn checkout
159# # set locale
160# case $LANG in
161#     ja*)LOCALE=ja ;;
162#     *) LOCALE=C ;;
163# esac
164
165# GetSrc_C(){
166#     echo -n "     "
167#     echo "Download source file with Subversion..."
168# }
169
170# GetSrc_ja(){
171#     echo -n "     "
172#     echo "Subversion を用いてソースファイルをダウンロードしています..."
173# }
174
175# GetSrc_$LOCALE
176
177# # svn checkout
178# . /etc/self-build.conf
179# (cd $TEMP_DIR
180# su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
181# %__mv %{pkgname}-%{svndate}.tar.bz2 %{_datadir}/%{name}/ || exit 1
182# )
183
184/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl0} 60000
185/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
186                                 %{pkgname}-libs-%{version}-%{release} \
187                                 %{pkgname}-devel-%{version}-%{release} \
188                                 %{pkgname}-devel-static-%{version}-%{release}
189
190
191%files
192%defattr(-,root,root)
193%{_datadir}/%{name}
194
195%changelog
196* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 0.8.0-1
197- new upstream release
198- change BR: self-build-a52dec to a52dec-devel
199
200* Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 0.7.1-1
201- new upstream release
202- add Patch3 for compatibility with openssl-1.1
203
204* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-4
205- rebuild
206
207* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-3
208- rebuilt
209
210* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
211- rebuilt
212
213* Mon Mar 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-1
214- new upstream release
215- remove Source101 (gpac-0.5.0-libdir.patch)
216
217* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-5
218- rebuilt
219
220* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
221- remove Requires(post): xmlrpc-epi-devel
222
223* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
224- added Obsoletes: %{name} < %{version}-%{release},
225  Obsoletes: %{pkgname} < %{version} and so on.
226
227* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
228- rebuild
229
230* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
231- new upstream release
232
233* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
234- rebuild
235
236* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
237- update snapshot svn20111217
238- removed upstreamed/obsolated patches
239- added Requires(post): subversion
240
241* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
242- rebuilt with internal openjpeg
243
244* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
245- rebuild
246
247* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
248- dropped Requires(post):  doxygen
249
250* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
251- renamed %%{Source0} to gpac-vl.spec
252
253* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
254- rebuild
255
256* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
257- changed from http://prdownloads.sourceforge.net in sourceurl0
258- added devel-static subpackage in gpac.spec
259- added gpac-0.4.5-mozjis-vine.patch
260  (do not install in /usr/share/self-build-gpac)
261
262* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-5
263- avoided to execute self-build-rpm.sh on RPM transaction
264  - moved %%post actions to %%posttrans
265
266* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
267- changed from http://prdownloads.sourceforge.net to http://dl.sourceforge.net
268  in sourceurl0
269- added BuildArch: noarch
270
271* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
272- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
273
274* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
275- dropped PreReq: self-build-ffmpeg
276  - rebuilt with ffmpeg-devel by self-build-ffmpeg
277
278* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
279- initial bulid
Note: See TracBrowser for help on using the repository browser.