source: projects/specs/trunk/nonfree/self-build-gpac/gpac-vl.spec @ 9973

Revision 9973, 11.4 KB checked in by munepi, 8 years ago (diff)

new upstream release

Line 
1#% global svndate  20111217
2
3%define with_static   1
4
5Name:        gpac
6Summary:     MPEG-4 multimedia framework
7Version:     0.5.2
8Release:     3%{?svndate:.svn%svndate}%{?_dist_release}
9License:     LGPLv2+
10Group:       System Environment/Libraries
11URL:         http://gpac.sourceforge.net/
12Source0:     https://github.com/gpac/gpac/archive/v%{version}.tar.gz
13#Source0:     gpac-%{svndate}.tar.bz2
14#Source9:     gpac-snapshot-vine.sh
15
16Patch2:      gpac-0.4.6-amr.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Obsoletes:      %{name} < %{version}, %{name}-libs < %{version}
21Obsoletes:      %{name}-devel < %{version}
22Obsoletes:      %{name}-devel-static < %{version}
23
24Requires: %{name}-libs = %{version}-%{release}
25BuildRequires:  ImageMagick
26BuildRequires:  SDL-devel
27BuildRequires:  librsvg2-devel >= 2.5.0
28BuildRequires:  libGLU-devel
29BuildRequires:  freeglut-devel
30BuildRequires:  freetype2-devel >= 2.1.4
31BuildRequires:  libjpeg-devel
32BuildRequires:  libpng-devel >= 1.2.5
33BuildRequires:  libxml2-devel
34BuildRequires:  openssl-devel
35#BuildRequires:  openjpeg-devel
36BuildRequires:  pulseaudio-libs-devel
37BuildRequires:  zlib-devel
38BuildRequires:  libogg-devel libvorbis-devel libtheora-devel
39BuildRequires:  libXt-devel
40BuildRequires:  libXpm-devel
41BuildRequires:  libXv-devel
42#BuildRequires:  wxGTK-devel
43%{?_with_mozilla:BuildRequires: gecko-devel}
44#BuildRequires:  doxygen
45BuildRequires:  desktop-file-utils
46%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
47# *-devel packages provided by other self-build-* should only be listed
48# in self-build-%{name}.spec as PreReq.
49#BuildRequires:  a52dec-devel
50#BuildRequires:  faad2-devel
51#BuildRequires:  libmad-devel
52#BuildRequires:  xvidcore-devel >= 1.0.0
53##BuildRequires:  ffmpeg-devel
54
55
56%description
57GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
58from scratch in ANSI C.  The original development goal is to provide a clean,
59small and flexible alternative to the MPEG-4 Systems reference software.
60
61GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
62X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
63MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
64for MP4 and 3GPP(2) files and many tools for scene descriptions
65(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
66
67%package        libs
68Summary:        Library for %{name}
69Group:          System Environment/Libraries
70
71%description    libs
72The %{name}-libs package contains library for %{name}.
73
74
75%package  devel
76Summary:  Development libraries and files for %{name}
77Group:    Development/Libraries
78Requires: %{name}-libs = %{version}-%{release}
79
80
81%description  devel
82Development libraries and files for gpac.
83
84
85%if %{with_static}
86%package  devel-static
87Summary:  Development libraries and files for %{name}
88Group:    Development/Libraries
89Requires: %{name}-devel = %{version}-%{release}
90
91
92%description  devel-static
93Static library for gpac.
94%endif
95
96
97%prep
98%setup -q
99## remove extra_libs directory
100%__rm -rf extra_libs
101
102%patch2 -p1 -b .amr
103
104## kwizart - enable dynamic mode - hardcoded with patch2
105# define SONAME number from the first number of gpac version.
106#define soname libgpac.so.0
107#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
108
109# Fix encoding warnings
110%__cp -p Changelog Changelog.origine
111iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
112touch -r Changelog.origine Changelog
113%__rm -rf Changelog.origine
114
115%__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
116iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine >  doc/ipmpx_syntax.bt
117touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
118%__rm -rf doc/ipmpx_syntax.bt.origine
119
120
121# executable ./configure
122chmod +x configure
123
124%build
125%configure \
126    --extra-cflags="$RPM_OPT_FLAGS -fPIC -DPIC -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
127  --X11-path=%{_prefix} \
128  --libdir=%{_lib} \
129    --disable-oss-audio \
130    %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
131    %{?_with_amr:--enable-amr} \
132    --disable-static \
133    --use-js=no \
134    \
135    --disable-wx \
136    ;
137
138#Avoid mess with setup.h
139%__cp -p config.h include/gpac
140
141# Parallele build will fail
142%__make all
143%__make sggen
144
145# ## kwizart - build doxygen doc for devel
146# pushd doc
147# doxygen
148# popd
149
150%install
151%__rm -rf $RPM_BUILD_ROOT
152%__make DESTDIR=$RPM_BUILD_ROOT install install-lib INSTFLAGS="-p"
153
154#Install generated sggen binaries
155#MPEG4 SVG X3D
156for b in MPEG4 X3D; do
157  pushd applications/generators/${b}
158    %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
159  popd
160done
161
162#config.h like but not only
163#Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
164%__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
165touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
166touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
167touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
168%__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
169
170
171%clean
172%__rm -rf $RPM_BUILD_ROOT
173
174%post libs -p /sbin/ldconfig
175
176%postun libs -p /sbin/ldconfig
177
178
179%files
180%defattr(-,root,root,-)
181%doc AUTHORS BUGS Changelog COPYING README TODO
182%{_bindir}/MP4*
183%{_bindir}/*Gen
184%{_datadir}/gpac/
185%{_mandir}/man1/*.1.*
186
187%files libs
188%defattr(-,root,root)
189%{_libdir}/libgpac.so.*
190%{_libdir}/gpac/
191
192%files devel
193%doc doc/CODING_STYLE doc/ipmpx_syntax.bt
194%defattr(-,root,root)
195%{_includedir}/gpac/
196%{_libdir}/libgpac.so
197
198%if %{with_static}
199%files devel-static
200%defattr(-,root,root,-)
201%{_libdir}/libgpac_static.a
202%else
203%exclude %{_libdir}/libgpac_static.a
204%endif
205
206
207%changelog
208* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-3
209- rebuilt
210
211* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
212- rebuilt
213
214* Mon Mar 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-1
215- new upstream release
216- remove Patch1 (gpac-0.5.0-libdir.patch)
217
218* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-5
219- rebuilt
220
221* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
222- remove BuildRequires: xmlrpc-epi-devel
223
224* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
225- added Obsoletes: %{name} < %{version} and so on.
226
227* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
228- rebuild
229
230* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
231- new upstream release
232
233* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
234- rebuild
235
236* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
237- update snapshot svn20111217
238- removed upstreamed/obsolated patches
239
240* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
241- rebuilt with internal openjpeg
242  - added --use-openjpeg=local in configure options
243- added --enable-pic in configure options
244
245* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
246- rebuild
247
248* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
249- removed doxygen support
250
251* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
252- change release to sync with self-build-gpac
253
254* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
255- rebuild
256
257* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
258- added --use-js=no in configure
259- added devel-static subpackage
260
261* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
262- change release to sync with self-build-gpac
263
264* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
265- change release to sync with self-build-gpac
266
267* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
268- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
269- corrected default %%defattr
270
271* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
272- dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
273  - rebuilt with ffmpeg-devel by self-build-ffmpeg
274
275* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
276- initial build based on RPM Fusion
277  - without Osmo4 and its plugins for Mozilla browsers
278  - added --disable-wx in configure options
279  - included %%{_libdir}/libgpac_static.a in devel subpackage
280
281* Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
282- Fix -devel doc timestamp which leads to multilib conflict
283  ( RPM Fusion #270 )
284
285* Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
286- Fix for ppc64
287
288* Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
289- Update to 0.4.5 (final)
290- Drop upstreamed patches - Rewrite some
291- Add More BR.
292- Conditionalize --with mozilla amr
293
294* Mon Sep  8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
295- Fix for Large File Support (was livna #2075 )
296
297* Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
298- Enable devel-static
299- Conditionalize Osmo4 (buggy).
300- Clean the spec
301
302* Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
303- Update to 20080217.
304- Split libs.
305- Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
306- Add openjpeg-devel missing BR
307- Static patching instead of dyn patch when possible.
308- Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
309- Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
310- Exclude static lib
311
312* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
313- Use %%{smp_mflags}
314- Oops, we're actually 0.4.5
315- Fix gpac so filenames
316- Only install nposmozilla when %%{with_firefox} is set
317
318* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
319- Update to 20080211cvs
320- Disable osmozilla, doesn't build with xulrunner
321- Fix builds with gcc 4.3
322
323* Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
324- Rebuild for rawhide
325
326* Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
327- Update to v4.4
328
329* Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
330- Update to cvs 20070526
331- Enable conditional build ( 3gpp firefox )
332
333* Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
334- Update to cvs 20070411
335
336* Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
337- Update to 20061208
338- Uses firefox-devel (since fc6!)
339- Drop tutorial
340- Use version-DEV-date with libgpac.so
341- Disabled osmozilla
342- Fix soname
343- Enabled gprof
344
345* Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
346- gpac snapshot.sh
347- Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
348- TODO: - no-soname make option for libgpac.so
349  - static lib in devel - needed ?
350  - osmozilla - xpt link problem.
351  - Osmo4: segmentation fault on exit.
352  - MP4Client: segmentation fault on launch.
353  - The program 'Osmo4' received an X Window System error:
354  "The error was 'BadMatch (invalid parameter attributes)'.
355  (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
356  - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
357
358* Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
359- Update to 0.4.2cvs20061017
360- Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
361- Enable mozilla plugin: osmozilla.
362- Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
363- Provide documentation html in doc .
364- Provide tutorial from http://www.wildamerica.com/pages/Marty.html
365- Various corrections.
366
367* Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
368- lib64 fixes
369
370* Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
371- initial package
Note: See TracBrowser for help on using the repository browser.