source: projects/specs/trunk/nonfree/self-build-gpac/gpac-vl.spec @ 7852

Revision 7852, 11.2 KB checked in by munepi, 11 years ago (diff)

added Obsoletes: %{name} <= %{version}-%{release} and so on.

Line 
1#% global svndate  20111217
2
3%define with_static   1
4
5Name:        gpac
6Summary:     MPEG-4 multimedia framework
7Version:     0.5.0
8Release:     3%{?svndate:.svn%svndate}%{?_dist_release}
9License:     LGPLv2+
10Group:       System Environment/Libraries
11URL:         http://gpac.sourceforge.net/
12Source0:     http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
13#Source0:     gpac-%{svndate}.tar.bz2
14#Source9:     gpac-snapshot-vine.sh
15
16Patch1:      gpac-0.5.0-libdir.patch
17Patch2:      gpac-0.4.6-amr.patch
18
19BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
20
21Obsoletes:      %{name} < %{version}, %{name}-libs < %{version}
22Obsoletes:      %{name}-devel < %{version}
23Obsoletes:      %{name}-devel-static < %{version}
24
25Requires: %{name}-libs = %{version}-%{release}
26BuildRequires:  ImageMagick
27BuildRequires:  SDL-devel
28BuildRequires:  librsvg2-devel >= 2.5.0
29BuildRequires:  libGLU-devel
30BuildRequires:  freeglut-devel
31BuildRequires:  freetype2-devel >= 2.1.4
32BuildRequires:  libjpeg-devel
33BuildRequires:  libpng-devel >= 1.2.5
34BuildRequires:  libxml2-devel
35BuildRequires:  openssl-devel
36#BuildRequires:  openjpeg-devel
37BuildRequires:  pulseaudio-libs-devel
38BuildRequires:  zlib-devel
39BuildRequires:  libogg-devel libvorbis-devel libtheora-devel
40BuildRequires:  libXt-devel
41BuildRequires:  libXpm-devel
42BuildRequires:  libXv-devel
43#BuildRequires:  wxGTK-devel
44BuildRequires:  xmlrpc-epi-devel
45%{?_with_mozilla:BuildRequires: gecko-devel}
46#BuildRequires:  doxygen
47BuildRequires:  desktop-file-utils
48%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
49# *-devel packages provided by other self-build-* should only be listed
50# in self-build-%{name}.spec as PreReq.
51#BuildRequires:  a52dec-devel
52#BuildRequires:  faad2-devel
53#BuildRequires:  libmad-devel
54#BuildRequires:  xvidcore-devel >= 1.0.0
55##BuildRequires:  ffmpeg-devel
56
57
58%description
59GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
60from scratch in ANSI C.  The original development goal is to provide a clean,
61small and flexible alternative to the MPEG-4 Systems reference software.
62
63GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
64X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
65MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
66for MP4 and 3GPP(2) files and many tools for scene descriptions
67(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
68
69%package        libs
70Summary:        Library for %{name}
71Group:          System Environment/Libraries
72
73%description    libs
74The %{name}-libs package contains library for %{name}.
75
76
77%package  devel
78Summary:  Development libraries and files for %{name}
79Group:    Development/Libraries
80Requires: %{name}-libs = %{version}-%{release}
81
82
83%description  devel
84Development libraries and files for gpac.
85
86
87%if %{with_static}
88%package  devel-static
89Summary:  Development libraries and files for %{name}
90Group:    Development/Libraries
91Requires: %{name}-devel = %{version}-%{release}
92
93
94%description  devel-static
95Static library for gpac.
96%endif
97
98
99%prep
100%setup -q -n gpac
101## remove extra_libs directory
102%__rm -rf extra_libs
103
104%patch1 -p1 -b .libdir
105%patch2 -p1 -b .amr
106
107## kwizart - enable dynamic mode - hardcoded with patch2
108# define SONAME number from the first number of gpac version.
109#define soname libgpac.so.0
110#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
111
112# Fix encoding warnings
113%__cp -p Changelog Changelog.origine
114iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
115touch -r Changelog.origine Changelog
116%__rm -rf Changelog.origine
117
118%__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
119iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine >  doc/ipmpx_syntax.bt
120touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
121%__rm -rf doc/ipmpx_syntax.bt.origine
122
123
124# executable ./configure
125chmod +x configure
126
127%build
128%configure \
129    --X11-path=%{_prefix} \
130    --libdir=%{_lib} \
131    %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
132    --enable-pic \
133    --disable-static \
134    --disable-wx \
135    --extra-cflags="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
136    --disable-oss-audio \
137    %{?_with_amr:--enable-amr} \
138    --use-js=no \
139    ;
140
141#Avoid mess with setup.h
142cp -p config.h include/gpac
143
144# Parallele build will fail
145%__make all OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
146#{?_smp_mflags}
147%__make sggen OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
148#{?_smp_mflags}
149
150# ## kwizart - build doxygen doc for devel
151# pushd doc
152# doxygen
153# popd
154
155%install
156%__rm -rf $RPM_BUILD_ROOT
157%__make DESTDIR=$RPM_BUILD_ROOT install install-lib
158
159#Install generated sggen binaries
160#MPEG4 SVG X3D
161for b in MPEG4 X3D; do
162  pushd applications/generators/${b}
163    %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
164  popd
165done
166
167# #Fix doxygen timestamp
168# touch -r Changelog doc/html/*
169
170#config.h like but not only
171#Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
172%__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
173touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
174touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
175touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
176%__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
177
178
179%clean
180%__rm -rf $RPM_BUILD_ROOT
181
182%post libs -p /sbin/ldconfig
183
184%postun libs -p /sbin/ldconfig
185
186
187%files
188%defattr(-,root,root,-)
189%doc AUTHORS BUGS Changelog COPYING README TODO
190%{_bindir}/MP4*
191%{_bindir}/*Gen
192%{_datadir}/gpac/
193%{_mandir}/man1/*.1.*
194
195%files libs
196%defattr(-,root,root)
197%{_libdir}/libgpac.so.*
198%{_libdir}/gpac/
199
200%files devel
201%doc doc/CODING_STYLE doc/ipmpx_syntax.bt
202%defattr(-,root,root)
203%{_includedir}/gpac/
204%{_libdir}/libgpac.so
205
206%if %{with_static}
207%files devel-static
208%defattr(-,root,root,-)
209%{_libdir}/libgpac_static.a
210%else
211%exclude %{_libdir}/libgpac_static.a
212%endif
213
214
215%changelog
216* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
217- added Obsoletes: %{name} < %{version} and so on.
218
219* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
220- rebuild
221
222* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
223- new upstream release
224
225* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
226- rebuild
227
228* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
229- update snapshot svn20111217
230- removed upstreamed/obsolated patches
231
232* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
233- rebuilt with internal openjpeg
234  - added --use-openjpeg=local in configure options
235- added --enable-pic in configure options
236
237* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
238- rebuild
239
240* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
241- removed doxygen support
242
243* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
244- change release to sync with self-build-gpac
245
246* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
247- rebuild
248
249* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
250- added --use-js=no in configure
251- added devel-static subpackage
252
253* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
254- change release to sync with self-build-gpac
255
256* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
257- change release to sync with self-build-gpac
258
259* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
260- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
261- corrected default %%defattr
262
263* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
264- dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
265  - rebuilt with ffmpeg-devel by self-build-ffmpeg
266
267* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
268- initial build based on RPM Fusion
269  - without Osmo4 and its plugins for Mozilla browsers
270  - added --disable-wx in configure options
271  - included %%{_libdir}/libgpac_static.a in devel subpackage
272
273* Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
274- Fix -devel doc timestamp which leads to multilib conflict
275  ( RPM Fusion #270 )
276
277* Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
278- Fix for ppc64
279
280* Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
281- Update to 0.4.5 (final)
282- Drop upstreamed patches - Rewrite some
283- Add More BR.
284- Conditionalize --with mozilla amr
285
286* Mon Sep  8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
287- Fix for Large File Support (was livna #2075 )
288
289* Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
290- Enable devel-static
291- Conditionalize Osmo4 (buggy).
292- Clean the spec
293
294* Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
295- Update to 20080217.
296- Split libs.
297- Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
298- Add openjpeg-devel missing BR
299- Static patching instead of dyn patch when possible.
300- Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
301- Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
302- Exclude static lib
303
304* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
305- Use %%{smp_mflags}
306- Oops, we're actually 0.4.5
307- Fix gpac so filenames
308- Only install nposmozilla when %%{with_firefox} is set
309
310* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
311- Update to 20080211cvs
312- Disable osmozilla, doesn't build with xulrunner
313- Fix builds with gcc 4.3
314
315* Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
316- Rebuild for rawhide
317
318* Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
319- Update to v4.4
320
321* Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
322- Update to cvs 20070526
323- Enable conditional build ( 3gpp firefox )
324
325* Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
326- Update to cvs 20070411
327
328* Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
329- Update to 20061208
330- Uses firefox-devel (since fc6!)
331- Drop tutorial
332- Use version-DEV-date with libgpac.so
333- Disabled osmozilla
334- Fix soname
335- Enabled gprof
336
337* Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
338- gpac snapshot.sh
339- Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
340- TODO: - no-soname make option for libgpac.so
341  - static lib in devel - needed ?
342  - osmozilla - xpt link problem.
343  - Osmo4: segmentation fault on exit.
344  - MP4Client: segmentation fault on launch.
345  - The program 'Osmo4' received an X Window System error:
346  "The error was 'BadMatch (invalid parameter attributes)'.
347  (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
348  - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
349
350* Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
351- Update to 0.4.2cvs20061017
352- Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
353- Enable mozilla plugin: osmozilla.
354- Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
355- Provide documentation html in doc .
356- Provide tutorial from http://www.wildamerica.com/pages/Marty.html
357- Various corrections.
358
359* Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
360- lib64 fixes
361
362* Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
363- initial package
Note: See TracBrowser for help on using the repository browser.