source: projects/specs/trunk/nonfree/self-build-gpac/gpac-vl.spec @ 12249

Revision 12249, 11.8 KB checked in by ara_t, 4 years ago (diff)

self-build-gpac: update to 0.8.0

Line 
1#% global svndate  20111217
2
3%define with_static   1
4
5Name:        gpac
6Summary:     MPEG-4 multimedia framework
7Version:     0.8.0
8Release:     1%{?svndate:.svn%svndate}%{?_dist_release}
9License:     LGPLv2+
10Group:       System Environment/Libraries
11URL:         http://gpac.sourceforge.net/
12Source0:     https://github.com/gpac/gpac/archive/v%{version}.tar.gz
13#Source0:     gpac-%{svndate}.tar.bz2
14#Source9:     gpac-snapshot-vine.sh
15
16# Patch2:      gpac-0.4.6-amr.patch
17Patch3:      gpac-compatibility-openssl-1.1.patch
18
19BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
20
21Obsoletes:      %{name} < %{version}, %{name}-libs < %{version}
22Obsoletes:      %{name}-devel < %{version}
23Obsoletes:      %{name}-devel-static < %{version}
24
25Requires: %{name}-libs = %{version}-%{release}
26BuildRequires:  ImageMagick
27BuildRequires:  SDL-devel
28BuildRequires:  librsvg2-devel >= 2.5.0
29BuildRequires:  libGLU-devel
30BuildRequires:  freeglut-devel
31BuildRequires:  freetype2-devel >= 2.1.4
32BuildRequires:  libjpeg-devel
33BuildRequires:  libpng-devel >= 1.2.5
34BuildRequires:  libxml2-devel
35BuildRequires:  openssl-devel
36#BuildRequires:  openjpeg-devel
37BuildRequires:  pulseaudio-libs-devel
38BuildRequires:  zlib-devel
39BuildRequires:  libogg-devel libvorbis-devel libtheora-devel
40BuildRequires:  libXt-devel
41BuildRequires:  libXpm-devel
42BuildRequires:  libXv-devel
43#BuildRequires:  wxGTK-devel
44%{?_with_mozilla:BuildRequires: gecko-devel}
45#BuildRequires:  doxygen
46BuildRequires:  desktop-file-utils
47%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
48# *-devel packages provided by other self-build-* should only be listed
49# in self-build-%{name}.spec as PreReq.
50##BuildRequires:  a52dec-devel
51#BuildRequires:  faad2-devel
52#BuildRequires:  libmad-devel
53#BuildRequires:  xvidcore-devel >= 1.0.0
54##BuildRequires:  ffmpeg-devel
55
56
57%description
58GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
59from scratch in ANSI C.  The original development goal is to provide a clean,
60small and flexible alternative to the MPEG-4 Systems reference software.
61
62GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
63X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
64MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
65for MP4 and 3GPP(2) files and many tools for scene descriptions
66(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
67
68%package        libs
69Summary:        Library for %{name}
70Group:          System Environment/Libraries
71
72%description    libs
73The %{name}-libs package contains library for %{name}.
74
75
76%package  devel
77Summary:  Development libraries and files for %{name}
78Group:    Development/Libraries
79Requires: %{name}-libs = %{version}-%{release}
80
81
82%description  devel
83Development libraries and files for gpac.
84
85
86%if %{with_static}
87%package  devel-static
88Summary:  Development libraries and files for %{name}
89Group:    Development/Libraries
90Requires: %{name}-devel = %{version}-%{release}
91
92
93%description  devel-static
94Static library for gpac.
95%endif
96
97
98%prep
99%setup -q
100## remove extra_libs directory
101%__rm -rf extra_libs
102
103# %patch2 -p1 -b .amr
104# %patch3 -p1 -b .openssl-1.1
105
106## kwizart - enable dynamic mode - hardcoded with patch2
107# define SONAME number from the first number of gpac version.
108#define soname libgpac.so.0
109#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
110
111# Fix encoding warnings
112%__cp -p Changelog Changelog.origine
113iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
114touch -r Changelog.origine Changelog
115%__rm -rf Changelog.origine
116
117%__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
118iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine >  doc/ipmpx_syntax.bt
119touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
120%__rm -rf doc/ipmpx_syntax.bt.origine
121
122
123# executable ./configure
124chmod +x configure
125
126%build
127%configure \
128    --extra-cflags="$RPM_OPT_FLAGS -fPIC -DPIC -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
129  --X11-path=%{_prefix} \
130  --libdir=%{_lib} \
131    --disable-oss-audio \
132    --disable-static \
133    --use-js=no \
134    \
135    --disable-wx \
136    ;
137
138#Avoid mess with setup.h
139%__cp -p config.h include/gpac
140
141# Parallele build will fail
142%__make all
143%__make sggen
144
145# ## kwizart - build doxygen doc for devel
146# pushd doc
147# doxygen
148# popd
149
150%install
151%__rm -rf $RPM_BUILD_ROOT
152%__make DESTDIR=$RPM_BUILD_ROOT install install-lib INSTFLAGS="-p"
153
154#Install generated sggen binaries
155#MPEG4 SVG X3D
156for b in MPEG4 X3D; do
157  pushd applications/generators/${b}
158    %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
159  popd
160done
161
162#config.h like but not only
163#Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
164%__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
165touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
166touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
167touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
168%__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
169
170rm -rf %{buildroot}%{_includedir}/win{32,ce}
171
172%clean
173%__rm -rf $RPM_BUILD_ROOT
174
175%post libs -p /sbin/ldconfig
176
177%postun libs -p /sbin/ldconfig
178
179
180%files
181%defattr(-,root,root,-)
182%doc AUTHORS BUGS Changelog COPYING README.md TODO
183%{_bindir}/MP4*
184%{_bindir}/*Gen
185%{_datadir}/gpac/
186%{_mandir}/man1/*.1.*
187
188%files libs
189%defattr(-,root,root)
190%{_libdir}/libgpac.so.*
191%{_libdir}/gpac/
192
193%files devel
194%doc doc/CODING_STYLE doc/ipmpx_syntax.bt
195%defattr(-,root,root)
196%{_includedir}/gpac/
197%{_libdir}/libgpac.so
198
199%if %{with_static}
200%files devel-static
201%defattr(-,root,root,-)
202%{_libdir}/libgpac_static.a
203%else
204%exclude %{_libdir}/libgpac_static.a
205%endif
206
207
208%changelog
209* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 0.8.0-1
210- new upstream release
211- change BR: self-build-a52dec to a52dec-devel
212
213* Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 0.7.1-1
214- new upstream release
215- add Patch3 for compatibility with openssl-1.1
216
217* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-4
218- rebuild
219
220* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-3
221- rebuilt
222
223* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
224- rebuilt
225
226* Mon Mar 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-1
227- new upstream release
228- remove Patch1 (gpac-0.5.0-libdir.patch)
229
230* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-5
231- rebuilt
232
233* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
234- remove BuildRequires: xmlrpc-epi-devel
235
236* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
237- added Obsoletes: %{name} < %{version} and so on.
238
239* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
240- rebuild
241
242* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
243- new upstream release
244
245* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
246- rebuild
247
248* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
249- update snapshot svn20111217
250- removed upstreamed/obsolated patches
251
252* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
253- rebuilt with internal openjpeg
254  - added --use-openjpeg=local in configure options
255- added --enable-pic in configure options
256
257* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
258- rebuild
259
260* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
261- removed doxygen support
262
263* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
264- change release to sync with self-build-gpac
265
266* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
267- rebuild
268
269* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
270- added --use-js=no in configure
271- added devel-static subpackage
272
273* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
274- change release to sync with self-build-gpac
275
276* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
277- change release to sync with self-build-gpac
278
279* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
280- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
281- corrected default %%defattr
282
283* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
284- dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
285  - rebuilt with ffmpeg-devel by self-build-ffmpeg
286
287* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
288- initial build based on RPM Fusion
289  - without Osmo4 and its plugins for Mozilla browsers
290  - added --disable-wx in configure options
291  - included %%{_libdir}/libgpac_static.a in devel subpackage
292
293* Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
294- Fix -devel doc timestamp which leads to multilib conflict
295  ( RPM Fusion #270 )
296
297* Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
298- Fix for ppc64
299
300* Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
301- Update to 0.4.5 (final)
302- Drop upstreamed patches - Rewrite some
303- Add More BR.
304- Conditionalize --with mozilla amr
305
306* Mon Sep  8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
307- Fix for Large File Support (was livna #2075 )
308
309* Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
310- Enable devel-static
311- Conditionalize Osmo4 (buggy).
312- Clean the spec
313
314* Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
315- Update to 20080217.
316- Split libs.
317- Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
318- Add openjpeg-devel missing BR
319- Static patching instead of dyn patch when possible.
320- Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
321- Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
322- Exclude static lib
323
324* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
325- Use %%{smp_mflags}
326- Oops, we're actually 0.4.5
327- Fix gpac so filenames
328- Only install nposmozilla when %%{with_firefox} is set
329
330* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
331- Update to 20080211cvs
332- Disable osmozilla, doesn't build with xulrunner
333- Fix builds with gcc 4.3
334
335* Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
336- Rebuild for rawhide
337
338* Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
339- Update to v4.4
340
341* Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
342- Update to cvs 20070526
343- Enable conditional build ( 3gpp firefox )
344
345* Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
346- Update to cvs 20070411
347
348* Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
349- Update to 20061208
350- Uses firefox-devel (since fc6!)
351- Drop tutorial
352- Use version-DEV-date with libgpac.so
353- Disabled osmozilla
354- Fix soname
355- Enabled gprof
356
357* Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
358- gpac snapshot.sh
359- Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
360- TODO: - no-soname make option for libgpac.so
361  - static lib in devel - needed ?
362  - osmozilla - xpt link problem.
363  - Osmo4: segmentation fault on exit.
364  - MP4Client: segmentation fault on launch.
365  - The program 'Osmo4' received an X Window System error:
366  "The error was 'BadMatch (invalid parameter attributes)'.
367  (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
368  - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
369
370* Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
371- Update to 0.4.2cvs20061017
372- Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
373- Enable mozilla plugin: osmozilla.
374- Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
375- Provide documentation html in doc .
376- Provide tutorial from http://www.wildamerica.com/pages/Marty.html
377- Various corrections.
378
379* Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
380- lib64 fixes
381
382* Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
383- initial package
Note: See TracBrowser for help on using the repository browser.