source: projects/specs/trunk/nonfree/self-build-ffmpeg2theora/self-build-ffmpeg2theora-vl.spec @ 7433

Revision 7433, 5.7 KB checked in by munepi, 11 years ago (diff)

new upstream release

Line 
1#% global posttag svn18423
2%define pkgname ffmpeg2theora
3%define name    self-build-%{pkgname}
4%define version 0.29
5%define release 1%{?posttag:.%{posttag}}%{?_dist_release}
6
7%define sourceurl       http://www.v2v.cc/~j/ffmpeg2theora/downloads/%{pkgname}-%{version}.tar.bz2
8
9Summary:        Package to automatically build %{pkgname} rpm package
10Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
11Name:           %{name}
12Version:        %{version}
13Release:        %{release}
14Source0:        %{pkgname}-vl.spec
15Source10:       ffmpeg2theora-snapshot.sh
16#Source100:     ffmpeg2theora-0.28+%{posttag}.patch
17License:        GPLv2+
18Group:          Restricted Software
19
20Requires(post):         self-build-setup >= 0.9.9
21
22# (build)requies of target package.
23Requires(post):         scons
24Requires(post):         libogg-devel >= 1.1
25Requires(post):         libtheora-devel >= 1.1.0
26Requires(post):         libvorbis-devel
27Requires(post):         self-build-ffmpeg >= 0.6.1
28
29BuildArch:      noarch
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31
32Packager:       munepi
33
34%description
35ffmpeg2theora is a tool to convert any file that ffmpeg can
36decode to theora.
37
38If you install this package, it automaticaly downloads source
39code ,compile it, and create rpm packages of %{pkgname}-%{version}.
40And the created rpm packages are automatically installed
41if installation is executed by apt-get command or synaptic
42package manager.
43
44
45[Note]
46This package requires many other packages to compile
47targetsoftware. So it consume more disk space than usual.
48Also installation takes logner time because of compilation.
49(This will take a few minutes to quarter or half of an hour,
50depends on building environment)
51
52[About self-build package]
53For some kind of software, distributing of binary package
54may viorate the patent or law. Therefore we chose self-build
55packge, create binary package on your machine, for such kind
56of softwares instead of distributing binary package.
57
58Please obey the national law when you use the created binary
59packages. And if you want to use the softwares using patented
60thechnology, it may be required to get a permission, make an
61agreement or purchas a license. Please consider it with your
62purpose or way of use and take appropriate action.
63
64%description -l ja
65ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
66に変換するツールです。
67
68このパッケージをインストールすると、自動的にソースコードを
69ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
70パッケージを作成します。
71また apt-get コマンドや synaptic パッケージマネージャから実行
72した場合は、作成された rpm パッケージのインストールも自動的に
73行います。
74
75
76[注意]
77コンパイルに必要な多くの関連パッケージを要求するので通常より
78ディスクの領域を多く消費します。
79またインストール時にコンパイルを行うため、通常より時間がかか
80る場合があります。(環境にもよりますが数分から数十分程度)
81
82[self-build パッケージについて]
83ソフトウェアによってはバイナリパッケージの配布が特許や法律に
84違反する可能性があるものがあります。その為、このような問題が
85懸念されるソフトウェアについてはバイナリパッケージを直接配布
86せずに、ユーザの環境でバイナリを作成する self-build パッケー
87ジという方法を採っています。
88
89作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
90アのライセンス、および利用する国の各種法令に従ってください。
91また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
92センスの購入などが必要となる場合がありますので、利用する目的
93や形態に応じて各自で判断し適切な対応を取ってください。
94
95
96%prep
97[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
98
99
100%install
101%{__rm} -rf ${RPM_BUILD_ROOT}
102%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
103%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
104#%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
105
106
107%clean
108%{__rm} -rf ${RPM_BUILD_ROOT}
109
110%posttrans
111/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 11000
112#/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
113
114%files
115%defattr(-,root,root)
116%{_datadir}/%{name}
117
118%changelog
119* Mon Feb  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.29-1
120- new upstream release
121
122* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.28-2.svn18423
123- update to the latest upstream commit
124  - for ffmpeg 0.10 compatibility
125
126* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.28-1
127- new upstream release
128- License: GPLv2+
129
130* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.27-1
131- new upstream release
132- fixed the location of %%sourceurl
133
134* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-2
135- renamed %%{Source0} to ffmpeg2theora-vl.spec
136
137* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-1
138- new upstream release
139  - with recent ffmpeg
140
141* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.24-1
142- new upstream release
143
144* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-2
145- added BuildArch: noarch
146- avoided to execute self-build-rpm.sh on RPM transaction
147  - moved %%post actions to %%posttrans
148
149* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-1
150- new upstream release
151- dropped ffmpeg2theora-0.20-new_ffmpeg.patch
152- added PreReq: scons
153
154* Sat May 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.20-2
155- spec in utf8
156
157* Sat May 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.20-1
158- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.