source: projects/specs/trunk/nonfree/self-build-ffmpeg2theora/self-build-ffmpeg2theora-vl.spec @ 615

Revision 615, 5.0 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname ffmpeg2theora
2%define name    self-build-%{pkgname}
3%define version 0.25
4%define release 2%{?_dist_release}
5
6%define sourceurl       http://www.v2v.cc/~j/ffmpeg2theora/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14License:        GPL
15Group:          Restricted Software
16
17Requires(post):         self-build-setup >= 0.9.9
18
19# (build)requies of target package.
20Requires(post):         scons
21Requires(post):         libogg-devel, libtheora-devel, libvorbis-devel
22Requires(post):         self-build-ffmpeg
23
24BuildArch:      noarch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27Packager:       munepi
28
29%description
30ffmpeg2theora is a tool to convert any file that ffmpeg can
31decode to theora.
32
33If you install this package, it automaticaly downloads source
34code ,compile it, and create rpm packages of %{pkgname}-%{version}.
35And the created rpm packages are automatically installed
36if installation is executed by apt-get command or synaptic
37package manager.
38
39
40[Note]
41This package requires many other packages to compile
42targetsoftware. So it consume more disk space than usual.
43Also installation takes logner time because of compilation.
44(This will take a few minutes to quarter or half of an hour,
45depends on building environment)
46
47[About self-build package]
48For some kind of software, distributing of binary package
49may viorate the patent or law. Therefore we chose self-build
50packge, create binary package on your machine, for such kind
51of softwares instead of distributing binary package.
52
53Please obey the national law when you use the created binary
54packages. And if you want to use the softwares using patented
55thechnology, it may be required to get a permission, make an
56agreement or purchas a license. Please consider it with your
57purpose or way of use and take appropriate action.
58
59%description -l ja
60ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
61に変換するツールです。
62
63このパッケージをインストールすると、自動的にソースコードを
64ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
65パッケージを作成します。
66また apt-get コマンドや synaptic パッケージマネージャから実行
67した場合は、作成された rpm パッケージのインストールも自動的に
68行います。
69
70
71[注意]
72コンパイルに必要な多くの関連パッケージを要求するので通常より
73ディスクの領域を多く消費します。
74またインストール時にコンパイルを行うため、通常より時間がかか
75る場合があります。(環境にもよりますが数分から数十分程度)
76
77[self-build パッケージについて]
78ソフトウェアによってはバイナリパッケージの配布が特許や法律に
79違反する可能性があるものがあります。その為、このような問題が
80懸念されるソフトウェアについてはバイナリパッケージを直接配布
81せずに、ユーザの環境でバイナリを作成する self-build パッケー
82ジという方法を採っています。
83
84作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
85アのライセンス、および利用する国の各種法令に従ってください。
86また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
87センスの購入などが必要となる場合がありますので、利用する目的
88や形態に応じて各自で判断し適切な対応を取ってください。
89
90
91%prep
92[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
93
94
95%install
96%{__rm} -rf ${RPM_BUILD_ROOT}
97%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
98%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
99
100
101%clean
102%{__rm} -rf ${RPM_BUILD_ROOT}
103
104%posttrans
105/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 10000
106#/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
107
108%files
109%defattr(-,root,root)
110%{_datadir}/%{name}
111
112%changelog
113* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-2
114- renamed %%{Source0} to ffmpeg2theora-vl.spec
115
116* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-1
117- new upstream release
118  - with recent ffmpeg
119
120* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.24-1
121- new upstream release
122
123* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-2
124- added BuildArch: noarch
125- avoided to execute self-build-rpm.sh on RPM transaction
126  - moved %%post actions to %%posttrans
127
128* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-1
129- new upstream release
130- dropped ffmpeg2theora-0.20-new_ffmpeg.patch
131- added PreReq: scons
132
133* Sat May 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.20-2
134- spec in utf8
135
136* Sat May 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.20-1
137- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.