source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 8803

Revision 8803, 13.6 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW: libcdio-paranoia
others: new upstream release or rebuild

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) ; \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} ; \
5    /bin/bash ${gpac_postinstall_sh} ; /bin/rm -f ${gpac_postinstall_sh}
6
7%global x264_postinstall     \
8    x264_postinstall_sh=$(mktemp) ; \
9    rpm -q --scripts self-build-x264 | \
10    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${x264_postinstall_sh} ; \
11    /bin/bash ${x264_postinstall_sh} ; /bin/rm -f ${x264_postinstall_sh}
12
13
14%global pkgname ffmpeg
15%global name    self-build-%{pkgname}
16%global major_version 1.2
17%global version %{major_version}.6
18#% define svndate       20110326
19%global release 2%{?svndate:.%svndate}%{?_dist_release}
20
21%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
22
23%global with_faac 1
24%global with_vaapi 1
25%global with_libvpx 1
26
27#% define enable_avconv 1
28
29Summary:        Package to automatically build %{pkgname} rpm package
30Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
31Name:           %{name}
32Version:        %{version}
33Release:        %{release}
34Source0:        %{pkgname}-vl.spec
35#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
36
37## prebuilt man pages
38Source10:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz
39
40License:        GPLv2+
41Group:          Restricted Software
42
43Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
44Obsoletes:      self-build-ffmpeg < %{version}
45
46Requires(post):         self-build-setup >= 0.9.9
47#Requires(post):                subversion
48
49# (build)requies of target package.
50Requires(post):  bzip2-devel
51Requires(post):  celt-devel
52##Requires(post):  dirac-devel
53Requires(post):  freetype2-devel
54Requires(post):  gnutls-devel
55Requires(post): gsm-devel
56Requires(post): imlib2-devel
57Requires(post): libdc1394-devel
58Requires(post): libogg-devel
59Requires(post):  libass-devel
60%{!?_without_cdio:Requires(post): libcdio-devel}
61%{!?_without_cdio:Requires(post): libcdio-paranoia-devel}
62#libcrystalhd is currently broken
63%{?_with_crystalhd:Requires(post):      libcrystalhd-devel}
64Requires(post): libraw1394-devel
65Requires(post): librtmp-devel >= 2.3
66Requires(post): libtheora-devel
67%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
68Requires(post):  libvdpau-devel
69Requires(post): libvorbis-devel
70%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.7}
71Requires(post):  libXvMC-devel
72%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
73%{!?_without_openal:Requires(post):  openal-soft-devel}
74%{?_with_opencv:Requires(post):  opencv-devel}
75%{?_with_openjpeg:Requires(post):  openjpeg-devel}
76##Requires(post):  schroedinger-devel
77Requires(post): SDL-devel
78Requires(post):  speex-devel
79##Requires(post):       texi2html
80Requires(post): zlib-devel
81Requires(post): libogg-devel
82Requires(post):         yasm
83Requires(post):         self-build-a52dec
84Requires(post):         self-build-faac
85Requires(post):         self-build-faad2
86Requires(post):         self-build-lame
87Requires(post):         self-build-libdca
88Requires(post):         self-build-x264 >= 0.129
89Requires(post):         self-build-xvidcore
90
91BuildRoot:      %{_tmppath}/%{name}-%{version}-root
92
93BuildArch:      noarch
94Packager:       munepi
95
96%description
97FFMpeg is a complete and free Internet live audio and video
98broadcasting solution for Linux/Unix. It also includes a
99digital VCR. It can encode in real time in many formats
100including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
101real, mjpeg, and flash.
102
103If you install this package, it automaticaly downloads source
104code ,compile it, and create rpm packages of %{pkgname}-%{version}.
105And the created rpm packages are automatically installed
106if installation is executed by apt-get command or synaptic
107package manager.
108
109[Note]
110This package requires many other packages to compile
111target software. So it consume more disk space than usual.
112Also installation takes longer time because of compilation.
113(This will take a few minutes to quarter or half of an hour,
114depends on building environment)
115
116[About self-build package]
117For some kind of software, distributing of binary package
118may viorate the patent or law. Therefore we chose self-build
119packge, create binary package on your machine, for such kind
120of softwares instead of distributing binary package.
121
122Please obey the national law when you use the created binary
123packages. And if you want to use the softwares using patented
124thechnology, it may be required to get a permission, make an
125agreement or purchas a license. Please consider it with your
126purpose or way of use and take appropriate action.
127
128%description -l ja
129FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
130ブオーティオ・ビデオブロードキャスティングソリューションです.
131またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
132MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
133多様なフォーマットをリアルタイムにエンコードすることができます.
134
135このパッケージをインストールすると、自動的にソースコードを
136ダウンロードしてコンパイルし、%{pkgname}-%{version}
137の rpm パッケージを作成します。
138また apt-get コマンドや synaptic パッケージマネージャから実行
139した場合は、作成された rpm パッケージのインストールも自動的に
140行います。
141
142[注意]
143コンパイルに必要な多くの関連パッケージを要求するので通常より
144ディスクの領域を多く消費します。
145またインストール時にコンパイルを行うため、通常より時間がかか
146る場合があります。(環境にもよりますが数分から数十分程度)
147
148[self-build パッケージについて]
149ソフトウェアによってはバイナリパッケージの配布が特許や法律に
150違反する可能性があるものがあります。その為、このような問題が
151懸念されるソフトウェアについてはバイナリパッケージを直接配布
152せずに、ユーザの環境でバイナリを作成する self-build パッケー
153ジという方法を採っています。
154
155作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
156アのライセンス、および利用する国の各種法令に従ってください。
157また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
158センスの購入などが必要となる場合がありますので、利用する目的
159や形態に応じて各自で判断し適切な対応を取ってください。
160
161%prep
162[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
163
164%install
165%{__rm} -rf ${RPM_BUILD_ROOT}
166%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
167%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
168%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
169
170%clean
171%{__rm} -rf ${RPM_BUILD_ROOT}
172
173%posttrans
174/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 86000
175/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
176                                 %{pkgname}-libs-%{version}-%{release} \
177                                 %{pkgname}-devel-%{version}-%{release}
178
179## Rebuild gpac with ffmpeg-devel
180# set locale
181case $LANG in
182    ja*)LOCALE=ja ;;
183    *) LOCALE=C ;;
184esac
185
186Rebuild_gpac_C(){
187    echo -n "     "
188    echo "Rebuild gpac with ffmpeg-devel"
189}
190
191Rebuild_gpac_ja(){
192    echo -n "     "
193    echo "ffmpeg-devel で gpac をリビルドします。"
194}
195
196Rebuild_gpac_$LOCALE
197%{gpac_postinstall}
198
199## Rebuild x264 with ffmpeg-devel
200# set locale
201case $LANG in
202    ja*)LOCALE=ja ;;
203    *) LOCALE=C ;;
204esac
205
206Rebuild_x264_C(){
207    echo -n "     "
208    echo "Rebuild x264 with ffmpeg-devel"
209}
210
211Rebuild_x264_ja(){
212    echo -n "     "
213    echo "ffmpeg-devel で x264 をリビルドします。"
214}
215
216Rebuild_x264_$LOCALE
217%{x264_postinstall}
218
219
220%files
221%defattr(-,root,root)
222%{_datadir}/%{name}
223
224%changelog
225* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
226- add BuildRequires: libcdio-paranoia-devel
227
228* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
229- new upstream release
230
231* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
232- new upstream release
233
234* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
235- new upstream release
236- added %%{x264_postinstall} in %%post
237
238* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
239- new upstream release
240- added man pages
241  - added Source10: ffmpeg-1.2.1-doc.tar.xz
242
243* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
244- new upstream release
245
246* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
247- new upstream release
248
249* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
250- libvpx >= 0.9.7
251
252* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
253- new upstream release /x264-0.129
254
255* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
256- new upstream release
257
258* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
259- new upstream release
260
261* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
262- new upstream release
263
264* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
265- new upstream release
266
267* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
268- new upstream release
269- enable CELT decoding via libcelt
270- enable FreeType support
271- drop faad2 support (dropped upstream)
272
273* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
274- added BuildArch: noarch
275
276* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
277- new upstream release
278
279* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
280- new upstream release
281
282* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
283- required latest x264 build
284- added BuildRequires: librtmp-devel >= 2.3
285
286* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
287- new upstream release
288
289* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
290- unpacked source archives
291
292* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
293- fixed some dependencies
294  - Requires(post): libva-devel
295  - Requires(post): libvpx-devel >= 0.9.1
296
297* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
298- new upstream release
299
300* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
301- bumped version to pre-0.6
302- updated source snapshot 20100410
303
304* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
305- fixed self-build log size
306
307* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
308- added ffprobe.1.gz
309
310* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
311- updated source snapshot 20100401
312
313* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
314- renamed %%{Source0} to ffmpeg-vl.spec
315
316* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
317- updated source snapshot 20100216
318  - rebuild with recent x264-devel
319- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
320- added BuildRequires:  libvdpau-devel
321
322* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
323- dropped BuildArch: noarch
324- added ffmpeg.1, ffplay.1, ffserver.1
325
326* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
327- avoided to execute self-build-rpm.sh on RPM transaction
328  - moved %%post actions to %%posttrans
329
330* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
331- added BuildArch: noarch
332- added ffmpeg-0.5-disable-texi2html.patch
333  - dropped PreReq: texi2html
334
335* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
336- added %%{gpac_postinstall} in %%post
337
338* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
339- corrected release number
340
341* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
342- new upstream release
343- added PreReq:
344  - speex-devel
345  - bzip2-devel
346
347* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
348- change release to sync with ffmpeg
349
350* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
351- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
352
353* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
354- 20090202 snapshot
355
356* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
357- 20090110 snapshot
358- dropped some patches
359
360* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
361- source updated (r15488)
362- fixed License: GPLv2+
363- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
364- added BuildRequires: yasm (only %%ix86)
365- applied ffmpeg-cpu.patch (merged from RPM Fusion)
366
367* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
368- spec in utf8
369
370* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
371- run pre-allocate-rpm.sh in %%post
372- set PreReq: self-build-setup >= 0.8
373- change release number
374
375* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
376- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
377  include Source1 in the binary package.
378- drop "Source100: ffmpeg-vine.patch".
379- drop "PreReq: subversion".
380
381* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
382- build with new versioning policy
383- change to use svn export from svn checkout on post install
384- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
385
386* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
387- For all pre-required package that is provied by self-build, 
388  changed to its self-build package
389 
390* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
391- initial build for Vine Linux 4.2
392- snapshot 2008/01/28 + some Rev.11662 2008/01/29
393
394### end of file
Note: See TracBrowser for help on using the repository browser.