source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 8313

Revision 8313, 13.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) ; \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} ; \
5    /bin/bash ${gpac_postinstall_sh} ; /bin/rm -f ${gpac_postinstall_sh}
6
7%global x264_postinstall     \
8    x264_postinstall_sh=$(mktemp) ; \
9    rpm -q --scripts self-build-x264 | \
10    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${x264_postinstall_sh} ; \
11    /bin/bash ${x264_postinstall_sh} ; /bin/rm -f ${x264_postinstall_sh}
12
13
14%global pkgname ffmpeg
15%global name    self-build-%{pkgname}
16%global major_version 1.2
17%global version %{major_version}.6
18#% define svndate       20110326
19%global release 1%{?svndate:.%svndate}%{?_dist_release}
20
21%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
22
23%global with_faac 1
24%global with_vaapi 1
25%global with_libvpx 1
26
27#% define enable_avconv 1
28
29Summary:        Package to automatically build %{pkgname} rpm package
30Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
31Name:           %{name}
32Version:        %{version}
33Release:        %{release}
34Source0:        %{pkgname}-vl.spec
35#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
36
37## prebuilt man pages
38Source10:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz
39
40License:        GPLv2+
41Group:          Restricted Software
42
43Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
44Obsoletes:      self-build-ffmpeg < %{version}
45
46Requires(post):         self-build-setup >= 0.9.9
47#Requires(post):                subversion
48
49# (build)requies of target package.
50Requires(post):  bzip2-devel
51Requires(post):  celt-devel
52##Requires(post):  dirac-devel
53Requires(post):  freetype2-devel
54Requires(post):  gnutls-devel
55Requires(post): gsm-devel
56Requires(post): imlib2-devel
57Requires(post): libdc1394-devel
58Requires(post): libogg-devel
59Requires(post):  libass-devel
60%{!?_without_cdio:Requires(post): libcdio-devel}
61#libcrystalhd is currently broken
62%{?_with_crystalhd:Requires(post):      libcrystalhd-devel}
63Requires(post): libraw1394-devel
64Requires(post): librtmp-devel >= 2.3
65Requires(post): libtheora-devel
66%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
67Requires(post):  libvdpau-devel
68Requires(post): libvorbis-devel
69%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.7}
70Requires(post):  libXvMC-devel
71%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
72%{!?_without_openal:Requires(post):  openal-soft-devel}
73%{?_with_opencv:Requires(post):  opencv-devel}
74%{?_with_openjpeg:Requires(post):  openjpeg-devel}
75##Requires(post):  schroedinger-devel
76Requires(post): SDL-devel
77Requires(post):  speex-devel
78##Requires(post):       texi2html
79Requires(post): zlib-devel
80Requires(post): libogg-devel
81Requires(post):         yasm
82Requires(post):         self-build-a52dec
83Requires(post):         self-build-faac
84Requires(post):         self-build-faad2
85Requires(post):         self-build-lame
86Requires(post):         self-build-libdca
87Requires(post):         self-build-x264 >= 0.129
88Requires(post):         self-build-xvidcore
89
90BuildRoot:      %{_tmppath}/%{name}-%{version}-root
91
92BuildArch:      noarch
93Packager:       munepi
94
95%description
96FFMpeg is a complete and free Internet live audio and video
97broadcasting solution for Linux/Unix. It also includes a
98digital VCR. It can encode in real time in many formats
99including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
100real, mjpeg, and flash.
101
102If you install this package, it automaticaly downloads source
103code ,compile it, and create rpm packages of %{pkgname}-%{version}.
104And the created rpm packages are automatically installed
105if installation is executed by apt-get command or synaptic
106package manager.
107
108[Note]
109This package requires many other packages to compile
110target software. So it consume more disk space than usual.
111Also installation takes longer time because of compilation.
112(This will take a few minutes to quarter or half of an hour,
113depends on building environment)
114
115[About self-build package]
116For some kind of software, distributing of binary package
117may viorate the patent or law. Therefore we chose self-build
118packge, create binary package on your machine, for such kind
119of softwares instead of distributing binary package.
120
121Please obey the national law when you use the created binary
122packages. And if you want to use the softwares using patented
123thechnology, it may be required to get a permission, make an
124agreement or purchas a license. Please consider it with your
125purpose or way of use and take appropriate action.
126
127%description -l ja
128FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
129ブオーティオ・ビデオブロードキャスティングソリューションです.
130またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
131MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
132多様なフォーマットをリアルタイムにエンコードすることができます.
133
134このパッケージをインストールすると、自動的にソースコードを
135ダウンロードしてコンパイルし、%{pkgname}-%{version}
136の rpm パッケージを作成します。
137また apt-get コマンドや synaptic パッケージマネージャから実行
138した場合は、作成された rpm パッケージのインストールも自動的に
139行います。
140
141[注意]
142コンパイルに必要な多くの関連パッケージを要求するので通常より
143ディスクの領域を多く消費します。
144またインストール時にコンパイルを行うため、通常より時間がかか
145る場合があります。(環境にもよりますが数分から数十分程度)
146
147[self-build パッケージについて]
148ソフトウェアによってはバイナリパッケージの配布が特許や法律に
149違反する可能性があるものがあります。その為、このような問題が
150懸念されるソフトウェアについてはバイナリパッケージを直接配布
151せずに、ユーザの環境でバイナリを作成する self-build パッケー
152ジという方法を採っています。
153
154作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
155アのライセンス、および利用する国の各種法令に従ってください。
156また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
157センスの購入などが必要となる場合がありますので、利用する目的
158や形態に応じて各自で判断し適切な対応を取ってください。
159
160%prep
161[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
162
163%install
164%{__rm} -rf ${RPM_BUILD_ROOT}
165%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
166%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
167%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
168
169%clean
170%{__rm} -rf ${RPM_BUILD_ROOT}
171
172%posttrans
173/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 86000
174/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
175                                 %{pkgname}-libs-%{version}-%{release} \
176                                 %{pkgname}-devel-%{version}-%{release}
177
178## Rebuild gpac with ffmpeg-devel
179# set locale
180case $LANG in
181    ja*)LOCALE=ja ;;
182    *) LOCALE=C ;;
183esac
184
185Rebuild_gpac_C(){
186    echo -n "     "
187    echo "Rebuild gpac with ffmpeg-devel"
188}
189
190Rebuild_gpac_ja(){
191    echo -n "     "
192    echo "ffmpeg-devel で gpac をリビルドします。"
193}
194
195Rebuild_gpac_$LOCALE
196%{gpac_postinstall}
197
198## Rebuild x264 with ffmpeg-devel
199# set locale
200case $LANG in
201    ja*)LOCALE=ja ;;
202    *) LOCALE=C ;;
203esac
204
205Rebuild_x264_C(){
206    echo -n "     "
207    echo "Rebuild x264 with ffmpeg-devel"
208}
209
210Rebuild_x264_ja(){
211    echo -n "     "
212    echo "ffmpeg-devel で x264 をリビルドします。"
213}
214
215Rebuild_x264_$LOCALE
216%{x264_postinstall}
217
218
219%files
220%defattr(-,root,root)
221%{_datadir}/%{name}
222
223%changelog
224* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
225- new upstream release
226
227* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
228- new upstream release
229
230* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
231- new upstream release
232- added %%{x264_postinstall} in %%post
233
234* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
235- new upstream release
236- added man pages
237  - added Source10: ffmpeg-1.2.1-doc.tar.xz
238
239* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
240- new upstream release
241
242* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
243- new upstream release
244
245* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
246- libvpx >= 0.9.7
247
248* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
249- new upstream release /x264-0.129
250
251* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
252- new upstream release
253
254* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
255- new upstream release
256
257* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
258- new upstream release
259
260* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
261- new upstream release
262
263* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
264- new upstream release
265- enable CELT decoding via libcelt
266- enable FreeType support
267- drop faad2 support (dropped upstream)
268
269* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
270- added BuildArch: noarch
271
272* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
273- new upstream release
274
275* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
276- new upstream release
277
278* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
279- required latest x264 build
280- added BuildRequires: librtmp-devel >= 2.3
281
282* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
283- new upstream release
284
285* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
286- unpacked source archives
287
288* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
289- fixed some dependencies
290  - Requires(post): libva-devel
291  - Requires(post): libvpx-devel >= 0.9.1
292
293* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
294- new upstream release
295
296* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
297- bumped version to pre-0.6
298- updated source snapshot 20100410
299
300* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
301- fixed self-build log size
302
303* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
304- added ffprobe.1.gz
305
306* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
307- updated source snapshot 20100401
308
309* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
310- renamed %%{Source0} to ffmpeg-vl.spec
311
312* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
313- updated source snapshot 20100216
314  - rebuild with recent x264-devel
315- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
316- added BuildRequires:  libvdpau-devel
317
318* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
319- dropped BuildArch: noarch
320- added ffmpeg.1, ffplay.1, ffserver.1
321
322* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
323- avoided to execute self-build-rpm.sh on RPM transaction
324  - moved %%post actions to %%posttrans
325
326* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
327- added BuildArch: noarch
328- added ffmpeg-0.5-disable-texi2html.patch
329  - dropped PreReq: texi2html
330
331* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
332- added %%{gpac_postinstall} in %%post
333
334* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
335- corrected release number
336
337* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
338- new upstream release
339- added PreReq:
340  - speex-devel
341  - bzip2-devel
342
343* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
344- change release to sync with ffmpeg
345
346* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
347- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
348
349* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
350- 20090202 snapshot
351
352* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
353- 20090110 snapshot
354- dropped some patches
355
356* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
357- source updated (r15488)
358- fixed License: GPLv2+
359- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
360- added BuildRequires: yasm (only %%ix86)
361- applied ffmpeg-cpu.patch (merged from RPM Fusion)
362
363* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
364- spec in utf8
365
366* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
367- run pre-allocate-rpm.sh in %%post
368- set PreReq: self-build-setup >= 0.8
369- change release number
370
371* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
372- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
373  include Source1 in the binary package.
374- drop "Source100: ffmpeg-vine.patch".
375- drop "PreReq: subversion".
376
377* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
378- build with new versioning policy
379- change to use svn export from svn checkout on post install
380- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
381
382* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
383- For all pre-required package that is provied by self-build, 
384  changed to its self-build package
385 
386* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
387- initial build for Vine Linux 4.2
388- snapshot 2008/01/28 + some Rev.11662 2008/01/29
389
390### end of file
Note: See TracBrowser for help on using the repository browser.