source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 789

Revision 789, 9.7 KB checked in by munepi, 14 years ago (diff)

updated self-build-ffmpeg

Line 
1%define gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%define pkgname ffmpeg
8%define name    self-build-%{pkgname}
9%define version 0.5
10%define svndate 20100401
11%define release 12%{?svndate:.%svndate}%{?_dist_release}
12
13Summary:        Package to automatically build %{pkgname} rpm package
14Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
15Name:           %{name}
16Version:        %{version}
17Release:        %{release}
18Source0:        %{pkgname}-vl.spec
19#Source1:               %{pkgname}-%{version}.tar.bz2
20Source1:                %{pkgname}-%{?svndate:%svndate}.tar.bz2
21Source2:        %{pkgname}-snapshot.sh
22Source90:       ffmpeg.1.gz
23Source91:       ffplay.1.gz
24Source92:       ffserver.1.gz
25Source93:       ffprobe.1.gz
26
27License:        GPLv2+
28Group:          Restricted Software
29
30Requires(post):         self-build-setup >= 0.9.9
31#Requires(post):                subversion
32
33# (build)requies of target package.
34Requires(post):  bzip2-devel
35Requires(post): gsm-devel
36Requires(post): imlib2-devel
37Requires(post): libdc1394-devel
38Requires(post): libraw1394-devel
39Requires(post): libtheora-devel
40Requires(post):  libvdpau-devel
41Requires(post): libvorbis-devel
42##Requires(post):  openjpeg-devel
43Requires(post): SDL-devel
44Requires(post):  speex-devel
45##Requires(post):       texi2html
46Requires(post): zlib-devel
47Requires(post): libogg-devel
48%ifarch %{ix86} x86_64
49Requires(post):         yasm
50%endif
51Requires(post):         self-build-xvidcore
52Requires(post):         self-build-faac
53Requires(post):         self-build-lame
54Requires(post):         self-build-x264
55Requires(post):         self-build-libdca
56Requires(post):         self-build-a52dec
57Requires(post):         self-build-faad2
58%{?_with_amr:Requires(post):            amrnb-devel amrwb-devel}
59
60BuildRoot:      %{_tmppath}/%{name}-%{version}-root
61
62Packager:       munepi
63
64%description
65FFMpeg is a complete and free Internet live audio and video
66broadcasting solution for Linux/Unix. It also includes a
67digital VCR. It can encode in real time in many formats
68including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
69real, mjpeg, and flash.
70
71If you install this package, it automaticaly downloads source
72code ,compile it, and create rpm packages of %{pkgname}-%{version}.
73And the created rpm packages are automatically installed
74if installation is executed by apt-get command or synaptic
75package manager.
76
77[Note]
78This package requires many other packages to compile
79target software. So it consume more disk space than usual.
80Also installation takes longer time because of compilation.
81(This will take a few minutes to quarter or half of an hour,
82depends on building environment)
83
84[About self-build package]
85For some kind of software, distributing of binary package
86may viorate the patent or law. Therefore we chose self-build
87packge, create binary package on your machine, for such kind
88of softwares instead of distributing binary package.
89
90Please obey the national law when you use the created binary
91packages. And if you want to use the softwares using patented
92thechnology, it may be required to get a permission, make an
93agreement or purchas a license. Please consider it with your
94purpose or way of use and take appropriate action.
95
96%description -l ja
97FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
98ブオーティオ・ビデオブロードキャスティングソリューションです.
99またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
100MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
101多様なフォーマットをリアルタイムにエンコードすることができます.
102
103このパッケージをインストールすると、自動的にソースコードを
104ダウンロードしてコンパイルし、%{pkgname}-%{version}
105の rpm パッケージを作成します。
106また apt-get コマンドや synaptic パッケージマネージャから実行
107した場合は、作成された rpm パッケージのインストールも自動的に
108行います。
109
110[注意]
111コンパイルに必要な多くの関連パッケージを要求するので通常より
112ディスクの領域を多く消費します。
113またインストール時にコンパイルを行うため、通常より時間がかか
114る場合があります。(環境にもよりますが数分から数十分程度)
115
116[self-build パッケージについて]
117ソフトウェアによってはバイナリパッケージの配布が特許や法律に
118違反する可能性があるものがあります。その為、このような問題が
119懸念されるソフトウェアについてはバイナリパッケージを直接配布
120せずに、ユーザの環境でバイナリを作成する self-build パッケー
121ジという方法を採っています。
122
123作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
124アのライセンス、および利用する国の各種法令に従ってください。
125また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
126センスの購入などが必要となる場合がありますので、利用する目的
127や形態に応じて各自で判断し適切な対応を取ってください。
128
129%prep
130[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
131
132%install
133%{__rm} -rf ${RPM_BUILD_ROOT}
134%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
135%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
136%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
137%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
138%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
139    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
140
141%clean
142%{__rm} -rf ${RPM_BUILD_ROOT}
143
144%posttrans
145/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 82000
146/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
147                                 %{pkgname}-libs-%{version}-%{release} \
148                                 %{pkgname}-devel-%{version}-%{release}
149
150## Rebuild gpac with ffmpeg-devel
151# set locale
152case $LANG in
153    ja*)LOCALE=ja ;;
154    *) LOCALE=C ;;
155esac
156
157Rebuild_gpac_C(){
158    echo -n "     "
159    echo "Rebuild gpac with ffmpeg-devel"
160}
161
162Rebuild_gpac_ja(){
163    echo -n "     "
164    echo "ffmpeg-devel で gpac をリビルドします。"
165}
166
167Rebuild_gpac_$LOCALE
168%{gpac_postinstall}
169
170
171%files
172%defattr(-,root,root)
173%{_datadir}/%{name}
174
175%changelog
176* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
177- fixed self-build log size
178
179* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
180- added ffprobe.1.gz
181
182* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
183- updated source snapshot 20100401
184
185* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
186- renamed %%{Source0} to ffmpeg-vl.spec
187
188* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
189- updated source snapshot 20100216
190  - rebuild with recent x264-devel
191- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
192- added BuildRequires:  libvdpau-devel
193
194* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
195- dropped BuildArch: noarch
196- added ffmpeg.1, ffplay.1, ffserver.1
197
198* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
199- avoided to execute self-build-rpm.sh on RPM transaction
200  - moved %%post actions to %%posttrans
201
202* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
203- added BuildArch: noarch
204- added ffmpeg-0.5-disable-texi2html.patch
205  - dropped PreReq: texi2html
206
207* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
208- added %%{gpac_postinstall} in %%post
209
210* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
211- corrected release number
212
213* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
214- new upstream release
215- added PreReq:
216  - speex-devel
217  - bzip2-devel
218
219* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
220- change release to sync with ffmpeg
221
222* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
223- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
224
225* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
226- 20090202 snapshot
227
228* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
229- 20090110 snapshot
230- dropped some patches
231
232* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
233- source updated (r15488)
234- fixed License: GPLv2+
235- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
236- added BuildRequires: yasm (only %%ix86)
237- applied ffmpeg-cpu.patch (merged from RPM Fusion)
238
239* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
240- spec in utf8
241
242* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
243- run pre-allocate-rpm.sh in %%post
244- set PreReq: self-build-setup >= 0.8
245- change release number
246
247* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
248- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
249  include Source1 in the binary package.
250- drop "Source100: ffmpeg-vine.patch".
251- drop "PreReq: subversion".
252
253* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
254- build with new versioning policy
255- change to use svn export from svn checkout on post install
256- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
257
258* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
259- For all pre-required package that is provied by self-build, 
260  changed to its self-build package
261 
262* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
263- initial build for Vine Linux 4.2
264- snapshot 2008/01/28 + some Rev.11662 2008/01/29
265
266### end of file
Note: See TracBrowser for help on using the repository browser.