source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 7689

Revision 7689, 12.5 KB checked in by munepi, 11 years ago (diff)

new upstream release

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%global pkgname ffmpeg
8%global name    self-build-%{pkgname}
9%global major_version 1.2
10%global version %{major_version}.1
11#% define svndate       20110326
12%global release 1%{?svndate:.%svndate}%{?_dist_release}
13
14%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
15
16%global with_faac 1
17%global with_vaapi 1
18%global with_libvpx 1
19
20#% define enable_avconv 1
21
22Summary:        Package to automatically build %{pkgname} rpm package
23Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
24Name:           %{name}
25Version:        %{version}
26Release:        %{release}
27Source0:        %{pkgname}-vl.spec
28#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
29
30## prebuilt man pages
31Source10:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz
32
33License:        GPLv2+
34Group:          Restricted Software
35
36Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
37Obsoletes:      self-build-ffmpeg < %{major_version}
38
39Requires(post):         self-build-setup >= 0.9.9
40#Requires(post):                subversion
41
42# (build)requies of target package.
43Requires(post):  bzip2-devel
44Requires(post):  celt-devel
45##Requires(post):  dirac-devel
46Requires(post):  freetype2-devel
47Requires(post):  gnutls-devel
48Requires(post): gsm-devel
49Requires(post): imlib2-devel
50Requires(post): libdc1394-devel
51Requires(post): libogg-devel
52Requires(post):  libass-devel
53%{!?_without_cdio:Requires(post): libcdio-devel}
54#libcrystalhd is currently broken
55%{?_with_crystalhd:Requires(post):      libcrystalhd-devel}
56Requires(post): libraw1394-devel
57Requires(post): librtmp-devel >= 2.3
58Requires(post): libtheora-devel
59%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
60Requires(post):  libvdpau-devel
61Requires(post): libvorbis-devel
62%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.7}
63Requires(post):  libXvMC-devel
64%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
65%{!?_without_openal:Requires(post):  openal-soft-devel}
66%{?_with_opencv:Requires(post):  opencv-devel}
67%{?_with_openjpeg:Requires(post):  openjpeg-devel}
68##Requires(post):  schroedinger-devel
69Requires(post): SDL-devel
70Requires(post):  speex-devel
71##Requires(post):       texi2html
72Requires(post): zlib-devel
73Requires(post): libogg-devel
74Requires(post):         yasm
75Requires(post):         self-build-a52dec
76Requires(post):         self-build-faac
77Requires(post):         self-build-faad2
78Requires(post):         self-build-lame
79Requires(post):         self-build-libdca
80Requires(post):         self-build-x264 >= 0.129
81Requires(post):         self-build-xvidcore
82
83BuildRoot:      %{_tmppath}/%{name}-%{version}-root
84
85BuildArch:      noarch
86Packager:       munepi
87
88%description
89FFMpeg is a complete and free Internet live audio and video
90broadcasting solution for Linux/Unix. It also includes a
91digital VCR. It can encode in real time in many formats
92including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
93real, mjpeg, and flash.
94
95If you install this package, it automaticaly downloads source
96code ,compile it, and create rpm packages of %{pkgname}-%{version}.
97And the created rpm packages are automatically installed
98if installation is executed by apt-get command or synaptic
99package manager.
100
101[Note]
102This package requires many other packages to compile
103target software. So it consume more disk space than usual.
104Also installation takes longer time because of compilation.
105(This will take a few minutes to quarter or half of an hour,
106depends on building environment)
107
108[About self-build package]
109For some kind of software, distributing of binary package
110may viorate the patent or law. Therefore we chose self-build
111packge, create binary package on your machine, for such kind
112of softwares instead of distributing binary package.
113
114Please obey the national law when you use the created binary
115packages. And if you want to use the softwares using patented
116thechnology, it may be required to get a permission, make an
117agreement or purchas a license. Please consider it with your
118purpose or way of use and take appropriate action.
119
120%description -l ja
121FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
122ブオーティオ・ビデオブロードキャスティングソリューションです.
123またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
124MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
125多様なフォーマットをリアルタイムにエンコードすることができます.
126
127このパッケージをインストールすると、自動的にソースコードを
128ダウンロードしてコンパイルし、%{pkgname}-%{version}
129の rpm パッケージを作成します。
130また apt-get コマンドや synaptic パッケージマネージャから実行
131した場合は、作成された rpm パッケージのインストールも自動的に
132行います。
133
134[注意]
135コンパイルに必要な多くの関連パッケージを要求するので通常より
136ディスクの領域を多く消費します。
137またインストール時にコンパイルを行うため、通常より時間がかか
138る場合があります。(環境にもよりますが数分から数十分程度)
139
140[self-build パッケージについて]
141ソフトウェアによってはバイナリパッケージの配布が特許や法律に
142違反する可能性があるものがあります。その為、このような問題が
143懸念されるソフトウェアについてはバイナリパッケージを直接配布
144せずに、ユーザの環境でバイナリを作成する self-build パッケー
145ジという方法を採っています。
146
147作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
148アのライセンス、および利用する国の各種法令に従ってください。
149また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
150センスの購入などが必要となる場合がありますので、利用する目的
151や形態に応じて各自で判断し適切な対応を取ってください。
152
153%prep
154[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
155
156%install
157%{__rm} -rf ${RPM_BUILD_ROOT}
158%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
159%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
160%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
161
162%clean
163%{__rm} -rf ${RPM_BUILD_ROOT}
164
165%posttrans
166/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 86000
167/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
168                                 %{pkgname}-libs-%{version}-%{release} \
169                                 %{pkgname}-devel-%{version}-%{release}
170
171## Rebuild gpac with ffmpeg-devel
172# set locale
173case $LANG in
174    ja*)LOCALE=ja ;;
175    *) LOCALE=C ;;
176esac
177
178Rebuild_gpac_C(){
179    echo -n "     "
180    echo "Rebuild gpac with ffmpeg-devel"
181}
182
183Rebuild_gpac_ja(){
184    echo -n "     "
185    echo "ffmpeg-devel で gpac をリビルドします。"
186}
187
188Rebuild_gpac_$LOCALE
189%{gpac_postinstall}
190
191
192%files
193%defattr(-,root,root)
194%{_datadir}/%{name}
195
196%changelog
197* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
198- new upstream release
199- added man pages
200  - added Source10: ffmpeg-1.2.1-doc.tar.xz
201
202* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
203- new upstream release
204
205* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
206- new upstream release
207
208* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
209- libvpx >= 0.9.7
210
211* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
212- new upstream release /x264-0.129
213
214* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
215- new upstream release
216
217* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
218- new upstream release
219
220* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
221- new upstream release
222
223* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
224- new upstream release
225
226* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
227- new upstream release
228- enable CELT decoding via libcelt
229- enable FreeType support
230- drop faad2 support (dropped upstream)
231
232* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
233- added BuildArch: noarch
234
235* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
236- new upstream release
237
238* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
239- new upstream release
240
241* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
242- required latest x264 build
243- added BuildRequires: librtmp-devel >= 2.3
244
245* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
246- new upstream release
247
248* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
249- unpacked source archives
250
251* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
252- fixed some dependencies
253  - Requires(post): libva-devel
254  - Requires(post): libvpx-devel >= 0.9.1
255
256* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
257- new upstream release
258
259* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
260- bumped version to pre-0.6
261- updated source snapshot 20100410
262
263* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
264- fixed self-build log size
265
266* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
267- added ffprobe.1.gz
268
269* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
270- updated source snapshot 20100401
271
272* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
273- renamed %%{Source0} to ffmpeg-vl.spec
274
275* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
276- updated source snapshot 20100216
277  - rebuild with recent x264-devel
278- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
279- added BuildRequires:  libvdpau-devel
280
281* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
282- dropped BuildArch: noarch
283- added ffmpeg.1, ffplay.1, ffserver.1
284
285* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
286- avoided to execute self-build-rpm.sh on RPM transaction
287  - moved %%post actions to %%posttrans
288
289* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
290- added BuildArch: noarch
291- added ffmpeg-0.5-disable-texi2html.patch
292  - dropped PreReq: texi2html
293
294* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
295- added %%{gpac_postinstall} in %%post
296
297* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
298- corrected release number
299
300* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
301- new upstream release
302- added PreReq:
303  - speex-devel
304  - bzip2-devel
305
306* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
307- change release to sync with ffmpeg
308
309* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
310- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
311
312* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
313- 20090202 snapshot
314
315* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
316- 20090110 snapshot
317- dropped some patches
318
319* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
320- source updated (r15488)
321- fixed License: GPLv2+
322- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
323- added BuildRequires: yasm (only %%ix86)
324- applied ffmpeg-cpu.patch (merged from RPM Fusion)
325
326* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
327- spec in utf8
328
329* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
330- run pre-allocate-rpm.sh in %%post
331- set PreReq: self-build-setup >= 0.8
332- change release number
333
334* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
335- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
336  include Source1 in the binary package.
337- drop "Source100: ffmpeg-vine.patch".
338- drop "PreReq: subversion".
339
340* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
341- build with new versioning policy
342- change to use svn export from svn checkout on post install
343- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
344
345* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
346- For all pre-required package that is provied by self-build, 
347  changed to its self-build package
348 
349* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
350- initial build for Vine Linux 4.2
351- snapshot 2008/01/28 + some Rev.11662 2008/01/29
352
353### end of file
Note: See TracBrowser for help on using the repository browser.