source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 615

Revision 615, 9.4 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%define pkgname ffmpeg
8%define name    self-build-%{pkgname}
9%define version 0.5
10%define svndate 20100216
11%define release 8%{?svndate:.%svndate}%{?_dist_release}
12
13Summary:        Package to automatically build %{pkgname} rpm package
14Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
15Name:           %{name}
16Version:        %{version}
17Release:        %{release}
18Source0:        %{pkgname}-vl.spec
19#Source1:               %{pkgname}-%{version}.tar.bz2
20Source1:                %{pkgname}-%{?svndate:%svndate}.tar.bz2
21Source2:        %{pkgname}-snapshot.sh
22Source90:       ffmpeg.1.gz
23Source91:       ffplay.1.gz
24Source92:       ffserver.1.gz
25
26License:        GPLv2+
27Group:          Restricted Software
28
29Requires(post):         self-build-setup >= 0.9.9
30#Requires(post):                subversion
31
32# (build)requies of target package.
33Requires(post):  bzip2-devel
34Requires(post): gsm-devel
35Requires(post): imlib2-devel
36Requires(post): libdc1394-devel
37Requires(post): libraw1394-devel
38Requires(post): libtheora-devel
39Requires(post):  libvdpau-devel
40Requires(post): libvorbis-devel
41##Requires(post):  openjpeg-devel
42Requires(post): SDL-devel
43Requires(post):  speex-devel
44##Requires(post):       texi2html
45Requires(post): zlib-devel
46Requires(post): libogg-devel
47%ifarch %{ix86} x86_64
48Requires(post):         yasm
49%endif
50Requires(post):         self-build-xvidcore
51Requires(post):         self-build-faac
52Requires(post):         self-build-lame
53Requires(post):         self-build-x264
54Requires(post):         self-build-libdca
55Requires(post):         self-build-a52dec
56Requires(post):         self-build-faad2
57%{?_with_amr:Requires(post):            amrnb-devel amrwb-devel}
58
59BuildRoot:      %{_tmppath}/%{name}-%{version}-root
60
61Packager:       munepi
62
63%description
64FFMpeg is a complete and free Internet live audio and video
65broadcasting solution for Linux/Unix. It also includes a
66digital VCR. It can encode in real time in many formats
67including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
68real, mjpeg, and flash.
69
70If you install this package, it automaticaly downloads source
71code ,compile it, and create rpm packages of %{pkgname}-%{version}.
72And the created rpm packages are automatically installed
73if installation is executed by apt-get command or synaptic
74package manager.
75
76[Note]
77This package requires many other packages to compile
78target software. So it consume more disk space than usual.
79Also installation takes longer time because of compilation.
80(This will take a few minutes to quarter or half of an hour,
81depends on building environment)
82
83[About self-build package]
84For some kind of software, distributing of binary package
85may viorate the patent or law. Therefore we chose self-build
86packge, create binary package on your machine, for such kind
87of softwares instead of distributing binary package.
88
89Please obey the national law when you use the created binary
90packages. And if you want to use the softwares using patented
91thechnology, it may be required to get a permission, make an
92agreement or purchas a license. Please consider it with your
93purpose or way of use and take appropriate action.
94
95%description -l ja
96FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
97ブオーティオ・ビデオブロードキャスティングソリューションです.
98またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
99MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
100多様なフォーマットをリアルタイムにエンコードすることができます.
101
102このパッケージをインストールすると、自動的にソースコードを
103ダウンロードしてコンパイルし、%{pkgname}-%{version}
104の rpm パッケージを作成します。
105また apt-get コマンドや synaptic パッケージマネージャから実行
106した場合は、作成された rpm パッケージのインストールも自動的に
107行います。
108
109[注意]
110コンパイルに必要な多くの関連パッケージを要求するので通常より
111ディスクの領域を多く消費します。
112またインストール時にコンパイルを行うため、通常より時間がかか
113る場合があります。(環境にもよりますが数分から数十分程度)
114
115[self-build パッケージについて]
116ソフトウェアによってはバイナリパッケージの配布が特許や法律に
117違反する可能性があるものがあります。その為、このような問題が
118懸念されるソフトウェアについてはバイナリパッケージを直接配布
119せずに、ユーザの環境でバイナリを作成する self-build パッケー
120ジという方法を採っています。
121
122作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
123アのライセンス、および利用する国の各種法令に従ってください。
124また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
125センスの購入などが必要となる場合がありますので、利用する目的
126や形態に応じて各自で判断し適切な対応を取ってください。
127
128%prep
129[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
130
131%install
132%{__rm} -rf ${RPM_BUILD_ROOT}
133%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
134%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
135%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
136%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
137%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} \
138    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
139
140%clean
141%{__rm} -rf ${RPM_BUILD_ROOT}
142
143%posttrans
144/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 505000
145/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
146                                 %{pkgname}-libs-%{version}-%{release} \
147                                 %{pkgname}-devel-%{version}-%{release}
148
149## Rebuild gpac with ffmpeg-devel
150# set locale
151case $LANG in
152    ja*)LOCALE=ja ;;
153    *) LOCALE=C ;;
154esac
155
156Rebuild_gpac_C(){
157    echo -n "     "
158    echo "Rebuild gpac with ffmpeg-devel"
159}
160
161Rebuild_gpac_ja(){
162    echo -n "     "
163    echo "ffmpeg-devel で gpac をリビルドします。"
164}
165
166Rebuild_gpac_$LOCALE
167%{gpac_postinstall}
168
169
170%files
171%defattr(-,root,root)
172%{_datadir}/%{name}
173
174%changelog
175* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
176- renamed %%{Source0} to ffmpeg-vl.spec
177
178* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
179- updated source snapshot 20100216
180  - rebuild with recent x264-devel
181- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
182- added BuildRequires:  libvdpau-devel
183
184* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
185- dropped BuildArch: noarch
186- added ffmpeg.1, ffplay.1, ffserver.1
187
188* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
189- avoided to execute self-build-rpm.sh on RPM transaction
190  - moved %%post actions to %%posttrans
191
192* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
193- added BuildArch: noarch
194- added ffmpeg-0.5-disable-texi2html.patch
195  - dropped PreReq: texi2html
196
197* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
198- added %%{gpac_postinstall} in %%post
199
200* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
201- corrected release number
202
203* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
204- new upstream release
205- added PreReq:
206  - speex-devel
207  - bzip2-devel
208
209* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
210- change release to sync with ffmpeg
211
212* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
213- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
214
215* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
216- 20090202 snapshot
217
218* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
219- 20090110 snapshot
220- dropped some patches
221
222* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
223- source updated (r15488)
224- fixed License: GPLv2+
225- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
226- added BuildRequires: yasm (only %%ix86)
227- applied ffmpeg-cpu.patch (merged from RPM Fusion)
228
229* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
230- spec in utf8
231
232* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
233- run pre-allocate-rpm.sh in %%post
234- set PreReq: self-build-setup >= 0.8
235- change release number
236
237* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
238- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
239  include Source1 in the binary package.
240- drop "Source100: ffmpeg-vine.patch".
241- drop "PreReq: subversion".
242
243* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
244- build with new versioning policy
245- change to use svn export from svn checkout on post install
246- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
247
248* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
249- For all pre-required package that is provied by self-build, 
250  changed to its self-build package
251 
252* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
253- initial build for Vine Linux 4.2
254- snapshot 2008/01/28 + some Rev.11662 2008/01/29
255
256### end of file
Note: See TracBrowser for help on using the repository browser.