source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 7546

Revision 7546, 12.1 KB checked in by munepi, 11 years ago (diff)

new upstream release

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%global pkgname ffmpeg
8%global name    self-build-%{pkgname}
9%global major_version 1.1
10%global version %{major_version}.3
11#% define svndate       20110326
12%global release 1%{?svndate:.%svndate}%{?_dist_release}
13
14%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
15
16%global with_faac 1
17%global with_vaapi 1
18%global with_libvpx 1
19
20#% define enable_avconv 1
21
22Summary:        Package to automatically build %{pkgname} rpm package
23Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
24Name:           %{name}
25Version:        %{version}
26Release:        %{release}
27Source0:        %{pkgname}-vl.spec
28#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
29
30License:        GPLv2+
31Group:          Restricted Software
32
33Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
34Obsoletes:      self-build-ffmpeg < %{major_version}
35
36Requires(post):         self-build-setup >= 0.9.9
37#Requires(post):                subversion
38
39# (build)requies of target package.
40Requires(post):  bzip2-devel
41Requires(post):  celt-devel
42##Requires(post):  dirac-devel
43Requires(post):  freetype2-devel
44Requires(post):  gnutls-devel
45Requires(post): gsm-devel
46Requires(post): imlib2-devel
47Requires(post): libdc1394-devel
48Requires(post): libogg-devel
49Requires(post):  libass-devel
50%{!?_without_cdio:Requires(post): libcdio-devel}
51#libcrystalhd is currently broken
52%{?_with_crystalhd:Requires(post):      libcrystalhd-devel}
53Requires(post): libraw1394-devel
54Requires(post): librtmp-devel >= 2.3
55Requires(post): libtheora-devel
56%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
57Requires(post):  libvdpau-devel
58Requires(post): libvorbis-devel
59%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.7}
60Requires(post):  libXvMC-devel
61%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
62%{!?_without_openal:Requires(post):  openal-soft-devel}
63%{?_with_opencv:Requires(post):  opencv-devel}
64%{?_with_openjpeg:Requires(post):  openjpeg-devel}
65##Requires(post):  schroedinger-devel
66Requires(post): SDL-devel
67Requires(post):  speex-devel
68##Requires(post):       texi2html
69Requires(post): zlib-devel
70Requires(post): libogg-devel
71Requires(post):         yasm
72Requires(post):         self-build-a52dec
73Requires(post):         self-build-faac
74Requires(post):         self-build-faad2
75Requires(post):         self-build-lame
76Requires(post):         self-build-libdca
77Requires(post):         self-build-x264 >= 0.129
78Requires(post):         self-build-xvidcore
79
80BuildRoot:      %{_tmppath}/%{name}-%{version}-root
81
82BuildArch:      noarch
83Packager:       munepi
84
85%description
86FFMpeg is a complete and free Internet live audio and video
87broadcasting solution for Linux/Unix. It also includes a
88digital VCR. It can encode in real time in many formats
89including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
90real, mjpeg, and flash.
91
92If you install this package, it automaticaly downloads source
93code ,compile it, and create rpm packages of %{pkgname}-%{version}.
94And the created rpm packages are automatically installed
95if installation is executed by apt-get command or synaptic
96package manager.
97
98[Note]
99This package requires many other packages to compile
100target software. So it consume more disk space than usual.
101Also installation takes longer time because of compilation.
102(This will take a few minutes to quarter or half of an hour,
103depends on building environment)
104
105[About self-build package]
106For some kind of software, distributing of binary package
107may viorate the patent or law. Therefore we chose self-build
108packge, create binary package on your machine, for such kind
109of softwares instead of distributing binary package.
110
111Please obey the national law when you use the created binary
112packages. And if you want to use the softwares using patented
113thechnology, it may be required to get a permission, make an
114agreement or purchas a license. Please consider it with your
115purpose or way of use and take appropriate action.
116
117%description -l ja
118FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
119ブオーティオ・ビデオブロードキャスティングソリューションです.
120またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
121MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
122多様なフォーマットをリアルタイムにエンコードすることができます.
123
124このパッケージをインストールすると、自動的にソースコードを
125ダウンロードしてコンパイルし、%{pkgname}-%{version}
126の rpm パッケージを作成します。
127また apt-get コマンドや synaptic パッケージマネージャから実行
128した場合は、作成された rpm パッケージのインストールも自動的に
129行います。
130
131[注意]
132コンパイルに必要な多くの関連パッケージを要求するので通常より
133ディスクの領域を多く消費します。
134またインストール時にコンパイルを行うため、通常より時間がかか
135る場合があります。(環境にもよりますが数分から数十分程度)
136
137[self-build パッケージについて]
138ソフトウェアによってはバイナリパッケージの配布が特許や法律に
139違反する可能性があるものがあります。その為、このような問題が
140懸念されるソフトウェアについてはバイナリパッケージを直接配布
141せずに、ユーザの環境でバイナリを作成する self-build パッケー
142ジという方法を採っています。
143
144作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
145アのライセンス、および利用する国の各種法令に従ってください。
146また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
147センスの購入などが必要となる場合がありますので、利用する目的
148や形態に応じて各自で判断し適切な対応を取ってください。
149
150%prep
151[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
152
153%install
154%{__rm} -rf ${RPM_BUILD_ROOT}
155%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
156%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
157
158%clean
159%{__rm} -rf ${RPM_BUILD_ROOT}
160
161%posttrans
162/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 86000
163/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
164                                 %{pkgname}-libs-%{version}-%{release} \
165                                 %{pkgname}-devel-%{version}-%{release}
166
167## Rebuild gpac with ffmpeg-devel
168# set locale
169case $LANG in
170    ja*)LOCALE=ja ;;
171    *) LOCALE=C ;;
172esac
173
174Rebuild_gpac_C(){
175    echo -n "     "
176    echo "Rebuild gpac with ffmpeg-devel"
177}
178
179Rebuild_gpac_ja(){
180    echo -n "     "
181    echo "ffmpeg-devel で gpac をリビルドします。"
182}
183
184Rebuild_gpac_$LOCALE
185%{gpac_postinstall}
186
187
188%files
189%defattr(-,root,root)
190%{_datadir}/%{name}
191
192%changelog
193* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
194- new upstream release
195
196* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
197- libvpx >= 0.9.7
198
199* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
200- new upstream release /x264-0.129
201
202* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
203- new upstream release
204
205* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
206- new upstream release
207
208* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
209- new upstream release
210
211* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
212- new upstream release
213
214* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
215- new upstream release
216- enable CELT decoding via libcelt
217- enable FreeType support
218- drop faad2 support (dropped upstream)
219
220* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
221- added BuildArch: noarch
222
223* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
224- new upstream release
225
226* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
227- new upstream release
228
229* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
230- required latest x264 build
231- added BuildRequires: librtmp-devel >= 2.3
232
233* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
234- new upstream release
235
236* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
237- unpacked source archives
238
239* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
240- fixed some dependencies
241  - Requires(post): libva-devel
242  - Requires(post): libvpx-devel >= 0.9.1
243
244* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
245- new upstream release
246
247* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
248- bumped version to pre-0.6
249- updated source snapshot 20100410
250
251* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
252- fixed self-build log size
253
254* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
255- added ffprobe.1.gz
256
257* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
258- updated source snapshot 20100401
259
260* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
261- renamed %%{Source0} to ffmpeg-vl.spec
262
263* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
264- updated source snapshot 20100216
265  - rebuild with recent x264-devel
266- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
267- added BuildRequires:  libvdpau-devel
268
269* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
270- dropped BuildArch: noarch
271- added ffmpeg.1, ffplay.1, ffserver.1
272
273* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
274- avoided to execute self-build-rpm.sh on RPM transaction
275  - moved %%post actions to %%posttrans
276
277* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
278- added BuildArch: noarch
279- added ffmpeg-0.5-disable-texi2html.patch
280  - dropped PreReq: texi2html
281
282* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
283- added %%{gpac_postinstall} in %%post
284
285* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
286- corrected release number
287
288* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
289- new upstream release
290- added PreReq:
291  - speex-devel
292  - bzip2-devel
293
294* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
295- change release to sync with ffmpeg
296
297* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
298- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
299
300* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
301- 20090202 snapshot
302
303* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
304- 20090110 snapshot
305- dropped some patches
306
307* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
308- source updated (r15488)
309- fixed License: GPLv2+
310- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
311- added BuildRequires: yasm (only %%ix86)
312- applied ffmpeg-cpu.patch (merged from RPM Fusion)
313
314* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
315- spec in utf8
316
317* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
318- run pre-allocate-rpm.sh in %%post
319- set PreReq: self-build-setup >= 0.8
320- change release number
321
322* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
323- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
324  include Source1 in the binary package.
325- drop "Source100: ffmpeg-vine.patch".
326- drop "PreReq: subversion".
327
328* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
329- build with new versioning policy
330- change to use svn export from svn checkout on post install
331- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
332
333* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
334- For all pre-required package that is provied by self-build, 
335  changed to its self-build package
336 
337* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
338- initial build for Vine Linux 4.2
339- snapshot 2008/01/28 + some Rev.11662 2008/01/29
340
341### end of file
Note: See TracBrowser for help on using the repository browser.