source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 6325

Revision 6325, 12.0 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%global pkgname ffmpeg
8%global name    self-build-%{pkgname}
9%global major_version 0.11
10%global version %{major_version}.1
11#% define svndate       20110326
12%global release 1%{?svndate:.%svndate}%{?_dist_release}
13
14%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
15
16%global with_faac 1
17%global with_vaapi 1
18%global with_libvpx 1
19
20#% define enable_avconv 1
21
22%define use_prebuilt_man 1
23
24Summary:        Package to automatically build %{pkgname} rpm package
25Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
26Name:           %{name}
27Version:        %{version}
28Release:        %{release}
29Source0:        %{pkgname}-vl.spec
30#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
31# pre-built man files
32%{?use_prebuilt_man:Source90:       ffmpeg-%{version}-doc.tar.xz}
33
34License:        GPLv2+
35Group:          Restricted Software
36
37Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
38Obsoletes:      self-build-ffmpeg < %{major_version}
39
40Requires(post):         self-build-setup >= 0.9.9
41#Requires(post):                subversion
42
43# (build)requies of target package.
44Requires(post):  bzip2-devel
45Requires(post):  celt-devel
46##Requires(post):  dirac-devel
47Requires(post):  freetype2-devel
48Requires(post): gsm-devel
49Requires(post): imlib2-devel
50Requires(post): libdc1394-devel
51Requires(post): libogg-devel
52Requires(post):  libass-devel
53%{!?_without_cdio:Requires(post): libcdio-devel}
54#libcrystalhd is currently broken
55%{?_with_crystalhd:Requires(post):      libcrystalhd-devel}
56Requires(post): libraw1394-devel
57Requires(post): librtmp-devel >= 2.3
58Requires(post): libtheora-devel
59%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
60Requires(post):  libvdpau-devel
61Requires(post): libvorbis-devel
62%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
63Requires(post):  libXvMC-devel
64%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
65%{!?_without_openal:Requires(post):  openal-soft-devel}
66%{?_with_opencv:Requires(post):  opencv-devel}
67%{?_with_openjpeg:Requires(post):  openjpeg-devel}
68##Requires(post):  schroedinger-devel
69Requires(post): SDL-devel
70Requires(post):  speex-devel
71##Requires(post):       texi2html
72Requires(post): zlib-devel
73Requires(post): libogg-devel
74Requires(post):         yasm
75Requires(post):         self-build-a52dec
76Requires(post):         self-build-faac
77Requires(post):         self-build-faad2
78Requires(post):         self-build-lame
79Requires(post):         self-build-libdca
80Requires(post):         self-build-x264 >= 0.120
81Requires(post):         self-build-xvidcore
82
83BuildRoot:      %{_tmppath}/%{name}-%{version}-root
84
85BuildArch:      noarch
86Packager:       munepi
87
88%description
89FFMpeg is a complete and free Internet live audio and video
90broadcasting solution for Linux/Unix. It also includes a
91digital VCR. It can encode in real time in many formats
92including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
93real, mjpeg, and flash.
94
95If you install this package, it automaticaly downloads source
96code ,compile it, and create rpm packages of %{pkgname}-%{version}.
97And the created rpm packages are automatically installed
98if installation is executed by apt-get command or synaptic
99package manager.
100
101[Note]
102This package requires many other packages to compile
103target software. So it consume more disk space than usual.
104Also installation takes longer time because of compilation.
105(This will take a few minutes to quarter or half of an hour,
106depends on building environment)
107
108[About self-build package]
109For some kind of software, distributing of binary package
110may viorate the patent or law. Therefore we chose self-build
111packge, create binary package on your machine, for such kind
112of softwares instead of distributing binary package.
113
114Please obey the national law when you use the created binary
115packages. And if you want to use the softwares using patented
116thechnology, it may be required to get a permission, make an
117agreement or purchas a license. Please consider it with your
118purpose or way of use and take appropriate action.
119
120%description -l ja
121FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
122ブオーティオ・ビデオブロードキャスティングソリューションです.
123またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
124MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
125多様なフォーマットをリアルタイムにエンコードすることができます.
126
127このパッケージをインストールすると、自動的にソースコードを
128ダウンロードしてコンパイルし、%{pkgname}-%{version}
129の rpm パッケージを作成します。
130また apt-get コマンドや synaptic パッケージマネージャから実行
131した場合は、作成された rpm パッケージのインストールも自動的に
132行います。
133
134[注意]
135コンパイルに必要な多くの関連パッケージを要求するので通常より
136ディスクの領域を多く消費します。
137またインストール時にコンパイルを行うため、通常より時間がかか
138る場合があります。(環境にもよりますが数分から数十分程度)
139
140[self-build パッケージについて]
141ソフトウェアによってはバイナリパッケージの配布が特許や法律に
142違反する可能性があるものがあります。その為、このような問題が
143懸念されるソフトウェアについてはバイナリパッケージを直接配布
144せずに、ユーザの環境でバイナリを作成する self-build パッケー
145ジという方法を採っています。
146
147作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
148アのライセンス、および利用する国の各種法令に従ってください。
149また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
150センスの購入などが必要となる場合がありますので、利用する目的
151や形態に応じて各自で判断し適切な対応を取ってください。
152
153%prep
154[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
155
156%install
157%{__rm} -rf ${RPM_BUILD_ROOT}
158%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
159%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
160%{?use_prebuilt_man:%{__install} -m 644 %{SOURCE90} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}}
161
162%clean
163%{__rm} -rf ${RPM_BUILD_ROOT}
164
165%posttrans
166/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 123000
167/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
168                                 %{pkgname}-libs-%{version}-%{release} \
169                                 %{pkgname}-devel-%{version}-%{release}
170
171## Rebuild gpac with ffmpeg-devel
172# set locale
173case $LANG in
174    ja*)LOCALE=ja ;;
175    *) LOCALE=C ;;
176esac
177
178Rebuild_gpac_C(){
179    echo -n "     "
180    echo "Rebuild gpac with ffmpeg-devel"
181}
182
183Rebuild_gpac_ja(){
184    echo -n "     "
185    echo "ffmpeg-devel で gpac をリビルドします。"
186}
187
188Rebuild_gpac_$LOCALE
189%{gpac_postinstall}
190
191
192%files
193%defattr(-,root,root)
194%{_datadir}/%{name}
195
196%changelog
197* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
198- new upstream release
199
200* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
201- new upstream release
202
203* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
204- new upstream release
205
206* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
207- new upstream release
208- enable CELT decoding via libcelt
209- enable FreeType support
210- drop faad2 support (dropped upstream)
211
212* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
213- added BuildArch: noarch
214
215* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
216- new upstream release
217
218* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
219- new upstream release
220
221* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
222- required latest x264 build
223- added BuildRequires: librtmp-devel >= 2.3
224
225* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
226- new upstream release
227
228* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
229- unpacked source archives
230
231* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
232- fixed some dependencies
233  - Requires(post): libva-devel
234  - Requires(post): libvpx-devel >= 0.9.1
235
236* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
237- new upstream release
238
239* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
240- bumped version to pre-0.6
241- updated source snapshot 20100410
242
243* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
244- fixed self-build log size
245
246* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
247- added ffprobe.1.gz
248
249* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
250- updated source snapshot 20100401
251
252* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
253- renamed %%{Source0} to ffmpeg-vl.spec
254
255* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
256- updated source snapshot 20100216
257  - rebuild with recent x264-devel
258- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
259- added BuildRequires:  libvdpau-devel
260
261* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
262- dropped BuildArch: noarch
263- added ffmpeg.1, ffplay.1, ffserver.1
264
265* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
266- avoided to execute self-build-rpm.sh on RPM transaction
267  - moved %%post actions to %%posttrans
268
269* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
270- added BuildArch: noarch
271- added ffmpeg-0.5-disable-texi2html.patch
272  - dropped PreReq: texi2html
273
274* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
275- added %%{gpac_postinstall} in %%post
276
277* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
278- corrected release number
279
280* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
281- new upstream release
282- added PreReq:
283  - speex-devel
284  - bzip2-devel
285
286* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
287- change release to sync with ffmpeg
288
289* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
290- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
291
292* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
293- 20090202 snapshot
294
295* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
296- 20090110 snapshot
297- dropped some patches
298
299* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
300- source updated (r15488)
301- fixed License: GPLv2+
302- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
303- added BuildRequires: yasm (only %%ix86)
304- applied ffmpeg-cpu.patch (merged from RPM Fusion)
305
306* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
307- spec in utf8
308
309* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
310- run pre-allocate-rpm.sh in %%post
311- set PreReq: self-build-setup >= 0.8
312- change release number
313
314* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
315- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
316  include Source1 in the binary package.
317- drop "Source100: ffmpeg-vine.patch".
318- drop "PreReq: subversion".
319
320* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
321- build with new versioning policy
322- change to use svn export from svn checkout on post install
323- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
324
325* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
326- For all pre-required package that is provied by self-build, 
327  changed to its self-build package
328 
329* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
330- initial build for Vine Linux 4.2
331- snapshot 2008/01/28 + some Rev.11662 2008/01/29
332
333### end of file
Note: See TracBrowser for help on using the repository browser.