source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 1373

Revision 1373, 10.5 KB checked in by munepi, 14 years ago (diff)

updated self-build-{mplayer,ffmpeg}: unpacked source archives

Line 
1%define gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%define pkgname ffmpeg
8%define name    self-build-%{pkgname}
9%define version 0.6
10#% define svndate       20100625
11%define release 4%{?svndate:.%svndate}%{?_dist_release}
12
13%define sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{version}.tar.bz2
14
15## available for v0.6 or lower
16%define with_libfaad 1
17
18%define with_vaapi 1
19%define with_libvpx 1
20
21Summary:        Package to automatically build %{pkgname} rpm package
22Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
23Name:           %{name}
24Version:        %{version}
25Release:        %{release}
26Source0:        %{pkgname}-vl.spec
27#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
28Source2:        %{pkgname}-snapshot.sh
29Source90:       ffmpeg.1.gz
30Source91:       ffplay.1.gz
31Source92:       ffserver.1.gz
32Source93:       ffprobe.1.gz
33
34License:        GPLv2+
35Group:          Restricted Software
36
37Requires(post):         self-build-setup >= 0.9.9
38#Requires(post):                subversion
39
40# (build)requies of target package.
41Requires(post):  bzip2-devel
42Requires(post): gsm-devel
43Requires(post): imlib2-devel
44Requires(post): libdc1394-devel
45Requires(post): libraw1394-devel
46Requires(post): libtheora-devel
47Requires(post):  libvdpau-devel
48%{?with_vaapi:Requires(post):  libva-devel}
49%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.1}
50Requires(post): libvorbis-devel
51#%{?_with_opencore_amr:Requires(post):  opencore-amr-devel}
52##Requires(post):  openjpeg-devel
53Requires(post): SDL-devel
54Requires(post):  speex-devel
55##Requires(post):       texi2html
56Requires(post): zlib-devel
57Requires(post): libogg-devel
58%ifarch %{ix86} x86_64
59Requires(post):         yasm
60%endif
61Requires(post):         self-build-xvidcore
62Requires(post):         self-build-faac
63Requires(post):         self-build-lame
64Requires(post):         self-build-x264
65Requires(post):         self-build-libdca
66Requires(post):         self-build-a52dec
67Requires(post):         self-build-faad2
68
69BuildRoot:      %{_tmppath}/%{name}-%{version}-root
70
71Packager:       munepi
72
73%description
74FFMpeg is a complete and free Internet live audio and video
75broadcasting solution for Linux/Unix. It also includes a
76digital VCR. It can encode in real time in many formats
77including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
78real, mjpeg, and flash.
79
80If you install this package, it automaticaly downloads source
81code ,compile it, and create rpm packages of %{pkgname}-%{version}.
82And the created rpm packages are automatically installed
83if installation is executed by apt-get command or synaptic
84package manager.
85
86[Note]
87This package requires many other packages to compile
88target software. So it consume more disk space than usual.
89Also installation takes longer time because of compilation.
90(This will take a few minutes to quarter or half of an hour,
91depends on building environment)
92
93[About self-build package]
94For some kind of software, distributing of binary package
95may viorate the patent or law. Therefore we chose self-build
96packge, create binary package on your machine, for such kind
97of softwares instead of distributing binary package.
98
99Please obey the national law when you use the created binary
100packages. And if you want to use the softwares using patented
101thechnology, it may be required to get a permission, make an
102agreement or purchas a license. Please consider it with your
103purpose or way of use and take appropriate action.
104
105%description -l ja
106FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
107ブオーティオ・ビデオブロードキャスティングソリューションです.
108またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
109MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
110多様なフォーマットをリアルタイムにエンコードすることができます.
111
112このパッケージをインストールすると、自動的にソースコードを
113ダウンロードしてコンパイルし、%{pkgname}-%{version}
114の rpm パッケージを作成します。
115また apt-get コマンドや synaptic パッケージマネージャから実行
116した場合は、作成された rpm パッケージのインストールも自動的に
117行います。
118
119[注意]
120コンパイルに必要な多くの関連パッケージを要求するので通常より
121ディスクの領域を多く消費します。
122またインストール時にコンパイルを行うため、通常より時間がかか
123る場合があります。(環境にもよりますが数分から数十分程度)
124
125[self-build パッケージについて]
126ソフトウェアによってはバイナリパッケージの配布が特許や法律に
127違反する可能性があるものがあります。その為、このような問題が
128懸念されるソフトウェアについてはバイナリパッケージを直接配布
129せずに、ユーザの環境でバイナリを作成する self-build パッケー
130ジという方法を採っています。
131
132作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
133アのライセンス、および利用する国の各種法令に従ってください。
134また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
135センスの購入などが必要となる場合がありますので、利用する目的
136や形態に応じて各自で判断し適切な対応を取ってください。
137
138%prep
139[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
140
141%install
142%{__rm} -rf ${RPM_BUILD_ROOT}
143%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
144%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
145#%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
146#%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
147%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
148    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
149
150%clean
151%{__rm} -rf ${RPM_BUILD_ROOT}
152
153%posttrans
154#/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
155/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 77000
156/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
157                                 %{pkgname}-libs-%{version}-%{release} \
158                                 %{pkgname}-devel-%{version}-%{release}
159
160## Rebuild gpac with ffmpeg-devel
161# set locale
162case $LANG in
163    ja*)LOCALE=ja ;;
164    *) LOCALE=C ;;
165esac
166
167Rebuild_gpac_C(){
168    echo -n "     "
169    echo "Rebuild gpac with ffmpeg-devel"
170}
171
172Rebuild_gpac_ja(){
173    echo -n "     "
174    echo "ffmpeg-devel で gpac をリビルドします。"
175}
176
177Rebuild_gpac_$LOCALE
178%{gpac_postinstall}
179
180
181%files
182%defattr(-,root,root)
183%{_datadir}/%{name}
184
185%changelog
186* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
187- unpacked source archives
188
189* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
190- fixed some dependencies
191  - Requires(post): libva-devel
192  - Requires(post): libvpx-devel >= 0.9.1
193
194* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
195- new upstream release
196
197* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
198- bumped version to pre-0.6
199- updated source snapshot 20100410
200
201* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
202- fixed self-build log size
203
204* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
205- added ffprobe.1.gz
206
207* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
208- updated source snapshot 20100401
209
210* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
211- renamed %%{Source0} to ffmpeg-vl.spec
212
213* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
214- updated source snapshot 20100216
215  - rebuild with recent x264-devel
216- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
217- added BuildRequires:  libvdpau-devel
218
219* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
220- dropped BuildArch: noarch
221- added ffmpeg.1, ffplay.1, ffserver.1
222
223* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
224- avoided to execute self-build-rpm.sh on RPM transaction
225  - moved %%post actions to %%posttrans
226
227* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
228- added BuildArch: noarch
229- added ffmpeg-0.5-disable-texi2html.patch
230  - dropped PreReq: texi2html
231
232* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
233- added %%{gpac_postinstall} in %%post
234
235* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
236- corrected release number
237
238* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
239- new upstream release
240- added PreReq:
241  - speex-devel
242  - bzip2-devel
243
244* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
245- change release to sync with ffmpeg
246
247* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
248- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
249
250* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
251- 20090202 snapshot
252
253* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
254- 20090110 snapshot
255- dropped some patches
256
257* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
258- source updated (r15488)
259- fixed License: GPLv2+
260- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
261- added BuildRequires: yasm (only %%ix86)
262- applied ffmpeg-cpu.patch (merged from RPM Fusion)
263
264* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
265- spec in utf8
266
267* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
268- run pre-allocate-rpm.sh in %%post
269- set PreReq: self-build-setup >= 0.8
270- change release number
271
272* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
273- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
274  include Source1 in the binary package.
275- drop "Source100: ffmpeg-vine.patch".
276- drop "PreReq: subversion".
277
278* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
279- build with new versioning policy
280- change to use svn export from svn checkout on post install
281- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
282
283* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
284- For all pre-required package that is provied by self-build, 
285  changed to its self-build package
286 
287* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
288- initial build for Vine Linux 4.2
289- snapshot 2008/01/28 + some Rev.11662 2008/01/29
290
291### end of file
Note: See TracBrowser for help on using the repository browser.