source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 1258

Revision 1258, 10.1 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1%define gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%define pkgname ffmpeg
8%define name    self-build-%{pkgname}
9%define version 0.6
10#% define svndate       20100625
11%define release 2%{?svndate:.%svndate}%{?_dist_release}
12
13## available for v0.6 or lower
14%define with_libfaad 1
15
16%define with_vaapi 1
17#% define with_libvpx 1
18
19Summary:        Package to automatically build %{pkgname} rpm package
20Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
21Name:           %{name}
22Version:        %{version}
23Release:        %{release}
24Source0:        %{pkgname}-vl.spec
25Source1:        %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
26Source2:        %{pkgname}-snapshot.sh
27Source90:       ffmpeg.1.gz
28Source91:       ffplay.1.gz
29Source92:       ffserver.1.gz
30Source93:       ffprobe.1.gz
31
32License:        GPLv2+
33Group:          Restricted Software
34
35Requires(post):         self-build-setup >= 0.9.9
36#Requires(post):                subversion
37
38# (build)requies of target package.
39Requires(post):  bzip2-devel
40Requires(post): gsm-devel
41Requires(post): imlib2-devel
42Requires(post): libdc1394-devel
43Requires(post): libraw1394-devel
44Requires(post): libtheora-devel
45Requires(post):  libvdpau-devel
46%{?with_vaapi:BuildRequires:libva-devel}
47%{?with_libvpx:BuildRequires:  libvpx-devel}
48Requires(post): libvorbis-devel
49%{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
50##Requires(post):  openjpeg-devel
51Requires(post): SDL-devel
52Requires(post):  speex-devel
53##Requires(post):       texi2html
54Requires(post): zlib-devel
55Requires(post): libogg-devel
56%ifarch %{ix86} x86_64
57Requires(post):         yasm
58%endif
59Requires(post):         self-build-xvidcore
60Requires(post):         self-build-faac
61Requires(post):         self-build-lame
62Requires(post):         self-build-x264
63Requires(post):         self-build-libdca
64Requires(post):         self-build-a52dec
65Requires(post):         self-build-faad2
66
67BuildRoot:      %{_tmppath}/%{name}-%{version}-root
68
69Packager:       munepi
70
71%description
72FFMpeg is a complete and free Internet live audio and video
73broadcasting solution for Linux/Unix. It also includes a
74digital VCR. It can encode in real time in many formats
75including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
76real, mjpeg, and flash.
77
78If you install this package, it automaticaly downloads source
79code ,compile it, and create rpm packages of %{pkgname}-%{version}.
80And the created rpm packages are automatically installed
81if installation is executed by apt-get command or synaptic
82package manager.
83
84[Note]
85This package requires many other packages to compile
86target software. So it consume more disk space than usual.
87Also installation takes longer time because of compilation.
88(This will take a few minutes to quarter or half of an hour,
89depends on building environment)
90
91[About self-build package]
92For some kind of software, distributing of binary package
93may viorate the patent or law. Therefore we chose self-build
94packge, create binary package on your machine, for such kind
95of softwares instead of distributing binary package.
96
97Please obey the national law when you use the created binary
98packages. And if you want to use the softwares using patented
99thechnology, it may be required to get a permission, make an
100agreement or purchas a license. Please consider it with your
101purpose or way of use and take appropriate action.
102
103%description -l ja
104FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
105ブオーティオ・ビデオブロードキャスティングソリューションです.
106またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
107MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
108多様なフォーマットをリアルタイムにエンコードすることができます.
109
110このパッケージをインストールすると、自動的にソースコードを
111ダウンロードしてコンパイルし、%{pkgname}-%{version}
112の rpm パッケージを作成します。
113また apt-get コマンドや synaptic パッケージマネージャから実行
114した場合は、作成された rpm パッケージのインストールも自動的に
115行います。
116
117[注意]
118コンパイルに必要な多くの関連パッケージを要求するので通常より
119ディスクの領域を多く消費します。
120またインストール時にコンパイルを行うため、通常より時間がかか
121る場合があります。(環境にもよりますが数分から数十分程度)
122
123[self-build パッケージについて]
124ソフトウェアによってはバイナリパッケージの配布が特許や法律に
125違反する可能性があるものがあります。その為、このような問題が
126懸念されるソフトウェアについてはバイナリパッケージを直接配布
127せずに、ユーザの環境でバイナリを作成する self-build パッケー
128ジという方法を採っています。
129
130作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
131アのライセンス、および利用する国の各種法令に従ってください。
132また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
133センスの購入などが必要となる場合がありますので、利用する目的
134や形態に応じて各自で判断し適切な対応を取ってください。
135
136%prep
137[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
138
139%install
140%{__rm} -rf ${RPM_BUILD_ROOT}
141%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
142%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
143%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
144%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
145%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
146    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
147
148%clean
149%{__rm} -rf ${RPM_BUILD_ROOT}
150
151%posttrans
152/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
153/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
154                                 %{pkgname}-libs-%{version}-%{release} \
155                                 %{pkgname}-devel-%{version}-%{release}
156
157## Rebuild gpac with ffmpeg-devel
158# set locale
159case $LANG in
160    ja*)LOCALE=ja ;;
161    *) LOCALE=C ;;
162esac
163
164Rebuild_gpac_C(){
165    echo -n "     "
166    echo "Rebuild gpac with ffmpeg-devel"
167}
168
169Rebuild_gpac_ja(){
170    echo -n "     "
171    echo "ffmpeg-devel で gpac をリビルドします。"
172}
173
174Rebuild_gpac_$LOCALE
175%{gpac_postinstall}
176
177
178%files
179%defattr(-,root,root)
180%{_datadir}/%{name}
181
182%changelog
183* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
184- new upstream release
185
186* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
187- bumped version to pre-0.6
188- updated source snapshot 20100410
189
190* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
191- fixed self-build log size
192
193* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
194- added ffprobe.1.gz
195
196* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
197- updated source snapshot 20100401
198
199* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
200- renamed %%{Source0} to ffmpeg-vl.spec
201
202* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
203- updated source snapshot 20100216
204  - rebuild with recent x264-devel
205- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
206- added BuildRequires:  libvdpau-devel
207
208* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
209- dropped BuildArch: noarch
210- added ffmpeg.1, ffplay.1, ffserver.1
211
212* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
213- avoided to execute self-build-rpm.sh on RPM transaction
214  - moved %%post actions to %%posttrans
215
216* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
217- added BuildArch: noarch
218- added ffmpeg-0.5-disable-texi2html.patch
219  - dropped PreReq: texi2html
220
221* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
222- added %%{gpac_postinstall} in %%post
223
224* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
225- corrected release number
226
227* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
228- new upstream release
229- added PreReq:
230  - speex-devel
231  - bzip2-devel
232
233* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
234- change release to sync with ffmpeg
235
236* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
237- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
238
239* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
240- 20090202 snapshot
241
242* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
243- 20090110 snapshot
244- dropped some patches
245
246* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
247- source updated (r15488)
248- fixed License: GPLv2+
249- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
250- added BuildRequires: yasm (only %%ix86)
251- applied ffmpeg-cpu.patch (merged from RPM Fusion)
252
253* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
254- spec in utf8
255
256* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
257- run pre-allocate-rpm.sh in %%post
258- set PreReq: self-build-setup >= 0.8
259- change release number
260
261* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
262- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
263  include Source1 in the binary package.
264- drop "Source100: ffmpeg-vine.patch".
265- drop "PreReq: subversion".
266
267* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
268- build with new versioning policy
269- change to use svn export from svn checkout on post install
270- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
271
272* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
273- For all pre-required package that is provied by self-build, 
274  changed to its self-build package
275 
276* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
277- initial build for Vine Linux 4.2
278- snapshot 2008/01/28 + some Rev.11662 2008/01/29
279
280### end of file
Note: See TracBrowser for help on using the repository browser.