source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 10030

Revision 10030, 14.4 KB checked in by munepi, 8 years ago (diff)

new upstream release

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) ; \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} ; \
5    /bin/bash ${gpac_postinstall_sh} ; /bin/rm -f ${gpac_postinstall_sh}
6
7%global x264_postinstall     \
8    x264_postinstall_sh=$(mktemp) ; \
9    rpm -q --scripts self-build-x264 | \
10    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${x264_postinstall_sh} ; \
11    /bin/bash ${x264_postinstall_sh} ; /bin/rm -f ${x264_postinstall_sh}
12
13
14%global pkgname ffmpeg
15%global name    self-build-%{pkgname}
16%global major_version 2.8
17%global version %{major_version}.6
18#% define svndate       20110326
19%global release 1%{?svndate:.%svndate}%{?_dist_release}
20
21%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
22
23%global with_faac 1
24%global with_vaapi 1
25%global with_libvpx 1
26
27#% define enable_avconv 1
28
29Summary:        Package to automatically build %{pkgname} rpm package
30Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
31Name:           %{name}
32Version:        %{version}
33Release:        %{release}
34Source0:        %{pkgname}-vl.spec
35#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
36
37License:        GPLv2+
38Group:          Restricted Software
39
40Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
41Obsoletes:      self-build-ffmpeg < %{version}
42
43Requires(post):         self-build-setup >= 0.9.9
44#Requires(post):                subversion
45
46# (build)requies of target package.
47Requires(post):  bzip2-devel
48Requires(post):  celt-devel
49##Requires(post):  dirac-devel
50Requires(post):  freetype2-devel
51Requires(post):  gnutls-devel
52Requires(post): gsm-devel
53Requires(post): imlib2-devel
54Requires(post): libdc1394-devel
55Requires(post): libogg-devel
56Requires(post):  libass-devel
57%{!?_without_cdio:Requires(post): libcdio-devel}
58%{!?_without_cdio:Requires: libcdio-paranoia-devel}
59#libcrystalhd is currently broken
60%{?_with_crystalhd:Requires(post):      libcrystalhd-devel}
61Requires(post): libraw1394-devel
62Requires(post): librtmp-devel >= 2.3
63Requires(post): libtheora-devel
64%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
65Requires(post):  libvdpau-devel
66Requires(post): libvorbis-devel
67%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.7}
68Requires(post):  libXvMC-devel
69%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
70%{!?_without_openal:Requires(post):  openal-soft-devel}
71%{?_with_opencv:Requires(post):  opencv-devel}
72%{?_with_openjpeg:Requires(post):  openjpeg-devel}
73##Requires(post):  schroedinger-devel
74Requires(post): SDL-devel
75Requires(post):  speex-devel
76##Requires(post):       texi2html
77Requires(post): zlib-devel
78Requires(post): libogg-devel
79Requires(post):         yasm
80Requires(post):         self-build-a52dec
81Requires(post):         self-build-faac
82Requires(post):         self-build-faad2
83Requires(post):         self-build-lame
84Requires(post):         self-build-libdca
85Requires(post):         self-build-x264 >= 0.142
86Requires(post):         self-build-x265 >= 1.4
87Requires(post):         self-build-xvidcore
88
89BuildRoot:      %{_tmppath}/%{name}-%{version}-root
90
91BuildArch:      noarch
92Packager:       munepi
93
94%description
95FFMpeg is a complete and free Internet live audio and video
96broadcasting solution for Linux/Unix. It also includes a
97digital VCR. It can encode in real time in many formats
98including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
99real, mjpeg, and flash.
100
101If you install this package, it automaticaly downloads source
102code ,compile it, and create rpm packages of %{pkgname}-%{version}.
103And the created rpm packages are automatically installed
104if installation is executed by apt-get command or synaptic
105package manager.
106
107[Note]
108This package requires many other packages to compile
109target software. So it consume more disk space than usual.
110Also installation takes longer time because of compilation.
111(This will take a few minutes to quarter or half of an hour,
112depends on building environment)
113
114[About self-build package]
115For some kind of software, distributing of binary package
116may viorate the patent or law. Therefore we chose self-build
117packge, create binary package on your machine, for such kind
118of softwares instead of distributing binary package.
119
120Please obey the national law when you use the created binary
121packages. And if you want to use the softwares using patented
122thechnology, it may be required to get a permission, make an
123agreement or purchas a license. Please consider it with your
124purpose or way of use and take appropriate action.
125
126%description -l ja
127FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
128ブオーティオ・ビデオブロードキャスティングソリューションです.
129またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
130MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
131多様なフォーマットをリアルタイムにエンコードすることができます.
132
133このパッケージをインストールすると、自動的にソースコードを
134ダウンロードしてコンパイルし、%{pkgname}-%{version}
135の rpm パッケージを作成します。
136また apt-get コマンドや synaptic パッケージマネージャから実行
137した場合は、作成された rpm パッケージのインストールも自動的に
138行います。
139
140[注意]
141コンパイルに必要な多くの関連パッケージを要求するので通常より
142ディスクの領域を多く消費します。
143またインストール時にコンパイルを行うため、通常より時間がかか
144る場合があります。(環境にもよりますが数分から数十分程度)
145
146[self-build パッケージについて]
147ソフトウェアによってはバイナリパッケージの配布が特許や法律に
148違反する可能性があるものがあります。その為、このような問題が
149懸念されるソフトウェアについてはバイナリパッケージを直接配布
150せずに、ユーザの環境でバイナリを作成する self-build パッケー
151ジという方法を採っています。
152
153作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
154アのライセンス、および利用する国の各種法令に従ってください。
155また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
156センスの購入などが必要となる場合がありますので、利用する目的
157や形態に応じて各自で判断し適切な対応を取ってください。
158
159%prep
160[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
161
162%install
163%{__rm} -rf ${RPM_BUILD_ROOT}
164%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
165%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
166
167%clean
168%{__rm} -rf ${RPM_BUILD_ROOT}
169
170%posttrans
171/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 93000
172/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
173                                 %{pkgname}-libs-%{version}-%{release} \
174                                 %{pkgname}-devel-%{version}-%{release}
175
176## Rebuild gpac with ffmpeg-devel
177# set locale
178case $LANG in
179    ja*)LOCALE=ja ;;
180    *) LOCALE=C ;;
181esac
182
183Rebuild_gpac_C(){
184    echo -n "     "
185    echo "Rebuild gpac with ffmpeg-devel"
186}
187
188Rebuild_gpac_ja(){
189    echo -n "     "
190    echo "ffmpeg-devel で gpac をリビルドします。"
191}
192
193Rebuild_gpac_$LOCALE
194%{gpac_postinstall}
195
196## Rebuild x264 with ffmpeg-devel
197# set locale
198case $LANG in
199    ja*)LOCALE=ja ;;
200    *) LOCALE=C ;;
201esac
202
203Rebuild_x264_C(){
204    echo -n "     "
205    echo "Rebuild x264 with ffmpeg-devel"
206}
207
208Rebuild_x264_ja(){
209    echo -n "     "
210    echo "ffmpeg-devel で x264 をリビルドします。"
211}
212
213Rebuild_x264_$LOCALE
214%{x264_postinstall}
215
216
217%files
218%defattr(-,root,root)
219%{_datadir}/%{name}
220
221%changelog
222* Mon Feb 15 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.6-1
223- new upstream release
224
225* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.5-1
226- new upstream release
227
228* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-2
229- rebuild with gnutils-3.4.7
230
231* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.7.1-1
232- new upstream release
233
234* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.3-1
235- new upstream release
236
237* Mon Apr 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.2-1
238- new upstream release
239
240* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.1-1
241- new upstream release
242
243* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6-1
244- new upstream release
245
246* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.4-1
247- new upstream release
248
249* Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.3-1
250- new upstream release
251
252* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
253- new upstream release
254
255* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
256- add BuildRequires: libcdio-paranoia-devel
257
258* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
259- new upstream release
260
261* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
262- new upstream release
263
264* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
265- new upstream release
266- added %%{x264_postinstall} in %%post
267
268* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
269- new upstream release
270- added man pages
271  - added Source10: ffmpeg-1.2.1-doc.tar.xz
272
273* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
274- new upstream release
275
276* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
277- new upstream release
278
279* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
280- libvpx >= 0.9.7
281
282* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
283- new upstream release /x264-0.129
284
285* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
286- new upstream release
287
288* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
289- new upstream release
290
291* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
292- new upstream release
293
294* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
295- new upstream release
296
297* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
298- new upstream release
299- enable CELT decoding via libcelt
300- enable FreeType support
301- drop faad2 support (dropped upstream)
302
303* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
304- added BuildArch: noarch
305
306* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
307- new upstream release
308
309* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
310- new upstream release
311
312* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
313- required latest x264 build
314- added BuildRequires: librtmp-devel >= 2.3
315
316* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
317- new upstream release
318
319* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
320- unpacked source archives
321
322* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
323- fixed some dependencies
324  - Requires(post): libva-devel
325  - Requires(post): libvpx-devel >= 0.9.1
326
327* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
328- new upstream release
329
330* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
331- bumped version to pre-0.6
332- updated source snapshot 20100410
333
334* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
335- fixed self-build log size
336
337* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
338- added ffprobe.1.gz
339
340* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
341- updated source snapshot 20100401
342
343* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
344- renamed %%{Source0} to ffmpeg-vl.spec
345
346* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
347- updated source snapshot 20100216
348  - rebuild with recent x264-devel
349- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
350- added BuildRequires:  libvdpau-devel
351
352* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
353- dropped BuildArch: noarch
354- added ffmpeg.1, ffplay.1, ffserver.1
355
356* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
357- avoided to execute self-build-rpm.sh on RPM transaction
358  - moved %%post actions to %%posttrans
359
360* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
361- added BuildArch: noarch
362- added ffmpeg-0.5-disable-texi2html.patch
363  - dropped PreReq: texi2html
364
365* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
366- added %%{gpac_postinstall} in %%post
367
368* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
369- corrected release number
370
371* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
372- new upstream release
373- added PreReq:
374  - speex-devel
375  - bzip2-devel
376
377* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
378- change release to sync with ffmpeg
379
380* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
381- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
382
383* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
384- 20090202 snapshot
385
386* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
387- 20090110 snapshot
388- dropped some patches
389
390* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
391- source updated (r15488)
392- fixed License: GPLv2+
393- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
394- added BuildRequires: yasm (only %%ix86)
395- applied ffmpeg-cpu.patch (merged from RPM Fusion)
396
397* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
398- spec in utf8
399
400* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
401- run pre-allocate-rpm.sh in %%post
402- set PreReq: self-build-setup >= 0.8
403- change release number
404
405* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
406- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
407  include Source1 in the binary package.
408- drop "Source100: ffmpeg-vine.patch".
409- drop "PreReq: subversion".
410
411* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
412- build with new versioning policy
413- change to use svn export from svn checkout on post install
414- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
415
416* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
417- For all pre-required package that is provied by self-build, 
418  changed to its self-build package
419 
420* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
421- initial build for Vine Linux 4.2
422- snapshot 2008/01/28 + some Rev.11662 2008/01/29
423
424### end of file
Note: See TracBrowser for help on using the repository browser.