source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 12248

Revision 12248, 14.8 KB checked in by ara_t, 5 years ago (diff)

self-build-ffmpeg: change BuildRequires?

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) ; \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} ; \
5    /bin/bash ${gpac_postinstall_sh} ; /bin/rm -f ${gpac_postinstall_sh}
6
7%global x264_postinstall     \
8    x264_postinstall_sh=$(mktemp) ; \
9    rpm -q --scripts self-build-x264 | \
10    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${x264_postinstall_sh} ; \
11    /bin/bash ${x264_postinstall_sh} ; /bin/rm -f ${x264_postinstall_sh}
12
13
14%global pkgname ffmpeg
15%global name  self-build-%{pkgname}
16%global major_version 2.8
17%global version %{major_version}.7
18#% define svndate 20110326
19%global release 3%{?svndate:.%svndate}%{?_dist_release}
20
21%global sourceurl0  http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
22
23%global with_faac 1
24%global with_vaapi 1
25%global with_libvpx 1
26
27#% define enable_avconv 1
28
29Summary:  Package to automatically build %{pkgname} rpm package
30Summary(ja):  %{pkgname} の rpm パッケージを自動作成するパッケージ
31Name:   %{name}
32Version:  %{version}
33Release:  %{release}
34Source0:  %{pkgname}-vl.spec
35#Source1: %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
36
37License:  GPLv2+
38Group:    Restricted Software
39
40Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
41Obsoletes:      self-build-ffmpeg < %{version}
42
43Requires(post):   self-build-setup >= 0.9.9
44#Requires(post):    subversion
45
46# (build)requies of target package.
47Requires(post):  bzip2-devel
48Requires(post):  celt-devel
49##Requires(post):  dirac-devel
50Requires(post):  freetype2-devel
51Requires(post):  gnutls-devel
52Requires(post): gsm-devel
53Requires(post): imlib2-devel
54Requires(post): libdc1394-devel
55Requires(post): libogg-devel
56Requires(post):  libass-devel
57%{!?_without_cdio:Requires(post): libcdio-devel}
58%{!?_without_cdio:Requires: libcdio-paranoia-devel}
59#libcrystalhd is currently broken
60%{?_with_crystalhd:Requires(post):  libcrystalhd-devel}
61Requires(post): libraw1394-devel
62Requires(post): librtmp-devel >= 2.3
63Requires(post): libtheora-devel
64%{?with_vaapi:Requires(post): libva-devel >= 0.31.0}
65Requires(post):  libvdpau-devel
66Requires(post): libvorbis-devel
67%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.7}
68Requires(post):  libXvMC-devel
69%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
70%{!?_without_openal:Requires(post):  openal-soft-devel}
71%{?_with_opencv:Requires(post):  opencv-devel}
72%{?_with_openjpeg:Requires(post):  openjpeg-devel}
73##Requires(post):  schroedinger-devel
74Requires(post): SDL-devel
75Requires(post):  speex-devel
76##Requires(post): texi2html
77Requires(post): zlib-devel
78Requires(post): libogg-devel
79Requires(post):   yasm
80Requires(post):   a52dec-devel
81Requires(post):   lame-devel
82# Requires(post):   self-build-a52dec
83Requires(post):   self-build-faac
84Requires(post):   self-build-faad2
85# Requires(post):   self-build-lame
86Requires(post):   self-build-libdca
87Requires(post):   self-build-x264 >= 0.142
88Requires(post):   self-build-x265 >= 1.4
89Requires(post):   self-build-xvidcore
90
91BuildRoot:  %{_tmppath}/%{name}-%{version}-root
92
93BuildArch:  noarch
94Packager: munepi
95
96%description
97FFMpeg is a complete and free Internet live audio and video
98broadcasting solution for Linux/Unix. It also includes a
99digital VCR. It can encode in real time in many formats
100including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
101real, mjpeg, and flash.
102
103If you install this package, it automaticaly downloads source
104code ,compile it, and create rpm packages of %{pkgname}-%{version}.
105And the created rpm packages are automatically installed
106if installation is executed by apt-get command or synaptic
107package manager.
108
109[Note]
110This package requires many other packages to compile
111target software. So it consume more disk space than usual.
112Also installation takes longer time because of compilation.
113(This will take a few minutes to quarter or half of an hour,
114depends on building environment)
115
116[About self-build package]
117For some kind of software, distributing of binary package
118may viorate the patent or law. Therefore we chose self-build
119packge, create binary package on your machine, for such kind
120of softwares instead of distributing binary package.
121
122Please obey the national law when you use the created binary
123packages. And if you want to use the softwares using patented
124thechnology, it may be required to get a permission, make an
125agreement or purchas a license. Please consider it with your
126purpose or way of use and take appropriate action.
127
128%description -l ja
129FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
130ブオーティオ・ビデオブロードキャスティングソリューションです.
131またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
132MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
133多様なフォーマットをリアルタイムにエンコードすることができます.
134
135このパッケージをインストールすると、自動的にソースコードを
136ダウンロードしてコンパイルし、%{pkgname}-%{version}
137の rpm パッケージを作成します。
138また apt-get コマンドや synaptic パッケージマネージャから実行
139した場合は、作成された rpm パッケージのインストールも自動的に
140行います。
141
142[注意]
143コンパイルに必要な多くの関連パッケージを要求するので通常より
144ディスクの領域を多く消費します。
145またインストール時にコンパイルを行うため、通常より時間がかか
146る場合があります。(環境にもよりますが数分から数十分程度)
147
148[self-build パッケージについて]
149ソフトウェアによってはバイナリパッケージの配布が特許や法律に
150違反する可能性があるものがあります。その為、このような問題が
151懸念されるソフトウェアについてはバイナリパッケージを直接配布
152せずに、ユーザの環境でバイナリを作成する self-build パッケー
153ジという方法を採っています。
154
155作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
156アのライセンス、および利用する国の各種法令に従ってください。
157また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
158センスの購入などが必要となる場合がありますので、利用する目的
159や形態に応じて各自で判断し適切な対応を取ってください。
160
161%prep
162[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
163
164%install
165%{__rm} -rf ${RPM_BUILD_ROOT}
166%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
167%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
168
169%clean
170%{__rm} -rf ${RPM_BUILD_ROOT}
171
172%posttrans
173/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 93000
174/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
175                                 %{pkgname}-libs-%{version}-%{release} \
176                                 %{pkgname}-devel-%{version}-%{release}
177
178## Rebuild gpac with ffmpeg-devel
179# set locale
180case $LANG in
181    ja*)LOCALE=ja ;;
182    *) LOCALE=C ;;
183esac
184
185Rebuild_gpac_C(){
186    echo -n "     "
187    echo "Rebuild gpac with ffmpeg-devel"
188}
189
190Rebuild_gpac_ja(){
191    echo -n "     "
192    echo "ffmpeg-devel で gpac をリビルドします。"
193}
194
195Rebuild_gpac_$LOCALE
196%{gpac_postinstall}
197
198## Rebuild x264 with ffmpeg-devel
199# set locale
200case $LANG in
201    ja*)LOCALE=ja ;;
202    *) LOCALE=C ;;
203esac
204
205Rebuild_x264_C(){
206    echo -n "     "
207    echo "Rebuild x264 with ffmpeg-devel"
208}
209
210Rebuild_x264_ja(){
211    echo -n "     "
212    echo "ffmpeg-devel で x264 をリビルドします。"
213}
214
215Rebuild_x264_$LOCALE
216%{x264_postinstall}
217
218
219%files
220%defattr(-,root,root)
221%{_datadir}/%{name}
222
223%changelog
224* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 2.8.6-3
225- change BR: self-build-{a52dec,lame} to {a52dec,lame}-devel
226
227* Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 2.8.6-2
228- rebuild
229
230* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
231- rebuild with libcdio-0.93
232
233* Mon Feb 15 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.6-1
234- new upstream release
235
236* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.5-1
237- new upstream release
238
239* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-2
240- rebuild with gnutils-3.4.7
241
242* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.7.1-1
243- new upstream release
244
245* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.3-1
246- new upstream release
247
248* Mon Apr 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.2-1
249- new upstream release
250
251* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.1-1
252- new upstream release
253
254* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6-1
255- new upstream release
256
257* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.4-1
258- new upstream release
259
260* Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.3-1
261- new upstream release
262
263* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
264- new upstream release
265
266* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
267- add BuildRequires: libcdio-paranoia-devel
268
269* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
270- new upstream release
271
272* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
273- new upstream release
274
275* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
276- new upstream release
277- added %%{x264_postinstall} in %%post
278
279* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
280- new upstream release
281- added man pages
282  - added Source10: ffmpeg-1.2.1-doc.tar.xz
283
284* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
285- new upstream release
286
287* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
288- new upstream release
289
290* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
291- libvpx >= 0.9.7
292
293* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
294- new upstream release /x264-0.129
295
296* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
297- new upstream release
298
299* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
300- new upstream release
301
302* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
303- new upstream release
304
305* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
306- new upstream release
307
308* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
309- new upstream release
310- enable CELT decoding via libcelt
311- enable FreeType support
312- drop faad2 support (dropped upstream)
313
314* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
315- added BuildArch: noarch
316
317* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
318- new upstream release
319
320* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
321- new upstream release
322
323* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
324- required latest x264 build
325- added BuildRequires: librtmp-devel >= 2.3
326
327* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
328- new upstream release
329
330* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
331- unpacked source archives
332
333* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
334- fixed some dependencies
335  - Requires(post): libva-devel
336  - Requires(post): libvpx-devel >= 0.9.1
337
338* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
339- new upstream release
340
341* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
342- bumped version to pre-0.6
343- updated source snapshot 20100410
344
345* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
346- fixed self-build log size
347
348* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
349- added ffprobe.1.gz
350
351* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
352- updated source snapshot 20100401
353
354* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
355- renamed %%{Source0} to ffmpeg-vl.spec
356
357* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
358- updated source snapshot 20100216
359  - rebuild with recent x264-devel
360- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
361- added BuildRequires:  libvdpau-devel
362
363* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
364- dropped BuildArch: noarch
365- added ffmpeg.1, ffplay.1, ffserver.1
366
367* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
368- avoided to execute self-build-rpm.sh on RPM transaction
369  - moved %%post actions to %%posttrans
370
371* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
372- added BuildArch: noarch
373- added ffmpeg-0.5-disable-texi2html.patch
374  - dropped PreReq: texi2html
375
376* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
377- added %%{gpac_postinstall} in %%post
378
379* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
380- corrected release number
381
382* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
383- new upstream release
384- added PreReq:
385  - speex-devel
386  - bzip2-devel
387
388* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
389- change release to sync with ffmpeg
390
391* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
392- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
393
394* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
395- 20090202 snapshot
396
397* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
398- 20090110 snapshot
399- dropped some patches
400
401* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
402- source updated (r15488)
403- fixed License: GPLv2+
404- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
405- added BuildRequires: yasm (only %%ix86)
406- applied ffmpeg-cpu.patch (merged from RPM Fusion)
407
408* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
409- spec in utf8
410
411* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
412- run pre-allocate-rpm.sh in %%post
413- set PreReq: self-build-setup >= 0.8
414- change release number
415
416* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
417- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
418  include Source1 in the binary package.
419- drop "Source100: ffmpeg-vine.patch".
420- drop "PreReq: subversion".
421
422* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
423- build with new versioning policy
424- change to use svn export from svn checkout on post install
425- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
426
427* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
428- For all pre-required package that is provied by self-build, 
429  changed to its self-build package
430 
431* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
432- initial build for Vine Linux 4.2
433- snapshot 2008/01/28 + some Rev.11662 2008/01/29
434
435### end of file
Note: See TracBrowser for help on using the repository browser.