source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 6241

Revision 6241, 11.8 KB checked in by munepi, 12 years ago (diff)

upgrade some self-build packages; remove obsolete self-build packages

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%global pkgname ffmpeg
8%global name    self-build-%{pkgname}
9%global version 0.11
10#% define svndate       20110326
11%global release 1%{?svndate:.%svndate}%{?_dist_release}
12
13%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
14
15%global with_faac 1
16%global with_vaapi 1
17%global with_libvpx 1
18
19#% define enable_avconv 1
20
21%define use_prebuilt_man 1
22
23Summary:        Package to automatically build %{pkgname} rpm package
24Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
25Name:           %{name}
26Version:        %{version}
27Release:        %{release}
28Source0:        %{pkgname}-vl.spec
29#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
30# pre-built man files
31%{?use_prebuilt_man:Source90:       ffmpeg-%{version}-doc.tar.xz}
32
33License:        GPLv2+
34Group:          Restricted Software
35
36Obsoletes:      ffmpeg < %{version}, ffmpeg-libs < %{version}, ffmpeg-devel < %{version}
37Obsoletes:      self-build-ffmpeg < %{version}
38
39Requires(post):         self-build-setup >= 0.9.9
40#Requires(post):                subversion
41
42# (build)requies of target package.
43Requires(post):  bzip2-devel
44Requires(post):  celt-devel
45##Requires(post):  dirac-devel
46Requires(post):  freetype2-devel
47Requires(post): gsm-devel
48Requires(post): imlib2-devel
49Requires(post): libdc1394-devel
50Requires(post): libogg-devel
51Requires(post):  libass-devel
52%{!?_without_cdio:Requires(post): libcdio-devel}
53#libcrystalhd is currently broken
54%{?_with_crystalhd:Requires(post):      libcrystalhd-devel}
55Requires(post): libraw1394-devel
56Requires(post): librtmp-devel >= 2.3
57Requires(post): libtheora-devel
58%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
59Requires(post):  libvdpau-devel
60Requires(post): libvorbis-devel
61%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
62Requires(post):  libXvMC-devel
63%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
64%{!?_without_openal:Requires(post):  openal-soft-devel}
65%{?_with_opencv:Requires(post):  opencv-devel}
66%{?_with_openjpeg:Requires(post):  openjpeg-devel}
67##Requires(post):  schroedinger-devel
68Requires(post): SDL-devel
69Requires(post):  speex-devel
70##Requires(post):       texi2html
71Requires(post): zlib-devel
72Requires(post): libogg-devel
73Requires(post):         yasm
74Requires(post):         self-build-a52dec
75Requires(post):         self-build-faac
76Requires(post):         self-build-faad2
77Requires(post):         self-build-lame
78Requires(post):         self-build-libdca
79Requires(post):         self-build-x264 >= 0.120
80Requires(post):         self-build-xvidcore
81
82BuildRoot:      %{_tmppath}/%{name}-%{version}-root
83
84BuildArch:      noarch
85Packager:       munepi
86
87%description
88FFMpeg is a complete and free Internet live audio and video
89broadcasting solution for Linux/Unix. It also includes a
90digital VCR. It can encode in real time in many formats
91including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
92real, mjpeg, and flash.
93
94If you install this package, it automaticaly downloads source
95code ,compile it, and create rpm packages of %{pkgname}-%{version}.
96And the created rpm packages are automatically installed
97if installation is executed by apt-get command or synaptic
98package manager.
99
100[Note]
101This package requires many other packages to compile
102target software. So it consume more disk space than usual.
103Also installation takes longer time because of compilation.
104(This will take a few minutes to quarter or half of an hour,
105depends on building environment)
106
107[About self-build package]
108For some kind of software, distributing of binary package
109may viorate the patent or law. Therefore we chose self-build
110packge, create binary package on your machine, for such kind
111of softwares instead of distributing binary package.
112
113Please obey the national law when you use the created binary
114packages. And if you want to use the softwares using patented
115thechnology, it may be required to get a permission, make an
116agreement or purchas a license. Please consider it with your
117purpose or way of use and take appropriate action.
118
119%description -l ja
120FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
121ブオーティオ・ビデオブロードキャスティングソリューションです.
122またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
123MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
124多様なフォーマットをリアルタイムにエンコードすることができます.
125
126このパッケージをインストールすると、自動的にソースコードを
127ダウンロードしてコンパイルし、%{pkgname}-%{version}
128の rpm パッケージを作成します。
129また apt-get コマンドや synaptic パッケージマネージャから実行
130した場合は、作成された rpm パッケージのインストールも自動的に
131行います。
132
133[注意]
134コンパイルに必要な多くの関連パッケージを要求するので通常より
135ディスクの領域を多く消費します。
136またインストール時にコンパイルを行うため、通常より時間がかか
137る場合があります。(環境にもよりますが数分から数十分程度)
138
139[self-build パッケージについて]
140ソフトウェアによってはバイナリパッケージの配布が特許や法律に
141違反する可能性があるものがあります。その為、このような問題が
142懸念されるソフトウェアについてはバイナリパッケージを直接配布
143せずに、ユーザの環境でバイナリを作成する self-build パッケー
144ジという方法を採っています。
145
146作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
147アのライセンス、および利用する国の各種法令に従ってください。
148また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
149センスの購入などが必要となる場合がありますので、利用する目的
150や形態に応じて各自で判断し適切な対応を取ってください。
151
152%prep
153[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
154
155%install
156%{__rm} -rf ${RPM_BUILD_ROOT}
157%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
158%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
159%{?use_prebuilt_man:%{__install} -m 644 %{SOURCE90} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}}
160
161%clean
162%{__rm} -rf ${RPM_BUILD_ROOT}
163
164%posttrans
165/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 123000
166/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
167                                 %{pkgname}-libs-%{version}-%{release} \
168                                 %{pkgname}-devel-%{version}-%{release}
169
170## Rebuild gpac with ffmpeg-devel
171# set locale
172case $LANG in
173    ja*)LOCALE=ja ;;
174    *) LOCALE=C ;;
175esac
176
177Rebuild_gpac_C(){
178    echo -n "     "
179    echo "Rebuild gpac with ffmpeg-devel"
180}
181
182Rebuild_gpac_ja(){
183    echo -n "     "
184    echo "ffmpeg-devel で gpac をリビルドします。"
185}
186
187Rebuild_gpac_$LOCALE
188%{gpac_postinstall}
189
190
191%files
192%defattr(-,root,root)
193%{_datadir}/%{name}
194
195%changelog
196* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
197- new upstream release
198
199* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
200- new upstream release
201
202* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
203- new upstream release
204- enable CELT decoding via libcelt
205- enable FreeType support
206- drop faad2 support (dropped upstream)
207
208* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
209- added BuildArch: noarch
210
211* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
212- new upstream release
213
214* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
215- new upstream release
216
217* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
218- required latest x264 build
219- added BuildRequires: librtmp-devel >= 2.3
220
221* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
222- new upstream release
223
224* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
225- unpacked source archives
226
227* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
228- fixed some dependencies
229  - Requires(post): libva-devel
230  - Requires(post): libvpx-devel >= 0.9.1
231
232* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
233- new upstream release
234
235* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
236- bumped version to pre-0.6
237- updated source snapshot 20100410
238
239* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
240- fixed self-build log size
241
242* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
243- added ffprobe.1.gz
244
245* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
246- updated source snapshot 20100401
247
248* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
249- renamed %%{Source0} to ffmpeg-vl.spec
250
251* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
252- updated source snapshot 20100216
253  - rebuild with recent x264-devel
254- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
255- added BuildRequires:  libvdpau-devel
256
257* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
258- dropped BuildArch: noarch
259- added ffmpeg.1, ffplay.1, ffserver.1
260
261* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
262- avoided to execute self-build-rpm.sh on RPM transaction
263  - moved %%post actions to %%posttrans
264
265* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
266- added BuildArch: noarch
267- added ffmpeg-0.5-disable-texi2html.patch
268  - dropped PreReq: texi2html
269
270* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
271- added %%{gpac_postinstall} in %%post
272
273* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
274- corrected release number
275
276* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
277- new upstream release
278- added PreReq:
279  - speex-devel
280  - bzip2-devel
281
282* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
283- change release to sync with ffmpeg
284
285* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
286- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
287
288* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
289- 20090202 snapshot
290
291* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
292- 20090110 snapshot
293- dropped some patches
294
295* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
296- source updated (r15488)
297- fixed License: GPLv2+
298- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
299- added BuildRequires: yasm (only %%ix86)
300- applied ffmpeg-cpu.patch (merged from RPM Fusion)
301
302* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
303- spec in utf8
304
305* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
306- run pre-allocate-rpm.sh in %%post
307- set PreReq: self-build-setup >= 0.8
308- change release number
309
310* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
311- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
312  include Source1 in the binary package.
313- drop "Source100: ffmpeg-vine.patch".
314- drop "PreReq: subversion".
315
316* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
317- build with new versioning policy
318- change to use svn export from svn checkout on post install
319- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
320
321* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
322- For all pre-required package that is provied by self-build, 
323  changed to its self-build package
324 
325* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
326- initial build for Vine Linux 4.2
327- snapshot 2008/01/28 + some Rev.11662 2008/01/29
328
329### end of file
Note: See TracBrowser for help on using the repository browser.