source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 9909

Revision 9909, 14.3 KB checked in by Takemikaduchi, 9 years ago (diff)

NetworkManager: move file
others: rebuild with gnutls-3.4.7

RevLine 
[5297]1%global gpac_postinstall     \
[7865]2    gpac_postinstall_sh=$(mktemp) ; \
[615]3    rpm -q --scripts self-build-gpac | \
[7865]4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} ; \
5    /bin/bash ${gpac_postinstall_sh} ; /bin/rm -f ${gpac_postinstall_sh}
[615]6
[7842]7%global x264_postinstall     \
[7865]8    x264_postinstall_sh=$(mktemp) ; \
[7842]9    rpm -q --scripts self-build-x264 | \
[7865]10    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${x264_postinstall_sh} ; \
11    /bin/bash ${x264_postinstall_sh} ; /bin/rm -f ${x264_postinstall_sh}
[7842]12
13
[5297]14%global pkgname ffmpeg
15%global name    self-build-%{pkgname}
[9663]16%global major_version 2.7
17%global version %{major_version}.1
[3126]18#% define svndate       20110326
[9909]19%global release 2%{?svndate:.%svndate}%{?_dist_release}
[615]20
[5297]21%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
[1373]22
[5297]23%global with_faac 1
24%global with_vaapi 1
25%global with_libvpx 1
[1258]26
[6241]27#% define enable_avconv 1
28
[615]29Summary:        Package to automatically build %{pkgname} rpm package
30Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
31Name:           %{name}
32Version:        %{version}
33Release:        %{release}
[5297]34Source0:        %{pkgname}-vl.spec
[1373]35#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
[615]36
37License:        GPLv2+
38Group:          Restricted Software
39
[6325]40Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
[7865]41Obsoletes:      self-build-ffmpeg < %{version}
[6241]42
[615]43Requires(post):         self-build-setup >= 0.9.9
44#Requires(post):                subversion
45
46# (build)requies of target package.
47Requires(post):  bzip2-devel
[5297]48Requires(post):  celt-devel
49##Requires(post):  dirac-devel
50Requires(post):  freetype2-devel
[7546]51Requires(post):  gnutls-devel
[615]52Requires(post): gsm-devel
53Requires(post): imlib2-devel
54Requires(post): libdc1394-devel
[6241]55Requires(post): libogg-devel
56Requires(post):  libass-devel
57%{!?_without_cdio:Requires(post): libcdio-devel}
[9215]58%{!?_without_cdio:Requires: libcdio-paranoia-devel}
[6241]59#libcrystalhd is currently broken
60%{?_with_crystalhd:Requires(post):      libcrystalhd-devel}
[615]61Requires(post): libraw1394-devel
[3126]62Requires(post): librtmp-devel >= 2.3
[615]63Requires(post): libtheora-devel
[3126]64%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
[615]65Requires(post):  libvdpau-devel
[3126]66Requires(post): libvorbis-devel
[7546]67%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.7}
[6241]68Requires(post):  libXvMC-devel
[5297]69%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
[6241]70%{!?_without_openal:Requires(post):  openal-soft-devel}
71%{?_with_opencv:Requires(post):  opencv-devel}
72%{?_with_openjpeg:Requires(post):  openjpeg-devel}
[3126]73##Requires(post):  schroedinger-devel
[615]74Requires(post): SDL-devel
75Requires(post):  speex-devel
76##Requires(post):       texi2html
77Requires(post): zlib-devel
78Requires(post): libogg-devel
79Requires(post):         yasm
[3126]80Requires(post):         self-build-a52dec
[615]81Requires(post):         self-build-faac
[3126]82Requires(post):         self-build-faad2
[615]83Requires(post):         self-build-lame
84Requires(post):         self-build-libdca
[9215]85Requires(post):         self-build-x264 >= 0.142
86Requires(post):         self-build-x265 >= 1.4
[3126]87Requires(post):         self-build-xvidcore
[615]88
89BuildRoot:      %{_tmppath}/%{name}-%{version}-root
90
[4754]91BuildArch:      noarch
[615]92Packager:       munepi
93
94%description
95FFMpeg is a complete and free Internet live audio and video
96broadcasting solution for Linux/Unix. It also includes a
97digital VCR. It can encode in real time in many formats
98including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
99real, mjpeg, and flash.
100
101If you install this package, it automaticaly downloads source
102code ,compile it, and create rpm packages of %{pkgname}-%{version}.
103And the created rpm packages are automatically installed
104if installation is executed by apt-get command or synaptic
105package manager.
106
107[Note]
108This package requires many other packages to compile
109target software. So it consume more disk space than usual.
110Also installation takes longer time because of compilation.
111(This will take a few minutes to quarter or half of an hour,
112depends on building environment)
113
114[About self-build package]
115For some kind of software, distributing of binary package
116may viorate the patent or law. Therefore we chose self-build
117packge, create binary package on your machine, for such kind
118of softwares instead of distributing binary package.
119
120Please obey the national law when you use the created binary
121packages. And if you want to use the softwares using patented
122thechnology, it may be required to get a permission, make an
123agreement or purchas a license. Please consider it with your
124purpose or way of use and take appropriate action.
125
126%description -l ja
127FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
128ブオーティオ・ビデオブロードキャスティングソリューションです.
129またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
130MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
131多様なフォーマットをリアルタイムにエンコードすることができます.
132
133このパッケージをインストールすると、自動的にソースコードを
134ダウンロードしてコンパイルし、%{pkgname}-%{version}
135の rpm パッケージを作成します。
136また apt-get コマンドや synaptic パッケージマネージャから実行
137した場合は、作成された rpm パッケージのインストールも自動的に
138行います。
139
140[注意]
141コンパイルに必要な多くの関連パッケージを要求するので通常より
142ディスクの領域を多く消費します。
143またインストール時にコンパイルを行うため、通常より時間がかか
144る場合があります。(環境にもよりますが数分から数十分程度)
145
146[self-build パッケージについて]
147ソフトウェアによってはバイナリパッケージの配布が特許や法律に
148違反する可能性があるものがあります。その為、このような問題が
149懸念されるソフトウェアについてはバイナリパッケージを直接配布
150せずに、ユーザの環境でバイナリを作成する self-build パッケー
151ジという方法を採っています。
152
153作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
154アのライセンス、および利用する国の各種法令に従ってください。
155また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
156センスの購入などが必要となる場合がありますので、利用する目的
157や形態に応じて各自で判断し適切な対応を取ってください。
158
159%prep
160[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
161
162%install
163%{__rm} -rf ${RPM_BUILD_ROOT}
164%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
165%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
166
167%clean
168%{__rm} -rf ${RPM_BUILD_ROOT}
169
170%posttrans
[7546]171/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 86000
[615]172/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
173                                 %{pkgname}-libs-%{version}-%{release} \
174                                 %{pkgname}-devel-%{version}-%{release}
175
176## Rebuild gpac with ffmpeg-devel
177# set locale
178case $LANG in
179    ja*)LOCALE=ja ;;
180    *) LOCALE=C ;;
181esac
182
183Rebuild_gpac_C(){
184    echo -n "     "
185    echo "Rebuild gpac with ffmpeg-devel"
186}
187
188Rebuild_gpac_ja(){
189    echo -n "     "
190    echo "ffmpeg-devel で gpac をリビルドします。"
191}
192
193Rebuild_gpac_$LOCALE
194%{gpac_postinstall}
195
[7842]196## Rebuild x264 with ffmpeg-devel
197# set locale
198case $LANG in
199    ja*)LOCALE=ja ;;
200    *) LOCALE=C ;;
201esac
[615]202
[7842]203Rebuild_x264_C(){
204    echo -n "     "
205    echo "Rebuild x264 with ffmpeg-devel"
206}
207
208Rebuild_x264_ja(){
209    echo -n "     "
210    echo "ffmpeg-devel で x264 をリビルドします。"
211}
212
213Rebuild_x264_$LOCALE
214%{x264_postinstall}
215
216
[615]217%files
218%defattr(-,root,root)
219%{_datadir}/%{name}
220
221%changelog
[9909]222* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-2
223- rebuild with gnutils-3.4.7
224
[9663]225* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.7.1-1
226- new upstream release
227
228* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.3-1
229- new upstream release
230
[9522]231* Mon Apr 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.2-1
232- new upstream release
233
[9450]234* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.1-1
235- new upstream release
236
[9423]237* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6-1
[9366]238- new upstream release
239
[9423]240* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.4-1
[9281]241- new upstream release
242
[9423]243* Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.3-1
[9215]244- new upstream release
245
[9423]246* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
247- new upstream release
248
[8803]249* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
250- add BuildRequires: libcdio-paranoia-devel
251
[8313]252* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
253- new upstream release
254
[7865]255* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
256- new upstream release
257
[7842]258* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
259- new upstream release
260- added %%{x264_postinstall} in %%post
261
[7689]262* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
263- new upstream release
264- added man pages
265  - added Source10: ffmpeg-1.2.1-doc.tar.xz
266
[7603]267* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
268- new upstream release
269
[7546]270* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
271- new upstream release
272
273* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
274- libvpx >= 0.9.7
275
276* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
277- new upstream release /x264-0.129
278
[6862]279* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
280- new upstream release
281
[6325]282* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
283- new upstream release
284
[6241]285* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
286- new upstream release
287
[5396]288* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
289- new upstream release
290
[5297]291* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
292- new upstream release
293- enable CELT decoding via libcelt
294- enable FreeType support
295- drop faad2 support (dropped upstream)
[4991]296
[4754]297* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
298- added BuildArch: noarch
299
[3763]300* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
301- new upstream release
302
[3538]303* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
304- new upstream release
305
[3126]306* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
307- required latest x264 build
308- added BuildRequires: librtmp-devel >= 2.3
309
[2156]310* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
311- new upstream release
312
[1373]313* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
314- unpacked source archives
315
[1306]316* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
317- fixed some dependencies
318  - Requires(post): libva-devel
319  - Requires(post): libvpx-devel >= 0.9.1
320
[1258]321* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
322- new upstream release
323
[861]324* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
325- bumped version to pre-0.6
326- updated source snapshot 20100410
327
[789]328* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
329- fixed self-build log size
330
[788]331* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
332- added ffprobe.1.gz
333
[786]334* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
335- updated source snapshot 20100401
336
[615]337* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
338- renamed %%{Source0} to ffmpeg-vl.spec
339
340* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
341- updated source snapshot 20100216
342  - rebuild with recent x264-devel
343- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
344- added BuildRequires:  libvdpau-devel
345
346* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
347- dropped BuildArch: noarch
348- added ffmpeg.1, ffplay.1, ffserver.1
349
350* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
351- avoided to execute self-build-rpm.sh on RPM transaction
352  - moved %%post actions to %%posttrans
353
354* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
355- added BuildArch: noarch
356- added ffmpeg-0.5-disable-texi2html.patch
357  - dropped PreReq: texi2html
358
359* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
360- added %%{gpac_postinstall} in %%post
361
362* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
363- corrected release number
364
365* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
366- new upstream release
367- added PreReq:
368  - speex-devel
369  - bzip2-devel
370
371* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
372- change release to sync with ffmpeg
373
374* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
375- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
376
377* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
378- 20090202 snapshot
379
380* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
381- 20090110 snapshot
382- dropped some patches
383
384* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
385- source updated (r15488)
386- fixed License: GPLv2+
387- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
388- added BuildRequires: yasm (only %%ix86)
389- applied ffmpeg-cpu.patch (merged from RPM Fusion)
390
391* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
392- spec in utf8
393
394* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
395- run pre-allocate-rpm.sh in %%post
396- set PreReq: self-build-setup >= 0.8
397- change release number
398
399* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
400- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
401  include Source1 in the binary package.
402- drop "Source100: ffmpeg-vine.patch".
403- drop "PreReq: subversion".
404
405* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
406- build with new versioning policy
407- change to use svn export from svn checkout on post install
408- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
409
410* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
411- For all pre-required package that is provied by self-build, 
412  changed to its self-build package
413 
414* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
415- initial build for Vine Linux 4.2
416- snapshot 2008/01/28 + some Rev.11662 2008/01/29
417
418### end of file
Note: See TracBrowser for help on using the repository browser.