source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl5.spec @ 2156

Revision 2156, 7.7 KB checked in by munepi, 14 years ago (diff)

updated self-build-ffmpeg; added {self-build-,}ffmpeg-vl5.spec files

Line 
1#TODO: Build with openjpeg
2%define name    ffmpeg
3%define version 0.5.3
4#% define svndate       20090227
5%define release 1%{?svndate:.%svndate}%{?_dist_release}
6
7Summary:        Digital VCR and streaming server
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11Source:         http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
12#Source1:        %{name}-snapshot.sh
13
14# For no texi2html
15# these man files for ffmpeg-0.5 are genereted with texi2html
16Source90:       ffmpeg.1.gz
17Source91:       ffplay.1.gz
18Source92:       ffserver.1.gz
19
20# get rid of textrels on x86_64 in yasm code (from RPM Fusion)
21Patch0:         %{name}-textrel.patch
22
23Patch10:        ffmpeg-0.5-disable-texi2html.patch
24
25License:        GPLv2+
26Group:          Applications/Multimedia
27URL:            http://ffmpeg.org/
28
29BuildRequires:  bzip2-devel
30BuildRequires:  zlib-devel
31BuildRequires:  SDL-devel
32BuildRequires:  imlib2-devel
33BuildRequires:  speex-devel
34#BuildRequires: texi2html
35BuildRequires:  libogg-devel
36BuildRequires:  libvorbis-devel
37#BuildRequires:  openjpeg-devel
38BuildRequires:  libtheora-devel
39BuildRequires:  gsm-devel
40BuildRequires:  libdc1394-devel
41BuildRequires:  libraw1394-devel
42%ifarch %{ix86} x86_64
43BuildRequires:  yasm
44%endif
45# *-devel packages provided by other self-build-* should only be listed
46# in self-build-%{name}.spec as PreReq.
47#BuildRequires: xvidcore-devel, faac-devel, lame-devel
48#BuildRequires: x264-devel, libdca-devel, a52dec-devel
49#BuildRequires: faad2-devel
50%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
51BuildRoot:      %{_tmppath}/%{name}-%{version}-root
52
53%description
54FFMpeg is a complete and free Internet live audio and video
55broadcasting solution for Linux/Unix. It also includes a digital
56VCR. It can encode in real time in many formats including MPEG1 audio
57and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
58
59%package libs
60Group: System Environment/Libraries
61Summary: Libraries for %{name}
62Group: System Environment/Libraries
63#Requires: a52dec, faad2
64
65%description libs
66FFMpeg is a complete and free Internet live audio and video
67broadcasting solution for Linux/Unix. It also includes a digital
68VCR. It can encode in real time in many formats including MPEG1 audio
69and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
70
71This package contains the libraries for %{name}.
72
73%package devel
74Summary: Development package for %{name}
75Group: Development/Libraries
76Requires: %{name}-libs = %{version}-%{release}
77Requires: pkgconfig
78
79%description devel
80FFMpeg is a complete and free Internet live audio and video
81broadcasting solution for Linux/Unix. It also includes a digital
82VCR. It can encode in real time in many formats including MPEG1 audio
83and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
84
85This package contains development files for %{name}.
86
87
88%prep
89#% setup -q -n %{name}-%{svndate}
90%setup -q
91%patch0 -p1 -b .textrel
92%patch10 -p1 -b .texi2html
93
94%build
95%ifarch ppc
96# compile with -mlongcall on ppc/ppc64 (rf804)
97export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
98%endif
99
100./configure \
101    --prefix=%{_prefix} \
102    --incdir=%{_includedir}/%{name} \
103    --shlibdir=%{_libdir} \
104    --libdir=%{_libdir} \
105    --mandir=%{_mandir} \
106    --arch=%{_target_cpu} \
107%ifarch %{ix86}
108    --cpu=%{_target_cpu} \
109%endif
110%ifarch ppc
111    --cpu=g3 \
112%endif
113    --enable-runtime-cpudetect \
114    --extra-cflags="$RPM_OPT_FLAGS" \
115    %{?_with_amr:--enable-libamr-nb --enable-libamr-wb --enable-nonfree} \
116    --enable-bzlib \
117    --enable-libdc1394 \
118    --enable-libfaac --enable-nonfree \
119    --enable-libfaad \
120    --enable-libgsm \
121    --enable-libmp3lame \
122    %{?_with_openjpeg:--enable-libopenjpeg} \
123    --enable-libtheora \
124    --enable-libvorbis \
125    --enable-libx264 \
126    --enable-libxvid \
127    --enable-x11grab \
128    --enable-avfilter \
129    --enable-avfilter-lavf \
130    --enable-postproc \
131    --enable-swscale \
132    --enable-pthreads \
133    --disable-static \
134    --enable-shared \
135    --enable-gpl \
136    --disable-debug \
137    --disable-stripping
138
139#% {__make} %{?_smp_mflags}
140%{__make}
141
142%install
143%__make install DESTDIR=$RPM_BUILD_ROOT
144
145## install man
146%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1
147%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} $RPM_BUILD_ROOT%{_mandir}/man1/
148   
149
150%clean
151%{__rm} -rf $RPM_BUILD_ROOT
152
153%post libs -p /sbin/ldconfig
154%postun libs -p /sbin/ldconfig
155
156
157%files
158%defattr(-,root,root,-)
159%doc COPYING.GPL CREDITS Changelog README RELEASE doc/*.*
160%{_prefix}/bin/ffmpeg
161%{_prefix}/bin/ffplay
162%{_prefix}/bin/ffserver
163%{_mandir}/man1/ffmpeg.1*
164%{_mandir}/man1/ffplay.1*
165%{_mandir}/man1/ffserver.1*
166%{_datadir}/ffmpeg
167%{?_with_amr:%{_datadir}/%{name}}
168
169%files libs
170%defattr(-,root,root,-)
171%{_libdir}/lib*.so.*
172%{_libdir}/vhook/
173
174%files devel
175%defattr(-,root,root,-)
176%{_includedir}/ffmpeg
177%{_libdir}/pkgconfig/lib*.pc
178%{_libdir}/lib*.so
179
180
181%changelog
182* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.3-1
183- new upstream release
184
185* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
186- change release to sync with self-build-ffmpeg
187
188* Thu Jun 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-1
189- new upstream release
190
191* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.1-1
192- new upstream release
193
194* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
195- applied ffmpeg-0.5-disable-texi2html.patch, return
196  (in face, no ffmpeg-0.5-disable-texi2html.patch applied for 0.5-4)
197- added ffmpeg.1, ffplay.1, ffserver.1
198
199* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
200- change release to sync with self-build-ffmpeg
201
202* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
203- applied ffmpeg-0.5-disable-texi2html.patch
204  - dropped BuildRequires: texi2html
205
206* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
207- change release to sync with self-build-ffmpeg
208
209* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
210- corrected release number
211
212* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
213- new upstream release
214- added BuildRequires:
215  - speex-devel
216  - bzip2-devel
217
218* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
219- 20090227 snapshot
220
221* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
222- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
223
224* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
225- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
226- dropped Requires: a52dec, faad2 in ffmpeg-libs
227
228* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
229- 20090202 snapshot
230
231* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
232- 20090110 snapshot
233- dropped some patches
234
235* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
236- source updated (r15488)
237- fixed License: GPLv2+
238- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
239- added BuildRequires: yasm (only %%ix86)
240- applied ffmpeg-cpu.patch (merged from RPM Fusion)
241
242* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
243- spec in utf8
244
245* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
246- change release to sync with self-build-ffmpeg
247
248* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
249- drop "Patch100: ffmpeg-vine.patch".
250
251* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
252- build with new versioning policy
253- change to use svn export from svn checkout on post install
254- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
255
256* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
257- [self-build-ffmpeg.spec]
258  For all pre-required package that is provied by self-build, 
259  changed to its self-build package
260
261* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
262- initial build for Vine Linux 4.2
263- snapshot 2008/01/28 + some Rev.11662 2008/01/29
264
265### end of file
Note: See TracBrowser for help on using the repository browser.