source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 8803

Revision 8803, 12.3 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW: libcdio-paranoia
others: new upstream release or rebuild

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%define with_faac 1
6%define with_vaapi 1
7%define with_libvpx 1
8
9#% define enable_avconv 1
10
11%global prebuild_doc 1
12
13%global major_version 1.2
14
15Summary:        Digital VCR and streaming server
16Name:           ffmpeg
17Version:        %{major_version}.6
18Release:        2%{?svndate:.%svndate}%{?_dist_release}
19Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
20## prebuilt man pages
21%{?prebuild_doc:Source10:       %{name}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz}
22
23%if 0%{?_with_amr:1}
24License:        GPLv3+
25%else
26License:        GPLv2+
27%endif
28Group:          Applications/Multimedia
29URL:            http://ffmpeg.org/
30
31BuildRequires:  bzip2-devel
32BuildRequires:  celt-devel
33##BuildRequires: dirac-devel
34BuildRequires:  freetype2-devel
35##BuildRequires: frei0r-devel
36BuildRequires:  gnutls-devel
37BuildRequires:  gsm-devel
38BuildRequires:  imlib2-devel
39BuildRequires:  libdc1394-devel
40BuildRequires:  libogg-devel
41BuildRequires:  libass-devel
42%{!?_without_cdio:BuildRequires: libcdio-devel}
43%{!?_without_cdio:BuildRequires: libcdio-paranoia-devel}
44#libcrystalhd is currently broken
45%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
46BuildRequires:  libraw1394-devel
47BuildRequires:  librtmp-devel >= 2.3
48BuildRequires:  libtheora-devel
49%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
50BuildRequires:  libvdpau-devel
51BuildRequires:  libvorbis-devel
52%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
53BuildRequires:  libXvMC-devel
54%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
55%{!?_without_openal:BuildRequires: openal-soft-devel}
56%{?_with_opencv:BuildRequires: opencv-devel}
57%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
58##BuildRequires:  schroedinger-devel
59BuildRequires:  SDL-devel
60BuildRequires:  speex-devel
61##BuildRequires:        texi2html
62BuildRequires:  zlib-devel
63BuildRequires:  yasm
64# *-devel packages provided by other self-build-* should only be listed
65# in self-build-%{name}.spec as PreReq.
66#BuildRequires: a52dec-devel
67#BuildRequires: faac-devel
68#BuildRequires: lame-devel
69#BuildRequires: libdca-devel
70#BuildRequires: x264-devel >= 0.0.0-18.20111216
71#BuildRequires: xvidcore-devel
72
73Requires:       %{name}-libs = %{version}-%{release}
74
75BuildRoot:      %{_tmppath}/%{name}-%{version}-root
76
77Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
78
79%description
80FFMpeg is a complete and free Internet live audio and video
81broadcasting solution for Linux/Unix. It also includes a digital
82VCR. It can encode in real time in many formats including MPEG1 audio
83and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
84
85%package libs
86Summary: Libraries for %{name}
87Group: System Environment/Libraries
88
89%description libs
90FFMpeg is a complete and free Internet live audio and video
91broadcasting solution for Linux/Unix. It also includes a digital
92VCR. It can encode in real time in many formats including MPEG1 audio
93and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
94
95This package contains the libraries for %{name}.
96
97%package devel
98Summary: Development package for %{name}
99Group: Development/Libraries
100Requires: %{name}-libs = %{version}-%{release}
101Requires: pkgconfig
102
103%description devel
104FFMpeg is a complete and free Internet live audio and video
105broadcasting solution for Linux/Unix. It also includes a digital
106VCR. It can encode in real time in many formats including MPEG1 audio
107and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
108
109This package contains development files for %{name}.
110
111
112%prep
113%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
114
115%{?prebuild_doc:%__tar -C %{_builddir} -xf %{SOURCE10} || exit 1}
116
117%build
118%ifarch ppc
119# compile with -mlongcall on ppc/ppc64 (rf804)
120export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
121%endif
122
123./configure \
124    --prefix=%{_prefix} \
125    --incdir=%{_includedir}/%{name} \
126    --shlibdir=%{_libdir} \
127    --libdir=%{_libdir} \
128    --mandir=%{_mandir} \
129    --arch=%{_target_cpu} \
130%ifarch %{ix86}
131    --cpu=%{_target_cpu} \
132%endif
133%ifarch ppc
134    --cpu=g3 \
135    --enable-pic \
136%endif
137    --enable-runtime-cpudetect \
138    --extra-cflags="$RPM_OPT_FLAGS" \
139    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
140    --enable-bzlib \
141    %{!?_with_crystalhd:--disable-crystalhd} \
142    --enable-zlib \
143    %{?_with_frei0r:--enable-frei0r} \
144    --enable-gnutls \
145    --enable-libass \
146    %{!?_without_cdio:--enable-libcdio} \
147    --enable-libcelt \
148    --enable-libdc1394 \
149    %{?_with_libdirac:--enable-libdirac} \
150    %{?with_faac:--enable-libfaac --enable-nonfree} \
151    --enable-libfreetype \
152    --enable-libgsm \
153    --enable-libmp3lame \
154    %{!?_without_openal:--enable-openal} \
155    %{?_with_opencv:--enable-libopencv} \
156    %{?_with_openjpeg:--enable-libopenjpeg} \
157    --enable-librtmp \
158    --enable-libspeex \
159    --enable-libtheora \
160    --enable-libvorbis \
161    %{?with_libvpx:--enable-libvpx} \
162    --enable-libx264 \
163    --enable-libxvid \
164    \
165    --enable-x11grab \
166    --enable-avfilter \
167    --enable-postproc \
168    --enable-pthreads \
169    --disable-static \
170    --enable-shared \
171    --enable-gpl \
172    %{?prebuild_doc:--disable-doc} \
173    --disable-debug \
174    --disable-stripping \
175    \
176    %{?enable_avconv:--enable-avconv} \
177    ;
178
179%__make %{?_smp_mflags}
180
181%__make alltools
182
183
184%install
185%__make install DESTDIR=$RPM_BUILD_ROOT
186
187## install tool/qt-faststart
188%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
189
190## install man
191%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
192%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
193
194
195%clean
196%{__rm} -rf $RPM_BUILD_ROOT
197
198%post libs -p /sbin/ldconfig
199
200%postun libs -p /sbin/ldconfig
201
202%files
203%defattr(-,root,root,-)
204%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
205%{?enable_avconv:%{_bindir}/avconv}
206%{_bindir}/ffmpeg
207%{_bindir}/ffplay
208%{_bindir}/ffprobe
209%{_bindir}/ffserver
210%{_bindir}/qt-faststart
211%{?enable_avconv:%{_mandir}/man1/avconv.1*}
212%{_mandir}/man1/ffmpeg.1*
213%{_mandir}/man1/ffplay.1*
214%{_mandir}/man1/ffprobe.1*
215%{_mandir}/man1/ffserver.1*
216%{_datadir}/ffmpeg
217
218
219%files libs
220%defattr(-,root,root,-)
221%{_libdir}/lib*.so.*
222
223%files devel
224%defattr(-,root,root,-)
225%doc MAINTAINERS doc/APIchanges doc/*.txt
226%{_includedir}/ffmpeg
227%{_libdir}/pkgconfig/lib*.pc
228%{_libdir}/lib*.so
229
230
231%changelog
232* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
233- add BuildRequires: libcdio-paranoia-devel
234
235* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
236- new upstream release
237
238* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
239- new upstream release
240
241* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
242- new upstream release
243
244* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
245- new upstream release
246- added man pages
247  - added Source10: ffmpeg-1.2.1-doc.tar.xz
248
249* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
250- new upstream release
251
252* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
253- new upstream release
254
255* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
256- libvpx >= 0.9.7
257
258* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
259- new upstream release /x264-0.129
260
261* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
262- new upstream release
263
264* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
265- new upstream release
266
267* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
268- new upstream release
269
270* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
271- new upstream release
272
273* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
274- new upstream release
275
276* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
277- new upstream release
278- enable CELT decoding via libcelt
279- enable FreeType support
280- drop faad2 support (dropped upstream)
281
282* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
283- change release to sync with self-build-ffmpeg-vl.spec
284
285* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
286- new upstream release
287
288* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
289- new upstream release
290
291* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
292- required latest x264 build
293- added BuildRequires: librtmp-devel >= 2.3
294- build PIC objects on PPC
295#- add qt-faststart tool
296
297* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
298- new upstream release
299
300* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
301- change release to sync with self-build-ffmpeg-vl.spec
302
303* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
304- added BuildRequires: libvpx-devel >= 0.9.1
305
306* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
307- new upstream release
308
309* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
310- bumped version to pre-0.6
311
312* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
313- updated source snapshot 20100410
314
315* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
316- change release to sync with self-build-ffmpeg-vl.spec
317
318* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
319- change release to sync with self-build-ffmpeg-vl.spec
320
321* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
322- updated source snapshot 20100401
323
324* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
325- updated source snapshot 20100326
326
327* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
328- change release to sync with self-build-ffmpeg
329
330* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
331- updated source snapshot 20100216
332  - rebuild with recent x264-devel
333- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
334- added BuildRequires:  libvdpau-devel
335
336* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
337- change release to sync with self-build-ffmpeg
338
339* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
340- change release to sync with self-build-ffmpeg
341
342* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
343- applied ffmpeg-0.5-disable-texi2html.patch
344  - dropped BuildRequires: texi2html
345
346* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
347- change release to sync with self-build-ffmpeg
348
349* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
350- corrected release number
351
352* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
353- new upstream release
354- added BuildRequires:
355  - speex-devel
356  - bzip2-devel
357
358* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
359- 20090227 snapshot
360
361* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
362- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
363
364* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
365- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
366- dropped Requires: a52dec, faad2 in ffmpeg-libs
367
368* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
369- 20090202 snapshot
370
371* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
372- 20090110 snapshot
373- dropped some patches
374
375* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
376- source updated (r15488)
377- fixed License: GPLv2+
378- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
379- added BuildRequires: yasm (only %%ix86)
380- applied ffmpeg-cpu.patch (merged from RPM Fusion)
381
382* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
383- spec in utf8
384
385* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
386- change release to sync with self-build-ffmpeg
387
388* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
389- drop "Patch100: ffmpeg-vine.patch".
390
391* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
392- build with new versioning policy
393- change to use svn export from svn checkout on post install
394- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
395
396* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
397- [self-build-ffmpeg.spec]
398  For all pre-required package that is provied by self-build, 
399  changed to its self-build package
400
401* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
402- initial build for Vine Linux 4.2
403- snapshot 2008/01/28 + some Rev.11662 2008/01/29
404
405### end of file
Note: See TracBrowser for help on using the repository browser.