source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 8313

Revision 8313, 12.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%define with_faac 1
6%define with_vaapi 1
7%define with_libvpx 1
8
9#% define enable_avconv 1
10
11%global prebuild_doc 1
12
13%global major_version 1.2
14
15Summary:        Digital VCR and streaming server
16Name:           ffmpeg
17Version:        %{major_version}.6
18Release:        1%{?svndate:.%svndate}%{?_dist_release}
19Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
20## prebuilt man pages
21%{?prebuild_doc:Source10:       %{name}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz}
22
23%if 0%{?_with_amr:1}
24License:        GPLv3+
25%else
26License:        GPLv2+
27%endif
28Group:          Applications/Multimedia
29URL:            http://ffmpeg.org/
30
31BuildRequires:  bzip2-devel
32BuildRequires:  celt-devel
33##BuildRequires: dirac-devel
34BuildRequires:  freetype2-devel
35##BuildRequires: frei0r-devel
36BuildRequires:  gnutls-devel
37BuildRequires:  gsm-devel
38BuildRequires:  imlib2-devel
39BuildRequires:  libdc1394-devel
40BuildRequires:  libogg-devel
41BuildRequires:  libass-devel
42%{!?_without_cdio:BuildRequires: libcdio-devel}
43#libcrystalhd is currently broken
44%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
45BuildRequires:  libraw1394-devel
46BuildRequires:  librtmp-devel >= 2.3
47BuildRequires:  libtheora-devel
48%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
49BuildRequires:  libvdpau-devel
50BuildRequires:  libvorbis-devel
51%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
52BuildRequires:  libXvMC-devel
53%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
54%{!?_without_openal:BuildRequires: openal-soft-devel}
55%{?_with_opencv:BuildRequires: opencv-devel}
56%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
57##BuildRequires:  schroedinger-devel
58BuildRequires:  SDL-devel
59BuildRequires:  speex-devel
60##BuildRequires:        texi2html
61BuildRequires:  zlib-devel
62BuildRequires:  yasm
63# *-devel packages provided by other self-build-* should only be listed
64# in self-build-%{name}.spec as PreReq.
65#BuildRequires: a52dec-devel
66#BuildRequires: faac-devel
67#BuildRequires: lame-devel
68#BuildRequires: libdca-devel
69#BuildRequires: x264-devel >= 0.0.0-18.20111216
70#BuildRequires: xvidcore-devel
71
72Requires:       %{name}-libs = %{version}-%{release}
73
74BuildRoot:      %{_tmppath}/%{name}-%{version}-root
75
76Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
77
78%description
79FFMpeg is a complete and free Internet live audio and video
80broadcasting solution for Linux/Unix. It also includes a digital
81VCR. It can encode in real time in many formats including MPEG1 audio
82and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
83
84%package libs
85Summary: Libraries for %{name}
86Group: System Environment/Libraries
87
88%description libs
89FFMpeg is a complete and free Internet live audio and video
90broadcasting solution for Linux/Unix. It also includes a digital
91VCR. It can encode in real time in many formats including MPEG1 audio
92and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
93
94This package contains the libraries for %{name}.
95
96%package devel
97Summary: Development package for %{name}
98Group: Development/Libraries
99Requires: %{name}-libs = %{version}-%{release}
100Requires: pkgconfig
101
102%description devel
103FFMpeg is a complete and free Internet live audio and video
104broadcasting solution for Linux/Unix. It also includes a digital
105VCR. It can encode in real time in many formats including MPEG1 audio
106and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
107
108This package contains development files for %{name}.
109
110
111%prep
112%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
113
114%{?prebuild_doc:%__tar -C %{_builddir} -xf %{SOURCE10} || exit 1}
115
116%build
117%ifarch ppc
118# compile with -mlongcall on ppc/ppc64 (rf804)
119export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
120%endif
121
122./configure \
123    --prefix=%{_prefix} \
124    --incdir=%{_includedir}/%{name} \
125    --shlibdir=%{_libdir} \
126    --libdir=%{_libdir} \
127    --mandir=%{_mandir} \
128    --arch=%{_target_cpu} \
129%ifarch %{ix86}
130    --cpu=%{_target_cpu} \
131%endif
132%ifarch ppc
133    --cpu=g3 \
134    --enable-pic \
135%endif
136    --enable-runtime-cpudetect \
137    --extra-cflags="$RPM_OPT_FLAGS" \
138    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
139    --enable-bzlib \
140    %{!?_with_crystalhd:--disable-crystalhd} \
141    --enable-zlib \
142    %{?_with_frei0r:--enable-frei0r} \
143    --enable-gnutls \
144    --enable-libass \
145    %{!?_without_cdio:--enable-libcdio} \
146    --enable-libcelt \
147    --enable-libdc1394 \
148    %{?_with_libdirac:--enable-libdirac} \
149    %{?with_faac:--enable-libfaac --enable-nonfree} \
150    --enable-libfreetype \
151    --enable-libgsm \
152    --enable-libmp3lame \
153    %{!?_without_openal:--enable-openal} \
154    %{?_with_opencv:--enable-libopencv} \
155    %{?_with_openjpeg:--enable-libopenjpeg} \
156    --enable-librtmp \
157    --enable-libspeex \
158    --enable-libtheora \
159    --enable-libvorbis \
160    %{?with_libvpx:--enable-libvpx} \
161    --enable-libx264 \
162    --enable-libxvid \
163    \
164    --enable-x11grab \
165    --enable-avfilter \
166    --enable-postproc \
167    --enable-pthreads \
168    --disable-static \
169    --enable-shared \
170    --enable-gpl \
171    %{?prebuild_doc:--disable-doc} \
172    --disable-debug \
173    --disable-stripping \
174    \
175    %{?enable_avconv:--enable-avconv} \
176    ;
177
178%__make %{?_smp_mflags}
179
180%__make alltools
181
182
183%install
184%__make install DESTDIR=$RPM_BUILD_ROOT
185
186## install tool/qt-faststart
187%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
188
189## install man
190%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
191%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
192
193
194%clean
195%{__rm} -rf $RPM_BUILD_ROOT
196
197%post libs -p /sbin/ldconfig
198
199%postun libs -p /sbin/ldconfig
200
201%files
202%defattr(-,root,root,-)
203%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
204%{?enable_avconv:%{_bindir}/avconv}
205%{_bindir}/ffmpeg
206%{_bindir}/ffplay
207%{_bindir}/ffprobe
208%{_bindir}/ffserver
209%{_bindir}/qt-faststart
210%{?enable_avconv:%{_mandir}/man1/avconv.1*}
211%{_mandir}/man1/ffmpeg.1*
212%{_mandir}/man1/ffplay.1*
213%{_mandir}/man1/ffprobe.1*
214%{_mandir}/man1/ffserver.1*
215%{_datadir}/ffmpeg
216
217
218%files libs
219%defattr(-,root,root,-)
220%{_libdir}/lib*.so.*
221
222%files devel
223%defattr(-,root,root,-)
224%doc MAINTAINERS doc/APIchanges doc/*.txt
225%{_includedir}/ffmpeg
226%{_libdir}/pkgconfig/lib*.pc
227%{_libdir}/lib*.so
228
229
230%changelog
231* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
232- new upstream release
233
234* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
235- new upstream release
236
237* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
238- new upstream release
239
240* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
241- new upstream release
242- added man pages
243  - added Source10: ffmpeg-1.2.1-doc.tar.xz
244
245* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
246- new upstream release
247
248* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
249- new upstream release
250
251* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
252- libvpx >= 0.9.7
253
254* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
255- new upstream release /x264-0.129
256
257* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
258- new upstream release
259
260* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
261- new upstream release
262
263* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
264- new upstream release
265
266* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
267- new upstream release
268
269* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
270- new upstream release
271
272* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
273- new upstream release
274- enable CELT decoding via libcelt
275- enable FreeType support
276- drop faad2 support (dropped upstream)
277
278* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
279- change release to sync with self-build-ffmpeg-vl.spec
280
281* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
282- new upstream release
283
284* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
285- new upstream release
286
287* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
288- required latest x264 build
289- added BuildRequires: librtmp-devel >= 2.3
290- build PIC objects on PPC
291#- add qt-faststart tool
292
293* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
294- new upstream release
295
296* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
297- change release to sync with self-build-ffmpeg-vl.spec
298
299* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
300- added BuildRequires: libvpx-devel >= 0.9.1
301
302* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
303- new upstream release
304
305* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
306- bumped version to pre-0.6
307
308* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
309- updated source snapshot 20100410
310
311* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
312- change release to sync with self-build-ffmpeg-vl.spec
313
314* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
315- change release to sync with self-build-ffmpeg-vl.spec
316
317* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
318- updated source snapshot 20100401
319
320* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
321- updated source snapshot 20100326
322
323* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
324- change release to sync with self-build-ffmpeg
325
326* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
327- updated source snapshot 20100216
328  - rebuild with recent x264-devel
329- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
330- added BuildRequires:  libvdpau-devel
331
332* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
333- change release to sync with self-build-ffmpeg
334
335* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
336- change release to sync with self-build-ffmpeg
337
338* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
339- applied ffmpeg-0.5-disable-texi2html.patch
340  - dropped BuildRequires: texi2html
341
342* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
343- change release to sync with self-build-ffmpeg
344
345* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
346- corrected release number
347
348* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
349- new upstream release
350- added BuildRequires:
351  - speex-devel
352  - bzip2-devel
353
354* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
355- 20090227 snapshot
356
357* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
358- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
359
360* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
361- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
362- dropped Requires: a52dec, faad2 in ffmpeg-libs
363
364* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
365- 20090202 snapshot
366
367* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
368- 20090110 snapshot
369- dropped some patches
370
371* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
372- source updated (r15488)
373- fixed License: GPLv2+
374- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
375- added BuildRequires: yasm (only %%ix86)
376- applied ffmpeg-cpu.patch (merged from RPM Fusion)
377
378* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
379- spec in utf8
380
381* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
382- change release to sync with self-build-ffmpeg
383
384* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
385- drop "Patch100: ffmpeg-vine.patch".
386
387* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
388- build with new versioning policy
389- change to use svn export from svn checkout on post install
390- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
391
392* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
393- [self-build-ffmpeg.spec]
394  For all pre-required package that is provied by self-build, 
395  changed to its self-build package
396
397* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
398- initial build for Vine Linux 4.2
399- snapshot 2008/01/28 + some Rev.11662 2008/01/29
400
401### end of file
Note: See TracBrowser for help on using the repository browser.