source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 7865

Revision 7865, 12.1 KB checked in by munepi, 11 years ago (diff)

new upstream release

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%define with_faac 1
6%define with_vaapi 1
7%define with_libvpx 1
8
9#% define enable_avconv 1
10
11%global prebuild_doc 1
12
13%global major_version 1.2
14
15Summary:        Digital VCR and streaming server
16Name:           ffmpeg
17Version:        %{major_version}.4
18Release:        1%{?svndate:.%svndate}%{?_dist_release}
19Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
20## prebuilt man pages
21%{?prebuild_doc:Source10:       %{name}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz}
22
23%if 0%{?_with_amr:1}
24License:        GPLv3+
25%else
26License:        GPLv2+
27%endif
28Group:          Applications/Multimedia
29URL:            http://ffmpeg.org/
30
31BuildRequires:  bzip2-devel
32BuildRequires:  celt-devel
33##BuildRequires: dirac-devel
34BuildRequires:  freetype2-devel
35##BuildRequires: frei0r-devel
36BuildRequires:  gnutls-devel
37BuildRequires:  gsm-devel
38BuildRequires:  imlib2-devel
39BuildRequires:  libdc1394-devel
40BuildRequires:  libogg-devel
41BuildRequires:  libass-devel
42%{!?_without_cdio:BuildRequires: libcdio-devel}
43#libcrystalhd is currently broken
44%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
45BuildRequires:  libraw1394-devel
46BuildRequires:  librtmp-devel >= 2.3
47BuildRequires:  libtheora-devel
48%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
49BuildRequires:  libvdpau-devel
50BuildRequires:  libvorbis-devel
51%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
52BuildRequires:  libXvMC-devel
53%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
54%{!?_without_openal:BuildRequires: openal-soft-devel}
55%{?_with_opencv:BuildRequires: opencv-devel}
56%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
57##BuildRequires:  schroedinger-devel
58BuildRequires:  SDL-devel
59BuildRequires:  speex-devel
60##BuildRequires:        texi2html
61BuildRequires:  zlib-devel
62BuildRequires:  yasm
63# *-devel packages provided by other self-build-* should only be listed
64# in self-build-%{name}.spec as PreReq.
65#BuildRequires: a52dec-devel
66#BuildRequires: faac-devel
67#BuildRequires: lame-devel
68#BuildRequires: libdca-devel
69#BuildRequires: x264-devel >= 0.0.0-18.20111216
70#BuildRequires: xvidcore-devel
71
72Requires:       %{name}-libs = %{version}-%{release}
73
74BuildRoot:      %{_tmppath}/%{name}-%{version}-root
75
76Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
77
78%description
79FFMpeg is a complete and free Internet live audio and video
80broadcasting solution for Linux/Unix. It also includes a digital
81VCR. It can encode in real time in many formats including MPEG1 audio
82and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
83
84%package libs
85Summary: Libraries for %{name}
86Group: System Environment/Libraries
87
88%description libs
89FFMpeg is a complete and free Internet live audio and video
90broadcasting solution for Linux/Unix. It also includes a digital
91VCR. It can encode in real time in many formats including MPEG1 audio
92and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
93
94This package contains the libraries for %{name}.
95
96%package devel
97Summary: Development package for %{name}
98Group: Development/Libraries
99Requires: %{name}-libs = %{version}-%{release}
100Requires: pkgconfig
101
102%description devel
103FFMpeg is a complete and free Internet live audio and video
104broadcasting solution for Linux/Unix. It also includes a digital
105VCR. It can encode in real time in many formats including MPEG1 audio
106and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
107
108This package contains development files for %{name}.
109
110
111%prep
112%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
113
114%{?prebuild_doc:%__tar -C %{_builddir} -xf %{SOURCE10} || exit 1}
115
116%build
117%ifarch ppc
118# compile with -mlongcall on ppc/ppc64 (rf804)
119export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
120%endif
121
122./configure \
123    --prefix=%{_prefix} \
124    --incdir=%{_includedir}/%{name} \
125    --shlibdir=%{_libdir} \
126    --libdir=%{_libdir} \
127    --mandir=%{_mandir} \
128    --arch=%{_target_cpu} \
129%ifarch %{ix86}
130    --cpu=%{_target_cpu} \
131%endif
132%ifarch ppc
133    --cpu=g3 \
134    --enable-pic \
135%endif
136    --enable-runtime-cpudetect \
137    --extra-cflags="$RPM_OPT_FLAGS" \
138    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
139    --enable-bzlib \
140    %{!?_with_crystalhd:--disable-crystalhd} \
141    --enable-zlib \
142    %{?_with_frei0r:--enable-frei0r} \
143    --enable-gnutls \
144    --enable-libass \
145    %{!?_without_cdio:--enable-libcdio} \
146    --enable-libcelt \
147    --enable-libdc1394 \
148    %{?_with_libdirac:--enable-libdirac} \
149    %{?with_faac:--enable-libfaac --enable-nonfree} \
150    --enable-libfreetype \
151    --enable-libgsm \
152    --enable-libmp3lame \
153    %{!?_without_openal:--enable-openal} \
154    %{?_with_opencv:--enable-libopencv} \
155    %{?_with_openjpeg:--enable-libopenjpeg} \
156    --enable-librtmp \
157    --enable-libspeex \
158    --enable-libtheora \
159    --enable-libvorbis \
160    %{?with_libvpx:--enable-libvpx} \
161    --enable-libx264 \
162    --enable-libxvid \
163    \
164    --enable-x11grab \
165    --enable-avfilter \
166    --enable-postproc \
167    --enable-pthreads \
168    --disable-static \
169    --enable-shared \
170    --enable-gpl \
171    %{?prebuild_doc:--disable-doc} \
172    --disable-debug \
173    --disable-stripping \
174    \
175    %{?enable_avconv:--enable-avconv} \
176    ;
177
178%__make %{?_smp_mflags}
179
180%__make alltools
181
182
183%install
184%__make install DESTDIR=$RPM_BUILD_ROOT
185
186## install tool/qt-faststart
187%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
188
189## install man
190%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
191%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
192
193
194%clean
195%{__rm} -rf $RPM_BUILD_ROOT
196
197%post libs -p /sbin/ldconfig
198
199%postun libs -p /sbin/ldconfig
200
201%files
202%defattr(-,root,root,-)
203%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
204%{?enable_avconv:%{_bindir}/avconv}
205%{_bindir}/ffmpeg
206%{_bindir}/ffplay
207%{_bindir}/ffprobe
208%{_bindir}/ffserver
209%{_bindir}/qt-faststart
210%{?enable_avconv:%{_mandir}/man1/avconv.1*}
211%{_mandir}/man1/ffmpeg.1*
212%{_mandir}/man1/ffplay.1*
213%{_mandir}/man1/ffprobe.1*
214%{_mandir}/man1/ffserver.1*
215%{_datadir}/ffmpeg
216
217
218%files libs
219%defattr(-,root,root,-)
220%{_libdir}/lib*.so.*
221
222%files devel
223%defattr(-,root,root,-)
224%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
225%{_includedir}/ffmpeg
226%{_libdir}/pkgconfig/lib*.pc
227%{_libdir}/lib*.so
228
229
230%changelog
231* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
232- new upstream release
233
234* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
235- new upstream release
236
237* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
238- new upstream release
239- added man pages
240  - added Source10: ffmpeg-1.2.1-doc.tar.xz
241
242* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
243- new upstream release
244
245* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
246- new upstream release
247
248* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
249- libvpx >= 0.9.7
250
251* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
252- new upstream release /x264-0.129
253
254* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
255- new upstream release
256
257* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
258- new upstream release
259
260* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
261- new upstream release
262
263* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
264- new upstream release
265
266* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
267- new upstream release
268
269* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
270- new upstream release
271- enable CELT decoding via libcelt
272- enable FreeType support
273- drop faad2 support (dropped upstream)
274
275* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
276- change release to sync with self-build-ffmpeg-vl.spec
277
278* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
279- new upstream release
280
281* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
282- new upstream release
283
284* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
285- required latest x264 build
286- added BuildRequires: librtmp-devel >= 2.3
287- build PIC objects on PPC
288#- add qt-faststart tool
289
290* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
291- new upstream release
292
293* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
294- change release to sync with self-build-ffmpeg-vl.spec
295
296* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
297- added BuildRequires: libvpx-devel >= 0.9.1
298
299* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
300- new upstream release
301
302* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
303- bumped version to pre-0.6
304
305* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
306- updated source snapshot 20100410
307
308* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
309- change release to sync with self-build-ffmpeg-vl.spec
310
311* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
312- change release to sync with self-build-ffmpeg-vl.spec
313
314* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
315- updated source snapshot 20100401
316
317* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
318- updated source snapshot 20100326
319
320* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
321- change release to sync with self-build-ffmpeg
322
323* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
324- updated source snapshot 20100216
325  - rebuild with recent x264-devel
326- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
327- added BuildRequires:  libvdpau-devel
328
329* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
330- change release to sync with self-build-ffmpeg
331
332* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
333- change release to sync with self-build-ffmpeg
334
335* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
336- applied ffmpeg-0.5-disable-texi2html.patch
337  - dropped BuildRequires: texi2html
338
339* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
340- change release to sync with self-build-ffmpeg
341
342* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
343- corrected release number
344
345* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
346- new upstream release
347- added BuildRequires:
348  - speex-devel
349  - bzip2-devel
350
351* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
352- 20090227 snapshot
353
354* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
355- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
356
357* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
358- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
359- dropped Requires: a52dec, faad2 in ffmpeg-libs
360
361* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
362- 20090202 snapshot
363
364* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
365- 20090110 snapshot
366- dropped some patches
367
368* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
369- source updated (r15488)
370- fixed License: GPLv2+
371- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
372- added BuildRequires: yasm (only %%ix86)
373- applied ffmpeg-cpu.patch (merged from RPM Fusion)
374
375* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
376- spec in utf8
377
378* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
379- change release to sync with self-build-ffmpeg
380
381* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
382- drop "Patch100: ffmpeg-vine.patch".
383
384* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
385- build with new versioning policy
386- change to use svn export from svn checkout on post install
387- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
388
389* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
390- [self-build-ffmpeg.spec]
391  For all pre-required package that is provied by self-build, 
392  changed to its self-build package
393
394* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
395- initial build for Vine Linux 4.2
396- snapshot 2008/01/28 + some Rev.11662 2008/01/29
397
398### end of file
Note: See TracBrowser for help on using the repository browser.