source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 7689

Revision 7689, 11.8 KB checked in by munepi, 11 years ago (diff)

new upstream release

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%define with_faac 1
6%define with_vaapi 1
7%define with_libvpx 1
8
9#% define enable_avconv 1
10
11%global major_version 1.2
12
13Summary:        Digital VCR and streaming server
14Name:           ffmpeg
15Version:        %{major_version}.1
16Release:        1%{?svndate:.%svndate}%{?_dist_release}
17Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
18## prebuilt man pages
19Source10:       %{name}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz
20
21%if 0%{?_with_amr:1}
22License:        GPLv3+
23%else
24License:        GPLv2+
25%endif
26Group:          Applications/Multimedia
27URL:            http://ffmpeg.org/
28
29BuildRequires:  bzip2-devel
30BuildRequires:  celt-devel
31##BuildRequires: dirac-devel
32BuildRequires:  freetype2-devel
33##BuildRequires: frei0r-devel
34BuildRequires:  gnutls-devel
35BuildRequires:  gsm-devel
36BuildRequires:  imlib2-devel
37BuildRequires:  libdc1394-devel
38BuildRequires:  libogg-devel
39BuildRequires:  libass-devel
40%{!?_without_cdio:BuildRequires: libcdio-devel}
41#libcrystalhd is currently broken
42%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
43BuildRequires:  libraw1394-devel
44BuildRequires:  librtmp-devel >= 2.3
45BuildRequires:  libtheora-devel
46%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
47BuildRequires:  libvdpau-devel
48BuildRequires:  libvorbis-devel
49%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
50BuildRequires:  libXvMC-devel
51%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
52%{!?_without_openal:BuildRequires: openal-soft-devel}
53%{?_with_opencv:BuildRequires: opencv-devel}
54%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
55##BuildRequires:  schroedinger-devel
56BuildRequires:  SDL-devel
57BuildRequires:  speex-devel
58##BuildRequires:        texi2html
59BuildRequires:  zlib-devel
60BuildRequires:  yasm
61# *-devel packages provided by other self-build-* should only be listed
62# in self-build-%{name}.spec as PreReq.
63#BuildRequires: a52dec-devel
64#BuildRequires: faac-devel
65#BuildRequires: lame-devel
66#BuildRequires: libdca-devel
67#BuildRequires: x264-devel >= 0.0.0-18.20111216
68#BuildRequires: xvidcore-devel
69
70Requires:       %{name}-libs = %{version}-%{release}
71
72BuildRoot:      %{_tmppath}/%{name}-%{version}-root
73
74Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
75
76%description
77FFMpeg is a complete and free Internet live audio and video
78broadcasting solution for Linux/Unix. It also includes a digital
79VCR. It can encode in real time in many formats including MPEG1 audio
80and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
81
82%package libs
83Summary: Libraries for %{name}
84Group: System Environment/Libraries
85
86%description libs
87FFMpeg is a complete and free Internet live audio and video
88broadcasting solution for Linux/Unix. It also includes a digital
89VCR. It can encode in real time in many formats including MPEG1 audio
90and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
91
92This package contains the libraries for %{name}.
93
94%package devel
95Summary: Development package for %{name}
96Group: Development/Libraries
97Requires: %{name}-libs = %{version}-%{release}
98Requires: pkgconfig
99
100%description devel
101FFMpeg is a complete and free Internet live audio and video
102broadcasting solution for Linux/Unix. It also includes a digital
103VCR. It can encode in real time in many formats including MPEG1 audio
104and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
105
106This package contains development files for %{name}.
107
108
109%prep
110%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
111
112%__tar -C %{_builddir} -xf %{SOURCE10} || exit 1
113
114%build
115%ifarch ppc
116# compile with -mlongcall on ppc/ppc64 (rf804)
117export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
118%endif
119
120./configure \
121    --prefix=%{_prefix} \
122    --incdir=%{_includedir}/%{name} \
123    --shlibdir=%{_libdir} \
124    --libdir=%{_libdir} \
125    --mandir=%{_mandir} \
126    --arch=%{_target_cpu} \
127%ifarch %{ix86}
128    --cpu=%{_target_cpu} \
129%endif
130%ifarch ppc
131    --cpu=g3 \
132    --enable-pic \
133%endif
134    --enable-runtime-cpudetect \
135    --extra-cflags="$RPM_OPT_FLAGS" \
136    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
137    --enable-bzlib \
138    %{!?_with_crystalhd:--disable-crystalhd} \
139    --enable-zlib \
140    %{?_with_frei0r:--enable-frei0r} \
141    --enable-gnutls \
142    --enable-libass \
143    %{!?_without_cdio:--enable-libcdio} \
144    --enable-libcelt \
145    --enable-libdc1394 \
146    %{?_with_libdirac:--enable-libdirac} \
147    %{?with_faac:--enable-libfaac --enable-nonfree} \
148    --enable-libfreetype \
149    --enable-libgsm \
150    --enable-libmp3lame \
151    %{!?_without_openal:--enable-openal} \
152    %{?_with_opencv:--enable-libopencv} \
153    %{?_with_openjpeg:--enable-libopenjpeg} \
154    --enable-librtmp \
155    --enable-libspeex \
156    --enable-libtheora \
157    --enable-libvorbis \
158    %{?with_libvpx:--enable-libvpx} \
159    --enable-libx264 \
160    --enable-libxvid \
161    \
162    --enable-x11grab \
163    --enable-avfilter \
164    --enable-postproc \
165    --enable-pthreads \
166    --disable-static \
167    --enable-shared \
168    --enable-gpl \
169    --disable-doc \
170    --disable-debug \
171    --disable-stripping \
172    \
173    %{?enable_avconv:--enable-avconv} \
174    ;
175
176%__make %{?_smp_mflags}
177
178%__make alltools
179
180
181%install
182%__make install DESTDIR=$RPM_BUILD_ROOT
183
184## install tool/qt-faststart
185%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
186
187## install man
188%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
189%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
190
191
192%clean
193%{__rm} -rf $RPM_BUILD_ROOT
194
195%post libs -p /sbin/ldconfig
196
197%postun libs -p /sbin/ldconfig
198
199%files
200%defattr(-,root,root,-)
201%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
202%{?enable_avconv:%{_bindir}/avconv}
203%{_bindir}/ffmpeg
204%{_bindir}/ffplay
205%{_bindir}/ffprobe
206%{_bindir}/ffserver
207%{_bindir}/qt-faststart
208%{?enable_avconv:%{_mandir}/man1/avconv.1*}
209%{_mandir}/man1/ffmpeg.1*
210%{_mandir}/man1/ffplay.1*
211%{_mandir}/man1/ffprobe.1*
212%{_mandir}/man1/ffserver.1*
213%{_datadir}/ffmpeg
214
215
216%files libs
217%defattr(-,root,root,-)
218%{_libdir}/lib*.so.*
219
220%files devel
221%defattr(-,root,root,-)
222%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
223%{_includedir}/ffmpeg
224%{_libdir}/pkgconfig/lib*.pc
225%{_libdir}/lib*.so
226
227
228%changelog
229* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
230- new upstream release
231- added man pages
232  - added Source10: ffmpeg-1.2.1-doc.tar.xz
233
234* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
235- new upstream release
236
237* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
238- new upstream release
239
240* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
241- libvpx >= 0.9.7
242
243* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
244- new upstream release /x264-0.129
245
246* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
247- new upstream release
248
249* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
250- new upstream release
251
252* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
253- new upstream release
254
255* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
256- new upstream release
257
258* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
259- new upstream release
260
261* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
262- new upstream release
263- enable CELT decoding via libcelt
264- enable FreeType support
265- drop faad2 support (dropped upstream)
266
267* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
268- change release to sync with self-build-ffmpeg-vl.spec
269
270* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
271- new upstream release
272
273* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
274- new upstream release
275
276* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
277- required latest x264 build
278- added BuildRequires: librtmp-devel >= 2.3
279- build PIC objects on PPC
280#- add qt-faststart tool
281
282* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
283- new upstream release
284
285* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
286- change release to sync with self-build-ffmpeg-vl.spec
287
288* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
289- added BuildRequires: libvpx-devel >= 0.9.1
290
291* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
292- new upstream release
293
294* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
295- bumped version to pre-0.6
296
297* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
298- updated source snapshot 20100410
299
300* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
301- change release to sync with self-build-ffmpeg-vl.spec
302
303* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
304- change release to sync with self-build-ffmpeg-vl.spec
305
306* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
307- updated source snapshot 20100401
308
309* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
310- updated source snapshot 20100326
311
312* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
313- change release to sync with self-build-ffmpeg
314
315* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
316- updated source snapshot 20100216
317  - rebuild with recent x264-devel
318- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
319- added BuildRequires:  libvdpau-devel
320
321* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
322- change release to sync with self-build-ffmpeg
323
324* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
325- change release to sync with self-build-ffmpeg
326
327* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
328- applied ffmpeg-0.5-disable-texi2html.patch
329  - dropped BuildRequires: texi2html
330
331* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
332- change release to sync with self-build-ffmpeg
333
334* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
335- corrected release number
336
337* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
338- new upstream release
339- added BuildRequires:
340  - speex-devel
341  - bzip2-devel
342
343* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
344- 20090227 snapshot
345
346* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
347- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
348
349* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
350- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
351- dropped Requires: a52dec, faad2 in ffmpeg-libs
352
353* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
354- 20090202 snapshot
355
356* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
357- 20090110 snapshot
358- dropped some patches
359
360* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
361- source updated (r15488)
362- fixed License: GPLv2+
363- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
364- added BuildRequires: yasm (only %%ix86)
365- applied ffmpeg-cpu.patch (merged from RPM Fusion)
366
367* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
368- spec in utf8
369
370* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
371- change release to sync with self-build-ffmpeg
372
373* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
374- drop "Patch100: ffmpeg-vine.patch".
375
376* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
377- build with new versioning policy
378- change to use svn export from svn checkout on post install
379- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
380
381* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
382- [self-build-ffmpeg.spec]
383  For all pre-required package that is provied by self-build, 
384  changed to its self-build package
385
386* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
387- initial build for Vine Linux 4.2
388- snapshot 2008/01/28 + some Rev.11662 2008/01/29
389
390### end of file
Note: See TracBrowser for help on using the repository browser.