source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 615

Revision 615, 7.5 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1#TODO: Build with openjpeg
2%define name    ffmpeg
3%define version 0.5
4%define svndate 20100216
5%define release 8%{?svndate:.%svndate}%{?_dist_release}
6
7Summary:        Digital VCR and streaming server
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11#Source:                %{name}-%{version}.tar.bz2
12Source:         %{name}-%{?svndate:%svndate}.tar.bz2
13Source1:        %{name}-snapshot.sh
14
15# pre-built man files
16Source90:       ffmpeg.1.gz
17Source91:       ffplay.1.gz
18Source92:       ffserver.1.gz
19
20# get rid of textrels on x86_64 in yasm code (from RPM Fusion)
21#Patch0:         %{name}-textrel.patch
22
23License:        GPLv2+
24Group:          Applications/Multimedia
25URL:            http://ffmpeg.org/
26
27BuildRequires:  bzip2-devel
28BuildRequires:  gsm-devel
29BuildRequires:  imlib2-devel
30BuildRequires:  libdc1394-devel
31BuildRequires:  libraw1394-devel
32BuildRequires:  libtheora-devel
33BuildRequires:  libvdpau-devel
34BuildRequires:  libvorbis-devel
35##BuildRequires:  openjpeg-devel
36BuildRequires:  SDL-devel
37BuildRequires:  speex-devel
38##BuildRequires:        texi2html
39BuildRequires:  zlib-devel
40BuildRequires:  libogg-devel
41%ifarch %{ix86} x86_64
42BuildRequires:  yasm
43%endif
44# *-devel packages provided by other self-build-* should only be listed
45# in self-build-%{name}.spec as PreReq.
46#BuildRequires: xvidcore-devel, faac-devel, lame-devel
47#BuildRequires: x264-devel, libdca-devel, a52dec-devel
48#BuildRequires: faad2-devel
49
50BuildRoot:      %{_tmppath}/%{name}-%{version}-root
51
52%description
53FFMpeg is a complete and free Internet live audio and video
54broadcasting solution for Linux/Unix. It also includes a digital
55VCR. It can encode in real time in many formats including MPEG1 audio
56and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
57
58%package libs
59Group: System Environment/Libraries
60Summary: Libraries for %{name}
61Group: System Environment/Libraries
62
63%description libs
64FFMpeg is a complete and free Internet live audio and video
65broadcasting solution for Linux/Unix. It also includes a digital
66VCR. It can encode in real time in many formats including MPEG1 audio
67and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
68
69This package contains the libraries for %{name}.
70
71%package devel
72Summary: Development package for %{name}
73Group: Development/Libraries
74Requires: %{name}-libs = %{version}-%{release}
75Requires: pkgconfig
76
77%description devel
78FFMpeg is a complete and free Internet live audio and video
79broadcasting solution for Linux/Unix. It also includes a digital
80VCR. It can encode in real time in many formats including MPEG1 audio
81and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
82
83This package contains development files for %{name}.
84
85
86%prep
87%setup -q -n %{name}-%{svndate}
88#% setup -q
89#%patch0 -p1 -b .textrel
90
91%build
92%ifarch ppc
93# compile with -mlongcall on ppc/ppc64 (rf804)
94export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
95%endif
96
97./configure \
98    --prefix=%{_prefix} \
99    --incdir=%{_includedir}/%{name} \
100    --shlibdir=%{_libdir} \
101    --libdir=%{_libdir} \
102    --mandir=%{_mandir} \
103    --arch=%{_target_cpu} \
104%ifarch %{ix86}
105    --cpu=%{_target_cpu} \
106%endif
107%ifarch ppc
108    --cpu=g3 \
109%endif
110    --enable-runtime-cpudetect \
111    --extra-cflags="$RPM_OPT_FLAGS" \
112    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
113    --enable-bzlib \
114    --enable-libdc1394 \
115    --enable-libfaac --enable-nonfree \
116    --enable-libfaad \
117    --enable-libgsm \
118    --enable-libmp3lame \
119    %{?_with_openjpeg:--enable-libopenjpeg} \
120    --enable-libtheora \
121    --enable-libvorbis \
122    --enable-libx264 \
123    --enable-libxvid \
124    --enable-x11grab \
125    --enable-avfilter \
126    --enable-avfilter-lavf \
127    --enable-postproc \
128    --enable-swscale \
129    --enable-pthreads \
130    --disable-static \
131    --enable-shared \
132    --enable-gpl \
133    --disable-debug \
134    --disable-stripping
135
136%{__make} %{?_smp_mflags}
137#% {__make}
138#%{__make} documentation
139
140
141%install
142%__make install DESTDIR=$RPM_BUILD_ROOT
143
144## install man
145%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
146%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} $RPM_BUILD_ROOT%{_mandir}/man1/
147
148
149%clean
150%{__rm} -rf $RPM_BUILD_ROOT
151
152%post libs -p /sbin/ldconfig
153
154%postun libs -p /sbin/ldconfig
155
156%files
157%defattr(-,root,root,-)
158%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
159%{_bindir}/ffmpeg
160%{_bindir}/ffplay
161%{_bindir}/ffserver
162%{_mandir}/man1/ffmpeg.1*
163%{_mandir}/man1/ffplay.1*
164%{_mandir}/man1/ffserver.1*
165%{_datadir}/ffmpeg
166
167
168%files libs
169%defattr(-,root,root,-)
170%{_libdir}/lib*.so.*
171
172%files devel
173%defattr(-,root,root,-)
174%doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
175%{_includedir}/ffmpeg
176%{_libdir}/pkgconfig/lib*.pc
177%{_libdir}/lib*.so
178
179
180%changelog
181* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
182- change release to sync with self-build-ffmpeg
183
184* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
185- updated source snapshot 20100216
186  - rebuild with recent x264-devel
187- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
188- added BuildRequires:  libvdpau-devel
189
190* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
191- change release to sync with self-build-ffmpeg
192
193* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
194- change release to sync with self-build-ffmpeg
195
196* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
197- applied ffmpeg-0.5-disable-texi2html.patch
198  - dropped BuildRequires: texi2html
199
200* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
201- change release to sync with self-build-ffmpeg
202
203* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
204- corrected release number
205
206* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
207- new upstream release
208- added BuildRequires:
209  - speex-devel
210  - bzip2-devel
211
212* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
213- 20090227 snapshot
214
215* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
216- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
217
218* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
219- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
220- dropped Requires: a52dec, faad2 in ffmpeg-libs
221
222* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
223- 20090202 snapshot
224
225* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
226- 20090110 snapshot
227- dropped some patches
228
229* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
230- source updated (r15488)
231- fixed License: GPLv2+
232- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
233- added BuildRequires: yasm (only %%ix86)
234- applied ffmpeg-cpu.patch (merged from RPM Fusion)
235
236* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
237- spec in utf8
238
239* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
240- change release to sync with self-build-ffmpeg
241
242* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
243- drop "Patch100: ffmpeg-vine.patch".
244
245* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
246- build with new versioning policy
247- change to use svn export from svn checkout on post install
248- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
249
250* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
251- [self-build-ffmpeg.spec]
252  For all pre-required package that is provied by self-build, 
253  changed to its self-build package
254
255* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
256- initial build for Vine Linux 4.2
257- snapshot 2008/01/28 + some Rev.11662 2008/01/29
258
259### end of file
Note: See TracBrowser for help on using the repository browser.