source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 6862

Revision 6862, 11.4 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%define with_faac 1
6%define with_vaapi 1
7%define with_libvpx 1
8
9#% define enable_avconv 1
10
11%define use_prebuilt_man 1
12
13%global major_version 0.11
14
15Summary:        Digital VCR and streaming server
16Name:           ffmpeg
17Version:        %{major_version}.2
18Release:        1%{?svndate:.%svndate}%{?_dist_release}
19Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
20
21# pre-built man files
22#$ tar Jcvf ~/rpm/SOURCES/ffmpeg/ffmpeg-0.10-doc.tar.xz ffmpeg-0.10/doc/*.html ffmpeg-0.10/doc/*.pod ffmpeg-0.10/doc/*.1
23%{?use_prebuilt_man:Source90:       ffmpeg-%{version}-doc.tar.xz}
24
25%if 0%{?_with_amr:1}
26License:        GPLv3+
27%else
28License:        GPLv2+
29%endif
30Group:          Applications/Multimedia
31URL:            http://ffmpeg.org/
32
33BuildRequires:  bzip2-devel
34BuildRequires:  celt-devel
35##BuildRequires:  dirac-devel
36BuildRequires:  freetype2-devel
37BuildRequires:  gsm-devel
38BuildRequires:  imlib2-devel
39BuildRequires:  libdc1394-devel
40BuildRequires:  libogg-devel
41BuildRequires:  libass-devel
42%{!?_without_cdio:BuildRequires: libcdio-devel}
43#libcrystalhd is currently broken
44%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
45BuildRequires:  libraw1394-devel
46BuildRequires:  librtmp-devel >= 2.3
47BuildRequires:  libtheora-devel
48%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
49BuildRequires:  libvdpau-devel
50BuildRequires:  libvorbis-devel
51%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
52BuildRequires:  libXvMC-devel
53%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
54%{!?_without_openal:BuildRequires: openal-soft-devel}
55%{?_with_opencv:BuildRequires: opencv-devel}
56%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
57##BuildRequires:  schroedinger-devel
58BuildRequires:  SDL-devel
59BuildRequires:  speex-devel
60%{!?use_prebuilt_man:BuildRequires:     texi2html}
61BuildRequires:  zlib-devel
62BuildRequires:  yasm
63# *-devel packages provided by other self-build-* should only be listed
64# in self-build-%{name}.spec as PreReq.
65#BuildRequires: a52dec-devel
66#BuildRequires: faac-devel
67#BuildRequires: lame-devel
68#BuildRequires: libdca-devel
69#BuildRequires: x264-devel >= 0.0.0-18.20111216
70#BuildRequires: xvidcore-devel
71
72Requires:       %{name}-libs = %{version}-%{release}
73
74BuildRoot:      %{_tmppath}/%{name}-%{version}-root
75
76Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
77
78%description
79FFMpeg is a complete and free Internet live audio and video
80broadcasting solution for Linux/Unix. It also includes a digital
81VCR. It can encode in real time in many formats including MPEG1 audio
82and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
83
84%package libs
85Summary: Libraries for %{name}
86Group: System Environment/Libraries
87
88%description libs
89FFMpeg is a complete and free Internet live audio and video
90broadcasting solution for Linux/Unix. It also includes a digital
91VCR. It can encode in real time in many formats including MPEG1 audio
92and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
93
94This package contains the libraries for %{name}.
95
96%package devel
97Summary: Development package for %{name}
98Group: Development/Libraries
99Requires: %{name}-libs = %{version}-%{release}
100Requires: pkgconfig
101
102%description devel
103FFMpeg is a complete and free Internet live audio and video
104broadcasting solution for Linux/Unix. It also includes a digital
105VCR. It can encode in real time in many formats including MPEG1 audio
106and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
107
108This package contains development files for %{name}.
109
110
111%prep
112%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
113%{?use_prebuilt_man:tar -C .. -xf %{SOURCE90}}
114
115%build
116%ifarch ppc
117# compile with -mlongcall on ppc/ppc64 (rf804)
118export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
119%endif
120
121./configure \
122    --prefix=%{_prefix} \
123    --incdir=%{_includedir}/%{name} \
124    --shlibdir=%{_libdir} \
125    --libdir=%{_libdir} \
126    --mandir=%{_mandir} \
127    --arch=%{_target_cpu} \
128%ifarch %{ix86}
129    --cpu=%{_target_cpu} \
130%endif
131%ifarch ppc
132    --cpu=g3 \
133    --enable-pic \
134%endif
135    --enable-runtime-cpudetect \
136    --extra-cflags="$RPM_OPT_FLAGS" \
137    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
138    --enable-bzlib \
139    %{!?_with_crystalhd:--disable-crystalhd} \
140    --enable-zlib \
141    %{?_with_frei0r:--enable-frei0r} \
142    --enable-gnutls \
143    --enable-libass \
144    %{!?_without_cdio:--enable-libcdio} \
145    --enable-libcelt \
146    --enable-libdc1394 \
147    %{?_with_libdirac:--enable-libdirac} \
148    %{?with_faac:--enable-libfaac --enable-nonfree} \
149    --enable-libfreetype \
150    --enable-libgsm \
151    --enable-libmp3lame \
152    %{!?_without_openal:--enable-openal} \
153    %{?_with_opencv:--enable-libopencv} \
154    %{?_with_openjpeg:--enable-libopenjpeg} \
155    --enable-librtmp \
156    --enable-libspeex \
157    --enable-libtheora \
158    --enable-libvorbis \
159    %{?with_libvpx:--enable-libvpx} \
160    --enable-libx264 \
161    --enable-libxvid \
162    \
163    --enable-x11grab \
164    --enable-avfilter \
165    --enable-postproc \
166    --enable-pthreads \
167    --disable-static \
168    --enable-shared \
169    --enable-gpl \
170    %{?use_prebuilt_man:--disable-doc} \
171    --disable-debug \
172    --disable-stripping \
173    \
174    %{?enable_avconv:--enable-avconv} \
175    ;
176
177%__make %{?_smp_mflags}
178
179%__make alltools
180
181
182%install
183%__make install DESTDIR=$RPM_BUILD_ROOT
184
185## install tool/qt-faststart
186%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
187
188## install man
189%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
190%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
191
192
193%clean
194%{__rm} -rf $RPM_BUILD_ROOT
195
196%post libs -p /sbin/ldconfig
197
198%postun libs -p /sbin/ldconfig
199
200%files
201%defattr(-,root,root,-)
202%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
203%{?enable_avconv:%{_bindir}/avconv}
204%{_bindir}/ffmpeg
205%{_bindir}/ffplay
206%{_bindir}/ffprobe
207%{_bindir}/ffserver
208%{_bindir}/qt-faststart
209%{?enable_avconv:%{_mandir}/man1/avconv.1*}
210%{_mandir}/man1/ffmpeg.1*
211%{_mandir}/man1/ffplay.1*
212%{_mandir}/man1/ffprobe.1*
213%{_mandir}/man1/ffserver.1*
214%{_datadir}/ffmpeg
215
216
217%files libs
218%defattr(-,root,root,-)
219%{_libdir}/lib*.so.*
220
221%files devel
222%defattr(-,root,root,-)
223%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
224%{_includedir}/ffmpeg
225%{_libdir}/pkgconfig/lib*.pc
226%{_libdir}/lib*.so
227
228
229%changelog
230* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
231- new upstream release
232
233* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
234- new upstream release
235
236* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
237- new upstream release
238
239* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
240- new upstream release
241
242* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
243- new upstream release
244
245* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
246- new upstream release
247- enable CELT decoding via libcelt
248- enable FreeType support
249- drop faad2 support (dropped upstream)
250
251* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
252- change release to sync with self-build-ffmpeg-vl.spec
253
254* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
255- new upstream release
256
257* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
258- new upstream release
259
260* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
261- required latest x264 build
262- added BuildRequires: librtmp-devel >= 2.3
263- build PIC objects on PPC
264#- add qt-faststart tool
265
266* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
267- new upstream release
268
269* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
270- change release to sync with self-build-ffmpeg-vl.spec
271
272* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
273- added BuildRequires: libvpx-devel >= 0.9.1
274
275* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
276- new upstream release
277
278* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
279- bumped version to pre-0.6
280
281* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
282- updated source snapshot 20100410
283
284* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
285- change release to sync with self-build-ffmpeg-vl.spec
286
287* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
288- change release to sync with self-build-ffmpeg-vl.spec
289
290* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
291- updated source snapshot 20100401
292
293* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
294- updated source snapshot 20100326
295
296* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
297- change release to sync with self-build-ffmpeg
298
299* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
300- updated source snapshot 20100216
301  - rebuild with recent x264-devel
302- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
303- added BuildRequires:  libvdpau-devel
304
305* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
306- change release to sync with self-build-ffmpeg
307
308* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
309- change release to sync with self-build-ffmpeg
310
311* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
312- applied ffmpeg-0.5-disable-texi2html.patch
313  - dropped BuildRequires: texi2html
314
315* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
316- change release to sync with self-build-ffmpeg
317
318* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
319- corrected release number
320
321* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
322- new upstream release
323- added BuildRequires:
324  - speex-devel
325  - bzip2-devel
326
327* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
328- 20090227 snapshot
329
330* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
331- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
332
333* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
334- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
335- dropped Requires: a52dec, faad2 in ffmpeg-libs
336
337* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
338- 20090202 snapshot
339
340* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
341- 20090110 snapshot
342- dropped some patches
343
344* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
345- source updated (r15488)
346- fixed License: GPLv2+
347- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
348- added BuildRequires: yasm (only %%ix86)
349- applied ffmpeg-cpu.patch (merged from RPM Fusion)
350
351* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
352- spec in utf8
353
354* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
355- change release to sync with self-build-ffmpeg
356
357* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
358- drop "Patch100: ffmpeg-vine.patch".
359
360* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
361- build with new versioning policy
362- change to use svn export from svn checkout on post install
363- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
364
365* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
366- [self-build-ffmpeg.spec]
367  For all pre-required package that is provied by self-build, 
368  changed to its self-build package
369
370* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
371- initial build for Vine Linux 4.2
372- snapshot 2008/01/28 + some Rev.11662 2008/01/29
373
374### end of file
Note: See TracBrowser for help on using the repository browser.