source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 3126

Revision 3126, 9.5 KB checked in by munepi, 13 years ago (diff)

updated self-build-ffmpeg-vl.spec, self-build-gpac-vl.spec self-build-libquicktime-vl.spec self-build-mplayer-vl.spec self-build-vlc-vl.spec self-build-x264-vl.spec; added rtmpdump-vl.spec

Line 
1#TODO: Build with openjpeg
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5## available for v0.6 or lower
6%define with_libfaad 1
7
8%define with_faac 1
9
10%define with_vaapi 1
11%define with_libvpx 1
12
13Summary:        Digital VCR and streaming server
14Name:           ffmpeg
15Version:        0.6.1
16Release:        2%{?svndate:.%svndate}%{?_dist_release}
17Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
18Source1:        %{name}-snapshot.sh
19
20# pre-built man files
21Source90:       ffmpeg.1.gz
22Source91:       ffplay.1.gz
23Source92:       ffserver.1.gz
24Source93:       ffprobe.1.gz
25
26License:        GPLv2+
27Group:          Applications/Multimedia
28URL:            http://ffmpeg.org/
29
30BuildRequires:  bzip2-devel
31##BuildRequires:  dirac-devel
32BuildRequires:  gsm-devel
33BuildRequires:  imlib2-devel
34BuildRequires:  libdc1394-devel
35BuildRequires:  libraw1394-devel
36BuildRequires:  librtmp-devel >= 2.3
37BuildRequires:  libtheora-devel
38%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
39BuildRequires:  libvdpau-devel
40BuildRequires:  libvorbis-devel
41%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
42%{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
43##BuildRequires:  openjpeg-devel
44##BuildRequires:  schroedinger-devel
45BuildRequires:  SDL-devel
46BuildRequires:  speex-devel
47##BuildRequires:        texi2html
48BuildRequires:  zlib-devel
49BuildRequires:  libogg-devel
50%ifarch %{ix86} x86_64
51BuildRequires:  yasm
52%endif
53# *-devel packages provided by other self-build-* should only be listed
54# in self-build-%{name}.spec as PreReq.
55#BuildRequires: a52dec-devel
56#BuildRequires: faac-devel
57#BuildRequires: lame-devel
58#BuildRequires: libdca-devel
59#BuildRequires: faad2-devel
60#BuildRequires: x264-devel >= 0.0.0-15.20110322
61#BuildRequires: xvidcore-devel
62
63Requires:       %{name}-libs = %{version}-%{release}
64
65BuildRoot:      %{_tmppath}/%{name}-%{version}-root
66
67%description
68FFMpeg is a complete and free Internet live audio and video
69broadcasting solution for Linux/Unix. It also includes a digital
70VCR. It can encode in real time in many formats including MPEG1 audio
71and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
72
73%package libs
74Summary: Libraries for %{name}
75Group: System Environment/Libraries
76
77%description libs
78FFMpeg is a complete and free Internet live audio and video
79broadcasting solution for Linux/Unix. It also includes a digital
80VCR. It can encode in real time in many formats including MPEG1 audio
81and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
82
83This package contains the libraries for %{name}.
84
85%package devel
86Summary: Development package for %{name}
87Group: Development/Libraries
88Requires: %{name}-libs = %{version}-%{release}
89Requires: pkgconfig
90
91%description devel
92FFMpeg is a complete and free Internet live audio and video
93broadcasting solution for Linux/Unix. It also includes a digital
94VCR. It can encode in real time in many formats including MPEG1 audio
95and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
96
97This package contains development files for %{name}.
98
99
100%prep
101%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
102#% setup -q
103#%patch0 -p1 -b .textrel
104
105%build
106%ifarch ppc
107# compile with -mlongcall on ppc/ppc64 (rf804)
108export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
109%endif
110
111./configure \
112    --prefix=%{_prefix} \
113    --incdir=%{_includedir}/%{name} \
114    --shlibdir=%{_libdir} \
115    --libdir=%{_libdir} \
116    --mandir=%{_mandir} \
117    --arch=%{_target_cpu} \
118%ifarch %{ix86}
119    --cpu=%{_target_cpu} \
120%endif
121%ifarch ppc
122    --cpu=g3 \
123    --enable-pic \
124%endif
125    --enable-runtime-cpudetect \
126    --extra-cflags="$RPM_OPT_FLAGS" \
127    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
128    --enable-bzlib \
129    --enable-zlib \
130    --enable-libdc1394 \
131    %{?_with_libdirac:--enable-libdirac} \
132    %{?with_faac:--enable-libfaac --enable-nonfree} \
133    %{?with_libfaad:--enable-libfaad} \
134    --enable-libgsm \
135    --enable-libmp3lame \
136    %{?_with_openjpeg:--enable-libopenjpeg} \
137    --enable-librtmp \
138    --enable-libspeex \
139    --enable-libtheora \
140    --enable-libvorbis \
141    %{?with_libvpx:--enable-libvpx} \
142    --enable-libx264 \
143    --enable-libxvid \
144    \
145    --enable-x11grab \
146    --enable-avfilter \
147    --enable-postproc \
148    --enable-pthreads \
149    --disable-static \
150    --enable-shared \
151    --enable-gpl \
152    --disable-doc \
153    --disable-debug \
154    --disable-stripping \
155    ;
156
157%{__make} %{?_smp_mflags}
158#% {__make}
159#%{__make} documentation
160
161
162%install
163%__make install DESTDIR=$RPM_BUILD_ROOT
164
165# ## install tool/qt-faststart
166# %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
167
168## install man
169%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
170%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
171    $RPM_BUILD_ROOT%{_mandir}/man1/
172
173
174%clean
175%{__rm} -rf $RPM_BUILD_ROOT
176
177%post libs -p /sbin/ldconfig
178
179%postun libs -p /sbin/ldconfig
180
181%files
182%defattr(-,root,root,-)
183%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
184%{_bindir}/ffmpeg
185%{_bindir}/ffplay
186%{_bindir}/ffprobe
187%{_bindir}/ffserver
188#%{_bindir}/qt-faststart
189%{_mandir}/man1/ffmpeg.1*
190%{_mandir}/man1/ffplay.1*
191%{_mandir}/man1/ffprobe.1*
192%{_mandir}/man1/ffserver.1*
193%{_datadir}/ffmpeg
194
195
196%files libs
197%defattr(-,root,root,-)
198%{_libdir}/lib*.so.*
199
200%files devel
201%defattr(-,root,root,-)
202%doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
203%{_includedir}/ffmpeg
204%{_libdir}/pkgconfig/lib*.pc
205%{_libdir}/lib*.so
206
207
208%changelog
209* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
210- required latest x264 build
211- added BuildRequires: librtmp-devel >= 2.3
212- build PIC objects on PPC
213#- add qt-faststart tool
214
215* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
216- new upstream release
217
218* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
219- change release to sync with self-build-ffmpeg-vl.spec
220
221* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
222- added BuildRequires: libvpx-devel >= 0.9.1
223
224* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
225- new upstream release
226
227* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
228- bumped version to pre-0.6
229
230* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
231- updated source snapshot 20100410
232
233* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
234- change release to sync with self-build-ffmpeg-vl.spec
235
236* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
237- change release to sync with self-build-ffmpeg-vl.spec
238
239* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
240- updated source snapshot 20100401
241
242* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
243- updated source snapshot 20100326
244
245* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
246- change release to sync with self-build-ffmpeg
247
248* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
249- updated source snapshot 20100216
250  - rebuild with recent x264-devel
251- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
252- added BuildRequires:  libvdpau-devel
253
254* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
255- change release to sync with self-build-ffmpeg
256
257* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
258- change release to sync with self-build-ffmpeg
259
260* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
261- applied ffmpeg-0.5-disable-texi2html.patch
262  - dropped BuildRequires: texi2html
263
264* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
265- change release to sync with self-build-ffmpeg
266
267* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
268- corrected release number
269
270* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
271- new upstream release
272- added BuildRequires:
273  - speex-devel
274  - bzip2-devel
275
276* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
277- 20090227 snapshot
278
279* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
280- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
281
282* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
283- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
284- dropped Requires: a52dec, faad2 in ffmpeg-libs
285
286* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
287- 20090202 snapshot
288
289* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
290- 20090110 snapshot
291- dropped some patches
292
293* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
294- source updated (r15488)
295- fixed License: GPLv2+
296- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
297- added BuildRequires: yasm (only %%ix86)
298- applied ffmpeg-cpu.patch (merged from RPM Fusion)
299
300* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
301- spec in utf8
302
303* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
304- change release to sync with self-build-ffmpeg
305
306* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
307- drop "Patch100: ffmpeg-vine.patch".
308
309* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
310- build with new versioning policy
311- change to use svn export from svn checkout on post install
312- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
313
314* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
315- [self-build-ffmpeg.spec]
316  For all pre-required package that is provied by self-build, 
317  changed to its self-build package
318
319* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
320- initial build for Vine Linux 4.2
321- snapshot 2008/01/28 + some Rev.11662 2008/01/29
322
323### end of file
Note: See TracBrowser for help on using the repository browser.