source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 1373

Revision 1373, 8.7 KB checked in by munepi, 14 years ago (diff)

updated self-build-{mplayer,ffmpeg}: unpacked source archives

Line 
1#TODO: Build with openjpeg
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5## available for v0.6 or lower
6%define with_libfaad 1
7
8%define with_vaapi 1
9%define with_libvpx 1
10
11Summary:        Digital VCR and streaming server
12Name:           ffmpeg
13Version:        0.6
14Release:        4%{?svndate:.%svndate}%{?_dist_release}
15Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
16Source1:        %{name}-snapshot.sh
17
18# pre-built man files
19Source90:       ffmpeg.1.gz
20Source91:       ffplay.1.gz
21Source92:       ffserver.1.gz
22Source93:       ffprobe.1.gz
23
24License:        GPLv2+
25Group:          Applications/Multimedia
26URL:            http://ffmpeg.org/
27
28BuildRequires:  bzip2-devel
29##BuildRequires:  dirac-devel
30BuildRequires:  gsm-devel
31BuildRequires:  imlib2-devel
32BuildRequires:  libdc1394-devel
33BuildRequires:  libraw1394-devel
34BuildRequires:  libtheora-devel
35%{?with_vaapi:BuildRequires:libva-devel}
36%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
37BuildRequires:  libvdpau-devel
38BuildRequires:  libvorbis-devel
39%{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
40##BuildRequires:  openjpeg-devel
41BuildRequires:  SDL-devel
42BuildRequires:  speex-devel
43##BuildRequires:        texi2html
44BuildRequires:  zlib-devel
45BuildRequires:  libogg-devel
46%ifarch %{ix86} x86_64
47BuildRequires:  yasm
48%endif
49# *-devel packages provided by other self-build-* should only be listed
50# in self-build-%{name}.spec as PreReq.
51#BuildRequires: xvidcore-devel, faac-devel, lame-devel
52#BuildRequires: x264-devel, libdca-devel, a52dec-devel
53#BuildRequires: faad2-devel
54
55Requires:       %{name}-libs = %{version}-%{release}
56
57BuildRoot:      %{_tmppath}/%{name}-%{version}-root
58
59%description
60FFMpeg is a complete and free Internet live audio and video
61broadcasting solution for Linux/Unix. It also includes a digital
62VCR. It can encode in real time in many formats including MPEG1 audio
63and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
64
65%package libs
66Summary: Libraries for %{name}
67Group: System Environment/Libraries
68
69%description libs
70FFMpeg is a complete and free Internet live audio and video
71broadcasting solution for Linux/Unix. It also includes a digital
72VCR. It can encode in real time in many formats including MPEG1 audio
73and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
74
75This package contains the libraries for %{name}.
76
77%package devel
78Summary: Development package for %{name}
79Group: Development/Libraries
80Requires: %{name}-libs = %{version}-%{release}
81Requires: pkgconfig
82
83%description devel
84FFMpeg is a complete and free Internet live audio and video
85broadcasting solution for Linux/Unix. It also includes a digital
86VCR. It can encode in real time in many formats including MPEG1 audio
87and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
88
89This package contains development files for %{name}.
90
91
92%prep
93%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
94#% setup -q
95#%patch0 -p1 -b .textrel
96
97%build
98%ifarch ppc
99# compile with -mlongcall on ppc/ppc64 (rf804)
100export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
101%endif
102
103./configure \
104    --prefix=%{_prefix} \
105    --incdir=%{_includedir}/%{name} \
106    --shlibdir=%{_libdir} \
107    --libdir=%{_libdir} \
108    --mandir=%{_mandir} \
109    --arch=%{_target_cpu} \
110%ifarch %{ix86}
111    --cpu=%{_target_cpu} \
112%endif
113%ifarch ppc
114    --cpu=g3 \
115%endif
116    --enable-runtime-cpudetect \
117    --extra-cflags="$RPM_OPT_FLAGS" \
118    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
119    --enable-bzlib \
120    --enable-libdc1394 \
121    --enable-libfaac --enable-nonfree \
122    %{?with_libfaad:--enable-libfaad} \
123    --enable-libgsm \
124    --enable-libmp3lame \
125    %{?_with_openjpeg:--enable-libopenjpeg} \
126    --enable-libtheora \
127    --enable-libvorbis \
128    %{?with_libvpx:--enable-libvpx} \
129    --enable-libx264 \
130    --enable-libxvid \
131    --enable-zlib \
132    \
133    --enable-x11grab \
134    --enable-avfilter \
135    --enable-avfilter-lavf \
136    --enable-postproc \
137    --enable-swscale \
138    --enable-pthreads \
139    --disable-static \
140    --enable-shared \
141    --enable-gpl \
142    --disable-doc \
143    --disable-debug \
144    --disable-stripping
145
146%{__make} %{?_smp_mflags}
147#% {__make}
148#%{__make} documentation
149
150
151%install
152%__make install DESTDIR=$RPM_BUILD_ROOT
153
154## install man
155%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
156%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
157    $RPM_BUILD_ROOT%{_mandir}/man1/
158
159
160%clean
161%{__rm} -rf $RPM_BUILD_ROOT
162
163%post libs -p /sbin/ldconfig
164
165%postun libs -p /sbin/ldconfig
166
167%files
168%defattr(-,root,root,-)
169%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
170%{_bindir}/ff*
171%{_mandir}/man1/ff*.1*
172%{_datadir}/ffmpeg
173
174
175%files libs
176%defattr(-,root,root,-)
177%{_libdir}/lib*.so.*
178
179%files devel
180%defattr(-,root,root,-)
181%doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
182%{_includedir}/ffmpeg
183%{_libdir}/pkgconfig/lib*.pc
184%{_libdir}/lib*.so
185
186
187%changelog
188* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
189- change release to sync with self-build-ffmpeg-vl.spec
190
191* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
192- added BuildRequires: libvpx-devel >= 0.9.1
193
194* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
195- new upstream release
196
197* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
198- bumped version to pre-0.6
199
200* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
201- updated source snapshot 20100410
202
203* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
204- change release to sync with self-build-ffmpeg-vl.spec
205
206* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
207- change release to sync with self-build-ffmpeg-vl.spec
208
209* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
210- updated source snapshot 20100401
211
212* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
213- updated source snapshot 20100326
214
215* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
216- change release to sync with self-build-ffmpeg
217
218* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
219- updated source snapshot 20100216
220  - rebuild with recent x264-devel
221- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
222- added BuildRequires:  libvdpau-devel
223
224* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
225- change release to sync with self-build-ffmpeg
226
227* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
228- change release to sync with self-build-ffmpeg
229
230* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
231- applied ffmpeg-0.5-disable-texi2html.patch
232  - dropped BuildRequires: texi2html
233
234* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
235- change release to sync with self-build-ffmpeg
236
237* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
238- corrected release number
239
240* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
241- new upstream release
242- added BuildRequires:
243  - speex-devel
244  - bzip2-devel
245
246* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
247- 20090227 snapshot
248
249* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
250- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
251
252* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
253- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
254- dropped Requires: a52dec, faad2 in ffmpeg-libs
255
256* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
257- 20090202 snapshot
258
259* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
260- 20090110 snapshot
261- dropped some patches
262
263* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
264- source updated (r15488)
265- fixed License: GPLv2+
266- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
267- added BuildRequires: yasm (only %%ix86)
268- applied ffmpeg-cpu.patch (merged from RPM Fusion)
269
270* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
271- spec in utf8
272
273* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
274- change release to sync with self-build-ffmpeg
275
276* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
277- drop "Patch100: ffmpeg-vine.patch".
278
279* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
280- build with new versioning policy
281- change to use svn export from svn checkout on post install
282- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
283
284* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
285- [self-build-ffmpeg.spec]
286  For all pre-required package that is provied by self-build, 
287  changed to its self-build package
288
289* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
290- initial build for Vine Linux 4.2
291- snapshot 2008/01/28 + some Rev.11662 2008/01/29
292
293### end of file
Note: See TracBrowser for help on using the repository browser.