source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 789

Revision 789, 7.9 KB checked in by munepi, 14 years ago (diff)

updated self-build-ffmpeg

Line 
1#TODO: Build with openjpeg
2%define name    ffmpeg
3%define version 0.5
4%define svndate 20100401
5%define release 12%{?svndate:.%svndate}%{?_dist_release}
6
7Summary:        Digital VCR and streaming server
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11#Source:                %{name}-%{version}.tar.bz2
12Source:         %{name}-%{?svndate:%svndate}.tar.bz2
13Source1:        %{name}-snapshot.sh
14
15# pre-built man files
16Source90:       ffmpeg.1.gz
17Source91:       ffplay.1.gz
18Source92:       ffserver.1.gz
19Source93:       ffprobe.1.gz
20
21# get rid of textrels on x86_64 in yasm code (from RPM Fusion)
22#Patch0:         %{name}-textrel.patch
23
24License:        GPLv2+
25Group:          Applications/Multimedia
26URL:            http://ffmpeg.org/
27
28BuildRequires:  bzip2-devel
29BuildRequires:  gsm-devel
30BuildRequires:  imlib2-devel
31BuildRequires:  libdc1394-devel
32BuildRequires:  libraw1394-devel
33BuildRequires:  libtheora-devel
34BuildRequires:  libvdpau-devel
35BuildRequires:  libvorbis-devel
36##BuildRequires:  openjpeg-devel
37BuildRequires:  SDL-devel
38BuildRequires:  speex-devel
39##BuildRequires:        texi2html
40BuildRequires:  zlib-devel
41BuildRequires:  libogg-devel
42%ifarch %{ix86} x86_64
43BuildRequires:  yasm
44%endif
45# *-devel packages provided by other self-build-* should only be listed
46# in self-build-%{name}.spec as PreReq.
47#BuildRequires: xvidcore-devel, faac-devel, lame-devel
48#BuildRequires: x264-devel, libdca-devel, a52dec-devel
49#BuildRequires: faad2-devel
50
51BuildRoot:      %{_tmppath}/%{name}-%{version}-root
52
53%description
54FFMpeg is a complete and free Internet live audio and video
55broadcasting solution for Linux/Unix. It also includes a digital
56VCR. It can encode in real time in many formats including MPEG1 audio
57and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
58
59%package libs
60Group: System Environment/Libraries
61Summary: Libraries for %{name}
62Group: System Environment/Libraries
63
64%description libs
65FFMpeg is a complete and free Internet live audio and video
66broadcasting solution for Linux/Unix. It also includes a digital
67VCR. It can encode in real time in many formats including MPEG1 audio
68and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
69
70This package contains the libraries for %{name}.
71
72%package devel
73Summary: Development package for %{name}
74Group: Development/Libraries
75Requires: %{name}-libs = %{version}-%{release}
76Requires: pkgconfig
77
78%description devel
79FFMpeg is a complete and free Internet live audio and video
80broadcasting solution for Linux/Unix. It also includes a digital
81VCR. It can encode in real time in many formats including MPEG1 audio
82and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
83
84This package contains development files for %{name}.
85
86
87%prep
88%setup -q -n %{name}-%{svndate}
89#% setup -q
90#%patch0 -p1 -b .textrel
91
92%build
93%ifarch ppc
94# compile with -mlongcall on ppc/ppc64 (rf804)
95export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
96%endif
97
98./configure \
99    --prefix=%{_prefix} \
100    --incdir=%{_includedir}/%{name} \
101    --shlibdir=%{_libdir} \
102    --libdir=%{_libdir} \
103    --mandir=%{_mandir} \
104    --arch=%{_target_cpu} \
105%ifarch %{ix86}
106    --cpu=%{_target_cpu} \
107%endif
108%ifarch ppc
109    --cpu=g3 \
110%endif
111    --enable-runtime-cpudetect \
112    --extra-cflags="$RPM_OPT_FLAGS" \
113    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
114    --enable-bzlib \
115    --enable-libdc1394 \
116    --enable-libfaac --enable-nonfree \
117    --enable-libfaad \
118    --enable-libgsm \
119    --enable-libmp3lame \
120    %{?_with_openjpeg:--enable-libopenjpeg} \
121    --enable-libtheora \
122    --enable-libvorbis \
123    --enable-libx264 \
124    --enable-libxvid \
125    --enable-x11grab \
126    --enable-avfilter \
127    --enable-avfilter-lavf \
128    --enable-postproc \
129    --enable-swscale \
130    --enable-pthreads \
131    --disable-static \
132    --enable-shared \
133    --enable-gpl \
134    --disable-debug \
135    --disable-stripping
136
137%{__make} %{?_smp_mflags}
138#% {__make}
139#%{__make} documentation
140
141
142%install
143%__make install DESTDIR=$RPM_BUILD_ROOT
144
145## install man
146%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
147%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
148    $RPM_BUILD_ROOT%{_mandir}/man1/
149
150
151%clean
152%{__rm} -rf $RPM_BUILD_ROOT
153
154%post libs -p /sbin/ldconfig
155
156%postun libs -p /sbin/ldconfig
157
158%files
159%defattr(-,root,root,-)
160%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
161%{_bindir}/ff*
162%{_mandir}/man1/ff*.1*
163%{_datadir}/ffmpeg
164
165
166%files libs
167%defattr(-,root,root,-)
168%{_libdir}/lib*.so.*
169
170%files devel
171%defattr(-,root,root,-)
172%doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
173%{_includedir}/ffmpeg
174%{_libdir}/pkgconfig/lib*.pc
175%{_libdir}/lib*.so
176
177
178%changelog
179* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
180- change release to sync with self-build-ffmpeg-vl.spec
181
182* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
183- change release to sync with self-build-ffmpeg-vl.spec
184
185* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
186- updated source snapshot 20100401
187
188* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
189- updated source snapshot 20100326
190
191* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
192- change release to sync with self-build-ffmpeg
193
194* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
195- updated source snapshot 20100216
196  - rebuild with recent x264-devel
197- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
198- added BuildRequires:  libvdpau-devel
199
200* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
201- change release to sync with self-build-ffmpeg
202
203* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
204- change release to sync with self-build-ffmpeg
205
206* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
207- applied ffmpeg-0.5-disable-texi2html.patch
208  - dropped BuildRequires: texi2html
209
210* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
211- change release to sync with self-build-ffmpeg
212
213* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
214- corrected release number
215
216* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
217- new upstream release
218- added BuildRequires:
219  - speex-devel
220  - bzip2-devel
221
222* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
223- 20090227 snapshot
224
225* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
226- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
227
228* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
229- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
230- dropped Requires: a52dec, faad2 in ffmpeg-libs
231
232* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
233- 20090202 snapshot
234
235* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
236- 20090110 snapshot
237- dropped some patches
238
239* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
240- source updated (r15488)
241- fixed License: GPLv2+
242- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
243- added BuildRequires: yasm (only %%ix86)
244- applied ffmpeg-cpu.patch (merged from RPM Fusion)
245
246* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
247- spec in utf8
248
249* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
250- change release to sync with self-build-ffmpeg
251
252* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
253- drop "Patch100: ffmpeg-vine.patch".
254
255* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
256- build with new versioning policy
257- change to use svn export from svn checkout on post install
258- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
259
260* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
261- [self-build-ffmpeg.spec]
262  For all pre-required package that is provied by self-build, 
263  changed to its self-build package
264
265* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
266- initial build for Vine Linux 4.2
267- snapshot 2008/01/28 + some Rev.11662 2008/01/29
268
269### end of file
Note: See TracBrowser for help on using the repository browser.