source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 4754

Revision 4754, 9.8 KB checked in by munepi, 13 years ago (diff)

updated self-build-*: supported vl7 (VineSeed)

Line 
1#TODO: Build with openjpeg, opencore-amr
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5## available for v0.6 or lower
6%define with_libfaad 1
7
8%define with_faac 1
9
10%define with_vaapi 1
11%define with_libvpx 1
12
13Summary:        Digital VCR and streaming server
14Name:           ffmpeg
15Version:        0.6.3
16Release:        2%{?svndate:.%svndate}%{?_dist_release}
17Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
18Source1:        %{name}-snapshot.sh
19
20# pre-built man files
21Source90:       ffmpeg.1.gz
22Source91:       ffplay.1.gz
23Source92:       ffserver.1.gz
24Source93:       ffprobe.1.gz
25
26License:        GPLv2+
27Group:          Applications/Multimedia
28URL:            http://ffmpeg.org/
29
30BuildRequires:  bzip2-devel
31##BuildRequires:  dirac-devel
32BuildRequires:  gsm-devel
33BuildRequires:  imlib2-devel
34BuildRequires:  libdc1394-devel
35BuildRequires:  libraw1394-devel
36BuildRequires:  librtmp-devel >= 2.3
37BuildRequires:  libtheora-devel
38%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
39BuildRequires:  libvdpau-devel
40BuildRequires:  libvorbis-devel
41%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
42%{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
43##BuildRequires:  openjpeg-devel
44##BuildRequires:  schroedinger-devel
45BuildRequires:  SDL-devel
46BuildRequires:  speex-devel
47##BuildRequires:        texi2html
48BuildRequires:  zlib-devel
49BuildRequires:  libogg-devel
50BuildRequires:  yasm
51# *-devel packages provided by other self-build-* should only be listed
52# in self-build-%{name}.spec as PreReq.
53#BuildRequires: a52dec-devel
54#BuildRequires: faac-devel
55#BuildRequires: lame-devel
56#BuildRequires: libdca-devel
57#BuildRequires: faad2-devel
58#BuildRequires: x264-devel >= 0.0.0-15.20110322
59#BuildRequires: xvidcore-devel
60
61Requires:       %{name}-libs = %{version}-%{release}
62
63BuildRoot:      %{_tmppath}/%{name}-%{version}-root
64
65%description
66FFMpeg is a complete and free Internet live audio and video
67broadcasting solution for Linux/Unix. It also includes a digital
68VCR. It can encode in real time in many formats including MPEG1 audio
69and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
70
71%package libs
72Summary: Libraries for %{name}
73Group: System Environment/Libraries
74
75%description libs
76FFMpeg is a complete and free Internet live audio and video
77broadcasting solution for Linux/Unix. It also includes a digital
78VCR. It can encode in real time in many formats including MPEG1 audio
79and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
80
81This package contains the libraries for %{name}.
82
83%package devel
84Summary: Development package for %{name}
85Group: Development/Libraries
86Requires: %{name}-libs = %{version}-%{release}
87Requires: pkgconfig
88
89%description devel
90FFMpeg is a complete and free Internet live audio and video
91broadcasting solution for Linux/Unix. It also includes a digital
92VCR. It can encode in real time in many formats including MPEG1 audio
93and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
94
95This package contains development files for %{name}.
96
97
98%prep
99%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
100#% setup -q
101#%patch0 -p1 -b .textrel
102
103%build
104%ifarch ppc
105# compile with -mlongcall on ppc/ppc64 (rf804)
106export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
107%endif
108
109./configure \
110    --prefix=%{_prefix} \
111    --incdir=%{_includedir}/%{name} \
112    --shlibdir=%{_libdir} \
113    --libdir=%{_libdir} \
114    --mandir=%{_mandir} \
115    --arch=%{_target_cpu} \
116%ifarch %{ix86}
117    --cpu=%{_target_cpu} \
118%endif
119%ifarch ppc
120    --cpu=g3 \
121    --enable-pic \
122%endif
123    --enable-runtime-cpudetect \
124    --extra-cflags="$RPM_OPT_FLAGS" \
125    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
126    --enable-bzlib \
127    --enable-zlib \
128    --enable-libdc1394 \
129    %{?_with_libdirac:--enable-libdirac} \
130    %{?with_faac:--enable-libfaac --enable-nonfree} \
131    %{?with_libfaad:--enable-libfaad} \
132    --enable-libgsm \
133    --enable-libmp3lame \
134    %{?_with_openjpeg:--enable-libopenjpeg} \
135    --enable-librtmp \
136    --enable-libspeex \
137    --enable-libtheora \
138    --enable-libvorbis \
139    %{?with_libvpx:--enable-libvpx} \
140    --enable-libx264 \
141    --enable-libxvid \
142    \
143    --enable-x11grab \
144    --enable-avfilter \
145    --enable-postproc \
146    --enable-pthreads \
147    --disable-static \
148    --enable-shared \
149    --enable-gpl \
150    --disable-doc \
151    --disable-debug \
152    --disable-stripping \
153    ;
154
155%{__make} %{?_smp_mflags}
156#% {__make}
157#%{__make} documentation
158
159
160%install
161%__make install DESTDIR=$RPM_BUILD_ROOT
162
163# ## install tool/qt-faststart
164# %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
165
166## install man
167%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
168%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
169    $RPM_BUILD_ROOT%{_mandir}/man1/
170
171
172%clean
173%{__rm} -rf $RPM_BUILD_ROOT
174
175%post libs -p /sbin/ldconfig
176
177%postun libs -p /sbin/ldconfig
178
179%files
180%defattr(-,root,root,-)
181%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
182%{_bindir}/ffmpeg
183%{_bindir}/ffplay
184%{_bindir}/ffprobe
185%{_bindir}/ffserver
186#%{_bindir}/qt-faststart
187%{_mandir}/man1/ffmpeg.1*
188%{_mandir}/man1/ffplay.1*
189%{_mandir}/man1/ffprobe.1*
190%{_mandir}/man1/ffserver.1*
191%{_datadir}/ffmpeg
192
193
194%files libs
195%defattr(-,root,root,-)
196%{_libdir}/lib*.so.*
197
198%files devel
199%defattr(-,root,root,-)
200%doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
201%{_includedir}/ffmpeg
202%{_libdir}/pkgconfig/lib*.pc
203%{_libdir}/lib*.so
204
205
206%changelog
207* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
208- change release to sync with self-build-ffmpeg-vl.spec
209
210* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
211- new upstream release
212
213* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
214- new upstream release
215
216* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
217- required latest x264 build
218- added BuildRequires: librtmp-devel >= 2.3
219- build PIC objects on PPC
220#- add qt-faststart tool
221
222* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
223- new upstream release
224
225* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
226- change release to sync with self-build-ffmpeg-vl.spec
227
228* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
229- added BuildRequires: libvpx-devel >= 0.9.1
230
231* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
232- new upstream release
233
234* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
235- bumped version to pre-0.6
236
237* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
238- updated source snapshot 20100410
239
240* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
241- change release to sync with self-build-ffmpeg-vl.spec
242
243* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
244- change release to sync with self-build-ffmpeg-vl.spec
245
246* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
247- updated source snapshot 20100401
248
249* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
250- updated source snapshot 20100326
251
252* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
253- change release to sync with self-build-ffmpeg
254
255* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
256- updated source snapshot 20100216
257  - rebuild with recent x264-devel
258- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
259- added BuildRequires:  libvdpau-devel
260
261* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
262- change release to sync with self-build-ffmpeg
263
264* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
265- change release to sync with self-build-ffmpeg
266
267* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
268- applied ffmpeg-0.5-disable-texi2html.patch
269  - dropped BuildRequires: texi2html
270
271* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
272- change release to sync with self-build-ffmpeg
273
274* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
275- corrected release number
276
277* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
278- new upstream release
279- added BuildRequires:
280  - speex-devel
281  - bzip2-devel
282
283* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
284- 20090227 snapshot
285
286* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
287- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
288
289* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
290- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
291- dropped Requires: a52dec, faad2 in ffmpeg-libs
292
293* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
294- 20090202 snapshot
295
296* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
297- 20090110 snapshot
298- dropped some patches
299
300* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
301- source updated (r15488)
302- fixed License: GPLv2+
303- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
304- added BuildRequires: yasm (only %%ix86)
305- applied ffmpeg-cpu.patch (merged from RPM Fusion)
306
307* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
308- spec in utf8
309
310* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
311- change release to sync with self-build-ffmpeg
312
313* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
314- drop "Patch100: ffmpeg-vine.patch".
315
316* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
317- build with new versioning policy
318- change to use svn export from svn checkout on post install
319- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
320
321* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
322- [self-build-ffmpeg.spec]
323  For all pre-required package that is provied by self-build, 
324  changed to its self-build package
325
326* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
327- initial build for Vine Linux 4.2
328- snapshot 2008/01/28 + some Rev.11662 2008/01/29
329
330### end of file
Note: See TracBrowser for help on using the repository browser.