source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 9522

Revision 9522, 12.8 KB checked in by munepi, 9 years ago (diff)

new upstream release

RevLine 
[5297]1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
[1258]2#TODO: add make test to %%check section
[615]3
[1258]4#% define svndate       20100625
[9215]5%global with_faac       1
6%global with_vaapi      1
7%global with_libvpx     1
[1258]8
[9423]9%global major_version   2.6
[5396]10
[615]11Summary:        Digital VCR and streaming server
[1258]12Name:           ffmpeg
[9522]13Version:        %{major_version}.2
[9215]14Release:        1%{?svndate:.%svndate}%{?_dist_release}
[1373]15Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
[7689]16## prebuilt man pages
[615]17
[5297]18%if 0%{?_with_amr:1}
19License:        GPLv3+
20%else
21License:        GPLv2+
22%endif
[615]23Group:          Applications/Multimedia
24URL:            http://ffmpeg.org/
25
26BuildRequires:  bzip2-devel
[5297]27BuildRequires:  celt-devel
[7546]28##BuildRequires: dirac-devel
[5297]29BuildRequires:  freetype2-devel
[7546]30##BuildRequires: frei0r-devel
31BuildRequires:  gnutls-devel
[615]32BuildRequires:  gsm-devel
33BuildRequires:  imlib2-devel
34BuildRequires:  libdc1394-devel
[5297]35BuildRequires:  libogg-devel
[6241]36BuildRequires:  libass-devel
37%{!?_without_cdio:BuildRequires: libcdio-devel}
[8803]38%{!?_without_cdio:BuildRequires: libcdio-paranoia-devel}
[6241]39#libcrystalhd is currently broken
40%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
[615]41BuildRequires:  libraw1394-devel
[3126]42BuildRequires:  librtmp-devel >= 2.3
[615]43BuildRequires:  libtheora-devel
[3126]44%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
[615]45BuildRequires:  libvdpau-devel
46BuildRequires:  libvorbis-devel
[7546]47%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
[6241]48BuildRequires:  libXvMC-devel
[5297]49%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
[6241]50%{!?_without_openal:BuildRequires: openal-soft-devel}
51%{?_with_opencv:BuildRequires: opencv-devel}
52%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
[3126]53##BuildRequires:  schroedinger-devel
[615]54BuildRequires:  SDL-devel
55BuildRequires:  speex-devel
[7546]56##BuildRequires:        texi2html
[615]57BuildRequires:  zlib-devel
58BuildRequires:  yasm
59# *-devel packages provided by other self-build-* should only be listed
60# in self-build-%{name}.spec as PreReq.
[3126]61#BuildRequires: a52dec-devel
62#BuildRequires: faac-devel
63#BuildRequires: lame-devel
64#BuildRequires: libdca-devel
[5396]65#BuildRequires: x264-devel >= 0.0.0-18.20111216
[3126]66#BuildRequires: xvidcore-devel
[615]67
[1258]68Requires:       %{name}-libs = %{version}-%{release}
69
[615]70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71
[6325]72Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
[6241]73
[615]74%description
75FFMpeg is a complete and free Internet live audio and video
76broadcasting solution for Linux/Unix. It also includes a digital
77VCR. It can encode in real time in many formats including MPEG1 audio
78and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
79
80%package libs
81Summary: Libraries for %{name}
82Group: System Environment/Libraries
83
84%description libs
85FFMpeg is a complete and free Internet live audio and video
86broadcasting solution for Linux/Unix. It also includes a digital
87VCR. It can encode in real time in many formats including MPEG1 audio
88and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
89
90This package contains the libraries for %{name}.
91
92%package devel
93Summary: Development package for %{name}
94Group: Development/Libraries
95Requires: %{name}-libs = %{version}-%{release}
96Requires: pkgconfig
97
98%description devel
99FFMpeg is a complete and free Internet live audio and video
100broadcasting solution for Linux/Unix. It also includes a digital
101VCR. It can encode in real time in many formats including MPEG1 audio
102and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
103
104This package contains development files for %{name}.
105
106
107%prep
[1258]108%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
[615]109
[9215]110%__sed -i "s/-O3 -g/$RPM_OPT_FLAGS/" configure
[7689]111
[615]112%build
113%ifarch ppc
114# compile with -mlongcall on ppc/ppc64 (rf804)
115export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
116%endif
117
118./configure \
119    --prefix=%{_prefix} \
120    --incdir=%{_includedir}/%{name} \
121    --shlibdir=%{_libdir} \
122    --libdir=%{_libdir} \
123    --mandir=%{_mandir} \
124    --arch=%{_target_cpu} \
125%ifarch %{ix86}
126    --cpu=%{_target_cpu} \
127%endif
128%ifarch ppc
129    --cpu=g3 \
[3126]130    --enable-pic \
[615]131%endif
132    --enable-runtime-cpudetect \
133    --extra-cflags="$RPM_OPT_FLAGS" \
[5297]134    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
[615]135    --enable-bzlib \
[6241]136    %{!?_with_crystalhd:--disable-crystalhd} \
[3126]137    --enable-zlib \
[6241]138    %{?_with_frei0r:--enable-frei0r} \
139    --enable-gnutls \
140    --enable-libass \
141    %{!?_without_cdio:--enable-libcdio} \
[5297]142    --enable-libcelt \
[615]143    --enable-libdc1394 \
[3126]144    %{?_with_libdirac:--enable-libdirac} \
145    %{?with_faac:--enable-libfaac --enable-nonfree} \
[5297]146    --enable-libfreetype \
[615]147    --enable-libgsm \
148    --enable-libmp3lame \
[6241]149    %{!?_without_openal:--enable-openal} \
150    %{?_with_opencv:--enable-libopencv} \
[615]151    %{?_with_openjpeg:--enable-libopenjpeg} \
[3126]152    --enable-librtmp \
153    --enable-libspeex \
[615]154    --enable-libtheora \
155    --enable-libvorbis \
[1258]156    %{?with_libvpx:--enable-libvpx} \
[615]157    --enable-libx264 \
[9215]158    --enable-libx265 \
[615]159    --enable-libxvid \
[1258]160    \
[615]161    --enable-x11grab \
162    --enable-avfilter \
163    --enable-postproc \
164    --enable-pthreads \
165    --disable-static \
166    --enable-shared \
167    --enable-gpl \
168    --disable-debug \
[3126]169    --disable-stripping \
[5396]170    \
[9215]171    --disable-doc --disable-htmlpages --disable-podpages --disable-txtpages \
[5396]172    %{?enable_avconv:--enable-avconv} \
[3126]173    ;
[615]174
[5297]175%__make %{?_smp_mflags}
[615]176
[5297]177%__make alltools
178
179
[615]180%install
181%__make install DESTDIR=$RPM_BUILD_ROOT
182
[5297]183## install tool/qt-faststart
184%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
[3126]185
[9215]186# ## install man
187# %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
188# %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
[615]189
190
191%clean
192%{__rm} -rf $RPM_BUILD_ROOT
193
194%post libs -p /sbin/ldconfig
195
196%postun libs -p /sbin/ldconfig
197
198%files
199%defattr(-,root,root,-)
200%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
[5396]201%{?enable_avconv:%{_bindir}/avconv}
[3126]202%{_bindir}/ffmpeg
203%{_bindir}/ffplay
204%{_bindir}/ffprobe
205%{_bindir}/ffserver
[5297]206%{_bindir}/qt-faststart
[7689]207%{?enable_avconv:%{_mandir}/man1/avconv.1*}
[9215]208# %{_mandir}/man1/ffmpeg*.1*
209# %{_mandir}/man1/ffplay*.1*
210# %{_mandir}/man1/ffprobe*.1*
211# %{_mandir}/man1/ffserver*.1*
[615]212%{_datadir}/ffmpeg
213
214
215%files libs
216%defattr(-,root,root,-)
217%{_libdir}/lib*.so.*
[9215]218# %{_mandir}/man3/lib*.3.gz
[615]219
220%files devel
221%defattr(-,root,root,-)
[9215]222%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
[615]223%{_includedir}/ffmpeg
224%{_libdir}/pkgconfig/lib*.pc
225%{_libdir}/lib*.so
226
227
228%changelog
[9522]229* Mon Apr 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.2-1
230- new upstream release
231
[9450]232* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.1-1
233- new upstream release
234
[9423]235* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6-1
[9366]236- new upstream release
237
[9423]238* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.4-1
[9281]239- new upstream release
240
[9423]241* Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.3-1
[9215]242- new upstream release
243
[9423]244* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
245- new upstream release
246
[8803]247* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
248- add BuildRequires: libcdio-paranoia-devel
249
[8313]250* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
251- new upstream release
252
[7865]253* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
254- new upstream release
255
[7842]256* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
257- new upstream release
258
[7689]259* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
260- new upstream release
261- added man pages
262  - added Source10: ffmpeg-1.2.1-doc.tar.xz
263
[7603]264* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
265- new upstream release
266
[7546]267* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
268- new upstream release
269
270* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
271- libvpx >= 0.9.7
272
273* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
274- new upstream release /x264-0.129
275
[6862]276* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
277- new upstream release
278
[6325]279* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
280- new upstream release
281
[6241]282* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
283- new upstream release
284
285* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
286- new upstream release
287
[5396]288* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
289- new upstream release
290
[5297]291* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
292- new upstream release
293- enable CELT decoding via libcelt
294- enable FreeType support
295- drop faad2 support (dropped upstream)
[4991]296
[4754]297* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
298- change release to sync with self-build-ffmpeg-vl.spec
299
[3763]300* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
301- new upstream release
302
[3538]303* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
304- new upstream release
305
[3126]306* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
307- required latest x264 build
308- added BuildRequires: librtmp-devel >= 2.3
309- build PIC objects on PPC
310#- add qt-faststart tool
311
[2156]312* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
313- new upstream release
314
[1373]315* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
316- change release to sync with self-build-ffmpeg-vl.spec
317
[1306]318* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
319- added BuildRequires: libvpx-devel >= 0.9.1
320
[1258]321* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
322- new upstream release
323
[861]324* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
325- bumped version to pre-0.6
326
327* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
328- updated source snapshot 20100410
329
[789]330* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
331- change release to sync with self-build-ffmpeg-vl.spec
332
[788]333* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
334- change release to sync with self-build-ffmpeg-vl.spec
335
[786]336* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
337- updated source snapshot 20100401
338
339* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
340- updated source snapshot 20100326
341
[615]342* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
343- change release to sync with self-build-ffmpeg
344
345* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
346- updated source snapshot 20100216
347  - rebuild with recent x264-devel
348- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
349- added BuildRequires:  libvdpau-devel
350
351* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
352- change release to sync with self-build-ffmpeg
353
354* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
355- change release to sync with self-build-ffmpeg
356
357* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
358- applied ffmpeg-0.5-disable-texi2html.patch
359  - dropped BuildRequires: texi2html
360
361* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
362- change release to sync with self-build-ffmpeg
363
364* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
365- corrected release number
366
367* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
368- new upstream release
369- added BuildRequires:
370  - speex-devel
371  - bzip2-devel
372
373* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
374- 20090227 snapshot
375
376* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
377- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
378
379* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
380- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
381- dropped Requires: a52dec, faad2 in ffmpeg-libs
382
383* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
384- 20090202 snapshot
385
386* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
387- 20090110 snapshot
388- dropped some patches
389
390* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
391- source updated (r15488)
392- fixed License: GPLv2+
393- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
394- added BuildRequires: yasm (only %%ix86)
395- applied ffmpeg-cpu.patch (merged from RPM Fusion)
396
397* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
398- spec in utf8
399
400* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
401- change release to sync with self-build-ffmpeg
402
403* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
404- drop "Patch100: ffmpeg-vine.patch".
405
406* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
407- build with new versioning policy
408- change to use svn export from svn checkout on post install
409- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
410
411* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
412- [self-build-ffmpeg.spec]
413  For all pre-required package that is provied by self-build, 
414  changed to its self-build package
415
416* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
417- initial build for Vine Linux 4.2
418- snapshot 2008/01/28 + some Rev.11662 2008/01/29
419
420### end of file
Note: See TracBrowser for help on using the repository browser.