source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 9215

Revision 9215, 12.3 KB checked in by munepi, 9 years ago (diff)

new upstream release

RevLine 
[5297]1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
[1258]2#TODO: add make test to %%check section
[615]3
[1258]4#% define svndate       20100625
[9215]5%global with_faac       1
6%global with_vaapi      1
7%global with_libvpx     1
[1258]8
[9215]9%global major_version   2.5
[5396]10
[615]11Summary:        Digital VCR and streaming server
[1258]12Name:           ffmpeg
[9215]13Version:        %{major_version}.2
14Release:        1%{?svndate:.%svndate}%{?_dist_release}
[1373]15Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
[7689]16## prebuilt man pages
[615]17
[5297]18%if 0%{?_with_amr:1}
19License:        GPLv3+
20%else
21License:        GPLv2+
22%endif
[615]23Group:          Applications/Multimedia
24URL:            http://ffmpeg.org/
25
26BuildRequires:  bzip2-devel
[5297]27BuildRequires:  celt-devel
[7546]28##BuildRequires: dirac-devel
[5297]29BuildRequires:  freetype2-devel
[7546]30##BuildRequires: frei0r-devel
31BuildRequires:  gnutls-devel
[615]32BuildRequires:  gsm-devel
33BuildRequires:  imlib2-devel
34BuildRequires:  libdc1394-devel
[5297]35BuildRequires:  libogg-devel
[6241]36BuildRequires:  libass-devel
37%{!?_without_cdio:BuildRequires: libcdio-devel}
[8803]38%{!?_without_cdio:BuildRequires: libcdio-paranoia-devel}
[6241]39#libcrystalhd is currently broken
40%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
[615]41BuildRequires:  libraw1394-devel
[3126]42BuildRequires:  librtmp-devel >= 2.3
[615]43BuildRequires:  libtheora-devel
[3126]44%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
[615]45BuildRequires:  libvdpau-devel
46BuildRequires:  libvorbis-devel
[7546]47%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
[6241]48BuildRequires:  libXvMC-devel
[5297]49%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
[6241]50%{!?_without_openal:BuildRequires: openal-soft-devel}
51%{?_with_opencv:BuildRequires: opencv-devel}
52%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
[3126]53##BuildRequires:  schroedinger-devel
[615]54BuildRequires:  SDL-devel
55BuildRequires:  speex-devel
[7546]56##BuildRequires:        texi2html
[615]57BuildRequires:  zlib-devel
58BuildRequires:  yasm
59# *-devel packages provided by other self-build-* should only be listed
60# in self-build-%{name}.spec as PreReq.
[3126]61#BuildRequires: a52dec-devel
62#BuildRequires: faac-devel
63#BuildRequires: lame-devel
64#BuildRequires: libdca-devel
[5396]65#BuildRequires: x264-devel >= 0.0.0-18.20111216
[3126]66#BuildRequires: xvidcore-devel
[615]67
[1258]68Requires:       %{name}-libs = %{version}-%{release}
69
[615]70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71
[6325]72Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
[6241]73
[615]74%description
75FFMpeg is a complete and free Internet live audio and video
76broadcasting solution for Linux/Unix. It also includes a digital
77VCR. It can encode in real time in many formats including MPEG1 audio
78and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
79
80%package libs
81Summary: Libraries for %{name}
82Group: System Environment/Libraries
83
84%description libs
85FFMpeg is a complete and free Internet live audio and video
86broadcasting solution for Linux/Unix. It also includes a digital
87VCR. It can encode in real time in many formats including MPEG1 audio
88and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
89
90This package contains the libraries for %{name}.
91
92%package devel
93Summary: Development package for %{name}
94Group: Development/Libraries
95Requires: %{name}-libs = %{version}-%{release}
96Requires: pkgconfig
97
98%description devel
99FFMpeg is a complete and free Internet live audio and video
100broadcasting solution for Linux/Unix. It also includes a digital
101VCR. It can encode in real time in many formats including MPEG1 audio
102and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
103
104This package contains development files for %{name}.
105
106
107%prep
[1258]108%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
[615]109
[9215]110%__sed -i "s/-O3 -g/$RPM_OPT_FLAGS/" configure
[7689]111
[615]112%build
113%ifarch ppc
114# compile with -mlongcall on ppc/ppc64 (rf804)
115export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
116%endif
117
118./configure \
119    --prefix=%{_prefix} \
120    --incdir=%{_includedir}/%{name} \
121    --shlibdir=%{_libdir} \
122    --libdir=%{_libdir} \
123    --mandir=%{_mandir} \
124    --arch=%{_target_cpu} \
125%ifarch %{ix86}
126    --cpu=%{_target_cpu} \
127%endif
128%ifarch ppc
129    --cpu=g3 \
[3126]130    --enable-pic \
[615]131%endif
132    --enable-runtime-cpudetect \
133    --extra-cflags="$RPM_OPT_FLAGS" \
[5297]134    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
[615]135    --enable-bzlib \
[6241]136    %{!?_with_crystalhd:--disable-crystalhd} \
[3126]137    --enable-zlib \
[6241]138    %{?_with_frei0r:--enable-frei0r} \
139    --enable-gnutls \
140    --enable-libass \
141    %{!?_without_cdio:--enable-libcdio} \
[5297]142    --enable-libcelt \
[615]143    --enable-libdc1394 \
[3126]144    %{?_with_libdirac:--enable-libdirac} \
145    %{?with_faac:--enable-libfaac --enable-nonfree} \
[5297]146    --enable-libfreetype \
[615]147    --enable-libgsm \
148    --enable-libmp3lame \
[6241]149    %{!?_without_openal:--enable-openal} \
150    %{?_with_opencv:--enable-libopencv} \
[615]151    %{?_with_openjpeg:--enable-libopenjpeg} \
[3126]152    --enable-librtmp \
153    --enable-libspeex \
[615]154    --enable-libtheora \
155    --enable-libvorbis \
[1258]156    %{?with_libvpx:--enable-libvpx} \
[615]157    --enable-libx264 \
[9215]158    --enable-libx265 \
[615]159    --enable-libxvid \
[1258]160    \
[615]161    --enable-x11grab \
162    --enable-avfilter \
163    --enable-postproc \
164    --enable-pthreads \
165    --disable-static \
166    --enable-shared \
167    --enable-gpl \
168    --disable-debug \
[3126]169    --disable-stripping \
[5396]170    \
[9215]171    --disable-doc --disable-htmlpages --disable-podpages --disable-txtpages \
[5396]172    %{?enable_avconv:--enable-avconv} \
[3126]173    ;
[615]174
[5297]175%__make %{?_smp_mflags}
[615]176
[5297]177%__make alltools
178
179
[615]180%install
181%__make install DESTDIR=$RPM_BUILD_ROOT
182
[5297]183## install tool/qt-faststart
184%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
[3126]185
[9215]186# ## install man
187# %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
188# %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
[615]189
190
191%clean
192%{__rm} -rf $RPM_BUILD_ROOT
193
194%post libs -p /sbin/ldconfig
195
196%postun libs -p /sbin/ldconfig
197
198%files
199%defattr(-,root,root,-)
200%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
[5396]201%{?enable_avconv:%{_bindir}/avconv}
[3126]202%{_bindir}/ffmpeg
203%{_bindir}/ffplay
204%{_bindir}/ffprobe
205%{_bindir}/ffserver
[5297]206%{_bindir}/qt-faststart
[7689]207%{?enable_avconv:%{_mandir}/man1/avconv.1*}
[9215]208# %{_mandir}/man1/ffmpeg*.1*
209# %{_mandir}/man1/ffplay*.1*
210# %{_mandir}/man1/ffprobe*.1*
211# %{_mandir}/man1/ffserver*.1*
[615]212%{_datadir}/ffmpeg
213
214
215%files libs
216%defattr(-,root,root,-)
217%{_libdir}/lib*.so.*
[9215]218# %{_mandir}/man3/lib*.3.gz
[615]219
220%files devel
221%defattr(-,root,root,-)
[9215]222%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
[615]223%{_includedir}/ffmpeg
224%{_libdir}/pkgconfig/lib*.pc
225%{_libdir}/lib*.so
226
227
228%changelog
[9215]229* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2
230- new upstream release
231
[8803]232* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
233- add BuildRequires: libcdio-paranoia-devel
234
[8313]235* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
236- new upstream release
237
[7865]238* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
239- new upstream release
240
[7842]241* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
242- new upstream release
243
[7689]244* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
245- new upstream release
246- added man pages
247  - added Source10: ffmpeg-1.2.1-doc.tar.xz
248
[7603]249* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
250- new upstream release
251
[7546]252* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
253- new upstream release
254
255* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
256- libvpx >= 0.9.7
257
258* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
259- new upstream release /x264-0.129
260
[6862]261* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
262- new upstream release
263
[6325]264* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
265- new upstream release
266
[6241]267* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
268- new upstream release
269
270* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
271- new upstream release
272
[5396]273* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
274- new upstream release
275
[5297]276* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
277- new upstream release
278- enable CELT decoding via libcelt
279- enable FreeType support
280- drop faad2 support (dropped upstream)
[4991]281
[4754]282* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
283- change release to sync with self-build-ffmpeg-vl.spec
284
[3763]285* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
286- new upstream release
287
[3538]288* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
289- new upstream release
290
[3126]291* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
292- required latest x264 build
293- added BuildRequires: librtmp-devel >= 2.3
294- build PIC objects on PPC
295#- add qt-faststart tool
296
[2156]297* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
298- new upstream release
299
[1373]300* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
301- change release to sync with self-build-ffmpeg-vl.spec
302
[1306]303* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
304- added BuildRequires: libvpx-devel >= 0.9.1
305
[1258]306* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
307- new upstream release
308
[861]309* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
310- bumped version to pre-0.6
311
312* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
313- updated source snapshot 20100410
314
[789]315* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
316- change release to sync with self-build-ffmpeg-vl.spec
317
[788]318* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
319- change release to sync with self-build-ffmpeg-vl.spec
320
[786]321* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
322- updated source snapshot 20100401
323
324* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
325- updated source snapshot 20100326
326
[615]327* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
328- change release to sync with self-build-ffmpeg
329
330* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
331- updated source snapshot 20100216
332  - rebuild with recent x264-devel
333- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
334- added BuildRequires:  libvdpau-devel
335
336* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
337- change release to sync with self-build-ffmpeg
338
339* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
340- change release to sync with self-build-ffmpeg
341
342* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
343- applied ffmpeg-0.5-disable-texi2html.patch
344  - dropped BuildRequires: texi2html
345
346* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
347- change release to sync with self-build-ffmpeg
348
349* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
350- corrected release number
351
352* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
353- new upstream release
354- added BuildRequires:
355  - speex-devel
356  - bzip2-devel
357
358* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
359- 20090227 snapshot
360
361* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
362- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
363
364* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
365- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
366- dropped Requires: a52dec, faad2 in ffmpeg-libs
367
368* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
369- 20090202 snapshot
370
371* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
372- 20090110 snapshot
373- dropped some patches
374
375* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
376- source updated (r15488)
377- fixed License: GPLv2+
378- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
379- added BuildRequires: yasm (only %%ix86)
380- applied ffmpeg-cpu.patch (merged from RPM Fusion)
381
382* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
383- spec in utf8
384
385* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
386- change release to sync with self-build-ffmpeg
387
388* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
389- drop "Patch100: ffmpeg-vine.patch".
390
391* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
392- build with new versioning policy
393- change to use svn export from svn checkout on post install
394- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
395
396* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
397- [self-build-ffmpeg.spec]
398  For all pre-required package that is provied by self-build, 
399  changed to its self-build package
400
401* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
402- initial build for Vine Linux 4.2
403- snapshot 2008/01/28 + some Rev.11662 2008/01/29
404
405### end of file
Note: See TracBrowser for help on using the repository browser.