source: projects/specs/trunk/nonfree/self-build-faad2/self-build-faad2-vl.spec @ 615

Revision 615, 5.2 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname faad2
2%define name    self-build-%{pkgname}
3%define version 2.7
4%define release 4%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/faac/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13
14Obsoletes:      faad2 < 2.7, faad2-devel < 2.7
15
16Source0:        %{pkgname}-vl.spec
17
18License:        GPLv2+
19Group:          Restricted Software
20
21Requires(post):         self-build-setup >= 0.9.9
22
23Requires(post): autoconf, automake, libtool
24Requires(post): gcc-c++, zlib-devel, sysfsutils-devel
25Requires(post): id3lib-devel, gtk+-devel
26%{?_with_xmms:Requires(post): xmms-devel}
27
28BuildArch:      noarch
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Packager:       munepi
32
33%description
34FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder, completely
35written from scratch.
36
37If you install this package, it automaticaly downloads source
38code ,compile it, and create rpm packages of %{pkgname}-%{version}.
39And the created rpm packages are automatically installed
40if installation is executed by apt-get command or synaptic
41package manager.
42
43[Note]
44This package requires many other packages to compile
45targetsoftware. So it consume more disk space than usual.
46Also installation takes logner time because of compilation.
47(This will take a few minutes to quarter or half of an hour,
48depends on building environment)
49
50[About self-build package]
51For some kind of software, distributing of binary package
52may viorate the patent or law. Therefore we chose self-build
53packge, create binary package on your machine, for such kind
54of softwares instead of distributing binary package.
55
56Please obey the national law when you use the created binary
57packages. And if you want to use the softwares using patented
58thechnology, it may be required to get a permission, make an
59agreement or purchas a license. Please consider it with your
60purpose or way of use and take appropriate action.
61
62%description -l ja
63FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder, completely
64written from scratch.
65
66
67このパッケージをインストールすると、自動的にソースコードを
68ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
69パッケージを作成します。
70また apt-get コマンドや synaptic パッケージマネージャから実行
71した場合は、作成された rpm パッケージのインストールも自動的に
72行います。
73
74[注意]
75コンパイルに必要な多くの関連パッケージを要求するので通常より
76ディスクの領域を多く消費します。
77またインストール時にコンパイルを行うため、通常より時間がかか
78る場合があります。(環境にもよりますが数分から数十分程度)
79
80[self-build パッケージについて]
81ソフトウェアによってはバイナリパッケージの配布が特許や法律に
82違反する可能性があるものがあります。その為、このような問題が
83懸念されるソフトウェアについてはバイナリパッケージを直接配布
84せずに、ユーザの環境でバイナリを作成する self-build パッケー
85ジという方法を採っています。
86
87作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
88アのライセンス、および利用する国の各種法令に従ってください。
89また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
90センスの購入などが必要となる場合がありますので、利用する目的
91や形態に応じて各自で判断し適切な対応を取ってください。
92
93
94%prep
95[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
96
97%install
98%{__rm} -rf ${RPM_BUILD_ROOT}
99%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
100%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
101
102%clean
103%{__rm} -rf ${RPM_BUILD_ROOT}
104
105%posttrans
106/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 40000
107/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
108                                 %{pkgname}-devel-%{version}-%{release}
109
110%files
111%defattr(-,root,root)
112%{_datadir}/%{name}
113
114%changelog
115* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-4
116- renamed %%{Source0} to faad2-vl.spec
117
118* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-3
119- applied a progress bar to show approximately building time
120
121* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-2
122- change release to sync with faad2.spec
123
124* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-1
125- new upstream release
126- check version between original spec and self-build spec in %%prep
127- added Obsoletes: faad2 < 2.7, faad2-devel < 2.7
128  - changed so name to libfaad.so.2
129
130* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.6.1-3
131- added BuildArch: noarch
132- avoided to execute self-build-rpm.sh on RPM transaction
133  - moved %%post actions to %%posttrans
134
135* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.6.1-2
136- initial bulid for self-build
Note: See TracBrowser for help on using the repository browser.