source: projects/specs/trunk/nonfree/self-build-faad2/faad2-vl.spec @ 615

Revision 615, 4.3 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define xmmsinputdir %{_libdir}/xmms/Input
2#%define date   20040923
3
4Summary: Library and frontend for decoding MPEG2/4 AAC
5Summary(ja): MPEG2/4 AAC のデコード用ライブラリおよびフロントエンド
6Name: faad2
7Version: 2.7
8Release: 4%{?_dist_release}
9License: GPLv2+
10Group: Applications/Multimedia
11URL: http://www.audiocoding.com/
12Source: %{name}-%{version}.tar.gz
13#Source: faad2-%{date}.tar.bz2
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: autoconf, automake, libtool
16BuildRequires: gcc-c++, zlib-devel, sysfsutils-devel
17BuildRequires: id3lib-devel, gtk+-devel
18%{?_with_xmms:BuildRequires: xmms-devel}
19
20%description
21FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder, completely
22written from scratch.
23
24%if %{?_with_xmms:1}%{!?_with_xmms:0}
25%package -n xmms-aac
26Summary: X MultiMedia System input plugin to play AAC files
27Group: Applications/Multimedia
28Requires: %{name} = %{version}, xmms, id3lib
29Provides: xmms-%{name} = %{version}-%{release}
30
31%description -n xmms-aac
32This xmms plugin reads AAC files with and without ID3 tags (version 2.x).
33AAC files are MPEG2 or MPEG4 files that can be found in MPEG4 audio files
34(.mp4). MPEG4 files with AAC inside can be read by RealPlayer or Quicktime.
35%endif
36
37
38%package devel
39Summary: Development libraries of the FAAD 2 AAC decoder
40Summary(ja): FAAD 2 AAC デコーダの開発用ライブラリ
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43
44%description devel
45FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder, completely
46written from scratch.
47
48This package contains development files and documentation for libfaad.
49
50
51%prep
52%setup -q
53
54### Required to make automake < 1.7 work
55%{__perl} -pi -e 's|dnl AC_PROG_CXX|AC_PROG_CXX|' configure.in
56
57%build
58# This is what the README.linux file recommends
59autoreconf -vif
60%configure \
61    --disable-static \
62    %{?_with_xmms:--with-xmms} \
63    --with-mpeg4ip \
64    --without-drm
65#    --with--mp4v2 \
66%{__make} %{?_smp_mflags}
67
68
69%install
70%{__rm} -rf %{buildroot}
71%{__make} install DESTDIR=%{buildroot}
72
73# Remove this wrong include
74#perl -pi -e 's|#include <systems.h>||g' %{buildroot}%{_includedir}/mpeg4ip.h
75
76## remove unuse files
77rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
78
79
80%clean
81%{__rm} -rf %{buildroot}
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87
88%files
89%defattr(-, root, root, 0755)
90%doc AUTHORS COPYING ChangeLog NEWS README TODO
91%{_bindir}/*
92%{_libdir}/*.so.*
93
94%if %{?_with_xmms:1}%{!?_with_xmms:0}
95%files -n xmms-aac
96%defattr(-, root, root, 0755)
97%doc plugins/xmms/AUTHORS plugins/xmms/NEWS
98%doc plugins/xmms/README plugins/xmms/TODO
99#%exclude %{xmmsinputdir}/*.a
100%exclude %{xmmsinputdir}/*.la
101%{xmmsinputdir}/*.so
102%endif
103
104%files devel
105%defattr(-, root, root, 0755)
106%{_includedir}/*
107#%{_libdir}/*.a
108#%{_libdir}/*.la
109%{_libdir}/*.so
110#exclude %{_libdir}/*.la
111
112
113%changelog
114* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-4
115- change release to sync with self-build-faad2
116
117* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-3
118- change release to sync with self-build-faad2
119
120* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-2
121- changed to --without-drm in configure options
122
123* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-1
124- new upstream release
125
126* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.6.1-3
127- change release to sync with self-build-faad2
128
129* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.6.1-2
130- applied faad2-cve-2008-4201.patch
131- added %%configure options: --disable-static
132- using %{?_with_xmms}
133
134* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1vl5
135- applied new versioning policy, spec in utf-8
136- removed *.la
137
138* Sun Dec 30 2007 Satoshi MACHINO <machino@vinelinux.org> 2.6.1-0vl1
139- new upstream release
140- dropped patch0
141
142* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5-1vl1
143- new upstream release based on DAG packages
144  * Fri Dec 15 2006 Matthias Saou <http://freshrpms.net/> 2.5-1 - 5002+/thias
145  - Update to 2.5.
146  - Completely remove xmms/bmp plugin, it's a real mess anyway. Use audacious.
147  - Rip out libmp4v2 too, it's best as a separate package.
148  - Add libsysfs-devel build requirement, as it seems configure checks for it.
149- added Japanese summary
150
151* Wed Nov 10 2004 Satoshi MACHINO <machino@vinelinux.org> 2.0-0.%{date}vl1
152- Built for VineLinux
Note: See TracBrowser for help on using the repository browser.