source: projects/specs/trunk/nonfree/self-build-faac/faac-vl.spec @ 5085

Revision 5085, 5.1 KB checked in by munepi, 13 years ago (diff)

libdvdnav, libmp4v2: changed to plus category; updated libdvdnav, libdvdread: new upstream release

Line 
1%define name faac
2%define version 1.28
3%define release 8%{?_dist_release}
4
5%define enable_libmp4v2_external 1
6
7Summary: Reference encoder and encoding library for MPEG2/4 AAC
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source: http://prdownloads.sourceforge.net/faac/faac-%{version}.tar.bz2
12Patch0: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
13## this patch is based on http://launchpadlibrarian.net/33120980/mp4v2-strcasestr.diff
14Patch1: mp4v2-strcasestr-vine.diff
15License: LGPLv2+
16Group: Applications/Multimedia
17URL: http://www.audiocoding.com/
18
19BuildRequires: nkf
20BuildRequires: autoconf, automake, libtool, gcc-c++
21%if %{enable_libmp4v2_external}
22BuildRequires: libmp4v2-devel
23%endif
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25
26%description
27FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
28COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
29multichannel and gapless encoding.
30
31%package devel
32Summary: Development libraries of the FAAC AAC encoder
33Group: Development/Libraries
34Requires: %{name} = %{version}
35
36%description devel
37FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
38COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
39multichannel and gapless encoding.
40
41This package contains development files and documentation for libfaac.
42
43
44%if !%{enable_libmp4v2_external}
45%package -n libmp4v2
46Summary:        Library for working with files using the mp4 container format
47Group:          System Environment/Libraries
48
49%description -n libmp4v2
50The libmp4v2 library provides an abstraction layer for working with files
51using the mp4 container format. This library is developed by mpeg4ip project
52and is an exact copy of the library distributed in the mpeg4ip package.
53
54This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
55
56%package -n libmp4v2-devel
57Summary:        Development files for the mp4v2 library
58Group:          Development/Libraries
59Requires:       libmp4v2 = %{version}-%{release}
60
61%description -n libmp4v2-devel
62The libmp4v2 library provides an abstraction layer for working with files
63using the mp4 container format. This library is developed by mpeg4ip project
64and is an exact copy of the library distributed in the mpeg4ip package.
65
66This package contains development files for libmp4v2.
67
68This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
69%endif
70
71
72%prep
73%setup -q
74#find . -type f -print|xargs nkf --unix --overwrite
75%if %{enable_libmp4v2_external}
76%patch0 -p1 -b .mp4v2
77%patch1 -p1 -b .mp4v2
78#touch -r configure.in.mp4v2 configure.in
79%endif
80
81# # avoid to append the string "2005-02-02" to the tag Requires:
82# chmod 644 ChangeLog
83
84# # modify configure.in to escape error
85# %__mv configure.in configure.in.org
86# %__sed -e 's/^CFLAGS=.*$/CFLAGS="-O2 -Wall"/' configure.in.org > configure.in
87
88
89%build
90sh bootstrap
91%configure \
92    --disable-static \
93%if !%{enable_libmp4v2_external}
94    --with-mp4v2
95%endif
96   
97%{__make} %{?_smp_mflags}
98
99
100%install
101%{__rm} -rf %{buildroot}
102%{__make} install DESTDIR=%{buildroot}
103
104
105%clean
106%{__rm} -rf %{buildroot}
107
108
109%post
110/sbin/ldconfig 2>/dev/null
111
112%postun
113/sbin/ldconfig 2>/dev/null
114
115
116%files
117%defattr(-,root,root,-)
118%doc AUTHORS COPYING ChangeLog NEWS README TODO docs/*
119%{_bindir}/*
120%{_libdir}/*.so.*
121%{_mandir}/man1/%{name}*
122
123%files devel
124%defattr(-,root,root,-)
125%exclude %{_libdir}/*.la
126%{_libdir}/*.so
127%{_includedir}/*.h
128
129%if !%{enable_libmp4v2_external}
130%files -n libmp4v2
131%defattr(-,root,root,-)
132%{_libdir}/libmp4v2.so.*
133
134%files -n libmp4v2-devel
135%defattr(-,root,root,-)
136%{_libdir}/libmp4v2.so
137%{_libdir}/libmp4v2.a
138%endif
139
140
141%changelog
142* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-8
143- s/self-build-libmp4v2/libmp4v2/
144
145* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
146- change release to sync with self-build-faac
147
148* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
149- applied mp4v2-strcasestr.diff from lauchpad
150  - fixed wrong declaration of strcasestr() in mpeg4ip.h
151
152* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
153- rebuilt with mp4v2 v1.9.1
154  - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
155
156* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
157- change release to sync with self-build-faac
158
159* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
160- added BuildRequires: nkf
161
162* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
163- change release to sync with self-build-faac
164
165* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
166- new upstream release
167
168* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
169- fixed Summary: , %%description
170  - removed internal mp4v2
171
172* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
173- new upstream release
174- added --disable-static in %%configure
175
176* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
177- spec in utf8
178- remove *.la
179
180* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
181- apply new versioning policy
182
183* Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
184- initial build
185
186### end of file
Note: See TracBrowser for help on using the repository browser.