source: projects/specs/trunk/nonfree/self-build-faac/faac-vl.spec @ 615

Revision 615, 5.2 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define name faac
2%define version 1.28
3%define release 7%{?_dist_release}
4
5%define enable_libmp4v2_external 1
6
7Summary: Reference encoder and encoding library for MPEG2/4 AAC
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source: http://prdownloads.sourceforge.net/faac/faac-%{version}.tar.bz2
12Patch0: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
13## this patch is based on http://launchpadlibrarian.net/33120980/mp4v2-strcasestr.diff
14Patch1: mp4v2-strcasestr-vine.diff
15License: LGPLv2+
16Group: Applications/Multimedia
17URL: http://www.audiocoding.com/
18
19BuildRequires: nkf
20BuildRequires: autoconf, automake, libtool, gcc-c++
21%if %{enable_libmp4v2_external}
22# *-devel pacages provided by other self-build-* should only be listed
23# in self-build-%{name}.spec as PreReq.
24# BuildRequires: libmp4v2-devel
25%endif
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27
28%description
29FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
30COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
31multichannel and gapless encoding.
32
33%package devel
34Summary: Development libraries of the FAAC AAC encoder
35Group: Development/Libraries
36Requires: %{name} = %{version}
37
38%description devel
39FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
40COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
41multichannel and gapless encoding.
42
43This package contains development files and documentation for libfaac.
44
45
46%if !%{enable_libmp4v2_external}
47%package -n libmp4v2
48Summary:        Library for working with files using the mp4 container format
49Group:          System Environment/Libraries
50
51%description -n libmp4v2
52The libmp4v2 library provides an abstraction layer for working with files
53using the mp4 container format. This library is developed by mpeg4ip project
54and is an exact copy of the library distributed in the mpeg4ip package.
55
56This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
57
58%package -n libmp4v2-devel
59Summary:        Development files for the mp4v2 library
60Group:          Development/Libraries
61Requires:       libmp4v2 = %{version}-%{release}
62
63%description -n libmp4v2-devel
64The libmp4v2 library provides an abstraction layer for working with files
65using the mp4 container format. This library is developed by mpeg4ip project
66and is an exact copy of the library distributed in the mpeg4ip package.
67
68This package contains development files for libmp4v2.
69
70This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
71%endif
72
73
74%prep
75%setup -q
76#find . -type f -print|xargs nkf --unix --overwrite
77%if %{enable_libmp4v2_external}
78%patch0 -p1 -b .mp4v2
79%patch1 -p1 -b .mp4v2
80#touch -r configure.in.mp4v2 configure.in
81%endif
82
83# # avoid to append the string "2005-02-02" to the tag Requires:
84# chmod 644 ChangeLog
85
86# # modify configure.in to escape error
87# %__mv configure.in configure.in.org
88# %__sed -e 's/^CFLAGS=.*$/CFLAGS="-O2 -Wall"/' configure.in.org > configure.in
89
90
91%build
92sh bootstrap
93%configure \
94    --disable-static \
95%if !%{enable_libmp4v2_external}
96    --with-mp4v2
97%endif
98   
99%{__make} %{?_smp_mflags}
100
101
102%install
103%{__rm} -rf %{buildroot}
104%{__make} install DESTDIR=%{buildroot}
105
106
107%clean
108%{__rm} -rf %{buildroot}
109
110
111%post
112/sbin/ldconfig 2>/dev/null
113
114%postun
115/sbin/ldconfig 2>/dev/null
116
117
118%files
119%defattr(-,root,root,-)
120%doc AUTHORS COPYING ChangeLog NEWS README TODO docs/*
121%{_bindir}/*
122%{_libdir}/*.so.*
123%{_mandir}/man1/%{name}*
124
125%files devel
126%defattr(-,root,root,-)
127%exclude %{_libdir}/*.la
128%{_libdir}/*.so
129%{_includedir}/*.h
130
131%if !%{enable_libmp4v2_external}
132%files -n libmp4v2
133%defattr(-,root,root,-)
134%{_libdir}/libmp4v2.so.*
135
136%files -n libmp4v2-devel
137%defattr(-,root,root,-)
138%{_libdir}/libmp4v2.so
139%{_libdir}/libmp4v2.a
140%endif
141
142
143%changelog
144* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
145- change release to sync with self-build-faac
146
147* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
148- applied mp4v2-strcasestr.diff from lauchpad
149  - fixed wrong declaration of strcasestr() in mpeg4ip.h
150
151* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
152- rebuilt with mp4v2 v1.9.1
153  - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
154
155* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
156- change release to sync with self-build-faac
157
158* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
159- added BuildRequires: nkf
160
161* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
162- change release to sync with self-build-faac
163
164* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
165- new upstream release
166
167* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
168- fixed Summary: , %%description
169  - removed internal mp4v2
170
171* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
172- new upstream release
173- added --disable-static in %%configure
174
175* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
176- spec in utf8
177- remove *.la
178
179* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
180- apply new versioning policy
181
182* Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
183- initial build
184
185### end of file
Note: See TracBrowser for help on using the repository browser.