source: projects/specs/trunk/nonfree/self-build-faac/faac-vl.spec @ 9440

Revision 9440, 5.9 KB checked in by inagaki, 9 years ago (diff)

2015-03-19 Ryoichi INAGAKI <ryo1@…>

  • self-build-faac: added patch
  • self-build-gstreamer1-plugins-bad: changed Group


Line 
1%define name faac
2%define version 1.28
3%define release 9%{?_dist_release}
4
5%define enable_libmp4v2_external 1
6
7Summary: Reference encoder and encoding library for MPEG2/4 AAC
8Summary(ja): MPEG2/4 AAC 用のリファレンスエンコーダ及びエンコードライブラリ
9Name: %{name}
10Version: %{version}
11Release: %{release}
12Source: http://prdownloads.sourceforge.net/faac/faac-%{version}.tar.bz2
13Patch0: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
14## this patch is based on http://launchpadlibrarian.net/33120980/mp4v2-strcasestr.diff
15Patch1: mp4v2-strcasestr-vine.diff
16## this patch is based on http://git.frugalware.org/gitweb/gitweb.cgi?p=frugalware-current.git;a=commitdiff;h=64908ea587e0ad04fb69e452446f6e13d2c664f3
17Patch2: mp4v2-2.0.0.patch
18
19License: LGPLv2+
20Group: Applications/Multimedia
21URL: http://www.audiocoding.com/
22
23BuildRequires: nkf
24BuildRequires: autoconf, automake, libtool, gcc-c++
25%if %{enable_libmp4v2_external}
26BuildRequires: libmp4v2-devel
27%endif
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29
30%description
31FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
32COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
33multichannel and gapless encoding.
34
35%description -l ja
36FAAC は AAC オーディオエンコーダーです.現在 MPEG-4 LTP, Main/Low Complexity object types, Main/LOW MPEG-2 object types をサポートしています.またマルチチャンネルやギャップレスエンコーディングもサポートしています.
37
38%package devel
39Summary: Development libraries of the FAAC AAC encoder
40Summary(ja): FAAC AAC エンコーダの開発用ライブラリ
41Group: Development/Libraries
42Requires: %{name} = %{version}
43
44%description devel
45FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
46COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
47multichannel and gapless encoding.
48
49This package contains development files and documentation for libfaac.
50
51
52%if !%{enable_libmp4v2_external}
53%package -n libmp4v2
54Summary:        Library for working with files using the mp4 container format
55Group:          System Environment/Libraries
56
57%description -n libmp4v2
58The libmp4v2 library provides an abstraction layer for working with files
59using the mp4 container format. This library is developed by mpeg4ip project
60and is an exact copy of the library distributed in the mpeg4ip package.
61
62This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
63
64%package -n libmp4v2-devel
65Summary:        Development files for the mp4v2 library
66Group:          Development/Libraries
67Requires:       libmp4v2 = %{version}-%{release}
68
69%description -n libmp4v2-devel
70The libmp4v2 library provides an abstraction layer for working with files
71using the mp4 container format. This library is developed by mpeg4ip project
72and is an exact copy of the library distributed in the mpeg4ip package.
73
74This package contains development files for libmp4v2.
75
76This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
77%endif
78
79
80%prep
81%setup -q
82#find . -type f -print|xargs nkf --unix --overwrite
83%if %{enable_libmp4v2_external}
84%patch0 -p1 -b .mp4v2
85%patch1 -p1 -b .strcasestr
86%patch2 -p0 -b .mp4v2-2.0.0
87#touch -r configure.in.mp4v2 configure.in
88%endif
89
90# # avoid to append the string "2005-02-02" to the tag Requires:
91# chmod 644 ChangeLog
92
93# # modify configure.in to escape error
94# %__mv configure.in configure.in.org
95# %__sed -e 's/^CFLAGS=.*$/CFLAGS="-O2 -Wall"/' configure.in.org > configure.in
96
97
98%build
99sh bootstrap
100%configure \
101    --disable-static \
102%if !%{enable_libmp4v2_external}
103    --with-mp4v2
104%endif
105   
106%{__make} %{?_smp_mflags}
107
108
109%install
110%{__rm} -rf %{buildroot}
111%{__make} install DESTDIR=%{buildroot}
112
113
114%clean
115%{__rm} -rf %{buildroot}
116
117
118%post
119/sbin/ldconfig 2>/dev/null
120
121%postun
122/sbin/ldconfig 2>/dev/null
123
124
125%files
126%defattr(-,root,root,-)
127%doc AUTHORS COPYING ChangeLog NEWS README TODO docs/*
128%{_bindir}/*
129%{_libdir}/*.so.*
130%{_mandir}/man1/%{name}*
131
132%files devel
133%defattr(-,root,root,-)
134%exclude %{_libdir}/*.la
135%{_libdir}/*.so
136%{_includedir}/*.h
137
138%if !%{enable_libmp4v2_external}
139%files -n libmp4v2
140%defattr(-,root,root,-)
141%{_libdir}/libmp4v2.so.*
142
143%files -n libmp4v2-devel
144%defattr(-,root,root,-)
145%{_libdir}/libmp4v2.so
146%{_libdir}/libmp4v2.a
147%endif
148
149
150%changelog
151* Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.28-9
152- added Patch2 for building with libmp4v2 2.0.0
153
154* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-8
155- s/self-build-libmp4v2/libmp4v2/
156
157* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
158- change release to sync with self-build-faac
159
160* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
161- applied mp4v2-strcasestr.diff from lauchpad
162  - fixed wrong declaration of strcasestr() in mpeg4ip.h
163
164* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
165- rebuilt with mp4v2 v1.9.1
166  - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
167
168* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
169- change release to sync with self-build-faac
170
171* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
172- added BuildRequires: nkf
173
174* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
175- change release to sync with self-build-faac
176
177* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
178- new upstream release
179
180* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
181- fixed Summary: , %%description
182  - removed internal mp4v2
183
184* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
185- new upstream release
186- added --disable-static in %%configure
187
188* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
189- spec in utf8
190- remove *.la
191
192* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
193- apply new versioning policy
194
195* Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
196- initial build
197
198### end of file
Note: See TracBrowser for help on using the repository browser.