source: projects/specs/trunk/nonfree/self-build-chromium-ffmpeg/self-build-chromium-ffmpeg-vl.spec @ 5627

Revision 5627, 4.1 KB checked in by munepi, 12 years ago (diff)

added self-build-chromium-ffmpeg

Line 
1%define pkgname chromium-ffmpeg
2%define name    self-build-%{pkgname}
3%define version 17.0.963.54
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://gsdview.appspot.com/chromium-browser-official/chromium-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        BSD
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20# (build)requies of target package.
21Requires:       chromium
22Requires(post):         zlib-devel
23
24BuildArch:      noarch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27Packager:       munepi
28
29%description
30FFMPEG library built from the chromium sources.
31
32If you install this package, it automaticaly downloads source
33code, compile it, and create rpm packages of
34%{pkgname}-%{version}.
35And the created rpm packages are automatically installed
36if installation is executed by apt-get command or synaptic
37package manager.
38
39
40[Note]
41This package requires many other packages to compile
42targetsoftware. So it consume more disk space than usual.
43Also installation takes logner time because of compilation.
44(This will take a few minutes to quarter or half of an hour,
45depends on building environment)
46
47[About self-build package]
48For some kind of software, distributing of binary package
49may viorate the patent or law. Therefore we chose self-build
50packge, create binary package on your machine, for such kind
51of softwares instead of distributing binary package.
52
53Please obey the national law when you use the created binary
54packages. And if you want to use the softwares using patented
55thechnology, it may be required to get a permission, make an
56agreement or purchas a license. Please consider it with your
57purpose or way of use and take appropriate action.
58
59%description -l ja
60chromium のソースから FFMPEG ライブラリをビルドします。
61
62このパッケージをインストールすると、自動的にソースコードをダ
63ウンロードしてコンパイルし、%{pkgname}-%{version}
64の rpm パッケージを作成します。
65また apt-get コマンドや synaptic パッケージマネージャから実行
66した場合は、作成された rpm パッケージのインストールも自動的に
67行います。
68
69
70[注意]
71コンパイルに必要な多くの関連パッケージを要求するので通常より
72ディスクの領域を多く消費します。
73またインストール時にコンパイルを行うため、通常より時間がかか
74る場合があります。(環境にもよりますが数分から数十分程度)
75
76[self-build パッケージについて]
77ソフトウェアによってはバイナリパッケージの配布が特許や法律に
78違反する可能性があるものがあります。その為、このような問題が
79懸念されるソフトウェアについてはバイナリパッケージを直接配布
80せずに、ユーザの環境でバイナリを作成する self-build パッケー
81ジという方法を採っています。
82
83作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
84アのライセンス、および利用する国の各種法令に従ってください。
85また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
86センスの購入などが必要となる場合がありますので、利用する目的
87や形態に応じて各自で判断し適切な対応を取ってください。
88
89
90%prep
91[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
92
93%install
94%{__rm} -rf ${RPM_BUILD_ROOT}
95%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
96%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
97
98
99%clean
100%{__rm} -rf ${RPM_BUILD_ROOT}
101
102%posttrans
103/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 358000
104
105%files
106%defattr(-,root,root)
107%{_datadir}/%{name}/*
108
109%changelog
110* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
111- initial build
Note: See TracBrowser for help on using the repository browser.