source: projects/specs/trunk/nonfree/self-build-broadcom-wl/self-build-broadcom-wl.spec @ 2224

Revision 2224, 5.0 KB checked in by daisuke, 13 years ago (diff)

self-build-broadcom-wl: remove unneeded patch (Source2)

Line 
1%define pkgname broadcom-wl
2%define name    self-build-%{pkgname}
3
4%define oname   hybrid-portsrc
5%define over    %(echo %{version} | tr . _)
6
7%ifarch %{ix86}
8%define source0path http://www.broadcom.com/docs/linux_sta/%{oname}_x86-32_v%{version}.tar.gz
9%endif
10%ifarch x86_64
11%define source0path http://www.broadcom.com/docs/linux_sta/%{oname}_x86-64_v%{version}.tar.gz
12%endif
13
14
15Summary:        Package to automatically build %{pkgname} rpm package
16Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
17Name:           %{name}
18Version:        5.60.246.6
19Release:        2%{?_dist_release}
20Source0:        %{pkgname}.spec
21Source1:        blacklist-broadcom.conf
22
23License:        Freeware and GPLv2 with exception
24Group:          Restricted Software
25
26Requires(pre):  self-build-setup >= 0.7-1
27
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29ExclusiveArch:  %{ix86} x86_64
30
31
32%description
33Proprietary hybrid driver for Broadcom wireless adapters.
34
35If you install this package, it automaticaly downloads source
36code ,compile it, and create rpm packages of %{pkgname}-%{version}.
37And the created rpm packages are automatically installed
38if installation is executed by apt-get command or synaptic
39package manager.
40
41[Note]
42This package requires many other packages to compile
43targetsoftware. So it consume more disk space than usual.
44Also installation takes logner time because of compilation.
45(This will take a few minutes to quarter or half of an hour,
46depends on building environment)
47
48[About self-build package]
49For some kind of software, distributing of binary package
50may viorate the patent or law. Therefore we chose self-build
51packge, create binary package on your machine, for such kind
52of softwares instead of distributing binary package.
53
54Please obey the national law when you use the created binary
55packages. And if you want to use the softwares using patented
56thechnology, it may be required to get a permission, make an
57agreement or purchas a license. Please consider it with your
58purpose or way of use and take appropriate action.
59
60%description -l ja
61Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
62
63このパッケージをインストールすると、自動的にソースコードを
64ダウンロードしてコンパイルし、%{pkgname}-%{version}
65の rpm パッケージを作成します。
66また apt-get コマンドや synaptic パッケージマネージャから実行
67した場合は、作成された rpm パッケージのインストールも自動的に
68行います。
69
70[注意]
71コンパイルに必要な多くの関連パッケージを要求するので通常より
72ディスクの領域を多く消費します。
73またインストール時にコンパイルを行うため、通常より時間がかか
74る場合があります。(環境にもよりますが数分から数十分程度)
75
76[self-build パッケージについて]
77ソフトウェアによってはバイナリパッケージの配布が特許や法律に
78違反する可能性があるものがあります。その為、このような問題が
79懸念されるソフトウェアについてはバイナリパッケージを直接配布
80せずに、ユーザの環境でバイナリを作成する self-build パッケー
81ジという方法を採っています。
82
83作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
84アのライセンス、および利用する国の各種法令に従ってください。
85また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
86センスの購入などが必要となる場合がありますので、利用する目的
87や形態に応じて各自で判断し適切な対応を取ってください。
88
89
90%install
91rm -rf %{buildroot}
92install -d %{buildroot}%{_datadir}/%{name}
93install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
94sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
95        %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}.spec
96
97
98%clean
99rm -rf %{buildroot}
100
101
102%posttrans
103/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}.spec "%{source0path}"
104/usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
105
106
107%files
108%defattr(-,root,root)
109%{_datadir}/%{name}/*
110
111
112%changelog
113* Sun Nov 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.60.246.6-2
114- remove Source2
115
116* Sat Nov 20 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.60.246.6-1
117- new upstream release
118
119* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
120- add Source2 to fix build failure on kernel >= 2.6.35
121  (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
122
123* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
124- new upstream release
125
126* Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
127- new upstream release
128
129* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
130- fix to ensure Source0 has correct version/release numbers
131
132* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
133- add ExclusiveArch
134
135* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
136- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.