source: projects/specs/trunk/nonfree/self-build-broadcom-wl/self-build-broadcom-wl.spec @ 6100

Revision 6100, 5.5 KB checked in by tomop, 12 years ago (diff)

self-build-broadcom-wl-5.100.82.112-1

Line 
1%define pkgname broadcom-wl
2%define name    self-build-%{pkgname}
3
4%define oname   hybrid-portsrc
5%define over    %(echo %{version} | tr . _)
6
7%ifarch %{ix86}
8%define source0path http://www.broadcom.com/docs/linux_sta/%{oname}_x86_32-v%{over}.tar.gz
9%endif
10%ifarch x86_64
11%define source0path http://www.broadcom.com/docs/linux_sta/%{oname}_x86_64-v%{over}.tar.gz
12%endif
13
14
15Summary:        Package to automatically build %{pkgname} rpm package
16Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
17Name:           %{name}
18Version:        5.100.82.112
19Release:        1%{?_dist_release}
20Source0:        %{pkgname}.spec
21Source1:        blacklist-broadcom.conf
22Source2:        5_100_82_112.patch
23
24License:        Freeware and GPLv2 with exception
25Group:          Restricted Software
26
27Requires(pre):  self-build-setup >= 0.7-1
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30ExclusiveArch:  %{ix86} x86_64
31
32
33%description
34Proprietary hybrid driver for Broadcom wireless adapters.
35
36If you install this package, it automaticaly downloads source
37code ,compile it, and create rpm packages of %{pkgname}-%{version}.
38And the created rpm packages are automatically installed
39if installation is executed by apt-get command or synaptic
40package manager.
41
42[Note]
43This package requires many other packages to compile
44targetsoftware. So it consume more disk space than usual.
45Also installation takes logner time because of compilation.
46(This will take a few minutes to quarter or half of an hour,
47depends on building environment)
48
49[About self-build package]
50For some kind of software, distributing of binary package
51may viorate the patent or law. Therefore we chose self-build
52packge, create binary package on your machine, for such kind
53of softwares instead of distributing binary package.
54
55Please obey the national law when you use the created binary
56packages. And if you want to use the softwares using patented
57thechnology, it may be required to get a permission, make an
58agreement or purchas a license. Please consider it with your
59purpose or way of use and take appropriate action.
60
61%description -l ja
62Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
63
64このパッケージをインストールすると、自動的にソースコードを
65ダウンロードしてコンパイルし、%{pkgname}-%{version}
66の rpm パッケージを作成します。
67また apt-get コマンドや synaptic パッケージマネージャから実行
68した場合は、作成された rpm パッケージのインストールも自動的に
69行います。
70
71[注意]
72コンパイルに必要な多くの関連パッケージを要求するので通常より
73ディスクの領域を多く消費します。
74またインストール時にコンパイルを行うため、通常より時間がかか
75る場合があります。(環境にもよりますが数分から数十分程度)
76
77[self-build パッケージについて]
78ソフトウェアによってはバイナリパッケージの配布が特許や法律に
79違反する可能性があるものがあります。その為、このような問題が
80懸念されるソフトウェアについてはバイナリパッケージを直接配布
81せずに、ユーザの環境でバイナリを作成する self-build パッケー
82ジという方法を採っています。
83
84作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
85アのライセンス、および利用する国の各種法令に従ってください。
86また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
87センスの購入などが必要となる場合がありますので、利用する目的
88や形態に応じて各自で判断し適切な対応を取ってください。
89
90
91%install
92rm -rf %{buildroot}
93install -d %{buildroot}%{_datadir}/%{name}
94install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
95install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/%{name}
96sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
97        %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}.spec
98
99
100%clean
101rm -rf %{buildroot}
102
103
104%posttrans
105/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}.spec "%{source0path}"
106/usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
107
108
109%files
110%defattr(-,root,root)
111%{_datadir}/%{name}/*
112
113
114%changelog
115* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.100.82.112-1
116- new upstream release.
117- dropped an old patch.
118- added SOURCE2 to compile for kernel-3.2.x.
119
120* Tue Oct  4 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-3
121- update SOURCE1 (see: http://www.broadcom.com/docs/linux_sta/bcma.txt)
122
123* Sun Aug 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-2
124- add a patch to fix build failure on linux > 2.6.37
125
126* Sun Jan 01 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-1
127- new upstream release
128
129* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
130- add Source2 to fix build failure on kernel >= 2.6.35
131  (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
132
133* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
134- new upstream release
135
136* Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
137- new upstream release
138
139* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
140- fix to ensure Source0 has correct version/release numbers
141
142* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
143- add ExclusiveArch
144
145* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
146- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.