source: projects/specs/trunk/nonfree/self-build-avidemux/self-build-avidemux-vl.spec @ 5297

Revision 5297, 10.5 KB checked in by munepi, 10 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1%define pkgname avidemux
2%define name    self-build-%{pkgname}
3%define version 2.5.5
4%define release 1%{?_dist_release}
5
6%define source0path     %{pkgname}/%{pkgname}_%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13
14Obsoletes:      avidemux-cli avidemux-gui avidemux-qt
15Obsoletes:      avidemux-devel <= 2.5.5
16
17Source0:        %{pkgname}-vl.spec
18Source1:        %{pkgname}-gtk.desktop
19Source2:        %{pkgname}-qt.desktop
20
21# Patch0 obtained from avidemux-2.5.0-patches-1.tar.bz2:
22# http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/distfiles/avidemux-2.5.0-patches-1.tar.bz2
23Source100:         2.5.0-coreImage-parallel-build.patch
24Source101:         avidemux-2.5-pulseaudio-default.patch
25Source102:         avidemux-2.4-qt4.patch
26# Prevents avidemux from creating the symlinks for .so files, which we do below
27Source103:         avidemux-2.5.3-tmplinktarget.patch
28# libADM_xvidRateCtl.so and libADM_vidEnc_pluginOptions.so are supposed to be
29# build statically according to upstream... Let's get them installed instead
30Source104:         avidemux-2.5.3-mpeg2enc.patch
31Source105:         avidemux-2.5.3-pluginlibs.patch
32# Source108 obtained from http://lists.rpmfusion.org/pipermail/rpmfusion-developers/2010-October/008645.html
33#Source106:         avidemux_2.5.4-ffmpeg-aac.patch
34Source106:         avidemux_2.5.5-ffmpeg_aac.patch
35Source107:         avidemux-2.5.5-gcc46_tmp_fix.patch
36# Source10 needed for version of x264 in F15/rawhide.
37# Use system libraries
38Source108:         avidemux-2.5.4-libass.patch
39Source109:         avidemux-2.5.4-liba52.patch
40Source110:        avidemux-2.5.4-libmad.patch
41Source111:        avidemux-2.5.4-libtwolame.patch
42Source112:        avidemux-2.5.5_fix_lav_audio_encoder.patch
43# Source10 for ABI change in x264 115.
44Source113:        avidemux-2.5.5-x264_i_to_b_open_gop.patch
45# Uses a header file not found in the standard package
46#Source116:        avidemux-2.5.4-mpeg2enc.patch
47
48## Vine customization patches
49Source150:         avidemux-2.5.2-no-qt4-ui.patch
50
51License:        GPLv2+
52Group:          Restricted Software
53
54Requires(post):         self-build-setup >= 0.9.9
55
56Requires(post): cmake
57Requires(post):  gettext
58Requires(post):  nasm >= 0.98.38
59Requires(post):  libxml2-devel >= 2.6.8
60Requires(post):  fontconfig-devel
61Requires(post):  freetype2-devel
62Requires(post):  js-devel
63Requires(post):  libXv-devel
64Requires(post):  libXmu-devel
65Requires(post): libsamplerate-devel
66Requires(post): jack-audio-connection-kit-devel
67Requires(post):  alsa-lib-devel >= 1.0.3
68Requires(post):  SDL-devel >= 1.2.7
69Requires(post):  libogg-devel >= 1.1
70Requires(post):  libvorbis-devel >= 1.0.1
71Requires(post):  self-build-faad2 >= 2.0
72Requires(post):  self-build-libmad >= 0.15.1
73Requires(post):  self-build-a52dec >= 0.7.4
74Requires(post):  self-build-faac >= 1.24
75Requires(post):  self-build-lame >= 3.96.1
76Requires(post):  self-build-libdca
77Requires(post):  self-build-xvidcore >= 1.0.2
78Requires(post):  self-build-x264 >= 0.0.0-9.20090522
79Requires(post):  self-build-ffmpeg
80Requires(post):  desktop-file-utils
81Requires(post):  gtk2-devel >= 2.8.0
82Requires(post):  cairo-devel
83
84%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
85Requires(post):  qt4-devel
86Requires(post):  qt4-designer
87%endif
88
89
90BuildArch:      noarch
91BuildRoot:      %{_tmppath}/%{name}-%{version}-root
92
93Packager:       munepi
94
95%description
96Avidemux is a free video editor designed for simple cutting, filtering and
97encoding tasks. It supports many file types, including AVI, DVD compatible
98MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated
99using projects, job queue and powerful scripting capabilities.
100
101[Note]
102This package requires many other packages to compile
103targetsoftware. So it consume more disk space than usual.
104Also installation takes logner time because of compilation.
105(This will take a few minutes to quarter or half of an hour,
106depends on building environment)
107
108[About self-build package]
109For some kind of software, distributing of binary package
110may viorate the patent or law. Therefore we chose self-build
111packge, create binary package on your machine, for such kind
112of softwares instead of distributing binary package.
113
114Please obey the national law when you use the created binary
115packages. And if you want to use the softwares using patented
116thechnology, it may be required to get a permission, make an
117agreement or purchas a license. Please consider it with your
118purpose or way of use and take appropriate action.
119
120%description -l ja
121Avidemux は簡単なカット,フィルターリング,エンコード作業のために
122デザインされたフリーな動画エディターです.
123種々のコーデックを使い,AVI, DVD 互換 MPEG, MP4, ASF を含む
124たくさんのファイル形式に対応しています.
125タスクは,プロジェクトやジョブキュー,強力なスクリプト処理により
126自動的に行われます.
127
128このパッケージをインストールすると、自動的にソースコードを
129ダウンロードしてコンパイルし、%{pkgname}-%{version}
130の rpm パッケージを作成します。
131また apt-get コマンドや synaptic パッケージマネージャから実行
132した場合は、作成された rpm パッケージのインストールも自動的に
133行います。
134
135[注意]
136コンパイルに必要な多くの関連パッケージを要求するので通常より
137ディスクの領域を多く消費します。
138またインストール時にコンパイルを行うため、通常より時間がかか
139る場合があります。(環境にもよりますが数分から数十分程度)
140
141[self-build パッケージについて]
142ソフトウェアによってはバイナリパッケージの配布が特許や法律に
143違反する可能性があるものがあります。その為、このような問題が
144懸念されるソフトウェアについてはバイナリパッケージを直接配布
145せずに、ユーザの環境でバイナリを作成する self-build パッケー
146ジという方法を採っています。
147
148作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
149アのライセンス、および利用する国の各種法令に従ってください。
150また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
151センスの購入などが必要となる場合がありますので、利用する目的
152や形態に応じて各自で判断し適切な対応を取ってください。
153
154%prep
155[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
156
157
158%install
159%{__rm} -rf ${RPM_BUILD_ROOT}
160%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
161%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
162%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
163%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
164%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
165%{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
166%{__install} -m 644 %{SOURCE102} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
167%{__install} -m 644 %{SOURCE103} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
168%{__install} -m 644 %{SOURCE104} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
169%{__install} -m 644 %{SOURCE105} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
170%{__install} -m 644 %{SOURCE106} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
171%{__install} -m 644 %{SOURCE107} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
172%{__install} -m 644 %{SOURCE108} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
173%{__install} -m 644 %{SOURCE109} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
174%{__install} -m 644 %{SOURCE110} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
175%{__install} -m 644 %{SOURCE111} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
176%{__install} -m 644 %{SOURCE112} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
177%{__install} -m 644 %{SOURCE113} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
178%{__install} -m 644 %{SOURCE150} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
179
180
181%clean
182%{__rm} -rf ${RPM_BUILD_ROOT}
183
184%posttrans
185/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
186    http://download{,2}.berlios.de/%{source0path} 3922000
187
188%files
189%defattr(-,root,root)
190%{_datadir}/%{name}
191
192%changelog
193* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.5-1
194- new upstream release
195- Obsoletes: avidemux-cli avidemux-gui avidemux-qt avidemux-devel <= 2.5.5
196
197* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-5
198- dropped Requires(post): esound-devel
199
200* Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
201- add %%{SOURCE107}
202
203* Sat Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-3
204- change release to sync with avidemux-vl.spec
205
206* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-2
207- renamed %%{Source0} to avidemux-vl.spec
208
209* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
210- new upstream release
211  - update patches accordingly
212  - added Obsoletes: %{pkgname}-qt < 2.5.0
213- applied a progress bar to show approximately building time
214
215* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2.4.4-2
216- applied avidemux-2.4.4-cmake.patch
217- check version between original spec and self-build spec in %%prep
218
219* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 2.4.4-1
220- new upstream release
221  - update patches accordingly
222  - build with x264 >= 0.0.0-9.20090522
223- dropped avidemux-2.4.3-ppc.patch, avidemux-x264.patch
224- added BuildArch: noarch
225- avoided to execute self-build-rpm.sh on RPM transaction
226  - moved %%post actions to %%posttrans
227
228* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 2.4.3-7
229- corrected release number in avidemux.spec
230- dropped ExclusiveArch:       
231
232* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.3-6
233- add ppc to ExclusiveArch
234
235* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-5
236- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
237- changed to PreReq:  self-build-libmad >= 0.15.1 from libmad-devel
238
239* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-4
240- fixed %%files section
241
242* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-3
243- added avidemux-x264.patch from Gentoo
244
245* Mon Dec 08 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-2
246- applied avidemux-2.4.3-alsa-device-default.patch
247
248* Mon Nov 24 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-1
249- initial build based on RPM Fusion of Fedora package
250  - changed to BuildRequires: gettext from gettext-devel
251  - added BuildRequires: qt4-designer for gtk subpackage
252  - dropped avidemux-2.4.3-qt4.patch
253
254### end of file
Note: See TracBrowser for help on using the repository browser.