source: projects/specs/trunk/n/ntp/ntp-vl.spec @ 521

Revision 521, 7.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _bindir %{_prefix}/sbin
2
3Summary: Synchronizes system time using the Network Time Protocol (NTP).
4Name: ntp
5Version: 4.2.4p7
6Release: 3%{?_dist_release}
7License: distributable
8Group: System Environment/Daemons
9URL: http://www.ntp.org/
10Source0: ftp://ftp.udel.edu/pub/ntp/ntp4/ntp-%{version}.tar.gz
11Source1: ntp.conf
12Source2: ntp.keys
13Source3: ntpd.init
14Source4: ntpd.sysconfig
15Source5: ntpd-NM-dispatch
16
17# Don't depend on perl modules
18Source999: filter-requires-ntp.sh
19
20#Patch0: ntp-4.0.99j-glibc22.patch
21#Patch1: ntp-4.1.2-vsnprintf.patch
22Patch3: ntp-4.0.99k23-usegethost.patch
23Patch4: ntp-4.2.0-config_crypto.patch
24Patch5: ntp-4.2.4p7-md5.patch
25
26# security
27# Patch100: ntp-4.2.4_CVE-2009-0159.patch
28
29PreReq: /sbin/chkconfig
30BuildRequires: openssl-devel, readline-devel
31BuildRequires: autoconf
32#Conflicts: xntp3
33Obsoletes: xntp3
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36# Working around perl dependency problem
37%define __find_requires %{SOURCE999}
38
39%description
40The Network Time Protocol (NTP) is used to synchronize a computer's
41time with another reference time source.  The ntp package contains
42utilities and daemons which will synchronize your computer's time to
43Coordinated Universal Time (UTC) via the NTP protocol and NTP servers.
44The ntp package includes ntpdate (a program for retrieving the date
45and time from remote machines via a network) and ntpd (a daemon which
46continuously adjusts system time).
47
48Install the ntp package if you need tools for keeping your system's
49time synchronized via the NTP protocol.
50#'
51
52%prep
53%setup -q
54
55#%patch1 -p1 -b .vsnprintf
56%patch3 -p1 -b .usegethost
57%ifarch alpha
58%patch4 -p1 -b .config_crypto
59%endif
60%patch5 -p1 -b .nomd5
61
62# security
63# %patch100 -p1 -b .CVE-2009-0159
64
65%build
66# autoconf
67autoreconf -vfi
68
69# XXX work around for anal ntp configure
70%define _target_platform        %{nil}
71#%configure
72CFLAGS="-g -DDEBUG" ./configure --prefix=/usr
73%undefine       _target_platform
74
75%__make %{?_smp_mflags}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%makeinstall
81
82{ cd $RPM_BUILD_ROOT
83
84  mkdir -p .%{_sysconfdir}/{ntp,rc.d/init.d,sysconfig}
85  mkdir -p .%{_sysconfdir}/NetworkManager/dispatcher.d
86  install -m644 $RPM_SOURCE_DIR/ntp.conf .%{_sysconfdir}/ntp.conf
87  touch .%{_sysconfdir}/ntp/drift
88  install -m600 $RPM_SOURCE_DIR/ntp.keys .%{_sysconfdir}/ntp/keys
89  touch .%{_sysconfdir}/ntp/step-tickers
90  install -m755 $RPM_SOURCE_DIR/ntpd.init .%{_sysconfdir}/rc.d/init.d/ntpd
91  install -m644 %{SOURCE4} .%{_sysconfdir}/sysconfig/ntpd
92  install -m755 %{SOURCE5} .%{_sysconfdir}/NetworkManager/dispatcher.d/06-ntpd
93
94  strip .%{_bindir}/* || :
95}
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post
101/sbin/chkconfig --add ntpd
102
103%preun
104if [ $1 = 0 ]; then
105    service ntpd stop > /dev/null 2>&1
106    /sbin/chkconfig --del ntpd
107fi
108
109%postun
110if [ "$1" -ge "1" ]; then
111# service ntpd condrestart > /dev/null 2>&1
112  service ntpd condrestart
113fi
114
115%files
116%defattr(-,root,root)
117%doc html/* NEWS TODO
118%{_bindir}/*
119%config                         %{_sysconfdir}/rc.d/init.d/ntpd
120%config(noreplace)              %{_sysconfdir}/ntp.conf
121%dir                            %{_sysconfdir}/ntp/
122%ghost %config(missingok)       %{_sysconfdir}/ntp/drift
123%config(noreplace)              %{_sysconfdir}/ntp/keys
124%ghost %config(missingok)       %{_sysconfdir}/ntp/step-tickers
125%config(noreplace)              %{_sysconfdir}/sysconfig/ntpd
126%{_sysconfdir}/NetworkManager/dispatcher.d/*
127%{_mandir}/man1/*
128
129%changelog
130* Fri Aug 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p7-3
131- add NetworkManager/dispatcher.d/06-ntpd for NM
132- fix changelog typo...
133
134* Wed May 20 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p7-2
135- turn on daemon restart message
136
137* Wed May 20 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p7-1
138- new upstream release with security fix (CVE-2009-0159,1252)
139- drop pacth100 (included in new release)
140- update patch5 to fit p7 release
141
142* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p6-2
143- add patch100 for fix CVE-2009-0159 (ntpq)
144- run autoreconf instead of autoconf
145
146* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.4p6-1
147- new upstream release with security fix (CVE-2009-0021)
148
149* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4p4-1
150- new upstream release
151
152* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4p3-0vl2
153- rebuilt
154
155* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4p3-0vl1
156- new upstream release
157- updated Patch5
158
159* Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.0-0vl7
160- rebuild for Vine Seed
161
162* Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.0-0vl6
163- add Patch5 to skip checking md5.h
164
165* Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.0-0vl5
166- rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
167
168* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.2.0-0vl4
169- rebuild with readline-5.1
170- add BuildRequires: openssl-devel, readline-devel
171
172* Fri Apr 09 2004 Tomoya TAKA <taka@vinelinux.org> 4.2.0-0vl3
173- rebuild with openssl-0.9.7d
174- add config_crypto.patch for alpha (Patch4)
175
176* Wed Mar  3 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 4.2.0-0vl2
177- ntp.conf (Source1): authenticate command has been disappeared.
178- ntpd.init (Source3): remove RedHat's firewall-related codes.
179- remove obsolete patches (Patch0, Patch1)
180
181* Mon Feb 16 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
182- update to 4.2.0
183- update ntpd.init (Source3): from Fedora ntp-4.2.0-5
184- add ntpd.sysconfig (Source4)
185- stop patching vsnprintf patch (Patch1)
186
187* Mon Sep  1 2003 IWAI, Masaharu <iwai@alib.jp> 4.1.2-0vl1
188- update to 4.1.2
189- update URL tag
190- update vsnprintf.patch (Patch1)
191
192* Tue May 06 2003 Tomoya TAKA <taka@vinelinux.org> 4.1.1-0vl2
193- rebuild with new toolchain
194
195* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 4.1.1-0vl1
196- update to 4.1.1
197
198* Tue Sep 04 2001 Jiro Yamada <jiro@fd.catv.ne.jp>
199- update to 4.1.0
200
201* Mon Apr 09 2001 akira yamada <akira@vinelinux.org>
202- new upstream version 4.0.99k23.
203
204* Thu Apr 05 2001 akira yamada <akira@vinelinux.org>
205- fixed buffer overrun (imported from debian).
206- imported from rawhide.
207
208* Mon Mar  5 2001 Preston Brown <pbrown@redhat.com>
209- allow comments in /etc/ntp/step-tickers file (#28786).
210- need patch0 (glibc patch) on ia64 too
211
212* Tue Feb 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
213- also set prog=ntpd in initscript
214
215* Tue Feb 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
216- use "$prog" instead of "$0" for the init script
217
218* Thu Feb  8 2001 Preston Brown <pbrown@redhat.com>
219- i18n-neutral .init script (#26525)
220
221* Tue Feb  6 2001 Preston Brown <pbrown@redhat.com>
222- use gethostbyname on addresses in /etc/ntp.conf for ntptime command (#26250)
223
224* Mon Feb  5 2001 Preston Brown <pbrown@redhat.com>
225- start earlier and stop later (#23530)
226
227* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
228- i18nize init script (#26078)
229
230* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
231- typo in ntp.conf (#23173).
232
233* Mon Dec 11 2000 Karsten Hopp <karsten@redhat.de>
234- rebuilt to fix permissions of /usr/share/doc/ntp-xxx
235
236* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
237- correct mis-spellings in ntpq.htm (#20007).
238
239* Thu Oct 19 2000 Jeff Johnson <jbj@redhat.com>
240- add %ghost /etc/ntp/drift (#15222).
241
242* Wed Oct 18 2000 Jeff Johnson <jbj@redhat.com>
243- comment out default values for keys, warn about starting with -A (#19316).
244- take out -A from ntpd startup as well.
245- update to 4.0.99k.
246
247* Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
248- use vsnprintf rather than vsprintf (#16676).
249
250* Mon Aug 14 2000 Jeff Johnson <jbj@redhat.com>
251- remove Conflicts: so that the installer is happy.
252
253* Tue Jul 25 2000 Jeff Johnson <jbj@redhat.com>
254- workaround glibc-2.1.90 lossage for now.
255
256* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
257- move initscript back
258
259* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
260- automatic rebuild
261
262* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
263- move and update init script, update post/preun/postun scripts
264
265* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
266- noreplace ntp.conf,keys files
267
268* Mon Jun 12 2000 Jeff Johnson <jbj@redhat.com>
269- Create 4.0.99j package.
270- FHS packaging.
Note: See TracBrowser for help on using the repository browser.