source: projects/specs/trunk/n/ntfsprogs/ntfsprogs-vl.spec @ 521

Revision 521, 5.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name    ntfsprogs
2%define ver     1.13.0
3%define rel     1%{?_dist_release}
4
5Summary: NTFS filesystem libraries and utilities
6Summary(ja): NTFS ファイルシステム用ライブラリおよびユーティリティ
7Name:      %{name}
8Version:   %{ver}
9Release:   %{rel}
10Source:    http://prdownloads.sf.net/linux-ntfs/ntfsprogs-%{ver}.tar.gz
11Buildroot: %{_tmppath}/%{name}-root
12License:   GPL
13Group:     System Environment/Base
14
15%description
16The Linux-NTFS project (http://www.linux-ntfs.org/) aims to bring full support
17for the NTFS filesystem to the Linux operating system.  The ntfsprogs package
18currently consists of a static library and utilities such as mkntfs, ntfscat,
19ntfsls, ntfsresize, and ntfsundelete (for a full list of included utilities
20see man 8 ntfsprogs after installation).
21
22%package gnomevfs
23Summary: NTFS GNOME virtual filesystem module
24Group: System Environment/Base
25Requires: ntfsprogs = %{ver}-%{rel}
26Requires: glib2 gnome-vfs2
27BuildRequires: glib2-devel gnome-vfs2-devel
28
29%description gnomevfs
30This package contains the NTFS GNOME virtual filesystem (VFS) module which
31allows GNOME VFS clients to seamlessly utilize the NTFS library (libntfs).
32
33#%package fuse
34#Summary: NTFS FUSE module (ntfsmount)
35#Group: System Environment/Base
36#Requires: ntfsprogs = %{ver}-%{rel}
37#Requires: fuse >= 2.3.0
38#
39#%description fuse
40#This package contains the ntfsmount utility which is an NTFS filesystem in
41#userspace (FUSE) module allowing users to mount an ntfs filesystem from
42#userspace and accessing it using the functionality provided by the NTFS
43#library (libntfs).
44
45
46%package devel
47Summary: files required to compile software that uses libntfs
48Group: Development/Libraries
49Requires: ntfsprogs = %{ver}-%{rel}
50
51%description devel
52This package includes the header files and libraries needed to link software
53with libntfs.
54
55
56%prep
57%setup
58
59%build
60if [ -n "$LINGUAS" ]; then unset LINGUAS; fi
61%configure --enable-gnome-vfs
62make
63
64
65%install
66rm -rf "$RPM_BUILD_ROOT"
67make DESTDIR="$RPM_BUILD_ROOT" install-strip
68
69## remove unuse files
70rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
71rm -rf $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
72
73
74%clean
75rm -rf "$RPM_BUILD_ROOT"
76
77
78%files
79%defattr(-,root,root)
80%doc AUTHORS COPYING CREDITS ChangeLog INSTALL NEWS README TODO.include TODO.libntfs TODO.ntfsprogs doc/CodingStyle doc/attribute_definitions doc/attributes.txt doc/compression.txt doc/tunable_settings doc/template.c doc/template.h doc/system_files.txt doc/system_security_descriptors.txt
81%{_bindir}/ntfs[^m][^o]*
82%{_sbindir}/*
83/sbin/mkfs.ntfs
84%{_mandir}/man8/mkntfs.8*
85%{_mandir}/man8/mkfs.ntfs.8*
86%{_mandir}/man8/ntfs[^m][^o]*.8*
87%{_libdir}/libntfs.*so*
88
89%files gnomevfs
90%defattr(-,root,root)
91%{_mandir}/man8/libntfs-gnomevfs.8*
92%{_libdir}/gnome-vfs-2.0/modules/libntfs-gnomevfs.*so*
93%config %{_sysconfdir}/gnome-vfs-2.0/modules/libntfs.conf
94
95%files devel
96%defattr(-,root,root)
97%{_includedir}/*
98%{_libdir}/libntfs.*a*
99%{_libdir}/gnome-vfs-2.0/modules/libntfs-gnomevfs.*a*
100
101%changelog
102* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.13.0-1vl5
103- applied new versioning policy, spec in utf-8
104- removed *.la
105
106* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.13.0-0vl1
107- added gnomevfs module
108- updated to 1.13.0
109  * Fri Oct 7 2005 Anton Altaparmakov <aia21@cantab.net>
110  - Fix the file distribution after new binaries have been added as they were
111    ending up in the wrong rpms.
112  * Mon Aug 15 2005 Szabolcs Szakacsits <szaka@sienet.hu>
113  - Add mkfs.ntfs.
114  * Wed Mar 10 2004 Anton Altaparmakov <aia21@cantab.net>
115  - Cleanup descriptions ready for 1.9.0 release.
116  * Mon Jan 19 2004 Anton Altaparmakov <aia21@cantab.net>
117  - Add %config to tell rpm that libntfs.conf is a config file.
118  * Thu Nov 6 2003 Anton Altaparmakov <aia21@cantab.net>
119  - merge libntfs-gnomevfs
120  * Fri Oct 19 2003 Richard Russon <ntfs@flatcap.org>
121  - added the new utility ntfscat
122  * Tue Sep 30 2003 Anton Altaparmakov <aia21@cantab.net>
123  - added the new utilities, ntfsclone, ntfscluster, ntfsinfo, ntfsls.
124
125* Thu Jul 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-0vl1
126- initial build for Vine Linux
127
128* Sat Jan 18 2003 Anton Altaparmakov <aia21@cantab.net>
129- renamed to ntfsprogs.spec.in
130- change source tar ball name to ntfsprogs
131
132* Tue Dec 10 2002 Anton Altaparmakov <aia21@cantab.net>
133- added ntfsresize
134
135* Wed Jul 18 2002 Richard Russon <ntfs@flatcap.org>
136- added ntfsundelete
137- change TODO names
138
139* Wed Jul 3 2002 Anton Altaparmakov <aia21@cantab.net>
140- update my email address
141
142* Mon Jun 3 2002 Anton Altaparmakov <aia21@cam.ac.uk>
143- update %doc with new TODO files
144
145* Tue Apr 12 2002 Anton Altaparmakov <aia21@cam.ac.uk>
146- update %description text for ntfslabel
147
148* Tue Mar 12 2002 Anton Altaparmakov <aia21@cam.ac.uk>
149- update %description text
150
151* Sat Jan 26 2002 Anton Altaparmakov <aia21@cam.ac.uk>
152- update %description text
153- make dependencies pick the right version automatically
154
155* Thu Jan 10 2002 Anton Altaparmakov <aia21@cam.ac.uk>
156- add dependency on linux-ntfs to linux-ntfs-devel
157- update %description text
158
159* Fri Nov 09 2001 Anton Altaparmakov <aia21@cam.ac.uk>
160- update %description text
161- (re)enable installation of shared libraries
162
163* Wed Aug 22 2001 Anton Altaparmakov <aia21@cam.ac.uk>
164- update %description text
165
166* Thu Aug 2 2001 Anton Altaparmakov <aia21@cam.ac.uk>
167- update %description text
168
169* Wed Jul 25 2001 Anton Altaparmakov <aia21@cam.ac.uk>
170- include sbin install path (mkntfs now is in sbin)
171
172* Tue Jul 24 2001 Anton Altaparmakov <aia21@cam.ac.uk>
173- update %description text
174
175* Mon Jun 11 2001 Anton Altaparmakov <aia21@cam.ac.uk>
176- remove duplicate %configure options
177- remove shared library installation as shared libraries are disabled by
178default
179
180* Sun Jun 10 2001 Anton Altaparmakov <aia21@cam.ac.uk>
181- add man pages stuff
182- update info text
183- add new doc/ stuff
184- modify installation to do install-strip instead of install followed by manual
185stripping
186- update download URL to be the fast sourceforge http download server
187
188* Fri Feb 2 2001 Anton Altaparmakov <aia21@cam.ac.uk>
189- started changelog
190
Note: See TracBrowser for help on using the repository browser.