source: projects/specs/trunk/n/ntfs-3g/ntfs-3g-vl.spec @ 8285

Revision 8285, 8.0 KB checked in by kenta, 10 years ago (diff)

ntfs-3g: new upstream release

Line 
1%bcond_with externalfuse
2
3Summary:        Linux NTFS userspace driver
4Summary(ja):    Linux NTFS ユーザ空間ドライバ
5Name:           ntfs-3g
6
7Version:        2014.2.15
8Release:        1%{?_dist_release}
9
10License:        GPL
11Group:          System Environment/Base
12URL:            http://www.ntfs-3g.org/
13
14Source0:        http://tuxera.com/opensource/%{name}_ntfsprogs-%{version}.tgz
15Source1:        20-ntfs-config-write-policy.fdi
16Patch0:         ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19
20BuildRequires:  libtool
21BuildRequires:  libattr-devel
22BuildRequires:  libconfig-devel
23BuildRequires:  libgcrypt-devel
24BuildRequires:  gnutls-devel
25BuildRequires:  libuuid-devel
26%if %{with externalfuse}
27BuildRequires:  fuse-devel
28Requires:       fuse
29%endif
30
31%description
32The ntfs-3g driver is an open source, GPL licensed, third generation
33Linux NTFS driver. It provides full read-write access to NTFS, excluding
34access to encrypted files, writing compressed files, changing file
35ownership, access right.
36
37Technically it's based on and a major improvement to the third
38generation Linux NTFS driver, ntfsmount. The improvements include
39functionality, quality and performance enhancements.
40
41ntfs-3g features are being merged to ntfsmount. In the meanwhile,
42ntfs-3g is currently the only free, as in either speech or beer, NTFS
43driver for Linux that supports unlimited file creation and deletion.
44
45%package devel
46Summary:        Development files and libraries for ntfs-3g
47Summary(ja):    ntfs-3g の開発ファイルとライブラリ
48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
50Provides:       ntfsprogs-devel = %{version}-%{release}
51Obsoletes:      ntfsprogs-devel < 2.0.0-3
52
53%description devel
54Headers and libraries for developing applications that use ntfs-3g
55functionality.
56
57%package -n ntfsprogs
58Summary:        NTFS filesystem libraries and utilities
59Summary(ja):    NTFS ファイルシステム用ライブラリおよびユーティリティ
60Group:          System Environment/Base
61Provides:       ntfsprogs-gnomevfs = %{version}-%{release}
62Obsoletes:      ntfsprogs-gnomevfs < 2.0.0-3
63
64%description -n ntfsprogs
65The ntfsprogs package currently consists of a library and utilities
66such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
67(for a full list of included utilities see man 8 ntfsprogs after
68installation).
69
70
71%prep
72%setup -q -n %{name}_ntfsprogs-%{version}
73%patch0 -p1 -b .unsupported
74
75%build
76%configure --disable-static \
77           --disable-ldconfig \
78%{?with_ externalfuse:--with-fuse=external} \
79           --exec-prefix=/ \
80           --bindir=/bin \
81           --sbindir=/sbin \
82           --libdir=/%{_lib} \
83           --enable-crypto \
84           --enable-extras
85make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
86
87%install
88rm -rf $RPM_BUILD_ROOT
89mkdir -p $RPM_BUILD_ROOT/sbin
90make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
91rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
92rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.a
93
94# make the symlink an actual copy to avoid confusion
95rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
96cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
97
98# make compatibility symlinks
99ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
100ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
101ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
102ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
103mkdir -p $RPM_BUILD_ROOT%{_bindir}
104ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
105ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
106
107# Put the .pc file in the right place.
108mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
109mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
110
111
112
113mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
114cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
115
116rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
117rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.la
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%files
127%defattr(-,root,root,-)
128%doc AUTHORS ChangeLog COPYING CREDITS NEWS README
129/sbin/mount.lowntfs-3g
130/sbin/mount.ntfs
131%attr(4754,root,root) /sbin/mount.ntfs-3g
132/sbin/mount.ntfs-fuse
133/bin/lowntfs-3g
134/bin/ntfs-3g
135/bin/ntfs-3g.probe
136/bin/ntfs-3g.secaudit
137/bin/ntfs-3g.usermap
138/bin/ntfsmount
139%{_bindir}/ntfs-3g
140%{_bindir}/ntfsmount
141/%{_lib}/libntfs-3g.so.*
142%{_datadir}/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi
143%{_mandir}/man8/mount.lowntfs-3g.*
144%{_mandir}/man8/mount.ntfs-3g.*
145%{_mandir}/man8/ntfs-3g*
146
147%files devel
148%defattr(-,root,root,-)
149%{_includedir}/ntfs-3g/
150/%{_lib}/libntfs-3g.so
151%{_libdir}/pkgconfig/*.pc
152
153%files -n ntfsprogs
154%doc AUTHORS COPYING CREDITS ChangeLog NEWS README
155/bin/ntfscat
156/bin/ntfscluster
157/bin/ntfscmp
158/bin/ntfsfix
159/bin/ntfsinfo
160/bin/ntfsls
161# extras
162/bin/ntfsck
163/bin/ntfsdecrypt
164/bin/ntfsdump_logfile
165/bin/ntfsmftalloc
166/bin/ntfsmove
167/bin/ntfstruncate
168/bin/ntfswipe
169/sbin/fsck.ntfs
170/sbin/mkfs.ntfs
171/sbin/mkntfs
172/sbin/ntfsclone
173/sbin/ntfscp
174/sbin/ntfslabel
175/sbin/ntfsresize
176/sbin/ntfsundelete
177%{_mandir}/man8/mkntfs.8*
178%{_mandir}/man8/mkfs.ntfs.8*
179%{_mandir}/man8/ntfs[^m][^o]*.8*
180
181
182%changelog
183* Sun Mar 02 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2014.2.15-1
184- new upstream release
185
186* Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2013.1.13-2
187- rebuilt with gnutls-3.2 and libgcrypt-1.6
188
189* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
190- new upstream release
191
192* Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
193- new upstream release
194- merge ntfsprogs
195  - add Obsoletes and Provides ntfsprogs*
196  - add BR: for ntfsprogs
197
198* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
199- new upstream release
200- fix %%files (add lowntfs-3g)
201
202* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
203- new upstream release
204- use internal fuse-lite, remove BR: fuse-devel and R: fuse
205- move binaries to /bin
206- move libraries to /%%{_lib}
207- add fdi file to enable hal automounting
208
209* Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
210- new upstream release
211
212* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
213- new upstream release
214
215* Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
216- new upstream release
217
218* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
219- new upstream release
220
221* Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
222- initial build for Vine Linux
223
224* Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
225- bump to 1.516
226- fix bugzilla 232031
227
228* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
229- bump to 1.417
230
231* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
232- bump to 1.416
233- drop patch0, upstreamed
234
235* Wed Apr  4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
236- allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
237
238* Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
239- bump to 1.328
240- drop patch, use --disable-ldconfig instead
241
242* Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
243- 1.0 release!
244
245* Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
246- symlink to mount.ntfs
247
248* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
249- bump to 20070118
250
251* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
252- bump to latest version for all active dists
253
254* Wed Jan  3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
255- bump to latest version (note that upstream fixed their date mistake)
256
257* Wed Nov  1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
258- add an obsoletes for ntfsprogs-fuse
259- make some convenience symlinks
260
261* Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
262- add some extra Provides
263
264* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
265- add explicit Requires on fuse
266
267* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
268- fixed versioning (bumped epoch, since it now shows as older)
269- change sbin symlink to actual copy to be safe
270
271* Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
272- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.