source: projects/specs/trunk/n/ntfs-3g/ntfs-3g-vl.spec @ 7076

Revision 7076, 8.0 KB checked in by daisuke, 12 years ago (diff)

ntfs-3g:

  • update to 2012.1.15
  • merged with ntfsprogs (in upstream)
Line 
1%bcond_with externalfuse
2
3Summary:        Linux NTFS userspace driver
4Summary(ja):    Linux NTFS ユーザ空間ドライバ
5Name:           ntfs-3g
6
7Version:        2012.1.15
8Release:        1%{?_dist_release}
9
10License:        GPL
11Group:          System Environment/Base
12URL:            http://www.ntfs-3g.org/
13
14Source0:        http://www.ntfs-3g.org/%{name}_ntfsprogs-%{version}.tgz
15Source1:        20-ntfs-config-write-policy.fdi
16Patch0:         ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
17Patch1:         ntfs-3g-junction-point-fix.patch
18# Windows 8 safety checks
19Patch2:         ntfs-3g-4d0b9163c9ef1f0cdbbf533317b291220c7fd1c7.patch
20Patch3:         ntfs-3g-559270a8f67c77a7ce51246c23d2b2837bcff0c9.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
23
24BuildRequires:  libtool
25BuildRequires:  libattr-devel
26BuildRequires:  libconfig-devel
27BuildRequires:  libgcrypt-devel
28BuildRequires:  gnutls-devel
29BuildRequires:  libuuid-devel
30%if %{with externalfuse}
31BuildRequires:  fuse-devel
32Requires:       fuse
33%endif
34
35%description
36The ntfs-3g driver is an open source, GPL licensed, third generation
37Linux NTFS driver. It provides full read-write access to NTFS, excluding
38access to encrypted files, writing compressed files, changing file
39ownership, access right.
40
41Technically it's based on and a major improvement to the third
42generation Linux NTFS driver, ntfsmount. The improvements include
43functionality, quality and performance enhancements.
44
45ntfs-3g features are being merged to ntfsmount. In the meanwhile,
46ntfs-3g is currently the only free, as in either speech or beer, NTFS
47driver for Linux that supports unlimited file creation and deletion.
48
49%package devel
50Summary:        Development files and libraries for ntfs-3g
51Summary(ja):    ntfs-3g の開発ファイルとライブラリ
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Provides:       ntfsprogs-devel = %{version}-%{release}
55Obsoletes:      ntfsprogs-devel < 2.0.0-3
56
57%description devel
58Headers and libraries for developing applications that use ntfs-3g
59functionality.
60
61%package -n ntfsprogs
62Summary:        NTFS filesystem libraries and utilities
63Summary(ja):    NTFS ファイルシステム用ライブラリおよびユーティリティ
64Group:          System Environment/Base
65Provides:       ntfsprogs-gnomevfs = %{version}-%{release}
66Obsoletes:      ntfsprogs-gnomevfs < 2.0.0-3
67
68%description -n ntfsprogs
69The ntfsprogs package currently consists of a library and utilities
70such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
71(for a full list of included utilities see man 8 ntfsprogs after
72installation).
73
74
75%prep
76%setup -q -n %{name}_ntfsprogs-%{version}
77%patch0 -p1 -b .unsupported
78%patch1 -p1 -b .junction-fix
79%patch2 -p1 -b .4d0b9163
80%patch3 -p1 -b .559270a8
81
82%build
83%configure --disable-static \
84           --disable-ldconfig \
85%{?with_ externalfuse:--with-fuse=external} \
86           --exec-prefix=/ \
87           --bindir=/bin \
88           --sbindir=/sbin \
89           --libdir=/%{_lib} \
90           --enable-crypto \
91           --enable-extras
92make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
93
94%install
95rm -rf $RPM_BUILD_ROOT
96mkdir -p $RPM_BUILD_ROOT/sbin
97make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
98rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
99rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.a
100
101# make the symlink an actual copy to avoid confusion
102rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
103cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
104
105# make compatibility symlinks
106ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
107ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
108ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
109ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
110mkdir -p $RPM_BUILD_ROOT%{_bindir}
111ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
112ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
113
114# Put the .pc file in the right place.
115mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
116mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
117
118
119
120mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
121cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
122
123rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
124rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.la
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%files
134%defattr(-,root,root,-)
135%doc AUTHORS ChangeLog COPYING CREDITS NEWS README
136/sbin/mount.lowntfs-3g
137/sbin/mount.ntfs
138%attr(4754,root,root) /sbin/mount.ntfs-3g
139/sbin/mount.ntfs-fuse
140/bin/lowntfs-3g
141/bin/ntfs-3g
142/bin/ntfs-3g.probe
143/bin/ntfs-3g.secaudit
144/bin/ntfs-3g.usermap
145/bin/ntfsmount
146%{_bindir}/ntfs-3g
147%{_bindir}/ntfsmount
148/%{_lib}/libntfs-3g.so.*
149%{_datadir}/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi
150%{_mandir}/man8/mount.lowntfs-3g.*
151%{_mandir}/man8/mount.ntfs-3g.*
152%{_mandir}/man8/ntfs-3g*
153
154%files devel
155%defattr(-,root,root,-)
156%{_includedir}/ntfs-3g/
157/%{_lib}/libntfs-3g.so
158%{_libdir}/pkgconfig/*.pc
159
160%files -n ntfsprogs
161%doc AUTHORS COPYING CREDITS ChangeLog NEWS README
162/bin/ntfscat
163/bin/ntfscluster
164/bin/ntfscmp
165/bin/ntfsfix
166/bin/ntfsinfo
167/bin/ntfsls
168# extras
169/bin/ntfsck
170/bin/ntfsdecrypt
171/bin/ntfsdump_logfile
172/bin/ntfsmftalloc
173/bin/ntfsmove
174/bin/ntfstruncate
175/bin/ntfswipe
176/sbin/fsck.ntfs
177/sbin/mkfs.ntfs
178/sbin/mkntfs
179/sbin/ntfsclone
180/sbin/ntfscp
181/sbin/ntfslabel
182/sbin/ntfsresize
183/sbin/ntfsundelete
184%{_mandir}/man8/mkntfs.8*
185%{_mandir}/man8/mkfs.ntfs.8*
186%{_mandir}/man8/ntfs[^m][^o]*.8*
187
188
189%changelog
190* Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
191- new upstream release
192- merge ntfsprogs
193  - add Obsoletes and Provides ntfsprogs*
194  - add BR: for ntfsprogs
195
196* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
197- new upstream release
198- fix %%files (add lowntfs-3g)
199
200* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
201- new upstream release
202- use internal fuse-lite, remove BR: fuse-devel and R: fuse
203- move binaries to /bin
204- move libraries to /%%{_lib}
205- add fdi file to enable hal automounting
206
207* Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
208- new upstream release
209
210* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
211- new upstream release
212
213* Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
214- new upstream release
215
216* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
217- new upstream release
218
219* Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
220- initial build for Vine Linux
221
222* Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
223- bump to 1.516
224- fix bugzilla 232031
225
226* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
227- bump to 1.417
228
229* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
230- bump to 1.416
231- drop patch0, upstreamed
232
233* Wed Apr  4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
234- allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
235
236* Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
237- bump to 1.328
238- drop patch, use --disable-ldconfig instead
239
240* Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
241- 1.0 release!
242
243* Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
244- symlink to mount.ntfs
245
246* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
247- bump to 20070118
248
249* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
250- bump to latest version for all active dists
251
252* Wed Jan  3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
253- bump to latest version (note that upstream fixed their date mistake)
254
255* Wed Nov  1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
256- add an obsoletes for ntfsprogs-fuse
257- make some convenience symlinks
258
259* Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
260- add some extra Provides
261
262* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
263- add explicit Requires on fuse
264
265* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
266- fixed versioning (bumped epoch, since it now shows as older)
267- change sbin symlink to actual copy to be safe
268
269* Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
270- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.